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Getting Started

Welcome
Welcome to SEnuke XCr!
This application offers individuals and organizations a powerful software solution
for automating SEO-related tasks.

Using This Guide
This user’s guide provides instructions on how to set up and fully use all SEnuke
XCr Script Recorder features.

Getting and Using Help
In addition to this guide, help is also available via the SEnuke XCr forum available
at http://senuke.com/forum/

Conventions Used in this Guide
The step-by-step operating instructions that you find in the SEnuke XCr
documentation follow these conventions:
Bold - Indicates that a word represents a command, window name, field name or
title that displays on a page or window. For example, Click the Save button.

Italics - Indicates a note or example information. For example, Note: The log in
credentials are case-sensitive.
Drop-Down List - Within the text you will come across the phrase “drop-down
list.” A drop-down list displays values that have been pre-defined in the system.
To select a value from a drop-down list, click the arrow on the field. The predefined values display. When you find the value you want, just select it and it
displays on the field. You may have to scroll within a drop-down list if it contains
several values.
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Example
The following image shows how a drop-down list looks when a value has been
selected:

Sample drop-down list

Computer Skills Needed
SEnuke XCr runs in Windows. If you are already familiar with the general
operation of the Windows Operating System and have used other browser-based
applications, you are well on your way to being able to use SEnuke XCr. You will
use the mouse and keyboard the same way as you do in those applications.
However, if you are not familiar with using a browser-based Graphical User
Interface (GUI) environment, it is recommended that you take some time to
familiarize yourself with this first. Before you can use SEnuke XCr, you need to
know how to perform the following:


Interpret windows or GUI terms, such as scroll



Use a mouse



Recognize the function of keyboard keys such as TAB



Fill-in windows and dialog boxes

System Requirements
Prior to using SEnuke XCr, make sure your system is equipped with the following:


A contemporary Internet browser such as Internet Explorer, Firefox, Safari,
or Chrome.

Starting and Terminating SEnuke XCr
You can easily start using and exit the SEnuke XCr application.
To start SEnuke XCr
1.

Click the application icon. The Application Update window opens. The
system checks for updates and automatically downloads them.

2.

The SEnuke XCr registration window opens. Enter your E-mail and
Password in the spaces provided.

3.

Click Verify. The SEnuke XCr main window is displayed:
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To exit SEnukeXCr
Simply right click on the SEnuke icon in the system tray and select “Exit SEnuke”
from the menu.

Getting Started ● 7

Quick Overview

Overview
SEnuke XCr was designed with a built-in list of websites from which the software
can build links. Even though there are thousands of websites, what do you do if
you come across a cool social network or a cool bookmarking website or a
website in any of the SEnuke modules that the software does not yet support?
The software does not know how to build a link from that website yet. Currently,
in SEnuke X you cannot add any website that you want. With SEnuke XCr, you
now have the ability to teach the software how to automate any website on the
Internet from which you would like to get a link.
The following steps outline the basics of automating a website. Details about
these steps are documented later in this guide.

Adding a New Script
Start by adding a new script.
1.

Create a new project by clicking New> Account Creation. Double-click this
project. The Script Recorder opens with the Account Creation Project in
view.

2.

Right-click in the Social-Custom group and select Add Script from the list.
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3.

In the Add Script window that is displayed, enter the website URL and
make sure Social – Custom displays in the Module field.

4.

Click the Save button. The Script Editor opens:

This window is where you will do most of your work.
5.

Go to the Signup page and click the Get Started button.

6.

Copy the URL for the signup page.

7.

Double-click step 1, the Navigate step. The URl field in the Navigate
window that opens contains a variable that currently navigates to the
home page. When you run the script, the variable gets replaced with the
site URL (wordpress.com). Paste the URL you copied in step 6 in place of
the variable. As the first step, SEnuke is now going to navigate to the
signup page.

8.

Click Save.
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Automating Fields
You are now ready to automate fields on the signup page.
1.

Click the Select Element icon ( ).

2.

Select the blog address field and choose Set Element Value from the list.

3.

The Set Element Value window opens:
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4.

Most of the time, the only item you will need to change in this window is
the Value field. SEnuke attempts to predict the value that should go there.
In this example, the Value field is populated with the $RandomLastName$
variable. Clearly, the Blog Address field should not take this value. Select
the $UserId$ variable instead. Leave everything else the same. SEnuke will
automatically fill in the rest.

5.

Click Save.

6.

Select the E-mail Address field. You will notice that SEnuke indicates which
element you are selecting by highlighting it.

7.

Right-click the E-mail Address field and select Set Element Value. SEnuke
correctly predicts that you want the $Email$ variable and preselects it in
the Value field. Click Save.

8.

Repeat step 7 for the Username, Password, and Confirm field. SEnuke
should automatically select the correct variable.

9.

Click the Select Element icon ( ) and right-click the Create Blog button.

10. Accept the defaults in the Click Element window that opens, and click

Save.
You have now automated the entire first page of how to create a
Wordpress account. Now run the script.
11. Click the Run icon (

). SEnuke should automatically fill in all the fields and
click the Create Blog button.

12. The next step is to have SEnuke wait for the “Now Check Your E-mail to

Complete Registration” text.
13. Right-click the text and select Wait for this text from the list.
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14. The Wait For window opens.

15. The Wait Timeout setting instructs SEnuke to wait 20 seconds for the text

after clicking the Create Blog button. If it is unable to find the text, it is
going to try the script from the beginning. You can select the Force wait
option, which forces SEnuke to wait. If you want the script to wait for five
minutes after clicking the button, you simply click the Force wait checkbox
and change the Wait Timeout setting to however many seconds you want.
16. Click Save.
17. The last step is to complete the script. Right- click in the right pane and

select Add. A list of all the actions that you can take are displayed in a list.
The last action you want to select is Mark Finished. That tells SEnuke that
the job is done once you have reached this step.

Automating a Content Submission
You have gone through the steps to automate the account creation of a
website. Next, automate the submission of content. In this case the content is a
Wordpress.com blog.
1.

From the SEnuke main window, select New> Social Network.

2.

Double-click the new project. The Social Network Project window opens.
Sample text is displayed in the left pane of the window. To obtain article
text you will need to generate an article. Enter a keyword, such as “dog”
and click the Download Content button. If you have set up accounts for
multiple article directories, SEnuke will ask you to select the one from
which you want to download content. Make your selection.
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3.

The article is populated in the left pane of the window. On the right there
is a Social Network - Custom group. Right-click this group and select Add
Script. When the Add Script window opens, enter the wordpress.com URL
in the Site URL field, and then click Save.

4.

You can log into the wordpress.com home page, but there is a better way.
Fill in the username and password fields with junk text and click Log In to
generate the Error login page.

5.

Click the Select Element icon ( ), right-click the “Email or Username “field,
and select Wait for this text from the list.

6.

When the Wait For window opens, click Save. The Wait For step instructs
SEnuke to go to the page specified and wait for the “Email or Username”
field title to make sure the page is noted properly.

7.

Create steps to fill in the UserId, Passsword, and the Log In button.

8.

Run the script. You are now logged in.
Now you need to create a Wait For step to tell Senuke that once you are
logged in, to expect text on the Dashboard.
To submit a new post, you can use the QuickPress box.

9.

Automate elements to enter the title, fill in the body (the article), the Tags,
and to click the Publish button.

10. Run the script.
11. Now that the post is published, you want to create a Wait For step that

tells SEnuke to wait for text that indicates the post has been published. If
SEnuke identifies the element with the exact URL of that blog post, you
want to get rid of that because each person's URL is going to be different.
You want to leave the words “View Post” in the field.
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12. Run the script again.
13. Once SEnuke clicks the link, create a Wait For step that tells SEnuke to wait

for the “Leave a Reply” text to make sure you are on the right page.

Adding the URL to the URL List
Now that you have created a new blog page, you now want to tell SEnuke to add
that URL to the URL list.
1.

Right-click in the bottom-right pane of the Script Editor and select Add URL
from the list. The Add URL window opens. The Location URL variable will
hold the URL of the page that you're currently on.

2.

Click Save. The URL is added to the URL list.

3.

You can now mark this Finished by right-clicking in the bottom-right pane
again and selecting Mark Finished from the list.

4.

You have now automated posting a blog to Wordpress.

Tips
There are so many cool things you can do with the account creation feature.
What if after creating the blog post you wanted to add a comment. Let’s say at
the Leave a Reply message you add a new comment: “Hope you guys like my first
post.”
Go through the following procedure to automate adding a comment:
1. Click the Select Element icon ( ), right-click the comment, and select
Add Element Click from the list. This is going to show you the appropriate
element for putting your comment in.
2. Enter the comment in the Value field. You can add spinner code if you
like. Click Save.
3. You have now posted a response. You want to right-click the posted
comment and select Wait for this text to make sure you are on the right
page. Every time you navigate to a different page or click a button, you
want to tell SEnuke to look for specific text after that page loads to make
sure you’re on the right page.
4. Using a Wait For step, now instruct SEnuke to wait for the “Says” text.
5. Next, add a Mark Finish step. That script will log into Wordpress, create a
new post, and leave a comment on it.
6. Close the Script Recorder and run the script in the actual submitter to
demonstrate that panes are working properly. The submission is
complete. The submission URL has an extracted and added to the URL
list.
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As you can see, it’s a piece of cake. You do not need to know any programming
whatsoever. Basic knowledge of HTML helps, but even without a basic
knowledge of HTML you will pick this up really fast. And the sky is virtually the
limit for what you can do with the software now.
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Basic Concepts of the Script Recorder

Overview
This chapter provides an explanation of the Script Recorder basic features.

Starting the Script Recorder
1.

Launch SEnuke XCr.

2.

Select New> Campaign. When the Add New Campaign window opens, give
the campaign a name, as shown in the following image:

3.

Click the Save Campaign button.

4.

Now you’re ready to create individual projects within the campaign.

5.

Create a project. For example, select New> Account Creation.
Now you want to obtain the script. To create an Account Creation script,
you must create an Account Creation project or use an existing Account
Creation project.
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6.

Double-click the new project name. The Account Creation Project window
opens:

Custom categories are displayed in the left area of the window labeled
Sites. These categories are associated with the type of scripts you can
create.
7.

Select a custom site, such as Article Directory

8.

Right-click and select Add Script from the list.

9.

In the Add Script window that opens, enter a URL, such as google.com, in
the space provided.

10. Optionally, enter a Script Name. The script name is the name that the

script will be identified by in the script portal. It can descriptive. For
example, squidoo lens with 3 modules. Click Save. The Script Editor window
opens with the website you specified in view, as shown in the following
image:

You are now ready to add steps to the script.
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Adding Steps to a Script
Once you create a project, you are ready to add steps (actions) to that project. A
step is basically a command for something you want SEnuke to do. Scripts that
you create in SEnuke are composed of many steps. Examples of a step include
“Navigate to a certain web page,” “Click on an item,” or “Fill in a value”.
1.

In the Script Editor window, click the Select Element icon ( ). The cursor
becomes a crossbar.

2.

Right-click the element you want to add. For example, the Google search
button.

3.

Select Add Element Click from the list, as shown in the following image:

4.

The Click Element window is displayed:

5.

Click Save. The step is added to the list.
You are now ready to run the script.
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As a best practice, test each step to ensure the intended actions occur. To
test a single step, simply right-click on it and select the Run Step(s) item
from the list.
When you run the script, the order of execution is top to bottom. The
number that is displayed next to the step does not matter. That is an
identifier for the step. To reorder the steps, simply click and drag the steps
to the desired location.
You can also test multiple steps together by using the mouse to draw a
rectangular around the steps you want to test, and then clicking the Play
button.

Adding Variables
A variable is text that is replaced by other text. For example, when you instruct
SEnuke to navigate, you are instructing the system to go to the $SiteUrl$
variable. The $SiteUrl$ variable is replaced by the URL that you specified. In the
Script Recorder, anything that is between two dollar symbols is considered a
variable. That means that the variable is going to be replaced when the script is
run.
This section will discuss the built-in variables and the differences in adding the
Script Editor to the various modules that SEnuke supports. Adding sites using the
Script Editor in all the modules that SEnuke supports is about 95% the same.
There are a few differences such as new variables depending on the type of
module and different check-in conditions. Let’s review the different variables.
In our example, we are navigating to a Site URL variable instead of specifying the
URL directly in the Site List. By using a variable we are able to replace the value
with any one of the URLs in the Site List. All of the website URLs would use the
same script. This is particularly useful when you want to automate a platform
such as phpbb or vbulletin, every single website that uses that platform can be
automated using the exact same commands. All you need to do is copy and
paste a list of all the different websites that all use the same platform into the
“Site List” box, and then write one script. SEnuke is then going to automatically
automate every single one of those websites using those same commands.
Variables are very important for using the Script Record properly because
throughout the Script Recorder you must use various variables.
Combo Select Variable
The $ComboSelectRandom$ variable selects a random choice when applied to a
drop-down list. It’s only applicable when you apply to a select element, which is
a drop-down element.
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Example
1.

Open the http://goarticles.com/submit website in the Script Editor.

2.

Right-click the Category drop-down list and select Set Element Value from
the list. The Set Element Value window is displayed.

3.

In the Set Element Value window that opens, select the
$ComboSelectRandom$ variable in the Value drop-down list and click
Save. Every time you run the variable, it’s going to select a different choice
from the drop-down list. It will never select the very first option, which is
usually something like “Please Select”.

Random Letter and Random Digits Variables
The $RandomLetter$ and $RandomDigits$ variables generates a random letter
or digit, respectively from a field.
Example 1
1.

Right-click the title on the goarticles website and select Set Element Value
from the list.

2.

When the Set Element Value window is displayed, select the
$RandomLetter$ variable from the Value drop-down list. Click Save. This
generates a random letter each time it is run. You can combine this
variable with the $RandomDigit$ variable (the Value field holds
$RandomLetter$$RandomDigit$) to generate one random variable and
random digit.

Example 2
If you want a bunch of different letters and digits, you can copy and paste the
variable over and over again, but there is an easier way. All you have to do is
insert curly brackets and then enter the number of times that you would like the
letter repeated. For example, if you want to generate five random letters each
time you would enter $RandomLetter${5} in the Value field and click Save.
Example 3
If you want to add a range of letters, for example between 2 and 5 letters each
time to reduce the footprint, all you have to do is add the two numbers of the
range separated by a comma ($RandomLetter{2|5}. Every time you run this
variable, it will generate a random number of letters each time.
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$LinkBBCode$ and $LinkHtml$ Variables
There are a bunch of websites that do not allow HTML in the signature. They
instead only allow BB code. The way you know this is if the website mentions
BBCode somewhere. For those websites, you will use the $LinkBBCode$ variable
when setting the element value. BBCode puts the actual URL inside a special
syntax. By clicking the Preview button located at the bottom of the screen you
can view how the signature will look.
There are a few special modules in SEnuke that have special variables, and a few
check-if conditions.
Forum Profile and Web 2.0 Profile Modules
All the Set to Item variables are pretty much the same as all the other modules,
except a couple.
Example
1.

Go to SEnuke Forum User Control Panel and select the Profile tab.

2.

Select Edit signature. For Forum Profile and Web 2.0 Profile modules, the
purpose of submission is to go and change the signature that is attached to
the profile.

3.

Right-click the Profile signature and select Set Element Value from the list.

4.

When the Set Element Value window opens, select the $LinkBBCode$ or
$LinkHtml$ variable depending on what the website allows. Click Save.

5.

By default, the text in the signature is separated by a new line (three lines
of text). You can replace the newline character with a comma (Enter
$LinkBBCode$ in the Value field and select the Replace option and enter
“\n” in the first space and a period in the second one. Click Save. When
you do a test, the items in the signature should be separated by a comma.
Similarly, you can use the $LinkHtml$ variable that will create the link
HTML. If you use this variable and the website does not allow HTML, the
HTML will be displayed in the signature.

6.

SEnuke adds two links to the signature because in the actual forum profile
(New Forum Profile Project> Post Profile Content tab> Add all links above
option) you have told it to add all the links above. If instead you selected
the option and specified to add only one link then SEnuke would only paste
a single link in the signature. You can go to the Edit profile section and add
a URL to the Website field. To do that, right-click on the Website link and
select Select Element Value from the drop-down list. When the Set
Element Value window is displayed, select the $Url$ variable from the
Value drop-down list. This variable will give you the clean HTTP URL
without any special code to it. For the websites that support that, you
could apply that as well.
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The Article Directory module has two special check-if conditions (go to the Script
Editor – Article Directory, right-click, and select Check If from the list.): Post
Article and Check Live Links. In the Article Directory project there are two items
in the drop-down list: Post articles and Check live links. Post articles is the most
familiar. The Check live links option logs into this website and extracts all the
links that have gone live. For example, if a week after submitting an article the
moderators that approve the article then you would run a check live links step to
extract all the links that have been approved and add those to the URL list.
You can control that step by right-clicking in Script Editor – Article Directory and
selecting Add> Check If from the list. When the Check window is displayed, select
Check Live Links from the drop-down list. If the user has chosen to check live
links, we can jump to a specific step. How you would teach SEnuke to go the
website, log in, and extract all the live links and put them into a URL list. For that
you will need to create a kind of a loop. That is a bit of an advanced loop.
The Social Bookmarking and RSS modules have a couple of special variables. We
have already discussed these in the previous video. I am just going to go over
them really quickly again.
$NextBookmarkingUrl$ Variable
This variable picks the next URL bookmark.
$CurrentBookmarkingUrl$ Variable
This variable picks the URL that was chosen by the $NextBookmarkingUrl$ URL.
This is only when some websites require you to add a URL twice. You can’t call
the next URL twice because each time it would give you a different URL. You can
call $Current Bookmarking URL variable to return the same URL that was
returned by the next bookmarking URL.
$NextRSSUrl$ Variable
For the RSS project there is the Next RSS Url variable. The process of creating a
bookmarking site goes like the following.
Example
1.

Select the element that you would like to place the URL in, and then fill in
$NextBookmarkingUrl$.

2.

Click the button to submit.

3.

Check to see if all URLs are bookmarked. If this condition holds true, it is
going to jump to the very last step, which may be the Mark Finished step. If
all the URLs are bookmarked, it’s going to mark everything as finished.
Otherwise, it is going to go to the next step and jump to step number 1 to
do the next URL in the queue.

Basic Concepts of the Script Recorder ● 22

$Subdomain$ Variable
The $Subdomain$ variable. Every time you go to create a blog in the social
network project, many of the websites are going to ask you for the blog address
where you put in a special subdomain. The subdomain that SEnuke gets is from
the Subdomain field in the Social Network Project. Every single time that the
subdomain variable is called, it is going to get a new subdomain for you because
a subdomain is supposed to be spun. So, every single time that you call it, it’s
going to get a new spun version of the subdomain. If you would like to use the
same subdomain that was used last time that you called the subdomain variable
you can also use the $LastUsedSubdomain$ variable. Every time you run it is
going to pick a subdomain.
Example: Filling a Text Box with an Email Address
1.

Click the Set Element icon ( ) and right-click the area where you want to
add a variable.

2.

Select Set Element Value from the list.

3.

In the Set Element Value window that opens, enter the $Email$ variable in
the Value field and click Save.

4.

Run the step.

The field is filled with the actual email variable: $Email$ because an email
address has not been specified in the Email Address of the Project Profile
window. Once you specify an email address and run the script, the email address
will be populated in the field. It picks up the value from the project it is
connected to. See the next section, “Setting Up Email Handling”, which details
how to set up email handing to extract a username and password from an email.

Setting Up Email Handling
Email handling only needs to be set up for those websites that send you a user
name and password in your email. When you sign up to a website and you are
requested to check your email for the username and password, that is when you
need to set up email handling.
To set up email handling
1.

Open the Script Editor and click the email handling icon. The Setup Email
Handling window is displayed.

2.

All you have to do is tell SEnuke how to extract the username and
password from the email. For the Extract username between fields, enter
the word Username and add the newline character (\n).Set up the
password the same way.

3.

Be sure to select the appropriate options for extracting the username and
password.

4.

Test that everything is working.
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►

5.

Copy the email to the clipboard, and then click the Test with email in
clipboard button.

6.

If the test is successful, you will see a message that identifies the username
and password.

Note: The fields are case-sensitive. So, if you were to put a lowercase u when the
Username uses a capital letter, the test will fail.
Other fields on the window:
90% of the time you will not have to use these.


Unique test in email



Part of activation link URL

If your only intention for setting up email handling is so that SEnuke is able to
click the activation link properly, then you really don’t need to set up email
handling. Every single email that SEnuke downloads clicks pretty much every
single link in that email. If by the odd chance you run the verification a couple of
times and you see that the link is not being clicked, then all you have to do is
part of the activation link URL. So if the activation link URL is
www.squidoo.com/verify, you only need to enter /verify in the Part of activation
URL field.
Chances are, whenever SEnuke downloads all the emails from your Inbox, you
will be able to identify which website sent which email because the from email
for that particular email is going to mention the site URL or the name of the
website is going to be mentioned inside of the email. Chances are when SEnuke
downloads an email, it knows which website sent that email so it can assign the
username and password appropriately. On the odd chance that SEnuke is not
able to verify which website sent that email, you’re going to know this when you
run email verification a few times and it is not able to extract the username and
password in the email. Even though the test indicates that it is working. If it is
not working, then you need to put in some unique text from the email. You can
put in something like “squidoo team” so when SEnuke detects that text in the
email it knows that that email belongs that website. 99% of the time SEnuke is
going to take care of these two options automatically.
Whenever you run email verification using the account creation project, SEnuke
is going to automatically extract the username and password and put them in
the appropriate profile or click the activation link.
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Reviewing the Script Editor Commands
To obtain a list of the commands, right-click in the Script Editor> Account
Creation window and select Add.
►

Note: There is a Comments field on every command window where you can
enter notes. The content you enter in this field will only be viewable by you.
When you save the item, the script shows up in the list. Your notes help to make
sense of the commands.
Advanced Users: You can also run JavaScript by navigating to something like
“javascript:somecode();” instead of an actual URL.

The following are the two most important commands in the Script Editor window:



Navigate –This command requires a URL. In addition to the right-click
Add menu, you can also access the Navigate step by selecting a link on
the web page with the Select Element icon ( ) and then choose Navigate
to link target from the list of options.



Set Element Value –The most important step to understand is the Set
Element Value step. You have two options for selecting this command:
(1) right-click in the bottom Script Editor pane or (2) click the Select
Element icon ( ), select the element on the web page that you would
like to set the value of, and then select Set Element Value from the list.

Options on the Set Element Value Window
The most important step to understand is the Set Element Value step.
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The following fields and options are available on the Set Element Value window:
►

Note: When automating websites, you can usually ignore all but the Value field.


►

Note: When you access the Set Element Value window from the right-click Add
menu, SEnuke does not auto-populate the Tag Name and Outer HTML. You must
do that manually.


►

Tag Name –This value tells SEnuke what the element is.

Note: When you access the Set Element Value window from the right-click Add
menu, SEnuke does not auto-populate the Tag Name field. You must do that
manually.


►

Frame Html –This optional field tells SEnuke that the element it is looking
for is inside an iFrame.

Outer HTml –This value tells SEnuke how to find the element on the
website. The element ID is displayed in this field. If you see a bunch of
random numbers in this field, that means that SEnuke uses that set of
numbers to identify an element. If a specific value is displayed in the field
and you think it might change with another user (such as username), you
can enter an asterisk in place of the actual username. An asterisk in
SEnuke XCr is a multiple character wildcard (it takes any value). You can
also use an asterisk as a single-character wildcard. The wildcard tells
SEnuke that you can have any value in the field that you want as long as
the rest of the content matches.

Note: When you access the Set Element Value window from the right-click Add
menu, SEnuke does not auto-populate the Outer HTML field. You must do that
manually.


Property –Every element you add will have a property. For most values it
will be Value. If you don’t know which property you should set, let
SEnuke pick it for you. Whenever you use the Select Element icon ( ),
SEnuke automatically fills in the property that it think you most likely
want to set. If you know HTML, there are several properties you can set.



Value –You can pick a variable from the list. The value is what the text
box for a particular element is going to be filled with. You can also type in
a new word or whatever text you want into the box or spinner code just
like you can outside the Script Editor. Whenever SEnuke sets the value, it
picks a different spun variable of this value.



Limit characters from left to x –Many websites have restrictions for the
maximum number of characters you can enter into a field. Use this field
to fill in a text box with a maximum number of characters. You can limit
the characters from the left to 100 characters, and then SEnuke allows
only the first 100 characters in the box.



Limit characters from right to x –This option is similar to the Limit
characters from left to x option, but the characters are limited from the
right.
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Replace –You will probably use this option regularly. It tells SEnuke to
replace one piece of text with another piece of text. Enter the word you
want replaced and the word to replace it with in the spaces provided. If
you want to replace the newline, you can enter “\n” in the space and
specify to replace it with a “<p> “.You can also replace text with a
newline.



Move Links to top –Use this option for those elements that have a
restriction for the number of characters that can go in a box. You want to
make sure that the links you have in your article will actually show up
before the rest of your article because if you tell SEnuke to limit the
characters to the left to some number, if your links start after that
number, your links are never going to show up. You can tell SEnuke to
move your links to the top of everything else.



Strip HTML code –A lot of different websites don’t let you put in HTML
code in your article. This is true for many press release sites. What you
can do is tell SEnuke to strip the HTML code to remove all the code from
the article, but keep the links. What happens is it keeps the http link
without the anchor tag around it. The link will not be clickable, but it will
be there. A lot of article directory websites will automatically make all
links clickable. For you to make it clickable, you would have to put HTML
code, but a lot of websites automatically make the links clickable even
when you strip the HTML code.

Adding Category Support to a Website
There are certain modules in SEnuke, such as the article directory or social
bookmarking project, that support being able to assign different categories to
different websites.
Adding categories to a website is a simple 3-step process: (1) Go to the website
you want to automate, (2) go to the category list and (3) Select the category list
using the element selector, and then select Copy items in list from the list. This is
going to copy all the items from the drop-down list to the clipboard.
Once you copied the websites, all you have to do is assign the items to the
required websites.
1.

Go back to the article directory project and select the website.

2.

Click Edit categories and paste the list of websites that were copied to the
clipboard. Be sure to delete any non-relevant text, such as “Please Select”
from the top of the Edit categories window.

3.

Click OK. Now the category list has been assigned to the website.
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4.

The last and final step is to add code that will select the chosen category.
All you need to do when you are automating the website is to click the
Category field drop-down list and select Set Element Value. In the Set
Element Value window that opens, SEnuke selects the
$ComboSelectRandom$ variable by default. You can use the $Category$
variable instead.

5.

Click Save. When you run the steps, SEnuke picks the correct category.

Click Element
Select an element on the page that you would like to click, and then select Add
Element Click.

The following fields and options are displayed on the Click Element window:



Tag Name – The name of the element.



Outer Html – How SEnuke identifies the element. You can use wildcards
in this field.



Is the last element – Sometimes SEnuke is going to find multiple
elements with that match the values in the Tag name and Outer Html
fields. When that happens, by default SEnuke selects the first element
that matches. If you would like to tell SEnuke to pick the last element that
matches that exact Outer Html and Tag Name, select this checkbox. After
it clicks the link, it waits a few seconds to make sure the next page has
had time to load.
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Wait For
This step tells SEnuke that after clicking a certain element or going to a certain
page, wait for a particular piece of text to make sure the page loads properly.

The following fields and options are displayed on the Wait For window:
►

Note: You can add multiple Wait For conditions by separating them with a pipe.
For example: condition1|condition2.


Condition – The text that SEnuke waits for. You can leave this field blank.



Wait Timeout - If SEnuke does not find the condition, the value in this
field instructs SEnuke how long to wait.



Force wait – Forces SEnuke to wait before going to the next step.



Auto-retry script if not found – If SEnuke does not see the word within
the timeout value, it will automatically retry the script from the first step.
Chances are, if it didn’t find the text, something went wrong.

Jump To
Use this step to control the exact order of execution of your script; to skip
certain steps.
►

Note: You can also create a Jump To step by selecting some text on the webpage
using the Set Element icon, and then choosing the “If this text found…” option”.
The most common use for this step is when you are trying to log into a certain
website, but it turns out that you are already logged in. The web browser saves a
cookie so you don’t have to log back into the website. What you can do is tell
SEnuke, when it finds the word “Logout” on that webpage, to skip all the steps to
log in to that page. Instead of trying to log in, SEnuke is going to just jump to the
steps which are probably going to be submit your articles.

Basic Concepts of the Script Recorder ● 29

The following fields and options are displayed on the Jump To window:



Condition –Find text in document. Tells SEnuke to jump to a new step if it
matches a certain piece of text on the webpage. You can also leave this
blank so SEnuke is forced to jump to that step every single time.



Jump to Step Id: - Jump to a specific step when the condition is met.



Auto Retry with different profile –If you come across certain words, such
as “Your account was banned” you can tell SEnuke to retry with a
different profile. This option only works if you have assigned multiple
profilesin a project.



Add Log –Adds an entry into the SEnuke Solution Center, which tells you
the kind of issues that SEnuke faced when trying to submit to a particular
website.



WB Status –Web Browser status is the piece of text that is displayed in
the bottom left of the browser window. For example, when the condition
that a website is skipped, you can add text that it was skipped because
the account was bad. If this was running in the submitter, nothing else
would happen.



Skip Site –Can skip site. For example, if the condition is “your IP was
banned”, auto retry with a different profile will not work. Skipping the
website is better in this case.



Delete Account – This is useful when an account is banned. It probably a
bad account and should be deleted.
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Set Variable
This step sets the value of a particular variable to something else. For example, if
you want to set the User ID to newUserID. This command is most useful when a
website asks you to log in using the email address and the password and not the
username. When SEnuke saves the account to the account profile, it saves the
user ID and the password. What you can do is tell SEnuke to make the User ID
the password. When SEnuke saves the account to the profile, it is going to save
the email address and the password.
►

Note: After an account creation script finishes, SEnuke will save the $UserID$
and $Passwords$ variables to the account profile. If you would like to change
what gets saved to the profile, you need to modify those variables accordingly
before the script finishes.

The following fields and options are displayed in the Variable window:



Name – How you want SEnuke to identify the variable.



Value – You can enter one or more variables in this field and any Value
field for other commands. For example, if you want to add the number 1
after the password, you can enter “$Password$1” in the Value field. You
can also do something like “$UserId$$Password$” or any combination of
variables. You can also add spin syntax. You can create your own variable.
In the Variable window, enter the name of your new variable in the Name
field and enter a variable name in the Value field. When you go Set
Element Value, you can enter your custom variable in the Value field in
the Set Element Value window. It may not be displayed in the Value dropdown list (that list does not contain all of the variables; just the most
common). If you create a new variable, you can use it in the rest of the
script editor.



Replace – Select this option to replace the variable.
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Browse File
(Add Browse to File Click) Use this command when you want to upload files to a
website. This step will do two things: (1) click the Browse button on the website
to open the file choosing dialog box, and then it will (2) type the file name to that
dialog box. The file name that it enters in the File Name dialog box comes from
the file name variable. Any module that supports file uploading, Like the PDF
submitter module will fill in the file name variable with the required file name.
Modules such as the account creation module, those modules that don’t support
file uploading you can specify the filename manually by setting the filename
variable to the full path of the file that you would like to upload. Note: The
filename must be the full path to the file, not just the file name. In the Variable
field, enter the variable Name (for example, $filename$ and the Value field is the
path to the file on your computer.
Find Item
This is an advanced step that allows you to select a particular element and assign
a particular property of that element to a particular variable.
Example

►

1.

Select a link.

2.

Assign the href property to the Variable of your choice and click Save.

3.

Set the element value to the Variable you selected previously.

4.

Run the script. SEnuke takes the href property from the actual link and the
Variable gets filled in the box.

Note: You will very rarely use this step. For any property of any element, You
must understand HML code and know what property holds what to be able to
take advantage of this step.
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Add Log
Adds an entry into the Solutions Center (a message and a solution). If you come
across “Your account was bad” In the solutions center you can add a message
“this website banned the account” and in the solution field enter create a new
account. When you run this script. A Solutions Center window is going to pop up
after the submission completes and it is going to show you the message you
added and the solution. This is beneficial to help you understand what is going
on, but you don’t really have to.

Add URL
Adds a URL to the URL list. The Location URL is the actual URL in the web
browser. You can also specify something like $siteurl$/$UserId. In the Add Url
window, check the RSS box to specify that the URL is an RSS URL, and it is going
to be added to the RSS URL list instead of the page URL list.

GoBack
Tells the web browser to go back.

GoForward
Tells the web browser to go forward.

Refresh
Tells the web browser to refresh.
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Mark Finished
When you want to tell SEnuke that the script is complete, you can add this step. You may
wonder why this is needed. Can’t you just let SEnuke run out of steps? You can have steps
below this step.

Solve Captcha
The Script Recorder makes solving CAPTCHA on a web page a piece of cake. All you have to
do is select the image that is showing the CAPTCHA with the Select Element icon ( ) and
choose Solve Captcha. When you run the script it will solve the CAPTCHA image using the
chosen CAPTCHA solving service in SEnuke, and save the response into the variable called
$CaptchaSolution$. Then all you have to select the text box where you add the CAPTCHA
response, select Set Element Value, and select the $CaptchaSolution$ variable. If you have
automatic CAPTCHA solving disabled, SEnuke shows a manual CAPTCHA solving window
(Script Editor CAPTCHA Entry window). Most of the time you can just press Save on this
window.

The Captcha window contains the following important field:



Outer Html – Check for random numbers that you need to replace with a
wildcard. Otherwise, the next time the page loads, those numbers will be
different and it is not going to be able to find this exact element. Any
random numbers, letters, or other identifiers; replace with a wild card
character (*).

Solving a Math Captcha
You can use SEnuke to solve this type of CAPTCHA; it is just a little complicated.
Here is a sample script that shows you how to do it. If you look through the steps
you'll be able to figure it out.
To use this with a different site, just change the outer HTML of both Find Item
steps.
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Here's how the logic works:
1.

The first step navigates to the correct site.

2.

The second step identifies the actual math equation and saves it in a
$Math$ variable

3.

The third step removes the "=" sign from the math equation (having the
equal sign breaks the javascript that will be used to solve it);

4.

The fourth step extracts the ID of the CAPTCHA solution textbox and saves
it in $CaptchaBoxId$

5.

The fifth and most complicated step actually solves the math equation
using javascript and fills it in the CAPTCHA solution textbox.

Check If
This step tells SEnuke to check for a specific condition. If the condition is found,
SEnuke jumps to the specified step. Otherwise, it skips the next step.

Example
1.

Create a social bookmarking project.

2.

Bookmark two websites.

3.

Create a new bookmarking script.

4.

Click Save.

5.

Set Element Value for bookmarking URL to hold one of the bookmarked
websites.

6.

Add a Jump To step to go back to step 1.

7.

Bookmark the next website.

8.

Add a Check If condition (If all websites are bookmarked, jump to the Mark
Finished step).
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Automating Account Creation

Overview
This chapter details how to create an account creation script. Here is an overview of
the steps:
1.

You must first create an account creation project. Select Add > Account
Creation. Keep the default name.

2.

Double-click the project to open the Account Creation Project window.
Before creating the project, enter all the fields.

3.

Select a profile from the Project Profile drop-down list.

4.

Click the Generate Random Profile button.

5.

Add an email address.

6.

Right-click Bookmarking – Custom in the Sites selection list. The Add Script
dialog is displayed.

7.

Enter delicious.com in the Site URL field.

8.

Select Bookmarking – Custom from the Module drop-down list.

9.

Click Save. The Script Editor window is displayed. Now, you are ready to
automate all the fields, pressing the Submit button, and creating the
account.

Creating the Basic Script
1.

Add a Wait For step after a Navigate or Click Button step, which makes
sure that the correct page is loaded before you move any further.

2.

Select the Select Element icon (

).
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3.

Right-click the Join Delicious button on the Deliciious.com web page, and
select Wait for this text from the list.

The Wait for dialog is displayed, as shown in the following image:

4.

Click Save.
Next, you want to click a button.

5.

Select the Select Element icon (

).
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6.
►

Right-click the “Join Delicious” button, and select Add Element Click. The
Click Element window is displayed.

Note: Whenever you select an element, try to remember to look at the text that
is displayed in the Outer Html field to identify any random numbers that look like
they might change every time the page is loaded.

7.

Click Save.

8.

Right-click step 3, the Click Item action, and select Run step(s) from the
list. The next page after clicking the “Join Delicious” button should be
displayed.

9.

Create another step. Click the Select Element icon (
), right-click the
“Welcome to Delicious” message, and select Wait for this text from the
list.

10. The Wait for window is displayed. Click Save.
11. Click the Select Element icon (

), right-click the email address link, and

select Add Element Click from the list. The Click Element window is
displayed. Notice that in the Outer Html field there is a wild card character
displayed in quotes. This takes this place of any type of character.
12. Run the step by right-clicking on the step and selecting Run step(s).
13. In the “Create a new Delicious account” window, click the Select Element
), right-click the title, and select Wait for this text from the list.
Click Save.
icon (

14. Start filling in the fields (select Set Element Value from the list and choose

the correct value). Create a step to fill in the USERNAME, EMAIL ADDRESS,
FULL NAME, and PASSWORD. Notice for the full name fields that
$randomfirstname$ and $randomlastname$ are displayed in the Value
field. You can keep these variables for random values or enter specific
values. You can also use Spin syntax.
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►

Note, you can disable the Select Element icon by pressing the ESC key on the
keyboard.

►

Note: SEnuke has the ability to upload a picture.
15. The next step is to solve the CAPTCHA. Right-click the CAPTCHA title and

select Solve Captcha.
16. Right-click the CAPTCHA box, select Set Element Value (the CAPTCHA

solution variable should be displayed), and click Save. (If you select the
option to disable CAPTCHA solution in SEnuke, a window will pop up asking
you to enter the CAPTCHA solution. If you enable this option, it will be
filled in automatically.)
17. The last box on the page is a “Create my account”. Right-click it and select

Add Element Click.
18. The Click Element window opens. Click Save. That completes the

automation for this page.
19. A web page with information about saving links is displayed. Right-click the

message and select Wait for this text.
20. In the Wait For window, click Save.
21. Add a Mark Finished step to tell SEnuke that everything is finished. Right-

click in an empty space in the bottom-right pane and select Add> Mark
Finished.

Tips
What do you do if the account already exists?
In the example, step 17 is a Wait For step that waits for the words “You currently
have no links….” Because there are other words, the system does not find it. It
instead finds the words that a user account already exits. When you see this
message, there are two possibilities: (1) SEnuke created the user account and
the system is just detecting this, or (2) someone has already used the account.
One option is to add a number at the end of the user name and start the account
creation process again. You can also assume that the account is taken because
you created it.
To fix this issue in our example you would follow these steps:
1.

Double-click step 17 (the Wait For condition “You currently have no
links…” ).

2.

In the Wait For window that opens, add a vertical pipe and the words
“already been taken. If the system finds the page that you “currently do
not have any links” or “already been taken”, it’s going to jump to the next
step (Mark Finished). SEnuke will not retry the script from the beginning.
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3.

Run the script again. You should see the words “Script Finished”. That is a
good sign that all went well. Once SEnuke goes to the Mark Finished step,
it is not going any further because that step tells the system to stop there.

What happens if the user enters the wrong CAPTCHA?
If you enter the wrong CAPTCHA, neither text will show up. So when that
happens, it will wait for 20 seconds for the text.
What If the user is already logged in?
If you try to run a script and the user is already logged in, the script will remain
on the current page while a countdown appears at the bottom of the window.
Once the countdown reaches zero, the script will start from the beginning. Once
you create an account at delicious.com, it creates a cookie, so the next time you
run the script, it’s not going to show you the Join Delicious page. It’s just going to
automatically log you in. This is important when you want to create multiple
accounts. So, before signing up each time, you should probably log out first.
Normally, you would see a log out button.
You then need to figure out when to go to the Logout page.
1.

You could simply change the site URL (select step 1 “Navigate – site URL”
to delicious.com/logout) so that every time it tries to create an account it
goes to the logout page and starts the whole process. That is the normal
route.

2.

Now look at jumping to steps. Select step 2, the Wait For step.

3.

When the Wait For window opens, enter a vertical pipe after the Condition
value and add the word “Following.” This is assuming that the word
“Following” shows up only on the Delicious web page when the user is
logged in. If there is a “Logout” word, use that instead. In this case, use
something that is only displayed when a user is logged in. Now, if SEnuke
finds any of those two pieces of text (“Join Delicious” or “Following”) it will
continue to the next step.

4.

Next, add a jump to condition (right-click in the bottom-right pane again,
and select Add> Jump To).

5.

In the Jump To window that opens, enter “Following’ in the Condition field
and then specify the step number to jump to (enter “99” in the Jump Step
Id field as a placeholder). Click Save.

6.

Move the Jump To step to the third position. What all this does is tell the
system to wait for the two pieces of text. If it finds “Following” it is going to
log out.

7.

Now you want to get to the Logout page. After the Mark Finished step, add
a Navigate step (right-click in the bottom-right pane and select Add>
Navigate).

8.

In the Navigate window, enter www.delicious.com/logout in the Url field.
Click Save.
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9.

Open the Jump To step and in the Jump to Step Id field, enter the Navigate
step number.

10. Run the Navigate step to test.
11. Add another Jump to step to take the system to condition number 2 again.

What you are trying to accomplish is once it jumps to the last step to log
you out, it jumps to step #2. Step 2 waits for Join Delicious and Following.
It should continue everything below it.
12. To test, copy username and log in from account creation page to log in

manually. Then run the script from the beginning.
►

Note, any time it not able to find the text in the Wait For condition, you will see a
time start at the bottom of the page. It starts with 20 seconds and goes all the
way down to zero. Then, it is going to autocreate the script from step 1.
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Automating Websites Running on the Same
Platform

Overview
This section explains how to add websites by the hundreds and the thousands
into SEnuke using just one script. All of these websites are going to be running on
the same platform. For example, the forums sites are phpbb or vbulletin. All of
these websites use the same software to run the website. That is why it is
possible to automate hundreds and thousands of websites at one time. For this
example we going to automate a forum platform called mybb. This forum
platform does not come with SEnuke, so it is a good example.

Creating a Platform Script
►

Note: This procedure assumes you have a list of all the URLs to the websites you
want to automate. If necessary, you can use ScrapeBox to harvest wesites for
different platforms. Google Scrapebox to locate a tutorial for this software.
1.

Create an Account Creation project or double-click an existing one.

2.

When the project opens, right-click the Forum Profile - Custom module and
select Add Script.

3.

When the Add Script window opens, add the URL for the first website you
want to automate in the Site URL field.

4.

Ensure Forum Profile - Custom is the value selected from the Module
drop-down list.

5.

Optionally, add a value in the Script Name field. This value is a simple
description of the script and can be different than the site URL. For
example, mybb account creation.

6.

Click Save. The Script Editor opens with the website in view in the Browser
tab

7.

Copy the entire list of website URLs into the Site List pane of the Script
Editor window.

8.

Go through the normal steps to create an automation script for a website.
See “Automating Account Creation” for the basic steps, if necessary.
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Once you have automated the first website in the list and tested the script,
you will test the script on the rest of the websites to make sure it works.
When you have hundreds or thousands of websites, you will not have the
time to manually test the script on every single website. Instead, you
should test 20 or 30 of the websites and keep improving the script until it
works with all 30 of the websites. Then you can assume that if it works with
a random sample then it is going to have a decent success rate for the rest
of them.
When you run the script, SEnuke is always going to pick the first website at
the top of the Site List. To prevent SEnuke from running the same website
twice, move the first website URL to the bottom of the list so that the
second site URL moves to the first position.

9.

10. Click the Run button (

) to test the script with the next website in the

list.
►

Note: You can also use the submitter to test your script on the remaining
websites. See “Using the SEnuke Submitter to Test Your Script“ for details.
11. Modify the script as needed to accommodate different elements you

encounter in the websites. The following section describes some of the
elements and unique issues you may encounter when automating platform
websites.
►

Note: Anytime you modify a script, SEnuke informs you that you haven't tested
the sites with that script.

Common Changes to Account Creation Scripts
The following are some of the most common elements and issues you may
encounter when testing your account creation script on the random sample of
websites.
Accessing the Websites
When you run your script to test the second and subsequent websites in your
list, you will be logged into the website. You need to log into each website, so
you have two options:


Clear your cache and cookies before running the account creation script,
or



Add a step to log out (best practice)

To create a step to log out
1.

Create the base script using the first website.

2.

Double-click the Wait For step in the script that causes SEnuke to wait for
text that indicates has not logged in, such as a registration agreement (this
step usually follows the initial Navigate step).
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3.

In the Wait For window that opens, add a vertical pipe after the Condition
value and add the text that indicates the user is already logged in, such as
“Welcome Back”. Click Save. After the first navigation step SEnuke will look
for either texts.

4.

Now create the Jump To step that SEnuke will move to in the script if it
detects the text that indicates the user is already logged in. Right-click the
text and select If this text found from the list. The Jump To window opens
with the Condition field prefilled with the conditional text.

5.

In the Jump to Step Id field, enter the anticipated number of the logout
step that you will create next, and click Save.

6.

Move the Jump To step after the Wait For step.

7.

Right-click the text to logout of the website and select Add Element Click
from the list.

8.

In the Click Element window that opens, the value in the Outer Html field is
the logout element that SEnuke will click to logout. You will see the entire
URL and a random logout key in the Outer Html field. Highlight the first
part of the URL and the random key and replace them with the wildcard
symbol (*). You need to do this step because each website will have a
different URL to the logout page.
Optionally, add text in the Comment field of the Click Element window to
indicate the purpose of the element. For example, “logout branch”.

9.

Click Save.

10. When you run the step, SEnuke logs you out of the website. Right-click the

login/register text and select Wait for this text from the list.
11. The Wait For window opens with the Condition field prefilled with the

conditional text. Click Save.
12. You need to create a step that jumps back to the login page. Right-click in

the right pane and select Add> Jump To from the list.
13. Leave the Condition field blank.
14. In the Jump to step Id field, add the number of the step that goes to the

login page (the initial Navigation step), and click Save. Once SEnuke logs
out, it is going to jump back to the top to try and register/login again.
15. Test the script to make sure everything functions as you expect.
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CAPTCHA Fields
Some websites may require you to solve a CAPTCHA as part of the
registration/login process. When you encounter these elements, simply add
them to your script.
►

Note: To make CAPTCHA solving faster, you can disable automatic CAPTCHA
solving. From the main SEnuke window, select Options. Then select the Captcha
tab and check the Enable auto-captcha solving option.
To create a CAPTCHA element
1.

Right-click the CAPTCHA image and select Solve Captcha from the list.

2.

Click Save.

3.

Right-click the solve CAPTCHA area and select Set Element Value from the
list.

4.

In the Set Element Value window, select the $CaptchaSolution$ variable in
the Value drop-down list.

5.

Click Save.

6.

Move the two CAPTCHA steps to their appropriate steps in the script.

7.

Test the script to ensure everything functions as you expect.

To create two CAPTCHA elements
Some websites include two types of CAPTCHA elements. If your script includes
steps for a single type of CAPTCHA, you will need to add the additional type.
Since there are now two CAPTCHA steps, SEnuke ignores one of them if a
website only has one CAPTCHA.
Add the step for the additional CAPTCHA and move the step to the appropriate
step in the script. [copy and paste the URL to the clipboard and paste it to the
Site List in the Script Editor. Add the elements for the additional CAPTCHA and
move the steps to the appropriate place in the list of steps.]
Duplicate Elements
If a website will not continue with a particular step, such as in the case of
duplicate registrations, you can create a step to skip the website. This forces
SEnuke to ignore the website and start automating the next website.
To skip a website
1.

Right-click on the text that indicates the duplication and select If this text
found from the list. The Jump To window opens with the Condition field
prefilled with the conditional text.

2.

Select the Skip Site option and click Save.
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3.

Move the Jump To step to the appropriate step in the script. For example,
if the conditional text is registration information, you would move the
Jump To step after the Navigate step.

4.

Double-click the Wait For step you have already created for the login
conditions. Add a vertical pipe and the conditional text that indicates a
duplicate event has occurred.

5.

Click Save.
Doing this step saves you time because otherwise SEnuke automatically
retries the step up to four times. So, if you know ahead of time that there is
text that indicates you will not be able to sign up for the website, then go
ahead and add a skip site step.

Optional Fields
When you create an account creation script for websites on the same platform,
you account for all the different elements in your websites. In doing so, many of
the elements may be optional. If SEnuke does not detect an element on a
website, it will wait five seconds to give the field a chance to show up. If it
doesn't show up after five seconds, it is just going to continue without that
particular field.
The message “Element not found. Continuing without it” will be displayed at the
bottom of the Script Editor window during processing. What this does is allow
you to create a lot of different fields that might show up on the page. If a certain
website has that field, great, it's going to fill it in. If a website doesn't have that
field it's going to keep going. This is how to deal with optional fields.
Birthdate Drop-Down Fields
It is very common for websites to request information from a drop-down list,
such as birth date, during registration. These fields typically include drop-down
fields that require you to make a selection.
To add birth date information
1.

Copy the text related to the birthdate field.

2.

Double-click the Wait For step that includes the login conditional text.

3.

When the Wait For window opens, add a vertical pipe character to the
Condition field and paste the text.

4.

Click Save.

5.

Click the Select Element icon (
), right-click the conditional text, and
select If this text found from the list of options.

6.

In the Jump To window that opens, enter the step number you want the
script to jump to if the conditional text is found. Click Save.
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7.

Click the Select Element icon (
), right-click the Day drop-down field,
and select Set Element Value from the list of options. In the Set Element
Value window that opens, the Outer Html value should be pre-filled. In the
Value field drop-down list, select the $ComboSelectRandom$ variable to
select a random day and month. Click Save.

8.

Repeat step 7 for the Month field.

9.

Now you are ready to add the Year element. Click the Select Element icon
(
), right-click the Year drop-down field, and select Set Element Value
from the list of options. In the Set Element Value window that opens, For
the year, add 19 as the first two digits to make sure the user is old enough.
Then add $RandomDigit${2}. This instructs SEnuke to pick any two
random digits after 19. Add information in the Comment field (for
example, “Fill date of birth branch”) and click Save.

10. Test the steps to make sure everything functions as you expect.

Using the SEnuke Submitter to Test Your Script
When you're ready to test a script against the second website, you can copy and
paste the site URL to the top of the Site List in the Script Editor window or run
the script in the SEnuke Submitter.
To use the SEnuke Submitter to test an account creation script

►

1.

Go to the account creation project.

2.

(Optional) Go to Options and select the General tab. Change the value for
the Submitter initial number of browsers option to 1 instead of the
default (16) so that the automation script runs in a single browser window
at a time where you can easily view the activity.

3.

Select all of the URLs you want to automate.

4.

Click the Start button. The SEnuke Submitter window opens. The script will
start running and you will be able to see which websites succeed and
which ones fail.

5.

If processing stops (for example, if a website requires information that you
have not automated), click STOP located at the top of the window, rightclick the URL of the website in the Account Creation Project window, and
select Copy selected URLs from the list of options. Double-click the
website URL. When the Script Editor opens, paste the URL at the top of the
Site List in the Script Editor.

Note: When you save a URL to the Site List, any duplicates are automatically
removed.
When creating jump steps, add info in the comments field to explain the purpose
of the condition and jump.
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Handling User Errors
If an error occurs due to user mistakes, such as entering the incorrect CAPTCHA
information, you can add special handling for the text, which would make it jump
to a specific step. You can also instruct SEnuke to retry from the beginning. If you
just added a Jump To step, every time that text was found, that can possibly
create an infinite loop. If you let SEnuke auto retry, it tries to run the step a
maximum of four times. If you add a Jump To step in every single case, there is a
chance that SEnuke will keep jumping infinitely. Instead of adding jumps that
could result in an infinite loop.

Removing Websites that Fail
When automating platforms, you will come across websites that have
differences. What you want to do is run a small sample of the hundreds or
thousands of websites that you are trying to automate and improve the script as
you go through each website. Once you automate about 30 or 40 websites, you
will have an accurate script that should work for a majority of your sites.
Once you are done with your submission and SEnuke informs you of the
websites that failed and succeeded, you will need to remove the failed sites.
Once you select all the sites and you run them and everything is complete, click
the flask icon ( ) and select the Remove sites with less than 100% success rate
option. This is going to remove all the bad websites from the Site List. All that
remains are websites that are working.
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Automating Social Bookmarking Websites

Overview
Social bookmarking is an activity that involves tagging websites to share with
others on the Internet. It is considered a great way to promote a website or blog
and increase traffic. To maximize the impact, you should submit your website or
blog to a large number of social bookmarking websites. SEnuke can help you
save time with social bookmarking by automating the effort.
This chapter explains the steps to automate a social bookmarking site using the
SEnuke Script Recorder. The site referenced in the instructions is newsvine.com,
a popular social bookmarking website.
Before you can start the process of automating a social bookmarking website,
you need to open your project in the Script Editor.
1.

From the main SEnuke window, double-click a social bookmarking project.
If you need to create one, simply click the New icon and select Social
Bookmarking from the list.

2.

Make sure all the fields on the window are completed to specify how you
want to configure the site. Select the Use Urls from Urls List option and
select a value from the list. This value determines where the project reads
from. The Count field next to this field indicates the number of URLs in the
list. You should also select the Bookmark All Websites Above option.

3.

In the Social Bookmarking tab, right-click the Bookmarking – Custom
category and select Add Script.

4.

In the Add Script window that opens, enter the URL of the website you are
automating. Make sure Bookmarking – Custom is displayed in the Module
field, as shown in the following image:
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5.

Click Save. The Script Editor window opens with the first page of the
website in the Browser tab, as shown in the following image:

You are now ready to start automating the social bookmarking website.
Automating a social bookmarking site involves the following steps:
1.

Log into the website.

2.

Post content to the website

3.

Save the URL to URL list in SEnuke.

4.

Add an initial logout step.

5.

Check the script for breaks.

Step 1: Log into the Social Bookmarking Website
When automating any website in just about any of the modules in SEnuke, there
are a few basic steps you have to follow.
►

Note: When you are adding the elements to your script, you will need to deselect
the Element Selector (Set Element icon). You can press the escape key to deselect
the Element Selector. Sometimes the Escape key doesn’t work and you have to
click the arrow icon.
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1.

Locate the log in element and add it to the script. In the case of the
newsvine website, clicking the Log In link opens a dialog window for you to
enter your login credentials. So to automate this element you must first
create a Wait For step after the Navigate step.

2.

Select the Set Element icon (
), right-click the Log In-Register area, and
select Wait for this text from the list. In the Wait For window that is
displayed, the conditional text should automatically be displayed in the
Condition field.

3.

Click Save.

4.

Now you can start automating the log in credentials. Right-click the Log In
link and select Add Element Click from the list.

5.

View the entire Outer Html field to make sure random numbers are not
present. If you do see random numbers, replace them with the wildcard
character (*).

6.

Click Save.

7.

Right-click on the step you just added and select Run Step(s) from the list
to run the step to make sure it works.

8.

Next, you need to automate the elements on the window that pops up
when you click the Log In link. For example, right-click the E-mail field and
select Set Element Value from the list. The Set Element Value window
pops up.

9.

Select the $UserId$ variable in the Value drop-down field. The
newsvine.com website is different from most websites in that you enter an
email address instead of a username when logging in. So, when creating
the account creation script for this website, you have to use the Set
Variable command to set the User ID to the email address because when
SEnuke saves the account information of that website, it will save the
username and the password instead of the email address and the
password. So, if you want to save the email and password, you have to set
the value of the $UserId$ variable equal to the value of the email variable.
See the “Quick Overview“ chapter for details, if necessary.

10. Click Save.
11. Next, automate the Password field. Right-click the field and select Add

Element Value from the list. The $Password$ variable should be displayed
automatically in the Value field.
12. Right-click the Log In button and select Add Element Click from the list.
13. Click Save.
14. Select the steps from the beginning and run them. You should be logged

into the website. Right-click the Log Out link and select Wait for this text
from the list. The Wait For window is displayed.
15. Click Save. Now you are ready to post content to the website.
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Step 2: Post Content to the Website
After you have logged into the social bookmarking website, the next step is to post
content. Each social bookmarking website is different. For the newsvine.com
website, the most simple way to add links is on the Seed Link page.
1.

You have options when accessing the page for posting content. You can
right-click the link that takes you to the content submission page and
select Add Element Click or Navigate to the link target. When you go with
the second option, the Navigate window opens. Add the URL of the page in
the URl field and click Save.

2.

Run the Navigate step to open the content submission page.

3.

Click the Select Element icon ( ), right-click the title of the page, and select
Wait for this text from the list.

4.

When the Wait For page is displayed, click Save.

5.

In the Basic Information section of the Seed a Link page, right-click the Link
address field and select Set Element Value from the list.

6.

When the Set Element Value window is displayed, select
$NextBookmarkingUrl$ from the Value drop-down list, and click Save.
Every time SEnuke calls the NextBookmarkingUrl variable, it is going to call
a different URL.

7.

Click the Select Element icon ( ), right-click the Headline field, and select
Set Element Value from the list. SEnuke retrieves the headline value from
the Anchor Text in the URL List. If you need to change this value:
 Go to the URLs tab in the main SEnuke window.
 Double-click the URL List you want to change.
 When the Page URL List page opens, select the URL list and click
the Edit Anchor icon from the toolbar.
 When the Enter Anchor Text window opens, change the value to
the appropriate value, such as SEnuke Blog, and click OK.

8.

When the Set Element Value window is displayed, select the $Title$
variable from the Value drop-down list.

9.

Click Save.

10. The next field asks the question, “Is this a report or an opinion about

recent news?” If you right-click this field and select Set Element Value from
the list, by default the $ComboSelectRandom$ variable is displayed in the
Value drop-down list. That variable tells SEnuke to choose a random value
in that drop-down list. There is a good chance that any link you submit is
not going to be about recent news; it is going to be about something we
want people to know about, which is not in the news. To set the value of
the field to “No”, right-click the field and select Set Element Value from
the list.
Automating Social Bookmarking Websites ● 52

11. When the Set Element Value window is displayed, type in the actual value

(No) in the Value field. When SEnuke reaches this field, it is going to search
all the values and when it finds No it is going to select it.
12. Test the steps at the Seed a Link page. Confirm the Headline element is

completed correctly.
13. The next section of the Seed a Link page is a Category drop-down list in the

Optional Information section. To extract a list of categories and save it in
SEnuke, right-click the field and select Copy items in list from the list. The
SEnuke Notification window is displayed with the message that “Items
from drop-down list copied to the clipboard!” Click OK.
14. Go to the Social Bookmarking project, right-click the website you just

added, and select Edit Categories from the list.
15. An empty box is displayed. Paste the contents of the clipboard in the

space. If a line is displayed above the list, just delete it. Click OK.
16. Now, whenever someone uses the script, when you submit to it, SEnuke is

going to ask you to pick a category first. That category can be filled into the
actual website.
17. Select a category for the website from the list.
18. Right-click the Category field and select Set Element Value from the list.

The $ComboSelectRandom$ is prefilled in the Value field. Change this to
the $Category$ variable and click Save.
19. Right-click the Summary field and select Set Element Value from the list.

By default, the $Body$ variable displays in the Value field. Select the
$Description$ variable from the list. Click Save.
►

Note: The $Body$ variable is ideal for social network articles and similar items.
20. Right-click the Tags field and select Set Element Value from the list. The

$Tags$ variable should be prefilled in the Value field. Click Save.
21. Right-click the Publish Seed button and select Add Element Click from the

list. Click Save.
►

Note: Be sure to look through the Outer Html field to make sure it does not
contain any random numbers.
22. Highlight the steps from the Category step to the end of the script. The

page should be submitted.
23. Click the Select Element icon (

), right-click the text that indicates when the

content was seeded, and select Wait for this text from the list.
24. In the Wait For window that is displayed, “Seeded on” and a hardcoded

date are prefilled in the Condition field. You do not want a hardcoded date
because that means that SEnuke will only seed content that has that
particular date. Instead, just leave the “Seeded on” text in the field and
click Save.
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Step 3: Saving the URL to URL List
Step three of the social bookmarking account creation process is saving a URL
and adding it to the URL list. The URL is in the browser navigation bar.
1.

Right-click in the Script Editor window and select Add> Add Url from the
list. The $Location URL$ variable is prefilled in the Location field of the Add
Url window. This will save whatever URL is in the browser’s URL navigation
bar. If the URL is for an RSS, you would select the RSS checkbox.

2.

Click Save.

Step 4: Adding an Initial Logout Step
Now that the three main steps of automating any website have been
accomplished: (1) logging in, (2) posting the content, and (3) extracting the URL
and saving it to the URL list. Step 4 is adding an initial log out step. This step is
needed when you first visit a website you are automating and you are not logged
in; the window would show the login link. The next time you go to that page it is
not going to show the login link because you are already logged in.
The first step in automating any website is logging out. Since you are unable to
logout until you have logged in, you will typically need to add the logout step
near the end of the script and then move it to the beginning of the script.
1.

Right-click the Log Out link and select Navigate to link target. The URL is
automatically populated in the Url field of the Navigate window that is
displayed. This is the link that will logout the user. Click Save.

2.

Move the Navigate step you just created to the beginning of the script.

3.

Right-click the Navigation step and select Run Step(s) to test the logout
step. You should be taken to the homepage of the website.

4.

Run the test again to make sure that if you are not logged in you are still
able to log out. Some websites will throw an error message when they
detect that you are trying to logout, but you are not already logged in.

5.

For the newsvine.com website, you can go directly to the logout step
instead of waiting for the Log In/Register step. So, instead of going to the
home page as the first step, you would just go to the logout page.
The steps so far have created a script to automate a website to submit one
URL. The social bookmarking project lets you submit multiple URLs (there is
a Bookmark All Websites Above option where SEnuke will read from the
URL list) or you can tell SEnuke to bookmark a few random lists (there is a
Bookmark <some number> random links at each bookmarking site
option). Adding a loop in the steps does the same thing.

6.

Right-click in the Script Editor – Social Bookmarking project and select
Add> Jump To from the list. This step will take SEnuke back to the home
page.
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7.

Once the script is finished and the URL is added to the URL list, it is going
to arrive at the final step (the Jump To step) and that is going to eventually
repeat everything all over again. This is going to be stuck in a loop that
never ends. In programming terms that is called an infinite loop. You need
to be able to check whether all of the URLs have been bookmarked, then
you can call the script to finish.

8.

Right-click in the Script Editor window and select Add> Check If from the
list. In the Check window that is displayed, select All URLs bookmarked
from the drop-down list.

9.

Select the step number to jump to if the condition is met. Click Save.

10. Move the step above the Jump To step so that SEnuke checks to see if all

URLs have not been bookmarked. If all URLs have not been bookmarked, it
is going to jump to the Mark Finished step. Otherwise, it is going to jump
to the next step (the Jump To step).
11. Right-click in the Script Editor window and select Add> Mark Finished from

the list. After SEnuke submits a URL and adds that URL from the URL list it
is going to check if all URLs are bookmarked. If all the URLs have been
bookmarked then it is going to skip the Jump To step and go to the Mark
Finished step.
This is something you need to keep in mind for any bookmarking site or any
RSS site where you need to go back and select multiple URLs one by one.
For any of those websites you need to add a Check For or Jump To step.
12. Test all the steps.

Step 5: What Could Break the Script
The last and final step of submitting a social bookmarking website is considering
other conditions that could possibly break the script.
If the URL you are trying to bookmark has been previously bookmarked, you can
simply bookmark the URL again. You just need to add another Jump To condition
that would jump (if that URL is found) to the next URL in the list.
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Automating AJAX-Based Websites

Overview
This chapter details how to automate something that makes identifying the exact
element difficult. The website used in the steps are to create a Squidoo Lens. The
instructions assume you are familiar with the account creation steps. Review the
“Automating Account Creation” chapter for the detailed steps, if necessary.
Automating a website such as Squidoo takes a lot of steps, but it is a great
example of how to use the advanced SEnuke features.

Automating the Login Page
The first step of automating any website for any type of project using SEnuke is
to add the login elements.
►

Note: Prior to testing the Login steps, make sure you have a username and
password saved for the website you are automating. If the Account Profile
doesn’t have a username and password for the site, SEnuke will throw an error.
If you have created an account creation script that creates the account, make
sure to run that script first so that the account is created and saves the login
information to your profile.
1.

Double-click a Social Network project.

2.

When the project opens, right-click in the Social Network – Custom area
and select Add Script from the list.

3.

Enter the URL of the website you want to automate in the Site URL field.

4.

Make sure the Social Network – Custom is selected in the Module dropdown list.

5.

Click Save. The Script Editor window is displayed. Now, you are ready to
automate all the fields for the website.

6.

You first need to automate the login screen. Right-click the Login link and
select Properties from the list. The window that opens will show the URL
for the login page.

7.

Copy the login page URL.
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8.

Double-click the Navigate step (step 1) and paste the login URL into the Url
field in the Navigate window that opens.

9.

Click Save.

10. Run the step. You will be taken to the website’s login page.
11. Set element values for the “username or email” and “password” fields.

(Click the Select Element icon, right-click the field, select Set Element
Value from the list, select the appropriate variable, and click Save.)
12. Set an Add Element Click for the Login button and click Save.
13. Run the steps following the Navigate step.

Automating Step 1: Login Elements
The first step of automating a website is creating the login elements.

►

1.

Once logged in, Wait For the “Activity Stream” text. Click the Select Element
icon ( ), right-click the Activity Stream heading, and select Wait for this
text from the list. Click Save.

2.

Click Save. Click the Create a Lens! button and copy the URL of page that
opens.

3.

Right-click in the right pane and select Add> Navigate.

4.

Paste the URL into the Url field of the Navigate window, and click Save.

5.

Click the Select Element icon ( ), right click the step 1 text on the page and
select Wait for this text from the list. Click Save.

6.

Right-click the My page is about field and select Set Element Value. Select
the $Title$ variable for the Value and click Save.

7.

Right-click the Continue button and select Add Element Click.

Note: Make sure to review the text in the Outer Html field to make sure no
random numbers are displayed.
8.

Click Save.

9.

Run the last two steps of the script.
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Automating Step 2: Lens Title
When you run the last two steps of the script, a page with information to
complete for step 2 is displayed. You must automate the elements on this page.
1.

Right-click the “Title your page!” title, select Wait for this text from the
list, and click Save.

2.

Right-click the Set your lens URL field and select Set Element Value. Set the
Value in the Set Element Value window to the $Subdomain$ variable. The
subdomain is specified in the Social Network Project settings.

3.

Right-click the Pick your topic field, right-click, and select Copy items in list
from the list. This step is necessary because it is a categories field. SEnuke
displays a message stating that the items from the drop-down list were
copied to the clipboard.

4.

The SEnuke Notification window opens with a statement informing you
that the item was copied to the clipboard. Click OK.

5.

Go to the Social Network tab on the Social Network Project page.

6.

In the bottom-right pane, right-click and select Edit Categories from the
list.

7.

In the Edit categories for <URL> window that opens, paste the contents of
the clipboard.

8.

Scroll to the top of the list and delete the sentence that states “Choose a
topic (the best that fits)”.

9.

Click OK.

10. In the same pane, go to the Index list and select a category from the

website.
11. Return to the Script Editor.
12. Click the Select Element icon (

), right-click the Pick your topic field, and

select Set Element Value. Set the Value to the $Category$ variable, and
click Save.
13. Right-click the Please rate your lens field. By default it states G Rated.
14. Right-click the Continue button and select Add Element Click.
15. Click Save.

Automating Step 3: Adding Tags
The third step for creating a Squidoo Lens is adding tags.
1.

Click the Select Element icon ( ), right click the “The best tag for my lens is”
field, and select Set Element Value from the list. When the Set Element
Value window opens, select the $Tag1$ variable from the list in the Value
field in the Set Element Value dialog. Click Save.
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2.
►

Repeat step 1 for the “3 more good ones here” field, selecting the $Tag2$,
$Tag3$, and $Tag4$ variables, respectively.

Note: You could use the $Tags$ variable when setting the tag element values,
but what that would give you all the tags, separated by a comma. This variable
is more suitable when a field requires multiple values. However, if there are
separate fields, use a tag for each one of them (choose them individually).
3.

Click Save.

4.

Right-click the CAPTCHA image and select Solve Captcha. When the
Captcha window opens, click Save.

5.

Right-click CAPTCHA field, select Set Element Value. In the Set Element
Value window that opens, select the $CaptchaSolution$ variable from the
Value drop-down list. Click Save.

6.

Right-click the Continue button and select Add Element Click from the list.
When the Click Element window opens, click Save.

7.

Click the Select Element icon ( ) to deselect it, and then run the script from
the tagging steps.

Automating Step 4: Monetizing Pages
After you add the tagging elements for your Squiddo Lens, the fourth step is to
automate the elements that determine how you want to monetize your Squidoo
pages.
1.

Click the Select Element icon ( ), right-click step 4 title, and select Wait for
this text from the list . When the Wait For window opens, click Save.

2.

Right-click the Continue button, select Add Element Click from the list.
When the Click Element window opens, click Save.

3.

Click the Select Element icon ( ) to deselect it, and then run the two steps
you just created.

Automating the Introduction Module
On Squidoo and other article directories, you have the option to create an
introduction module for your content. In Squidoo, this step consists of adding
introductory text and uploading an image.
To automate introductory text
1.

Click the Select Element icon ( ), right-click the Introduction text, and select
Wait for this text from the list. When the Set Element Value window
opens, click Save.
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2.

Right-click the Edit Title button and select Add Element Click from the list.
In the Outer Html field of the Click Element window that opens, you will
notice the subdomain value you specified. This value is going to change
every single time, so replace it with the wild card character (*). Click Save.

3.

Run the steps. The “Introduction, Contents & Discovery Tool” page opens
with the Intro Text tab in view.

4.

Click the Select Element icon, ( ) right-click the Lens Intro Title field, and
select Set Element Value from the list. When the Set Element Value
window opens, select the $Title$ variable from the Value drop-down list.
Click Save.

5.

Right-click the Lens Description field and select Set Element Value from
the list. When the Select Element Value window opens, select the $Body$
variable in the Value field. Select the “Limit characters from left to x”
option and enter 250 as the character limit. This amount will be sufficient
to provide a summary for the users. Click Save.

6.

Run the last two Set Element Value steps.

To automate uploading an image
1.

Right-click in the right pane of the Script Editor window and select Add>
Set Variable. When the Variable window opens, enter $filename$ in the
Value field, enter the path to the image file you want to use Click Save.

2.

Click the Select Element icon ( ), right-click the Lens Photo field, and select
Add Browse File Click from the list. When the Click Element window
opens, click Save.

3.

Right-click the Upload Photo button and select Add Element Click from the
list. When the Click Element window opens, click Save.

4.

Run the three steps you just added.

Next, you need to add a Wait For step that will wait long enough for the photo to
be complete. There are two ways to do this using a Wait For step.
Option 1
You can look through the HTML code of the Upload an intro image! page to
find the text that shows up only when the photo is complete.
1.

In the Script Editor, select the Source tab and enter “penguins” in the
Find field. Look through the text to search for text that will only be
displayed when a photo is successfully loaded. For the Squidoo website,
the path you provided to an image is modified to include “fakepath”.
This text shows up only when the image upload process is complete.

2.

In the right pane of the Script Editor and click Add> Wait For. In the
Wait For window that opens, enter the text that you discovered in the
previous step in the Condition field. Enter a Wait Timeout value of 1020 seconds. This should be sufficient time to wait for an image to load.
Click Save.
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Option 2
A second option to use when uploading an image is to simply create a Wait
For step that causes SEnuke to wait a specific amount of time.
1.

In the bottom-right pane of the Script Editor, click Add> Wait For from
the list.

2.

In the Wait For window that opens, leave the Condition field blank and
select the Force Wait option. Deselect the auto-retry script if not found
option and enter a Wait Timeout amount (10-20 is good) in the space
provided. Click Save.

5.

►

In the bottom-right pane of the Script Editor, right-click and selected Add>
Click Item. You add the step using this method because using the Select
Element icon to add the element generates an error.

Note: When selecting objects on a website, you may receive a message that the
element is complicated. When this happens, you must manually add the step.
6.

When the Click Element window opens, enter BUTTON in the Tag Name
field. You can obtain this by looking at the error message. The first tag is
the Tag Name. In the Outer Html field, enter “value=”Save”> Save. Click
Save.

7.

Click the Select Element icon ( ) to deselect it, and then run the step to
make sure the values are correct.

At this point you have uploaded a photo and added a summary. To prevent the
abrupt end of a sentence at your character limit, you could add an ellipsis to
indicate there is more to the article. Now you are ready to add a new text
module.

Automating a New Text Module
The text module is where you create your content.
1.

Right-click in the bottom-right pane of the Script Editor and select Wait For
from the list. When the Wait For window opens, enter five in the Wait
Timeout field, select the Force wait option, and click Save. This step tells
SEnuke to wait five seconds after clicking the Save button before going to
the next page.

2.

Click the Select Element icon ( ), right-click the Edit button located in the
New Text module section, and select Add Element Click.

3.

In the Click Element window that opens, check for random numbers that
may change with every user and replace them with the wildcard character
(*). Click Save.
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4.

Run the Click Item step you just added. A page opens for you to add
information about the text module.

5.

Click the Select Element icon ( ), right-click the title field, and select Set
Element Value from the list.

6.

In the Set Element Value window that opens, set the Value field to the
$Title$ variable. Click Save.

7.

Right-click the Enter your text below field and select Set Element Value
from the list. When the Set Element Value window opens, set the Value
field to the $Body$ variable. Look in the Outer Html field for random
values. Remember to change them to wildcard characters. Click Save.

8.

Run the last three steps. The actual article should be filled in the “Enter
your text below” field.

9.

Some fields specify a character limit. Double-click the Set Element Value
step for the Body, select the “Limit characters from left to x” checkbox and
enter 10000. If there is more than 100000 characters, SEnuke is not going
to add them.

10. Click the Select Element icon (

), right-click the Save button, and select Add

Element Click from the list. When the Click Element window opens, click
Save.
11. Run the step. The Introduction and Text modules are now complete. You

can now create additional modules.

Automating an Amazon Module
The Amazon module allows you to create content to feature on Amazon. The
steps in this section explain how to automate this process.
1.

Click the Select Element icon ( ), right-click the Edit button, and select Add
Element Click from the list.

2.

When the Click Element window opens, replace any random numbers with
a wildcard (*), and click Save.

3.

Run the step you just added to make sure SEnuke opens the Amazon.

4.

Click the Select Element icon ( ), right-click the Give your module a title
field, select Wait for this text from the list.

5.

When the Set Element Value window opens, click Save.

6.

Right-click the Enter your search terms field and select Set Element Value
from the list.

7.

When the Set Element Value window opens, replace any random numbers
with the wildcard character (*), select the $Tag1$ variable in the Value
field, and click Save.
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8.

Click the Select Element icon ( ) to deselect it, and run the step you just
added.

9.

Click the Select Element icon ( ), right-click the value in the Number of
products to display field that you want to use (for example, 5), and select
Add Click Element from the list.

10. When the Click Element window opens, change any random ID numbers

that may vary to wildcard characters. Click Save.
11. Click the Select Element icon (

) to deselect it, and run the step.

12. If you attempt to add the Save button element and an error message

displays stating that the element is too complex, you must add the
element manually.
To manually create the Click Item step
To manually create elements, you must understand HTML. The error message
will give you some clues, but you need to be able to interpret the information.
You must be sure that the field you enter in the Outer Html field corresponds to
the element you are working with. This process may require some trial and error.
In this example, simply looking for the conditional text in the error message does
not work. When you are trying to identify any HTML element on a page, there
could many different elements on a page that are identified by using the exact
same Outer Html value. For example, there could be a lot of Save buttons on a
page that are identified as using the exact same Outer Html. In SEnuke it is easy
to select the first element that is identified by the Outer Html or the last
element.
If you are having difficulty manually entering the element, you can right-click the
field you want to automate and look for the error message. If using “values=”
does not work, try module numbers. However, it is possible for an identification
number to be different for every different user. So , you will be unable to
hardcode these numbers.
The following steps show how to extract an identification number from another
element on a page.
1.

Copy the module number in the error message.

2.

Select the Source tab and paste the number in the Find field and click the
Find Next button.
SEnuke searches for exact tags. You must save the module number to a
variable, and then reference the element using that variable. For this
example, the content you need in in a DIV tag.

3.

Right-click in the bottom-right pane and select Add> Find Item.
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4.

In the Find Item window that opens, search for the Tag Name. For
example, enter DIV in the field. In the Outer Html field, enter the HTML for
the item. For this example, enter “class=”module amazon”. In the Property
field, select Id from the list. In the Variable field, create a new variable,
$ModuleId$. Click Save.
This step is going to cause SEnuke to look for the Outer Html value, take
the ID from that value, and assign it to the new variable.
An alternative, if some number precedes the module number, you can
create a Set Variable step. In the Variable window you would select the
Replace option and enter the text you want replaced with a blank value.
SEnuke will remove those words from the beginning. This will enable you to
get to the exact piece of text you need by replacing everything that is
unnecessary.

5.

Move the Find Item step up one.

6.

Copy the text in the error message that contains the class information for
the button.

7.

Open the Click Item step that is now the last step, and paste the text in the
Outer Html field. Replace the ID number with the $ModuleId$ variable you
created in step 4. Click Save. This is going to extract the module ID from
the DIV tag and identify the Save button using that ID.

8.

Run the last two steps you just added. The Amazon module is not added.

To add more modules, for example, an eBay module, right-click on the module
name in the Browser tab, and select Set Element Value from the list. When the
Set Element Value window opens, set the Value in the module to “1”and then
click Save. You would then create an element for the Add button.
Adding more modules and information about yourself can help give your lens a
higher quality number. The higher the number, the better your chances of being
featured on Squidoo and showing up high in the search engine ranking. The
SEnuke Script Recorder gives you the ability to do exactly what you want with a
Squidoo lens, and any other page.

Publishing a Module
Now that you have automated the steps to create the module, you can then
publish it.
1.

Click the Select Element icon ( ), right-click the Publish button, and select
Add Element Click from the list.

2.

When the Click Element window opens, check the Outer Html field for
random number to replace with wildcard characters, and click Save.

3.

Click the Select Element icon ( ) to deselect it, and then run the step you
just added.
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4.

If publishing the lens is successful, click the Select Element icon ( ), rightclick the success message, and select Wait for this text from the list. Click
Save.

5.

Right-click the Go see it link and select Add Click Element from the list.
Check the Outer Html field for random numbers to replace with wildcard
characters, and click Save.

6.

Click the Select Element icon ( ) to deselect it, and then run the two steps
you just added. Your new Squidoo Lens should be displayed.
After the lens creation is complete, you need to add a Wait For step. For
example, the Lens stats link.

7.

Click the Select Element icon ( ), right-click the conditional text, and
select Wait for this text from the list.

8.

In the Set Element Value window that opens, click Save.

9.

Add the URL to the list by right-clicking the right pane and selecting Add
Url.

10. When the Add Url window opens, click Save.
11. Right-click in the bottom-right pane and select Add> Mark Finished from

the list.
You have now created a script to automate a submission to an article directory.

Tips
This section includes a few tips to help you when automating an article directly
website.
Tip 1
When the script is run, the user is logged in to the website. Run the script from
the beginning to see if anything breaks. If it breaks, the first step is to logout.
1.

Right-click the Logout link and select Properties.

2.

Copy the URL of the Logout page.

3.

Right-click in the bottom-right pane and select Add> Navigate.

4.

In the Navigate window that opens, paste the URL of the Logout page in
the Url field and click Save.

5.

Move the step to the top of the script, and then run the script again.

6.

Click the Select Element icon ( ), right-click the Login button, and select
Wait for this text from the list.

7.

When the Wait For window opens, click Save.

8.

Move the Wait For step to the top of the script, just after the Navigate step
you created in step 3.
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►

Note: If a black screen shows up and covers your screen, it is a part of the viewer
and will not mess up your screen.
9.

After running script, a “multiple lenses with the same content” message is
displayed if you do not use spun content. This shows up because the actual
lens did not contain spun content. If the lens had spun content, then it
would not detect that the content was duplicate. You can spin the article
and spin the title to make sure you don’t get the error message again. If
you are sure testing is going to be fine, you can run the article in the actual
spinner window from the Social Network Project window. Click the Start
button in the article submitter. You can see the pages in action.

Tip 2
Don’t forget to add a Wait For step after every Click Item step. Clicking a radio
button does not need a wait step.
Tip 3
If you have difficulty reading the Parameters for each step, you can add
comments to each step to make things easier to understand. To add a comment,
open the step and add the comment text in the Comment field.
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Using a Loop to Extract Live Links

Overview
This chapter explains how to extract all the live links from an article directory
website. This is an advanced tutorial that is going to show you how to create a
loop that goes to an article directory website and extracts all the links that have
been published.
►

This chapter assumes you understand HTML code.

Automating the Login Page
The first step you must perform when creating a script for any SEnuke project is
adding the login elements.
1.

Double-click an Article Directory project.

2.

When the Article Directory Project window opens, select Check Live Links
from the drop-down list located next to the Start button (see image
below):

When running the script for this project, SEnuke refers to the value
selected in the drop-down list when the script you create for this project is
run.
3.

Right-click in the Article Directory – Custom area and select Add Script
from the list.
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4.

In the Site URL field of the Add Script window that opens, enter the URL of
the article directory website from which you want SEnuke to extract links.

5.

Make sure ArticleDirectory – Custom is selected in the Module drop-down
list.

6.

Click Save. The Script Editor window is displayed.

7.

Add a login step. Copy the website URL (for this example it is
https://my.exinarticles.com), double-click the step one (the Navigate step),
and paste the Url field of the Navigate window that opens.

8.

Click Save.

9.

Create element values for the Email Address and Password fields and the
Sign In button:
 Email Address field: Click the Select Element icon ( ), right-click
the Email Address field, and select Set Element Value from the list.
Select the $UserId$ variable from the Value drop-down list. Click
Save.
 Password field: Right-click the Password field and select Set
Element Value from the list. Select the $Password$ variable from
the Value drop-down list in the Set Element Value window that is
displayed. Click Save.
 Sign –In Button: Right-click the Sign In button and select Add
Element Click from the list. In the Click Element window that is
displayed, make sure BUTTON is displayed in the Tag Name field.
Click Save.

10. Run the steps to log in.
11. Once logged in, right-click text in the window that indicates you are logged

in. (For the Squidoo website that text is “Recent Achievements”.) Select
Wait for this text from the list. When the Wait For window opens, click
Save.

Automating the Check Live Links Option
When creating scripts for projects in SEnuke, you would normally start
submitting content after automating the login elements. When extracting links
from an article directory you do not need to perform this step.
1.

Right-click in the bottom right pane of the Script Editor window and select
Add> Check If from the list.

2.

In the Check window that is displayed, select Check Live Links from the
drop-down list and enter a step in the Step Number field (enter 99 for
now). This step instructs SEnuke to go the specified step if the user has
selected to check live links. Click Save.
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3.

The Check step is automatically added to the bottom of the script. Move it
after the step to check for the conditional text that indicates the user is
logged in.
To determine the next action (Post Articles or Check Live Links), SEnuke
refers to the value selected in the drop-down listed located next to the
Start button in the Article Directory Project window. For this example, you
want to Check Live Links.

4.

The Published Articles link located at the bottom of the Squidoo page that
is displayed when the user is logged in opens the Live Links pages. Rightclick the link and select Properties from the list.

5.

Copy the URL from the Properties page.

6.

Right-click in the right pane of the window and select Add> Navigate.

7.

Paste the URL in the Url field in the Navigate window that is displayed. The
step should automatically be added after the Mark Finished step.
If the user chooses to post an article, SEnuke runs step 1 through to the
step just before the Mark Finished step. If the user chooses to check live
links, SEnuke skips all the steps after the Jump step and submits article
links.

8.

Run the Navigation step you added in step 6 to open the Published Articles
page.

9.

Click the Select Element icon ( ), right-click the introductory text to the
list of published articles, and select Wait for this text.

10. Click Save.

The next step is instructing SEnuke to capture the URL of every single live link.

Automating Link Extraction
Once you have added steps to log in to the article directory and select the Check
Live Links option, you are now ready to automate link extraction.
1.

In the list of published articles, click the gear icon located next to an article
title. A menu list opens.

2.

Click the Select Element icon ( ), right-click the View on
EzineArticles.com item, and select Assign to variable from the list.

3.

The Find Item window opens. Replace the numerical ID with a wild card
character (*), select href from the Property drop-down list, enter the
$ArticleLink variable in the Variable field, and click Save.

4.

Right-click in the bottom-right pane and select Add> Add Url.

5.

In the Add Url window that opens, enter the $ArticleLink$ variable in the
Location field and click Save.

Using a Loop to Extract Live Links ● 69

The Find Item step extracts the URL and then the Add Url step adds the URL
to the URL list. This obtains the first URL. The script runs in a loop, but at
this point is only going to find the same item on the page. To find the next
element, you must change the first element it finds to something that
won’t be recognized the next time the Find Item step is run.
6.

Click the Select Element icon ( ), right-click the View on
EzineArticles.com option, and select Set Element Value from the list.
Change the Value field to a blank value. This hides that element from the
page. SEnuke first extracts the URL, adds it to the URL list, then hides the
element. Click Save.

7.

Right-click the bottom-right pane of the Script Editor window and select
Add> JumpTo. This step finds the next element.

8.

The Jump To window opens. Leave the Condition field blank and add the
step number of the step of the Find Item step in the Jump to Step Id field.
Click Save.
You have now created a loop. To end the loop, you must add another
condition.

9.

Right-click in the bottom-right pane of the Script Editor window and select
Add> Jump To from the list. if these words (option words – View on
EzineArticles.com) are found. Add 99 in the Jump to Step Id field. Once it
assigns the URL of the first link, and adds it to a URL list, the second thing
it’s going to do is make the link invisible. When you set the Outer Html to a
blank value, the next time that SEnuke encounter the Jump To condition, it
will return to the Find Item step and find the next link. If no links exist (all
links have been extracted), it will continue to the next step, which is Mark
Finished.

10. Run the steps to make sure all the links are extracted.
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Using the Script Portal

Overview
The Cr in SEnuke XCr stands for crowdsourcing. Crowdsourcing is defined as a
distributed problem solving and production model. The idea is to use a large
mass of people to accomplish something.
There are more than a dozen programmers on the SEnuke team, but they cannot
even come close to the power of thousands of SEnuke users collaborating with
each other to make the software better.
Here's the general idea: you create a script that automates getting a link from a
certain website and share that script with the whole community. That earns you
10 points. In exchange, you get to download scripts shared by others, with each
download costing 1 point. So, sharing one script means you get to download 10
scripts shared by others!
You can also earn points for fixing broken scripts or improving scripts created by
other people. The exact number of points you earn for each task can be found in
the points table on the next page.
The eventual goal is that for every place on the Internet that lets you get a free
link, there will be a script for it in the SEnuke Script Portal.
Taking part in the Script Portal is optional. If you're happy with the existing
number of websites in SEnuke, then you don't need to take part in this. The
number of websites that come with the software will slowly grow just like it has
been growing for the past 2 years. Our developers will continue to actively add
more sites into the software on a weekly basis and fix broken sites. But if you
would like to increase the power of the software, we highly recommend being an
active part of the script portal. Find one new place to get a link from and
automate it, and the community will reward you with 10 new places they've
found.
Downloading a script will cost 1 point, regardless of how many sites that one
script automates! There are some scripts that automate thousands of sites using
the same script because all those sites are running on the same platform.
Downloading such a script will only cost 1 point as well!

Using the Script Portal ● 71

Other than being able to automate more sites using the software, the other
advantage of the Script Portal is that very few people will actually obtain links
from the same site! Because you have to be a contributor to download scripts
from the Script Portal, a very small fraction of SEnuke users will actually build
links from those sites. This means you will be able to get links from fresh,
untapped websites that very few other people know about!

Points Table
The SEnuke points system is listed in the following table.
Activity

Point

Upload a script that automates a
single site

+10

Fix a broken script (with less than
50% success rate)

7

Upload a platform (multi-site)
script

+10 points + 0.1 points per site
(max of 30 points). Example:
uploading a script that automates
200 sites gets you 30 points
(10+0.1*200).

Download a script

1 points

Using the Script Portal
The following screenshot shows the SEnuke Script Portal:
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The following steps detail how to use the Script Portal.
1.

Download a script from the portal by clicking the Portal icon ( )in the
main window. You will be taken to a list of all scripts available in the portal.
The various columns will give you more details about each script. You can
click the column names to sort in ascending and descending order. The first
three columns (ID, Name, and Module) are self-explanatory.
The Downloads columns show you how many SEnukers have downloaded
that script. The scripts in SEnuke are going to continue to grow.
The Site Count column shows how many accounts a script automates. Most
scripts will automate just one site, but there are platform scripts that can
automate thousands of websites. Downloading a script costs one point,
regardless of how many scripts it automates.
The Version number increases by one each time someone makes a change
to that script and uploads it.
The Success Rate AC and Success Rate Posting columns show the account
creation and posting success rates. You can hide scripts that have less than
50% success rate in either account creation or posting. Scripts with a less
than 50% success rate are free to download for fixing purposes.

2.

To download a script, check all the sites that you would like to download
and click the Download Selected button. You can also Shift-Click or CtrlClick to select multiple sites.

3.

The scripts you have previously downloaded are colored yellow and are
free to download again, for example on different computers. Check the
Select/deselect previously downloaded scripts checkbox and click
Download Selected. Your currently installed scripts are in green and the rest of
the scripts are in whites.

Downloading a Script
1.

Select a script and click the Download Selected button.

2.

When the SEnuke Notification window is displayed, you will see a message
that informs you how many points the download will cost. If you previously
downloaded the script, it will not cost you anything. Click Yes to confirm
your selection. A message is displayed informing you that the number of
files you selected have been downloaded.
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3.

Click Yes.

4.

The site you selected turns green in the list, indicating that the script is on
your computer.

Uploading a Script
Uploading new scripts through the Script Portal is a simple process.
1.

Create a script in the Script Editor and click the Portal icon (

2.

Select Upload new script from the drop-down menu.

).

To keep all the scripts in the portal high quality, you first do some checks to
ensure the scripts are up to par for the Script Portal. If any of those tests fail, you
will see a Script Issues window that will tell you what is wrong. You can also
access this screen by clicking the Detect Issues icon (

).

After creating a script or modifying an existing script, every site that that script
automates must be tested in the SEnuke submitter. SEnuke will only let you
upload scripts to the portal once they succeed in the submitter.
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Testing Your Scripts
Select the script outside the Script Editor window and Click Start (go to Account
Creation Project and select a link – for example a link in the Social – Custom
window). After that whole process is done, you will be allowed to upload your
script to the portal.
►

Note: For those scripts that require account creation, the account creation script
must be tested along with the posting script. It is, however, possible to upload
scripts to the portal that does not require an account creation script. For
example, posting to guest books.
Keep in mind that the Script Portal works on a trust basis. While we do our best
to confirm that the script you are about to upload is a high-quality script before
you are allowed to upload it, you could take scripts that do nothing and upload
those to the portal. We are very strict in banning accounts that do that because
it can quickly deteriorate the quality of the portal. Please make sure you don’t
add any junk scripts to the portal. If you do, your access to the Script Portal will
be permanently banned. Even if you try to create a new SEnuke account in the
future, you will not be able to access the Script Portal. We will be taking this very
seriously.
Downloading a script that has lower than a 50% success rate in either account
creation or posting is free; it does not cost you any points. If you would like to
earn some quick points, simply download scripts with low success rates and fix
them. Fixing scripts is a much simpler task than creating a new script. It usually
involves modifying a couple of steps.

Fixing Scripts

►

1.

Download the script as normal.

2.

Open the script in the Script Editor and run it. The script will stop at the
broken step.

3.

Make the required modifications, then test the script outside of the Script
Editor once more.

4.

Once the script is tested, click the Portal icon ( ) and select Upload fixed
script from the list. Uploading a fixed script earns you seven points for
much less work than sharing a new script, which earns you 10 points.

Note: You will only earn points if you fix scripts that have lower than a 50%
success rate. If you improve upon scripts that already have a high success rate
you will not earn any points for that.
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Automating Multiple Sites
The process for working with scripts that automate multiple sites is very similar
to the process of working with a script that automates only one site. However,
you have some special tools available to you to make working with multiple sites
easier. If you click the Filter icon ( ), you will see a drop-down list of options
available to you when working with multiple sites:


Remove duplicates sites (same domain) – These sites have the same root
domain.



Remove duplicates sites (same URL) – These sites have the same URL.



Remove sites with less than 100% success rate – These sites have failed
tests in the submitter. If you have thousands of websites automated by
that script, you don’t have to go and remove each website one-by-one.

If you are fixing a script that automates multiple websites, keep in mind that
every single site that is automated by that script will need to be tested again
after your modifications. This can be a time-consuming process. So, make
changes to the script steps only if absolutely necessary.

Adding Sites to an Existing Platform
You can earn points by adding more sites to an existing platform script. Each site
that you add will give you 0.1 points for a maximum of 20 points. If you add 200
new websites to a script, you will add the maximum of 20 points.
To add new sites, paste them in the site list and then click the Newly Added Sites
button.
►

Note: This option will not delete any sites from the online version of the script.
Even if you have removed them from your local script file. It will only add new
sites to the online version of the script. Sites will automatically be removed from
the online version if they consistently get a low success rate.

Uploading New Categories for Sites
You can upload new categories for a website if the category list changes, and use
the Report a script as a junk script option. You would report a script as a junk
script if it does not do anything useful. For example, if script just logs into a
website and does not actually do anything further. The intent behind junk scripts
is to earn quick points without providing anything useful to the community.
These junk scripts will be investigated manually and people’s accounts will be
banned accordingly. When you report a script as junk, specify a precise reason of
why you think so. An example of such a reason is “The script does not do
anything after logging into the website.”
►

Note: If a user initially added steps to make a script useful, but now those steps
have stopped working because the website changed something, that type of
script should not be reported as a junk script.
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