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Chapter

1
Introduction to AutoCAD Plant 3D
The plant design industry creates and communicates a vast array of information. Because the industry
consists of many facets of design, the industry requires a broad solution. AutoCAD Plant 3D, and
Navisworks are two separate software applications that work together to meet the requirements of a
broad solution. In this chapter, you learn about many of the general topics for plant design and the use
of AutoCAD Plant 3D to create plant designs that meet your design requirements and workflows.

Objectives
After completing this chapter, you will be able to:
■

■
■

■

Navigate the Project Manager and explain the purpose of a project and where the drawings and
data are stored.
Open drawings within the context of the project from the Project Manager.
Identify the aspects of the user interface that are unique for plant design and the workflow for
creating and modifying a P&ID or 3D plant design.
Explain the philosophy behind the three methods of layering and explain the project setup options
for layers and colors.

Chapter Overview

■

1-1

Lesson: Working in a Project
This lesson describes how to navigate the Project Manager, the purpose of a project, and where the
data and drawings for a project are stored.
Because a complete plant design project can be composed of many different drawings files, it is
important to be able to efficiently access and create the files while keeping them associated with
the project. The Project Manager is the central hub where you access all of the drawings. Along with
providing easy navigation to the various drawings, you can also use the Project Manager to set up
drawings, establish common project settings, import and export data, and create project reports.

Objectives
After completing this lesson, you will be able to:
Describe how AutoCAD P&ID and AutoCAD Plant 3D projects work with data.
Explain how data is organized in AutoCAD Plant 3D.
Describe the Project Manager user interface.
Explain the purpose of the Data Manager.

■
■
■
■

About Projects
A project in AutoCAD P&ID or AutoCAD Plant 3D is made up of a collection of drawings and other
forms of data. When collected together, these data sources interact within the larger context of
a project. When you work with any individual component of the project, such as orthographic or
isometric drawings, you do so from within the project rather than by directly opening these drawings
from outside of the project. This approach maintains the integrity of the relationships between the
components within the larger project. One of the primary reasons to use AutoCAD P&ID or AutoCAD
Plant 3D instead of AutoCAD is that AutoCAD P&ID and AutoCAD Plant 3D create not just a simple
drawing but data associated with drawings and the items in them.

Project Components
Some of the drawings that are used as components of a project are:
■
P&ID
■
3D model
■
Orthographic
■
Isometric
Additional data that could be used as part of a typical project are:
■
Process information, such as stream tables.
■
Equipment and instrument cut-sheets.
■
Catalog and specs for piping.
■
Structural analysis, if required.
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Following is a diagram that illustrates how these components interact.

Project and Drawing Options
You can set options and other settings for the overall project or for individual components within the
project. You find most of these settings on right-click menus. Properties of the overall project affect the
project as a whole, and properties for individual components only affect those specific components.

Project right-click menu.

Drawing right-click menu.

Lesson: Working in a Project
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Data Organization
Data that is used in a project is organized in a system of default folders. These locations might
be different depending on what operating system you are using. If you work in a multiple user
environment, it is recommended that you store the data in a centralized network location. Following is
an example project folder structure:

Linked, Relative, and Absolute Paths
There are several ways to organize the files for a project. The most common way to do this is to store
them under a 'Projects' folder, with folders underneath corresponding to the projects that are being
worked on. A separate folder for templates can be created to store company or project standards.
All of these folders should be located in a place accessible to everyone working on the project. All of
the settings for the locations of these folders are located in the project settings described later on.
If you are confident that the project is not going to be moved or shared with someone in another
location, you can define the project's folders with absolute paths, which use the complete path to the
folder in the folder description. If there is the possibility of the project being moved or shared, it is
better to use the relative path option so that all of the project's subfolders are located relative to the
parent folder instead. This will keep the structure intact if necessary.
Once the project structure is set up, you can either copy or link existing drawings that need to be
used into the project. The Copy command makes a copy of the selected file and places it into the
project folder structure defined in the project settings. The link command creates a link, or shortcut,
in the project tree to the location of the drawing, but it does not move the drawing. Drawings that
are part of the project do not necessarily have to be in the defined project folders, although it is
recommended that you store them in a folder within the project.
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The Welcome Screen
When you open AutoCAD P&ID or AutoCAD Plant 3D, you are presented with a welcome screen, which
shows items you have been working on. The welcome screen varies in what it presents, depending on
the situation. You can stop its display by clearing the check mark from the Show this window at startup
option at the bottom of the welcome screen. The Project Manager is located on the left of the screen.
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About the Project Manager
The Project Manager provides access to the project-wide settings and data, as well as individual data
components within the project.

Current Project
At the top of the Project Manager palette is the Current Project list, which shows the current project
and enables you to select from other projects. Hovering over any of the project names in the
dropdown displays a tooltip of the actual location of the project. Other options in the dropdown
enable you to create a new project or to open an existing project.

Reports and Publish
In the Project Manager, to the right of the Current Project list are the Publish and Reports commands.
These commands are accessible project-wide. The Reports command provides access to tools that
include:
■
Data Manager
■
Import/Export
■
Reports

1-6
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Project Panel
The Project panel displays a "tree-view" of the drawings in the project. The most common tab
used is the Source Files tab. The drawings shown in the Source Files tab are P&ID drawings and 3D
model files. If your project is composed only of P&ID drawings, then there is no reason to go to
the Orthographic or Isometric tabs because they have files associated only with the 3D part of the
program.

Folders are organized to suit a particular project's structure or needs. However, what you see in the
project manager tree view may or may not be a 1:1 representation of the actual folders and drawings
in a project. When a folder is created, the option: Create folders relative to parent folder storage
location is available. If checked, the folder will be created in the project manager and the project folder
structure. If not checked, folders will be created as virtual folders with aliases to documents stored in
them.
The three folders that are in the top level of the tree (P&ID drawings, Plant 3D Drawings, and Related
files) can either be used as is, or they can have additional folders created to store drawings or links/
aliases to associated documents underneath them. These subfolders should be structured to match
the project structure. Drawings, folders, and other items in the tree can be arranged as necessary by
using standard Windows techniques, such as dragging and dropping.
The Related files folder is a convenient place to put links to documents associated with the project,
such as cut sheets, spreadsheets, and so on. As mentioned above, the folder can have additional
subfolders added to organize these files.
The Project Manager takes advantage of the fact that what you see in the tree is just a representation
of the folder or drawing in the project. The drawing icons change based on what is happening to the
drawings in the project. Some icon changes could include the indication of locked or missing drawings.

Lesson: Working in a Project
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Details/Preview/History Panel
The bottom panel of the Project Manager provides information about any one of the drawings
selected in the project panel. This panel toggles between basic drawing details, drawing preview, and
drawing history.
■
Details: provides basic details of the item selected, such as drawing location and size, the status of
the drawing and who created and worked on it last.
■
Preview: presents a thumbnail preview of the drawing selected.
■
History: provides a work history of the drawing. This enables you to track the status and notes
added to a drawing.

About the Data Manager
When you add items to a P&ID or to a 3D model, you are not just adding graphics to a drawing. Each
item added to a drawing can contain properties in addition to the graphical symbol in the drawing
screen. The Data Manager gives you another view into your project and the data in the project. You
use the Data Manager to create reports and import/output from your project data. You can also
change the data in the drawing by using the Data Manager.
The Data Manager information can be filtered to present:
Current Drawing Data
P&ID Project Data
Project Reports

■
■
■
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Exercise: Work in a Project
In this exercise, you open a project and examine the
various settings and data in the project. You then
explore project-wide options, and drawing-specific
settings.

Import a Project
In this section of the exercise, you import a project
and examine the various settings of the drawings and
data in the project.
1.
2.

Start AutoCAD Plant 3D.
If the Project Manager palette is not displayed,
on the Welcome screen, click Show Project
Manager.

3.

In the Project Manager, for Current Project,
click Open.

4.
5.

6.

In the lower section of the Project Manager,
examine the details of the drawing.

7.

Click Preview to preview the drawing.

Navigate to ..Plant Design\General Plant Design.
Open Project.xml.
In the Source Files tab, expand P&ID. Select the
PID001 drawing.

Lesson: Working in a Project
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8.

Click Work History to view the history of the
drawing.

9.

On the right side of the Project Manager, click
the Orthographic DWG tab. Examine the Ortho
data.

Project-Wide Options

10. Click the Isometric DWG tab. Examine the
Isometrics data.
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In this section of the exercise, you examine projectwide settings and data.
1. In the Project Manager, for Current Project,
click New Project to start the Project Setup
Wizard.
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2.

Examine the general settings available on the
first page of the wizard.

3.

Click Cancel. Click Yes. You do not create a new
project in this exercise.
In the Project Manager, right-click Training
Project. Click Properties.

4.

5.

In the Project Setup dialog box, examine the
settings and options available for the Project
Details. When finished, click Cancel.

6.

In the Project Manager, right-click Training
Project. Click Validation Settings.

7.

In the P&ID Validation Settings dialog box,
select some of the error reporting conditions
and review the descriptions. When finished,
close the P&ID Validation Settings dialog box.

Lesson: Working in a Project
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8.

At the top of the Project Manager, click Reports.
Click Data Manager. This gives access to the
database that is behind the drawings.
10. Close the Data Manager.
11. At the top of the Project Manager, click Reports
> Export Data. In the Export Report Data dialog
box, examine the Reports available.

9.

Examine the data in the Data Manager.

12. Close the Export Report Data dialog box.
13. At the top of the Project Manager, click Reports
> Reports. From the Project Reports list, select
Equipment List. Examine the report data.
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6.

Close the Data Manager.

14. Close the Data Manager.

Drawing Options
In this section of the exercise, you examine settings
and options for specific drawings in the project.
1.
2.
3.

4.
5.

In the Project Manager, click the Source Files
tab.
Expand Plant 3D Drawings. Right-click the
Structures drawing. Click Properties.
Examine the Drawing Properties dialog box.

Close the Drawing Properties dialog box.
Right-click the Structures drawing. Click Data
Manager. The Data Manager is displayed. This
is a filtered version of the Data Manager that
shows only data from this specific drawing, and
not the entire project.

Lesson: Working in a Project
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Review
A Plant 3D project consists only of drawing (.dwg) files.
True
False
The Project Manager identifies if someone else is working on a project drawing.
True
False
What are the two types of 2D drawings generated from the 3D model?
Orthographic drawings
Process flow diagrams
Isometrics
P&IDs
You can add additional data fields to customize the project database.
True
False
What happens if you use the Remove Drawing shortcut menu option on a file in the Project manager
tree?
The drawing will still be listed in the project, but the file will be deleted.
You will remove the file from the project, but the file will stay where it is on the drive.
You will put the file in the project trash can and the file will not be deleted.
You will remove the file from the project and delete the file.
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Lesson: Opening a Drawing
When you are working in Windows applications like AutoCAD P&ID and AutoCAD Plant 3D, you have
many different ways to open files. While you have multiple ways that you can open a drawing file, the
best way to access drawings is through the project manager. To realize the full benefit of projects and
the project manager, you must know how to open drawings within the context of the project and from
within the Project Manager.

Objectives
After completing this lesson, you will be able to:
■
■

Describe how AutoCAD P&ID and Plant 3D work with drawings.
Describe how AutoCAD P&ID and Plant 3D work with drawings.

Lesson: Opening a Drawing
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Opening Drawings
Opening Drawings
The best way to access the project and the drawings within AutoCAD P&ID or AutoCAD Plant 3D is
through the Project Manager.
From within the Project Manager, you open the drawings in the Project pane by:
■
Using the right-click menu
■
Double-clicking the drawing

Right-Click

Double-Click

Drawing Icons
Drawings in the Project Manager display icons to represent their status. The two primary icons are
a drawing lock that represents that the drawing is currently open, and the second is a slash that
indicates the drawing cannot be found. In the following example, the PID001 and Equipment drawings
are open, and the Structures drawing cannot be found.
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Drawing History
If the project has been set up to prompt for work history when you open a project, a dialog box
displays when the drawing is open in the editor to allow you to enter work history information.

Lesson: Opening a Drawing

■
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Renaming Drawings
Drawings can be renamed from the Project Manager. To do so, you right-click the drawing in the
Project Manager and select Rename Drawing. The Rename DWG dialog box is displayed and you enter
the new name. After clicking OK, the new name will be displayed in the Project Manager and the file
in the project will also be renamed.
The following illustration shows access to renaming drawings from the Project Manager.

The following illustration shows a drawing being renamed in the Rename DWG dialog box.
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Exercise: Open a Drawing in AutoCAD Plant 3D
In this exercise, you open and close drawings within
AutoCAD Plant 3D using various tools and options.

5.

You can open a drawing by double-clicking the
drawing in the Project Manager. Under the
Plant 3D Drawings, double-click the Equipment
drawing.

6.

You can open multiple drawings. With the
Equipment drawing still open, in the Project
Manager, double-click the Structures drawing.
To view the open drawings, on the status bar,
click Quick View Drawings.

The completed exercise

1.
2.

3.

4.

Start AutoCAD Plant 3D.
Set General Plant Design as the current project
as follows:
■
In the Project Manager, Current Project list,
click Open.
■
In the Open dialog box, navigate to the
folder ..Plant DesignGeneral Plant Design.
■
Select the file Project.xml.
■
Click Open.

7.

8.

Quick View Drawings displays images of
all open drawings in the lower center of
the drawing screen. To close the Structures
drawing, with the previews displayed, click the
Close in the Structures drawing preview.

9.

A third option to close drawings is to use the
Application menu in the upper-left corner of
the AutoCAD Plant 3D application. Select Close
from the menu. This gives you the option to
close either the current drawing or all drawings.

Right-click the PID001 drawing. Click Open.

To close the PID001 drawing without closing
AutoCAD Plant 3D, in canvas, click Close. This
returns you to the Welcome screen.

Lesson: Opening a Drawing
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Review
After you add a drawing to the project, it can only be opened in the Project Manager.
True
False
Plant 3D keeps a history of all of the times a drawing has been opened.
True
False
What are the ways a drawing can be opened from the Project Manager? (Select all that apply.)
Select the drawing and type the letter "O" for 'open'.
Right-click the drawing. Click Open.
Double click the drawing.
Select the drawing and double click on the drawing in the 'preview' window
What are the ways a drawing can be closed? (Select all that apply.)
Click Close in the program title bar.
Click Close in the drawing area.
Type 'Q' on the Command line.
On the Application menu, click Close > Current Drawing.
You can have multiple drawings open at one time in Plant 3D.
True
False
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Lesson: Exploring the User Interface
In this lesson, you learn how the AutoCAD Plant 3D commands are integrated into the standard
AutoCAD user interface.
AutoCAD Plant 3D is built on AutoCAD, and uses AutoCAD commands as a basis, with some AutoCAD
Plant 3D commands added to the ribbon menus, Properties palette, and right-click menus. The
approach is the same for both the P&ID and the 3D part of AutoCAD Plant 3D. Some of the commands
are for different types of items, whether they are in 2D or 3D. You can determine which set of
commands you wish to use through the Workspace command.

Objectives
After completing this lesson, you will be able to:
■
■
■
■
■

Identify how different workspaces are organized.
Explain how ribbons integrate AutoCAD Plant 3D and standard AutoCAD commands.
Describe how tool palettes are organized.
State the data that is added to the Properties palette.
Describe on-screen tools added to AutoCAD Plant 3D.

Lesson: Exploring the User Interface
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Task Specific Workspaces
In this section of the lesson, you explore how workspaces are integrated in AutoCAD P&ID and Plant
3D.

Workspaces Defined
The Workspace command allows you to set up and customize sets of commands so that they arrange
the interface to meet your specific need. AutoCAD P&ID and Plant 3D add several new workspaces to
standard AutoCAD:
■
3D Piping
■
P&ID PIP
■
P&ID ISO
■
P&ID ISA
■
P&ID DIN
■
P&ID JIS-ISO
The primary difference between the P&ID workspaces is the palettes of symbols that are displayed.
These change based on the P&ID standard on which the workspace is based.
You change the workspace using the Workspace Switching command on the AutoCAD status bar.

Task Specific Ribbons
The main method of interaction in AutoCAD P&ID and Plant 3D is the ribbon. To make design creation
and editing easier, the commands for creating and editing a P&ID or 3D plant design are arranged into
ribbon panels grouped by task. The majority of these task-specific panels reside on the Home tab. The
panels displayed on the Home tab vary based on the active workspace.
P&ID Home Tab Panels
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3D Piping Home Tab Panels

Isos and Structure Tabs
When the 3D Piping workspace is active, in addition to the panels on the Home tab, you have access
to the Isos tab and the Structure tab. The Isos tab contains the commands dealing with isometric
generation. The Structure tab has commands dealing with structural part generation in the 3D model
space.

Iso Tab

Structure Tab

You can drag a panel out of the ribbon and place it anywhere on the screen. This
enables you to have the commands on that panel available, even though you might
click on another tab on the ribbon.

Lesson: Exploring the User Interface
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There are additional context tabs that appear when you are in an orthographic
drawing.

About Tool Palettes
Tool palettes in AutoCAD P&ID and Plant 3D contain items specific to the workspace you are working
in. The differences between the P&ID workspaces are primarily in the symbols available on the tool
palettes.

P&ID Tool Palettes
The P&ID tool palettes are divided into tabs. The symbols on each tab are grouped to be similar in
layout to the class definitions in the project setup. Additional custom symbols that are created for
use in a project can be added to these palettes. In addition, in a multi-user project, a set of common
tool palettes can be created. You change the palette that is displayed by clicking on the tool palette's
properties and selecting another palette.

3D Tool Palettes
In the 3D Piping workspace, the tool palettes are divided into tabs. Each tab contains a selection of
items from a piping specification. The Dynamic Pipe Specification tab contains the specific information
for the current pipe specification. To display a pipe specification, you select it on the Part Insertion
panel. Once selected, the tool palette will be populated with the different components in that
specification.
One additional tab has pipe supports. Out of the box, these are not comprehensive. However, you can
add additional piping items as required to the tool palette using the commands available in the pipe
spec viewer. Unlike P&ID tool palettes, you are free to add, remove, change, or reorganize the tool
palettes to suit your personal preference.
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Changing Tool Palettes
You can switch between the tool palettes that correspond to different workspaces by right-clicking the
title bar, and selecting the tool palette from the menu. While you can switch to a different palette at
any time, you will typically do this if you switch from working on a P&ID to working on a 3D model.
Switching to a different standard within the same P&ID is not typically done nor needed.

You can customize these tool palettes using standard AutoCAD customization
commands.

Lesson: Exploring the User Interface
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About the Properties Palette
The Properties palette is a useful tool for viewing and changing properties of items that you select in
the drawing. It is recommended that you leave the Properties palette open and docked, so that as you
work with items you can view and access the properties of those items.

Accessing the Properties Palette
To access the Properties palette:
■
Double-click the item.
■
Right-click on the item. Click Properties.
■
Enter properties on the command line.
■
Press CTRL+1.
AutoCAD Plant 3D adds a section to the Properties palette specific to the item selected. For example,
if you are working on a P&ID and select a valve, a P&ID section is displayed at the bottom of the
Properties palette with P&ID properties. If you are working on a 3D piping drawing and select a valve,
a Plant 3D section is displayed with 3D properties of that object. The Plant 3D list of properties can
be quite long as there are a lot of properties involved with the 3D model, including but not limited to
pipe specs and part geometry.
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On-Screen Tools
The following commands and options are available when you select or hover over an item in the
drawing window. These options vary based on the drawing type and item selected.

Grips
A single click on an item in the drawing window selects the item and displays any grips that are
applicable to it. These grips allow you to modify the item in specific ways. Following is a partial list of
some of the AutoCAD Plant 3D-specific grips available, depending on what item you have selected:
■
Continuation grip
■
Endline grip
■
Substitution grip
■
Add nozzle
Refer to AutoCAD Plant 3D Help topics for a more comprehensive list and explanation
of grips.
Following are examples of grips:

Shortcut Menus
Right-clicking an object displays an item-specific menu. This menu has the standard AutoCAD items, as
well as additional AutoCAD Plant 3D menu items relevant to the selected object. Because these menus
vary based on the drawing type and item selected, you can use this menu as a shortcut to the menu
item you need.

Lesson: Exploring the User Interface

■

1-27

2D Grid and Snaps
It is strongly recommended that you use the standard grid/snaps in P&ID at all times. This assists
in lining up items and making sure the layout is spread out and organized in a standard manner. If
your P&ID is imperial, the industry standard snap spacing is 1/8". It can be helpful to first layout
equipment on a 1/4" grid, and position text on a 1/16" grid.

Object Snaps
While the use of object snaps is nothing new, one thing you may find different is that the node and
near object snaps are enabled by default in Plant 3D. These object snaps are on by default because
of their benefit in connecting a pipe to an existing one, connecting to nozzles, or positioning piping
components on a pipe.
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Exercise: Explore the User Interface
In this exercise, you explore the various commands
that have been added to AutoCAD as part of AutoCAD
Plant 3D. You examine tool palettes, ribbons, the
Properties palette, and on-screen tools.

The completed exercise

3.

In the Project Manager, double-click the PID001
drawing to open it. One of the first things you
notice is the custom tool palette and ribbon
layout.

4.

Examine the tool palette. Notice that by
default, AutoCAD Plant 3D defaults to a
workspace, tool palette, and ribbon for 3D
design.

Tool Palettes and Ribbons
In this section of the exercise, you explore
workspaces, tool palettes, and ribbons.
1.
2.

Start AutoCAD Plant 3D.
Set General Plant Design as the current project
as follows:
■
In the Project Manager, Current Project list,
click Open.
■
In the Open dialog box, navigate to the
folder ..Plant DesignGeneral Plant Design.
■
Select the file Project.xml.
■
Click Open.
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5.

Examine the ribbon layout.

6.

On the status bar, click Workspace Switching.

2.
7.

Select the P&ID PIP workspace.
3.

8.

Examine the changes on the tool palette and
ribbon.

4.

Properties Palette
In this section of the exercise, you view data for
objects in the Properties palette.
1. To open the Properties palette, in the drawing
screen, double-click the vessel as shown.
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To dock the Properties palette, press CTRL, and
dock it on the side of the canvas.
Note: It is recommended that you keep the
Properties palette open while working in
AutoCAD Plant 3D.
Examine the P&ID data that is specific to the
vessel selected.

■
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Select any other object in the drawing. Notice
that the data changes in the Properties palette
to represent the object selected.

On-Screen Tools
In this section of the exercise, you explore various
tools that you access directly on the drawing screen.
You explore:
■
Grips
■
Tooltips
■
Context menus
■
Grips in 3D drawings
1.

Select the valve as shown. Notice the custom
grips.

2.

Hover over the grip as shown. Notice that
you can substitute this valve with another
component.

3.

Use the Move grip to drag the valve to another
location on the line. This also breaks the line at
the new location.

4.

With the valve still selected, right-click and
examine the P&ID-specific commands available
on the context menu.

5.

Hover over any object in the drawing to display
a tooltip that provides information about that
object.

6.

In the Project Manager, under Plant 3D
drawings, double-click the Piping drawing to
open it.
In the lower-left of the model, select the Pipe
Inline Asset.

7.

8.

Click the Continue Pipe Routing grip.
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9.

To extend the pipe:
■
Drag and click the pipe to the desired
length, or enter a value.
■
Press ENTER to end the command.

When first starting work with AutoCAD Plant
3D, it is recommended that you select some of
the objects to become familiar with the custom
grips that are available.
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Review
Plant 3D introduces a whole new interface to AutoCAD.
True
False
The supplied AutoCAD P&ID and Plant 3D interface ribbons and palettes are not customizable.
True
False
What are the valid access points for the commands and options for creating and editing P&ID objects
in a drawing? (Select all that apply.)
Properties palette
Right click shortcut menu
Tool Palette
Ribbon menu
Tool palettes in AutoCAD P&ID and Plant 3D contain items specific to the workspace you are working
in.
True
False
Information that is added to the data manager always shows up on the P&ID.
True
False

Lesson: Exploring the User Interface
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Lesson: Managing Layers and Colors
Layers and colors are an important part of efficiently managing and interacting with the plant design
geometry. This lesson describes the layer palette and project setup options regarding layers and
colors. This lesson also explains the basic philosophy behind layering in a P&ID drawing, 3D model,
and 2D orthographic and isometric drawings.

Objectives
After completing this lesson, you will be able to:
■

Describe how layers are managed.

About Layers
About Layers
Layers and colors in AutoCAD Plant 3D are organized using two separate methods:
■
2D drawings use predefined layers in templates.
■
3D drawings can generate layers automatically during the design process based on automation
schemes.
Regardless of layer organization, it is recommended that you set the color of items to ByLayer. This has
several advantages including ensuring that objects of a particular color can be operated on by all the
options in the Layer palette.

2D Drawing Layers - P&IDs, Orthographic, and Isometrics
Layers in a 2D drawing are most closely associated with the organization, editing, and output of the
drawing into a final form, such as a DWF, PDF, or hardcopy. This means that the various objects on
the drawing are organized into layers associated with that general class of item. You use colors to
distinguish between the various objects so that you can tell each object at a glance. Depending on
the plotting options selected (ctb or stb) the color is also used to determine the line thickness of the
object on the output selected.
For example, on a P&ID, you organize the instrumentation onto an instrumentation layer, the
piping onto a piping layer, annotation onto an annotation layer, and so on. On an isometric drawing,
geometry may be on different layers based on the size of the pipe or fitting or other special
characteristics.
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Layers in the 3D model files
In a 3D model file, layers are used to organize the various items in the model into easily manageable
groups. This enables you to manipulate the model during the design process and to select items, such
as piping, steel, or equipment, as needed. Because every project in 3D is different, there are fewer set
standards for 3D.
Most companies have standards for how they want designers to use the layers in 3D. Typical layer
organization in 3D might be as follows:
■
Every piece of equipment is on its own layer, named after the equipment number.
■
The various types of structural steel have their own layers (stairs, supports, handrails), unless
they are associated with a piece of equipment, in which case they are on a layer named after the
equipment with the structure type appended to it; for example, P-100A_Supports.
■
Piping is a special case. You can set up an Automated Layer and Color Scheme depending on your
company standards. This enables you to automate the layers on which the piping and other inline
objects are placed to meet company standards. A typical standard for piping may be to have the
layer set to the line number, and the color of the layer set to the service of the line.
The following illustration shows access to the Layer and Color settings in the Project Setup dialog box.

Lesson: Managing Layers and Colors
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Exercise: Manage Layers and Colors
In AutoCAD Plant 3D, layers are used to both manage
items in a 3D model and organize how the final
drawings will be output in the 2D drawings. In
this exercise, you explore the various areas that
demonstrate where layers are set and used in an
AutoCAD Plant 3D project.

P&ID Layers
In this section of the exercise, you explore P&ID layers
in a template.

6.

1.
2.

P&ID Symbol Layer Management

3.

Start AutoCAD Plant 3D.
Set General Plant Design as the current project
as follows:
■
In the Project Manager, Current Project list,
click Open.
■
In the Open dialog box, navigate to the
folder ..Plant Design\General Plant Design.
■
Select the file Project.xml.
■
Click Open.

In this section of the exercise, you explore how layers
are used in P&ID symbol definitions.
1. In the Project manager, right-click Training
Project. Click Properties.

To open and examine the layers in a template
drawing, click New Drawing.
2.

4.
5.

1-36

Close the drawing.

Select the PID ISO A1 - Color Dependent Plot
Styles.dwt template. Click Open.
Open the Layers Properties Manager. Examine
the layers that are in this template.

■

Chapter 1: Introduction to AutoCAD Plant 3D

In the Project Setup dialog box, expand: P&ID
DWG Settings > P&ID Class Definitions >
Engineering Items > Equipment > Blowers.
Select Centrifugal Blower.

3D Object Layer Management
In this section of the exercise, you explore how layers
are used in 3D object definitions.
1.
2.

3.
4.

5.
6.

In the Project Manager, right-click the Training
Project. Click Properties.
In the Project Settings dialog box, expand
Plant 3D DWG Settings. Select Layer and Color
Settings.

In Class setting: Centrifugal Blower, click Edit
Symbol.
In the Symbol Settings dialog box, notice that
this symbol color is set to ByLayer, and the layer
is set to Equipment.

3.

In the Automated Layer and Color Assignment
section, examine the settings:
■
Automation Schemes is set to Default.
■
Assign Layer By is set to Line Number Tag.
■
Assign Color By is set to Nominal Diameter.

4.

Under Assign Color By, select Service. Examine
the changes that are made to the Color
settings.

5.

Close the Project Setup dialog box.

Explore the settings for some of the other
symbols.
Close all open dialog boxes.

3D Layers
In this section of the exercise, you explore layer
settings in a 3D template.
1. Click New Drawing.
2.
3.

4.
5.

Select the Plant 3D ISO - Color Dependent Plot
Styles.dwt template. Click Open.
Open the Layers Properties Manager. Notice
this template only has a 0 layer.

Close the Layer Manager.
Close the drawing.
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3D Layers in a Drawing
In this section of the exercise, you open a 3D drawing
and examine the layers that have been generated.
1.
2.

In the Project Manager, under Plant 3D
Drawings, double-click the Piping drawing to
open it.
Open the Layer manager and examine the
layers.
Note: These layers were automatically created
while adding objects to the drawing based on
the automation scheme.

3.

Close the drawing.
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Review
Layers in the 3D model are used to organize the various items in the model into easily manageable
groups.
True
False
Piping has one layer associated with each pipe line.
True
False
What is the recommended method for setting the color of P&ID and Plant 3D objects?
ByLayer
ByStandard
ByObject
ByBlock
You configure the layer and color settings for a P&ID drawing in the same manner you configure for the
3D models in a Plant 3D drawing.
True
False
Which types of drawings have their drawing geometry organized into layers associated with that
general class of item so the geometry displays correctly when printed? (Select all that apply.)
P&IDs
Isometrics
3D Models
Orthographics

Lesson: Managing Layers and Colors
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Chapter Summary
In this chapter, you learned about many of the general topics for plant design and the use of AutoCAD
P&ID and AutoCAD Plant 3D to create your plant designs and meet those design requirements and
workflows.
Having completed this chapter, you can:
■

■
■

■
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Navigate the Project Manager and explain the purpose of a project and where the drawings and
data are stored.
Open drawings within the context of the project from the Project Manager.
Identify the aspects of the user interface that are unique for plant design and the workflow for
creating and modifying a 2D or 3D plant design.
Explain the philosophy behind the three methods of layering and explain the project setup options
for layers and colors.

■
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Chapter

2
AutoCAD P&ID
When you are creating piping and instrumentation diagrams (P&ID), you are creating a schematic
representation of the sequence of equipment and systems in a plant design. During the creation of
P&IDs, there are many tasks that you need to accomplish before the design is complete. Some of those
tasks include adding industry-standard symbols to the drawing, breaking and mending lines, ensuring
flow direction, adding tags and annotations in industry-formats, identifying and correcting potential
inconsistencies, and sharing project information. In this chapter, you learn how to use AutoCAD P&ID
to create, modify and manage 2D piping and instrumentation diagrams for a plant design.

Objectives
After completing this chapter, you will be able to:
■

■

■

■
■

■
■

■

■
■

■

Add drawings to a project by creating new drawings, linking to existing drawings, and copying them
from another project.
Place equipment, set the tag, see the pre-defined type, and make changes to a symbol like adding
nozzles.
Add pipelines to connect equipment, group pipe segments, assign tags and information to the line,
and add and remove components to the line.
Add general and in line instruments and set up an instrument loop.
Describe the purpose of tags and create unique tags including a unique tag that links symbols over
multiple drawings.
Place annotations and modify the properties and data driving the annotations.
Make changes and modifications to the generated P&ID using AutoCAD P&ID's Sline grips and
substitute arrow commands and with AutoCAD's move, copy and stretch commands.
Use the Data Manager to create reports, review information in the P&ID, export the data to
external files (XLS, XLSX, CSV) and import that same data again after revising externally. Also adjust
the columns displayed in the Data Manager.
Create one-off symbols by converting inserted blocks of symbols to P&ID objects.
Add off-page connectors and connect these with other drawings and utilize them to navigate
between drawings.
Use the identified advanced topics to assist in creating a P&ID and use the validation tool to
validate that the P&ID is consistent.
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Conduct administrative functions that are relevant for a P&ID user.
Use of Report Creator to generate different reports of a plant design.

■
■
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Lesson: Creating a New Drawing
New design projects often consist of a combination of new designs and the reuse of aspects of existing
designs. To have all of the required drawings properly associated to your project, you need to know the
proper way to create new drawings and leverage existing drawings. This lesson describes how to add
drawings to the active project by creating a new P&ID drawing and copying an existing drawing from
another project to the active project.

Objectives
After completing this lesson, you will be able to:
■
■
■
■

Create project folders and sub-folders in the current P&ID project.
Create a new drawing in a P&ID project.
Link or copy an existing drawing to the current P&ID project.
Access the drawing properties for a drawing in the current P&ID project.

Creating Project Folders and Sub-Folders
To help organize your P&ID drawings in the Project panel, you can create folders and subfolders
under the P&ID Drawings folder in the Project Manager. The process of creating the folders is
straightforward, just like creating folders in Windows Explorer.
The following illustration shows the sample project with drawings organized into project folders and
sub-folders.

Lesson: Creating a New Drawing
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Process: Creating Project Folders and Sub-folders
You create a project folder or subfolder by right-clicking P&ID Drawings in the Project Manager and
then clicking New Folder on the shortcut menu. Within the Project Folder Properties dialog box, you
then enter the name of the folder, specify whether a drive folder should also be created for drawing
storage, specify what template to use, and specify whether you should be prompted for a template
for each drawing to be created.

Creating a Drawing
As a P&ID Project progresses, it is likely that additional drawings will be added to the project. The
Project Manager enables you to quickly create a new P&ID drawing.

Process: Creating a New Drawing
You can add new drawings to the current project by right-clicking the P&ID Drawings folder in the
Project pane of the Project Manager and clicking New Drawing. The New DWG dialog box will be
displayed. Here, you can name the drawing, enter the drawing author, and browse to select a DWG
template.
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Adding Existing Drawings to the Project
You often need to include existing drawings in the current P&ID project. Adding existing drawings
enables you to work more efficiently by reducing the amount of new data created. The Project
Manager enables you to copy drawings to the current project.

Process: Adding Existing Drawings to the Project
To copy a drawing to the current project, you right-click the P&ID Drawings folder and select Copy
Drawing to Project. You then navigate to the drawing file location and select the desired drawing file.
When you copy a drawing to a project, the original drawing remains in its current location, and a copy
of the selected drawing is made and added to the current project.

Access Drawing Properties
The Drawing Properties enable to you to assign basic information to the drawings in your P&ID
project.

Lesson: Creating a New Drawing
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The following illustration shows the Drawing Properties dialog box for AutoCAD P&ID.

You access the drawing properties of a P&ID drawing by locating the drawing in the Project pane of
the Project Manager, right-clicking, and clicking Properties. This displays the Drawing Properties dialog
box.
The following illustration shows accessing the Drawing Properties of a P&ID drawing.
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Exercise: Create a New P&ID Drawing
In this exercise, you learn to create a new drawing,
link a drawing to the project, and copy an existing
drawing from another project to the active project.

3.

To open a P&ID drawing:
■
In the Project Manager, expand P&ID
Drawings.
■
Right-click PID001.
■
Click Open.

4.

To create a new P&ID drawing:
■
In the Project Manager, under Training
Project, right-click P&ID Drawings.
■
Click New Drawing.

In a real-life environment, often drawings exist
that need to be added to the project. You have the
chance to reuse existing drawings and information to
streamline the creation process.

The completed exercise

1.
2.

Start AutoCAD P&ID.
Open an existing project by doing the following:
■
In the Project Manager, Current Project list,
click Open.
■
In the Open dialog box, navigate to the
folder ..Plant Design\Creating a New P&ID
Drawing.
■
Select the file Project.xml. Click Open.
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5.

To define basic drawing properties:
■
In the New DWG dialog box, for File Name,
enter PID002.
■
If desired, under Drawing Properties >
Author, enter an author's name.
■
If desired, select a DWG template.
■
Click OK.

6.

The new P&ID drawing is created.

7.

To edit the drawing properties:
■
In the Project Manager, under Training
Project > P&ID Drawings, expand P&ID
Drawings.
■
Right-click PID002. Click Properties.
■
In the Drawing Properties dialog box, under
General, for Description, enter New P&ID
Drawing.
■
Click OK.
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8.

To create a project folder:
■
In the Project Manager, right-click P&ID
Drawings.
■
Click New Folder.

9.

To assign property information and create
nested folders on the hard drive:
■
In the Project Folder Properties dialog box,
enter Area 10.
■
Select Create Folder Relative to Parent
Folder Storage Location, so that the check
mark is displayed.
■
Note the change in the Store New Project
DWG Files In location.
■
Click OK.

12. In the Project Data Merged dialog box, click
OK. The drawing is copied to the project and
displayed in the Project Manager. The PID003
and PID004 drawings in the project are located
in the P&ID Drawings folder for this active
project.

10. Create another folder called Area 20. The
folders are displayed in the Project Manager.

13. Close all files. Do not save.

11. To copy a drawing to the project:
■
In the Project Manager, right-click P&ID
Drawings.
■
Click Copy Drawing to Project.
■
Navigate to the folder containing the
project file and SHIFT+Select PID003.dwg
and PID004.dwg.
■
Click Open.

Lesson: Creating a New Drawing
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Review
What drawing properties are available by default?
DWG Number
DWG Title
DWG Revision
Description
Which property is mandatory when creating a drawing?
DWG Number
DWG Title
Author
Description
You can move drawings around in the project.
True
False
How do you rename or remove folders from the project?
Just renaming the folder and/or the drawing with Windows Explorer is sufficient.
By using the context menu (Right-Click) on the Project Manager.
You can move a drawing to a different folder in Project Manager.
True
False
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Lesson: Equipment and Nozzles
In this lesson you learn to place equipment, set the tag, see the pre-defined type and make changes to
a symbol using the P&ID object edit function. You also learn how to manually add nozzles to a symbol
without changing the original symbol.
Because P&IDs represent the piping, equipment, and control devices in diagram form, the place to
start when creating a P&ID is to add the equipment to the drawing. After you add the equipment, such
as tanks and heat exchangers, you are then able to connect the equipment with lines. To establish this
starting point, you need to know how to add equipment to the drawing and manipulate it after it has
been added.
The following illustration shows the beginning of a design after adding equipment symbols for two
vessels, a tank, a pump, and an exchanger.

Objectives
After completing this lesson, you will be able to:
■
■
■
■

Add P&ID equipment to a drawing.
Modify an existing P&ID symbol.
Add a nozzle to a P&ID symbol.
Add Tag information to new and existing components in a P&ID design.

Lesson: Equipment and Nozzles
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Adding Equipment
Knowing how to access the Equipment tool palette, then locate and insert enables you to create P&ID
designs efficiently. The equipment required to create a P&ID design is located on the Equipment tool
palette, which is divided into logical groups to enable you to quickly find the P&ID symbol needed.
The following illustration shows the Tool Palette -P&ID PIP palette with the Equipment palette active.

Process: Adding Equipment
The process for adding P&ID equipment to your design is very straightforward. To add equipment,
you locate the desired symbol in the appropriate group and click it, then click in your drawing where
the symbol is to be located. Depending on which symbol is selected, you may be able to perform
additional operations such as scaling.
The following illustrations show a Horizontal Centrifugal Pump being selected in the Equipment tool
palette, then being located in the drawing.
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Modify an Existing P&ID Symbol
Often at some point in the design process, a P&ID symbol will require some type of change. Should this
situation occur, it is important to know how to edit an existing symbol. Even though the edited P&ID
symbol is an AutoCAD block, it will still remain independent of other similar symbols when edited.
The following illustration shows a P&ID symbol being edited in the Block Editor.

Lesson: Equipment and Nozzles
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Process: Modifying an Existing P&ID Symbol
To edit an existing P&ID symbol, you open it in the AutoCAD block editor. To do so, you select the
desired symbol in the drawing and right-click. From the menu, select Edit P&ID Object's Block.
The block opens in the AutoCAD block editor. There, you can modify the geometry to match your
situation. Also, as shown here, you can add geometry to the symbol.

Adding Nozzles
A storage tank is not useful without the ability to add or remove contents. While some nozzles are
automatically added to the design, such as when a pipe line is connected to a tank, often you need to
manually add a nozzle to the design.
The following illustration shows a typical P&ID design with various types of equipment, all requiring
nozzles.
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Process: Adding Nozzles
To add a nozzle to a component in a P&ID drawing, you need to access the available nozzles on the
Fittings tool palette. You click the desired nozzle, then click the component that it will be attached to.
Then you click or enter a numerical value to set the orientation of the nozzle.

Adding Tag Information
Virtually every component of a P&ID design can have information assigned to it using a Tag. In some
cases, when you insert a P&ID symbol the Assign Tag dialog box is displayed, prompting you to enter
or select tag information. In other cases, tag information can be added after the symbol is inserted.
The following illustration shows the Assign Tag dialog box. In this case, the dialog box was
automatically displayed upon the insertion of a P&ID Tank.
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Process: Adding Tag Information
Tag information is added in the Assign Tag dialog box. This dialog box is automatically accessed when
you insert certain symbols. To edit Tag information or add it to symbols where the dialog box is not
automatically displayed, you right-click the symbol and click Assign Tag in the menu. From this point
on, the process for adding or editing tag information is the same.
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1.
2.

Access the Assign Tag dialog box.
Enter the Number value or select
Number (arrow) to assign the next
sequential number of that type of
object selected.

3.

To display the tag information in the
drawing, select the Place annotation
after assigning tag check box.

4.

Select the Annotation Style.

■
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5.

Place the tag in the drawing (if it is to
be displayed).
Any time the data is changed, the tag
will automatically update with the
changes.
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Exercise: Equipment and Nozzles
In this exercise, you learn to place equipment, set
the tag, see the predefined type and make changes
to a symbol using the P&ID object edit function. You
also learn how to manually add nozzles to a symbol
without changing the original symbol.
6.

On the Tool Palettes - P&ID PIP, click the
Equipment tab.

7.

To begin to insert a vessel, on the Equipment
tool palette, under Vessel and Miscellaneous
Vessel Details, click the first icon as shown.

8.

To locate and scale the vessel:
■
To locate the vessel, click a point in canvas
near the lower left corner as shown.
■
To scale, move the cursor and note the
change in size.
■
At the Scale Factor prompt, enter 25.

The completed exercise

1.
2.

3.
4.
5.
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Start AutoCAD Plant 3D.
Open an existing project by doing the
following:
■
In the Project Manager, Current Project list,
click Open.
■
In the Open dialog box, navigate to the
folder ..Plant Design\Equipment and
Nozzles.
■
Select the file Project.xml.
■
Click Open.

In the Project Manager, open PID002.dwg.
Click Workspace Switching > P&ID PIP.
To switch to model space, on the status bar,
click Model.

■
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9.

To assign tag information:
■
In the Assign Tag dialog box, note the Type.
■
For number, click the icon at the end of
the field, as shown. P&ID will search the
document and display the next available
number.

10. To place the annotation in the drawing:
■
Under Existing Tanks, select Place
Annotation After Assigning Tag, so that the
check mark is displayed.
■
For Annotation Style, select Equipment Tag.
■
Click Assign.

11. To place the annotation in canvas, click above
the vessel as shown.

12. Copy the vessel using standard AutoCAD
techniques as shown.
Note the question mark of the annotation tag
of the copied vessel.

Lesson: Equipment and Nozzles
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■

■

■
■

For Number, click the next available
number icon.
Under Existing Tank, select Place
Annotation After Assigning Tag.
Click Assign.
Locate the tag near the new tank.

13. To update the annotation tag:
■
Right-click the copied vessel.
■
Click Assign Tag.
■
In the Assign Tag dialog box, for Number,
click the icon for the next available number.
■
Under Existing Tanks, clear the check mark
for Place Annotation After Assigning Tag.
■
Click Assign.

16. To place a pump:
■
On the Equipment tool palette, under
Pumps, select Horizontal Centrifugal Pump.
■
In canvas, click to the right of the tanks.
■
In the Assign Tag dialog box, click the next
available number icon.
■
Place the annotation tag near the pump.

14. To place a storage tank:
■
On the Equipment tool palette, under
Storage Tanks, click Open Top Tank.
■
In canvas, click above other tanks.
■
For scale, enter 10.
15. To assign tag information:
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17. Using the same process as the tanks and pump,
place a TEMA-type BEM Exchanger next to
the tanks. For Number, manually enter 005.
Show the annotation tag and place it within the
exchanger.

18. On the Tool Palettes tab, click Fittings.

■

■

To locate the nozzle, click the right vertical
line of the tank.
To orient the nozzle direction, move the
cursor directly to the right of the location.
Click in canvas.

20. Using the same process defined in the previous
step, add a Flanged Nozzle to the same tank as
shown.

19. To add a nozzle to a tank:
■
On the Fittings tool palette, under Nozzles,
click Single Line Nozzle.
■
To select the tank, click the geometry that
defines tank TK-004.
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21. Move the cursor to the first nozzle placed. Note
the tooltip information. The tag information is
already assigned.

22. To display the tag:
■
Right-click the nozzle.
■
Click Annotate > Tag.
■
Place the annotation tag next to the nozzle.

23. To edit a P&ID symbol:
■
Right-click tank TK-005.
■
Click Edit P&ID Object's Block.
■
In the Block Editor, using standard AutoCAD
tools, add the line and circle as shown.
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24. In the Edit P&ID Object's Block dialog box, click
Save Changes and Exit Block Editor.
Note that only tank TK-005 was changed.

25. Close all files. Do not save.

Review
Can you see, when setting the tag, if a tag number is already in use?
No. The validation function will tell you if a tag is already in use.
Yes. The "Assign Tag" dialog box shows the list of already used tags.
No. There is no check for that.

When you modify a symbol, will the original symbol change as well.
True
False
There is a limit on how many nozzles can be added to a tank.
True
False
How can you change the tag of a symbol, are there more ways to achieve that?
You can’t change the tag of a symbol. You have to delete the symbol and insert it again.
You can change the tag using the AutoCAD Properties Palette.
You can change the tag by using the Data Manager.
You can make a double-click on the tag.
With pump symbols you don't see nozzles; however in the Data Manager nozzles are shown. How can
this be happening?
Because it is set this way in the project setup, but it can be changed.
Pump symbols never show nozzles.

Lesson: Equipment and Nozzles
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Lesson: Piping
Creating and modifying pipe and instrumentation lines in a P&ID drawing is an important task. In this
lesson, you learn how to work with pipelines (Sline), including how to add pipelines to connecting
equipment, group pipe segments, assign tags and information to the line, and add and remove line
components. With each pipe line created, flow arrows display to indicate the direction of travel. These
lines also dictate the orientation of check valves when they are used. Also, each time a line is attached
to a vessel or tank, a nozzle is automatically displayed at the connection point.

Objectives
After completing this lesson, you will be able to:
Add pipe lines to a P&ID design.
Connect unassigned lines to a P&ID component.
Annotate lines used in a P&ID drawing.
Insert valves into a P&ID design.
Group lines to a common line number.

■
■
■
■
■
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Creating Lines
Every plant uses piping and instrumentation to complete the tasks it has been designed to do.
Therefore, every P&ID design will require the use of pipe and instrumentation lines.
Pipe lines are the arteries of a P&ID design. Without them, the needed fluids and gasses cannot move
about the plant and perform the functions required to manufacture products. Knowing how to create
pipe lines, assign data to them, and edit them is essential to creating any P&ID Project.
Instrumentation lines are just as critical. Instrumentation allows you to monitor what is going on
internally in pipe lines, tanks, and other components within a plant. Proper implementation of
instrumentation lines is critical to the everyday safety and operations of any plant.
The following illustration shows the Lines tool palette. This palette contains the tools to add both
piping and instrumentation lines to your drawing. You add piping and instrumentation lines using the
same process, but the linetype and locations differ.

Process: Creating Lines
To add a line to a P&ID design, you first select the type of line to add on the Lines tool palette. From
there you select the points to define a starting point (1). Since all lines are created orthogonally, you
need to add any jogs (2) in the line to arrive at the termination point (3).
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Attaching Lines to a Component
Generally lines start and terminate at a component within the P&ID design. When that option is not
available, you need to manually attach the line to the component.
A quick and easy way to review the from and to attachment information for a line is to hover the
cursor over the line. Based on the information in the tooltip, you can determine if either end is not
attached. In the following illustration, the tooltip information for a line is shown before and after
attaching the end to the tank.

Process: Attaching Lines to a Component
The following steps describe how to attach a line when the line is not already physically attached to a
component.
1.
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Right-click the line. Click
Schematic Line Edit > Attach
to Component.
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2.

Select the Component and
then select the endpoint of
the line.

Annotating Lines
Each line placed in a drawing has a specific purpose. To ensure an accurate design, each line should be
tagged with all pertinent information.
The following illustration shows access to the Assign Tag dialog box. You use this dialog box to assign
tag information to different components in a P&ID design. In this instance, the line is selected for the
input or editing of tag information.
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Process: Annotating Lines
The following illustrations show the Assign Tag dialog box and the resulting tag applied to a pipe
line. After accessing the Assign Tag dialog box, you fill in the required data to fulfill your design
requirements. To display the tag on the drawing, you place a check mark in the Place Annotation After
Assigning Tag check box. When you are satisfied with the data entered, you click Assign and then click
in the drawing to locate the tag if displayed.

Inserting Valves
Valves are critical to a P&ID design because they control the flow through the different pipes. When
valves are inserted into a pipeline, they will automatically break the line and be oriented to the line. If
the valve has flow control, it will match the flow direction of the line.
Valves are inserted into P&ID designs in the same manner as most other symbols. To insert a valve you
locate the desired valve on the Valves tool palette. Click the desired valve and then click an insertion
point in the P&ID design. To edit the Tag information, you right-click the valve and select Assign Tag
from the menu.
In the following illustrations, a check valve is selected in the Valves tool palette and then inserted in a
pipe line in the design. Notice that the flow direction of a check valve is critical. Since the line has an
assigned direction, the check valve will automatically be inserted in the proper direction.
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Grouping Lines
You group lines when you want to group various pipe line segments into one pipe line group.
The reason for grouping lines is that the pipe line group is carrying the line number and service
information. Typically, a line list is created, which is made up of the pipe line group information. The
line number is a vital part of that list.
When a line is started on an existing line, it will be assigned to the line group of the existing line.
However, if a line is terminated on an existing line, it will not be automatically assigned to the existing
group.
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The following illustrations show two lines before and after the grouping process. The tag information
for the top line is automatically updated to display the Pipe Line Group Service designation and the
Group Line Number.

Process: Grouping Lines
To group lines, you start the Make Group command. You are prompted to select the source line. The
tag information assigned to this line will be the data used for both lines. You then select additional
lines to be added to the group.
The following illustration shows how to access the Make Group command on the ribbon.

Guidelines
Follow these guidelines when creating lines and line groups:
■
Pipe line groups carry line number and service information.
■
A line started on an existing line is automatically assigned to that existing line’s group.
■
A new line terminating to an existing line will not be automatically assigned to the existing group.
■
When creating a new line group, the tag information assigned to the first selected line is the data
used for all lines added to the group.
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Exercise: Place Lines and Inline Components
In this exercise, you add pipe lines to connect
equipment and then add valves and reducers to the
line to complete it. Finally, you place a spec breaker
and delete a previously placed reducer.

6.

To add pipe lines to the design:
■
On the Lines palette, under Pipe Lines, click
Primary Line Segment.
■
Select a point above TK-004 (1).
■
Track from the top of tank TK-005 and
select the intersection of the line and the
tracking point (2).
■
Select the top quadrant of TK-005, as shown
(3).
Note that a nozzle is automatically added.

7.

To add a line to the open tank:
■
Start the Primary Line Segment.
■
Select tank TK-005 as shown (1).
■
Click above the open tank (2).
■
Click near the opening of the open tank (3).

The completed exercise

1.
2.

3.
4.
5.

Start AutoCAD Plant 3D.
Open an existing project by doing the following:
■
In the Project Manager, Current Project list,
click Open.
■
In the Open dialog box, navigate to the
folder ..Plant Design\Place Lines and Inline
Components.
■
Select the file Project.xml. Click Open.
Open PID002.dwg.
Click Workspace Switching > P&ID PIP.
To make the Lines palette current, on the Tool
Palettes - P&ID PIP, click the Lines palette.
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8.

9.

Using the same technique, add the following
four pipe lines to the design:
■
(1) From TK-005 to the pump nozzle.
■
(2) From the top pump nozzle to the nozzle
on tank E-005.
■
(3) From the nozzle on E-005 to TK-005.
■
(4) From below the object to the junction
on line (1).

To assign tag data:
■
Right-click line 4 from the last step. Click
Assign Tag.
■
In the Assign Tag dialog box, enter the data
as shown.

10. To place the tag:
■
In the Assign Tag dialog box, under Existing
Pipe Line Segments, select Place Annotation
After Assigning Tag.
■
Click Assign.
■
Place the annotation near the line.
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11. Assign tag data to the line going from TK-005
to P-005. In the Assign Tag dialog box, enter
the same values as before, except for Pipe
Line Group.Line Number, enter 002. Place the
annotation near the line.

12. To group pipe segments:
■
Move the cursor to the segment from
TK-005 to the pump (1). Note the line
segment that highlights.
■
On the ribbon, click Home > Line Group
panel > Make Group.
■
When prompted to select the Source Line,
select the line from TK-005 to the pump.
■
When prompted to add lines, select the line
to the pump (2).
■
Press ENTER.
■
Move the cursor over either of the lines.
Note that they both highlight and that the
group numbers match.

13. To access tag information for the pipe line:
■
Hover the cursor over the line from empty
space to TK-005. Note the information
already assigned to the pipe.
■
Right-click the pipe.
■
Click Assign Tag.

14. To assign information to the line:
■
In the Assign Tag dialog box, select the
information from the lists as shown.
■
For Pipe Line Group.Line Number, enter
1000.
■
Under Existing Pipe Line Segments, select
Place Annotation After Assigning Tag.

15. To add the tag to the design:
■
Click Assign.
■
Click above the line to place the tag
information.

16. To add the same annotation to a different
segment of the line:
■
Right-click the same pipe just above TK-005.
■
Click Annotation > Pipeline Tag.
■
Place the tag.
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17. On the Tool Palettes, click the Fittings tool
palette.

18. To add a reducer to the pipe segment:
■
On the Fittings tool palette, under Piping
Fittings, click Concentric Reducer.
■
Click the pipe line as shown.
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19. To edit the reducer size:
■
Right-click the pipe line to the left of the
reducer.
■
Click Assign Tag.
■
In the Assign Tag dialog box, for size, select
4".
■
Clear the check mark for Place Annotation
After Assigning Tag.
■
Click Assign.
Note the new values and the orientation of the
reducer.

20. To delete the reducer:
■
Right-click the reducer.
■
Click Erase.
■
In the Select Segment dialog box, click Keep
Segment 2.
■
Click OK.

21. Make the Non-Engineering tool palette active.
22. To add a Segment Breaker to the design:
■
On the Non-Engineering palette, under
Miscellaneous Symbols, click Segment
Breaker.
■
Select the pipe as shown.

23. To modify the pipe and update the segment
breaker:
■
Right-click the pipe segment to the left of
the segment breaker.
■
Click Assign Tag.
■
Change the Spec to CS300.
■
Verify that Place Annotation After Assigning
Tag is not selected.
■
Click Assign.

24. Make the Valves tool palette active.
25. To insert a valve:
■
On the Valves tool palette, under Valves,
click Gate Valve.
■
Select the pipe segment at the bottom of
TK-005 as shown.

26. To move the valve to a different pipe segment,
select the valve and drag it to the new location,
as shown. Press ESC to clear grips.
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27. To place a check valve:
■
Under Valves, click Check Valve.
■
Select the pipe segment from the pump to
E-005.
Note that the direction of the valve matches
the direction of the pipe flow.

28. To review pipe information:
■
Hover the cursor over the segment going
from TK-005 to the TK-006 (Open Tank).
■
Note that the line goes from TK-005 to
Unassigned.
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29. To assign a pipe to a component:
■
Right-click the pipe segment.
■
Click Schematic Line Edit > Attach to
Component.
■
Select TK-006 (Open Tank).
■
Select the endpoint of the pipe line.

30. Close all files. Do not save.

Review
When deleting a reducer or spec break, how do you determine which info of the line remains?
You can’t.
You will be asked.
A placed check valve, looks at the pipeline to determine the flow direction.
True
False
When the flow direction changes of a pipeline, the reducer also changes its direction.
True
False
How can you change the flow direction of a check valve without changing the flow direction of the
pipeline?
By selecting the check-valve and click in the flow grip.
By making a right-click on the check-valve and select "change flow direction".
Which information is updated to the pipeline through the pipeline group?
Spec
Size
Line Number
Service

Lesson: Piping
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Lesson: Instruments and Instrument Lines
In this lesson, you learn to place the different types of instruments and to set up a measurement loop
using instruments and several different instrument lines. You also learn the difference between a
general instrument and an inline instrument.
In the following illustration, a section of the design is shown before and after instruments and
instruments lines.

Objectives
After completing this lesson, you will be able to:
■
■
■

2-38

Add general instruments to a P&ID design.
Add inline instruments to a P&ID design.
Add instrumentation lines to a P&ID design.

■
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Adding General Instruments
General Instrument symbols are used in a P&ID design to represent instrumentation that monitors the
various lines and components in the design. You access General Instruments from the Instruments tool
palette.
The following illustration shows the General Instruments panel on the Instruments tool palette.

Process: Adding General Instruments
To add a General Instrument symbol to a P&ID drawing, you access the Instruments > General
Instruments tool palette and select the desired instrument symbol. You then click in canvas to locate
the symbol. When adding a general instrument symbol, you can pick a random area in the canvas, or
insert the symbol inline with existing instrumentation lines.
When the symbol is placed, the Assign Tag dialog box is displayed, enabling you to define parameters
regarding the specifics of the instrument to be used in the design. In addition, you have the option to
display the tag information and pick the annotation style.
The following illustrations show the process after the instrument symbol has been placed in the
canvas. On the left, the data defining the instrument is entered and selected in the Assign Tag dialog
box. On the right, the resulting instrumentation symbol and tag is displayed.
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Adding Inline Instruments
Inline instrumentation is added to a P&ID design by selecting the desired symbol in the Instruments
palette > Primary Element Symbols (Flow) tool palette. You then locate the symbol by selecting pipe
line.
Like most other symbols, when you locate the inline symbol, the Assign Tag dialog box is displayed to
enable you to specify data regarding the symbol. When complete, AutoCAD P&ID will automatically
break the pipe line around the inserted inline symbol.
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The following illustration shows the Instruments > Primary Element Symbols (Flow) tool palette. In the
palette, the Restriction Orifice symbol is being selected.

Process: Adding Inline Instrumentation
You add an instrumentation symbol in a line by selecting the symbol to add and then the location on
the line. After specifying its insertion location, you assign its tag information. The following illustrations
show tag information being added to an inline instrument and the resulting placement of the symbol.
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Using Instrumentation Lines
Introduction to Using Instrumentation Lines
Instrumentation lines connect the general instrumentation symbols to the pipe lines and other
components comprising a P&ID design. The following illustration shows instrument lines connecting
gauges to the plant components.

Process: Using Instrumentation Lines
To add Instrument Lines to your design, you select the type of line needed in the Lines tool palette.
You then select the starting and ending points of the line to connect the components. At any time you
can add or remove components from the line. The following illustrations show the Electrical Signal
instrumentation line being selected in the Lines tool palette, and the resulting line created to connect
two general instrument symbols in the P&ID design.
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Exercise: Instruments and Instrument Lines
In this exercise, you place an inline instrument
(orifice, flow instrument, and so on) and add the
necessary tag that will be made visible with the
instrument balloon. Next, you create a temperature
measuring loop around the heat exchanger that
measures the temperature difference in front of and
after the heat exchanger. The signals lead to a control
instrument that sends a signal to the control valve to
open or close it.

6.
The completed exercise

1.
2.

3.
4.
5.

Start AutoCAD Plant 3D.
Open an existing project by doing the following:
■
In the Project Manager, Current Project list,
click Open.
■
In the Open dialog box, navigate to the
folder ..Plant Design\Instruments and
Instrument Lines.
■
Select the file Project.xml. Click Open.
Open PID002.dwg.
Click Workspace Switching > P&ID PIP.
On the Tool Palettes - P&ID PIP, click
Instruments.

To add an orifice to the design:
■
On the Instruments tool palette, under
Primary Element Symbols (Flow), click
Restriction Orifice.
■
Locate the orifice by clicking the line to the
right of Ball Value HA-122 as shown.
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7.

To assign tag information:
■
In the Assign Tag dialog box, for Area, enter
10.
■
For Type, click in the field and select FEFlow Element from the list.
■
For Loop Number, enter 005.
■

8.

To complete the addition of the orifice:
■
In the Assign Tag dialog box, click Assign.
■
Click below the symbol.
Note: Symbol color has been changed for
clarity.

9.

To define a control valve to add to your design:
■
On the Instruments tool palette, under
Control Valve, click Control Valve.
■
In the Control Valve Browser dialog box,
under Select Control Valve Body, select Gate
Valve.
■
Under Select Control Valve Actuator, select
Piston Actuator.
■
Click OK.
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10. To locate the control valve:
■
Click the pipe line below E-005 as shown.
■
Click to the right of the valve to locate the
tag.
■
In the Assign Tag dialog box, for Area, enter
10.
■
For Loop Number, enter 005.

11. Click Assign.
Note: The symbol color has been changed for
clarity.

■

■

In the Assign Tag dialog box, for Type, enter
TS.
Click Assign.

14. Place three additional instruments as shown.
12. To add an instrument:
■
On the Instruments tool palette, under
General Instruments, click Field Discrete
Instrument.
■
In canvas, click to the left of Control Valve
CV-005.
■
In the Assign Tag dialog box, for Area, enter
10.
■
For Type, enter TC.
■
For Loop Number, enter 005.
■
Click Assign.

13. To add another instrument:
■
Press ENTER.
■
Click below the first instrument.
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15. Make the Lines tool palette active.

16. To add a leader line:
■
On the Lines tool palette, under Instrument
Lines, click Leader.
■
Select the Quadrant of the instrument.
■
Select the pipe line for both the
instruments as shown (arrows).
Note: After completing the first line, press
ENTER to restart the command.

17. To add electrical lines:
■
On the Lines tool palette, click Electric
Signal.
■
Place the four lines as shown (arrows).

18. To add a pneumatic line:
■
On the Instrument tool palette, click
Pneumatic Signal.
■
Click the control valve and the instrument
as shown.

19. Close all files. Do not save.
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Review
It is possible to place general instruments inline.
True
False
What types of instruments do exist?
Inline Instruments.
General instruments.
Valve instruments.
The instrument balloon is a representation of the instrument tag.
True
False
Do instruments lines carry a tag similar to the pipelines?
Yes, they carry the same info as pipe lines.
No, the tag property is not available for instrument lines.
Yes, the tag property is available for instrument lines.
Can you substitute an instrument balloon with an inline instrument?
No, you can only substitute instrumentation with instrumentation, and inline with lnline.
Yes, by using the substitution grip.
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Lesson: Tagging Concepts
In this lesson, you learn how tagging can be used to create unique tags and how it can be used to
create a unique tag that is used to link symbols over multiple drawings.
You can assign tags to your components and lines. A tag is data and is never displayed on a drawing.
An annotation, however, often includes a tag property and displays that property on a drawing.
To fully benefit from tags and tag data, you need to understand their purpose and where they are
created and used.

Objectives
After completing this lesson, you will be able to:
■
■

2-48

Explain how to view existing tag data.
Link tag data to symbols in multiple drawings.

■
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View Existing Tag Numbers
Each time a drawing is added to a project, the data from that drawing is incorporated into the project.
When you assign tag information in the Assign Tag dialog box, you can view the existing tags by
expanding the dialog box.
Just below the Number field, a label that begins with Existing is displayed. The exact name will depend
on the component that is being assigned tag information. For example, when assigning tag information
for a Heat Exchanger, the title will be Existing Heat Exchangers. For a pump, it will be Existing Pumps.
By clicking the arrows at the end of the title area, you see all of the components of the same type
listed with their tag numbers.
The following illustration shows the Assign Tag dialog box with the existing component information
hidden, then displayed.
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Linking Symbols to Multiple Drawings
Often the symbol for one component in the PID design has to be displayed in two or more drawings
within the project. In these situations, you can link the tag information assigned to one of the symbols
to the other iterations of it within the project. To perform this operation, each drawing to be linked
needs to be open.
The following illustration shows the Assign Tag dialog box. The list of used tags for the project, in this
case heat exchangers, is displayed by expanding the area below Existing Heat Exchangers. Reviewing
this list will enable you to see all the tag numbers used in the project.
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Process: Link Symbols to Multiple Drawings
The following steps describe how to link symbols in two drawings to each other.
1.

Open both drawings
containing the same symbol
in the project to be linked.

2.

Insert a new symbol or go
to the symbol in need of tag
information.

3.

Access the Assign Tag dialog
box and review the list of
assigned tags.
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4.

In the Number field, enter
the number of the symbol to
be linked. Click Assign. In the
Tag Already Assigned dialog
box, click Assign this Tag to
the Selected Component.
Click OK.
Note: To display the tag
data, In the Assign Tag dialog
box, be sure to check Place
Annotation After Assigning
Tag.

5.

The two symbols are linked.

■
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Exercise: Add a Tag and Link Multiple Symbols to a Tag
In this exercise you review a tag to determine if it
is already in use and you link symbols over multiple
drawings using the same tag.

6.

To edit a P&ID symbol tag using the Properties
palette:
■
Select Heat Exchanger E-005.
■
In the Properties palette, under P&ID > Tag,
click the More button (arrow).
■
In the Assign Tag dialog box, for Number,
enter 006.
■
Click Assign.

7.
8.

Close the Properties palette.
To view other tags:
■
Right-click Heat Exchanger E-006.
■
Click Assign Tag.
■
In the Assign Tag dialog box, under Existing
Heat Exchangers, expand the list.

The completed exercise

1.
2.

3.
4.
5.

Start AutoCAD Plant 3D.
Open an existing project by doing the following:
■
In the Project Manager, Current Project list,
click Open.
■
In the Open dialog box, navigate to the
folder ..\Plant Design\Add a Tag and Link
Multiple Symbols to a Tab.
■
Select the file Project.xml. Click Open.
Open PID002.dwg.
Click Workspace Switching > P&ID PIP.
To display the AutoCAD Properties palette,
press CTRL+1.

9.

Note the presence of the E-001 Heat Exchanger.
In the Assign Tag dialog box, for Number,
enter 001.
■
A message is displayed informing you that
the number entered is already assigned to
an asset.
■
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10. To return to the drawing:
■
In the message box, click OK.
■
In the Assign Tag dialog box, for Number,
enter 100.
■
Click Assign.
11. In the Project Manager, under P&ID Drawings,
right-click PID001. Click Open.

12. In drawing PID001, zoom into the area of the
heat exchanger as shown.
Note that the heat exchanger has not been
assigned a tag.
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13. To assign a tag to the heat exchanger:
■
Right-click the heat exchanger.
■
Click Assign Tag.
■
In the Assign Tag dialog box, for Number,
enter 100.
■
Click Assign.

14. To link the heat exchangers in the two
drawings:
■
In the Tag Already Assigned dialog box,
select Assign This Tag to the Selected
Component.
■
Click OK.

15. To display the tag:
■
Right-click the heat exchanger.
■
Click Annotate > Equipment Tag.
■
Click inside the heat exchanger.

16. Close all files. Do not save.
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Review
Is it possible to create duplicate tags?
Yes. You just have to have both drawings opened. Then you can type in the tag again and
AutoCAD P&ID will ask you whether or not you want to use the same tag.
Yes. Just type in the tag again and AutoCAD P&ID will not bother you with a question.
No. It's not possible and would be potentially dangerous.
Can I copy a symbol that already has a tag?
Yes, but the copy will use the same tag as the original.
No, the copy command is not available in AutoCAD P&ID.
Yes. The tag of the copy will get an additional "?" to differ it from the original.
What happens with the tag in a drawing that is being linked to the project and the tag already exists in
the project?
The tags will receive a "?" at the end of their tags.
The tags won't be changed.
The tags will be renumbered.
Can I delete/clear tags that are not in use anymore?
Yes. Deleting the symbol deletes the tag.
Yes. Deleting the symbol deletes the tag, but "Compress Database" and "Audit Project" should be
used as well to make sure the tags are available again.
No. If a tag was used once it can't ever be used again.
Can a tag be generated automatically (full or partial).
True
False
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Lesson: Annotation Concepts
In this lesson, you learn how to place annotations and what types of annotations can be placed. This
lesson also describes the difference between a tag, an equipment tag, and an info label.
While tags store data, annotation is the text on the drawing that communicates vital information to
others. Annotation displays the properties or tag data of a component or line. Being able to leverage
the tag data as annotation is important for decreasing the time it takes to finalize a plant design and to
eliminate annotation entry mistakes.
The following illustration shows a typical plant design with various P&ID symbols annotated with tag
information.

Objectives
After completing this lesson, you will be able to:
■
■
■

Explain where tag data resides.
Annotate symbols and edit annotations.
Recognize and access different tag styles.
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About Tag Data
Tag data can and should be assigned to every symbol in a P&ID project. While the specific information
about the symbol will vary depending on the object, the base information should enable anyone
familiar with the project to determine specifically what component is needed. This information
enables those involved in the project to perform calculations and other engineering requirements, as
well as helping purchasing to order the correct components.

Definition of Tag Data
Tag data is information assigned a P&ID symbol to convey vital information about the symbol. The
data can be displayed in the drawing if desired, but is always held in the Data Manager. From there,
the data can be exported and shared with others in the project and used for downstream applications.

Example of Tag Data
The following illustration show a Centrifugal Pump in the P&ID design. The tag information is
displayed under the pump and also in the Data Manager.
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Annotating a Symbol
To annotate an object in a P&ID drawing, you right-click the object and select Annotate, then pick
the style you wish to use. You then click in the drawing to locate the tag. To edit, you can double-click
the tag data. This will display the Edit Annotation dialog box. The options available for editing are
dependent upon the symbol selected.
The following illustration shows the access to the Pump Infotag annotation.

If the default Infotag data does not fulfill your requirements, you can double-click the infotag to display
the Edit Annotation dialog box. In this dialog box you can add or omit data from the available fields.
If the annotation data is changed using the Data Manager, then the annotation will update
automatically.
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Tag Styles
You can display the tag data in the canvas of your design at any time during the design process. In
many cases, the Assign Tag dialog box is displayed when the symbol is placed and you can select to
display the tag information then. In other cases, or if the data was not displayed when placed, you can
right-click the item and click Assign Tag. The Assign Tag dialog box will display and you can choose to
display the tag then.
To change the style of displayed tag information, you can right-click the symbol and choose Annotate,
then select a style from the available styles. Depending on the type of symbol selected, the available
styles will vary.
The following illustration contains two examples of the options available when annotating symbols
in a P&ID design. On the right are the basic options available for most symbols. On the left, the
annotation options for a general instrument symbol.
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Examples of Tag Styles
The following table shows the different basic styles available to change the display of tag data in your
drawings.

Equipment tag

Oval Style

Tag
Info Tag
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Exercise: Annotate Your P&ID
In this exercise, you place several annotations using
the right mouse button functionality. You then make
changes to components using the Data Manager and
the Properties dialog box. Changes are immediately
reflected in the placed annotations. You will also add
information for a piece of equipment after doubleclicking on its info label.

6.

The completed exercise

1.
2.

3.
4.
5.
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Start AutoCAD Plant 3D.
Open an existing project by doing the
following:
■
In the Project Manager, Current Project list,
click Open.
■
In the Open dialog box, navigate to the
folder ..\Plant Design\Annotate Your P&ID.
■
Select the file Project.xml. Click Open.
Open PID002.dwg.
Click Workspace Switching > P&ID PIP.
Note the annotations called out with arrows
in the following illustration. Using standard
AutoCAD techniques, delete them.

■
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To display missing or deleted tag information:
■
Right-click the pump symbol in the lowerright corner of the design.
■
Click Annotate > Tag.
■
To locate the tag, click to the right of the
pump symbol.

7.

To add a different style tag to the same symbol:
■
Right-click the pump symbol.
■
Click Annotate > Pump Infotag.
■
To locate the tag, click below the pump
symbol.

8.

To edit the tag information:
■
Double-click the tag.
■
In the Edit Annotation dialog box, for
Description, enter CENTRIFUGAL PUMP.
■
For Manufacturer, enter KSB.
■
Click OK.
Note the dynamic update in the preview
window.

9.

To display a valve tag:
■
Right-click the valve to the left of the
Centrifugal Pump P-005.
■
Click Annotate > Valve Label.

10. To display the pipe tag:
■
Select the pipe line coming out of the top
of tank TK-005.
■
Right-click. Click Annotate > Pipeline Tag.
■
To locate the tag, select the midpoint of the
pipe line segment.
Note: Object snaps will affect the location of
the tag.
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11. Note that the pipe line is broken. To resolve
this, select the pipe line tag. Select the grip and
drag the tag to the left of the pipe line. Note
that the line is reconnected.

12. To view data using the Data Manager:
■
On the ribbon, click Home tab > Project
panel > Data Manager.
■
Under Current Drawing Data, click
Equipment.
■
Locate the Description column text for item
P-005.

13. To add text from the Data Manager to the
drawing, click and drag CENTRIFUGAL PUMP
from the Data Manager to the drawing, as
shown.
Note that the information is attached to the
symbol.
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14. Close all files. Do not save.

Review
What is the most common way to place an annotation?
Placing the annotation when the "Assign Tag" dialog box is closed.
Using the DTEXT or MTEXT command.
Annotations will always be placed automatically.
If I just want to place one property next to the symbol that is not part of any annotation, how can I
achieve that?
It is not possible.
Drag & Drop the value from Data Manager into the drawing.
How can I change information that is shown in the different annotations?
Data Manager
Double-Click on the annotation
Properties palette
If the change made doesn't appear directly on the drawing, how can I refresh the screen?
Regen
Update button in Data Manager
Update button in Project Manager
Reopen your drawing
If you change information using the default find & replace action of AutoCAD, it will change the info
that is connected to the symbol.
True
False
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Lesson: Editing Techniques
The way a design is initially created very rarely exactly matches the final delivered design. To go from
the initial creation to the final deliverable, you must be able to make changes to the initially created
design. This lesson describes making changes and modifications to a generated P&ID using the
AutoCAD P&ID Slinegrips and substitute arrow commands and the AutoCAD move, copy, and stretch
commands.

Objectives
After completing this lesson, you will be able to:
■
■
■
■
■
■

Add line segments in the middle of a line.
Link two lines that are not physically connected.
In a P&ID design, create a gap in a line.
Perform basic line edits using grips and standard AutoCAD edit commands.
Access and substitute symbols.
Change the flow direction of a pipeline.

Applying Corners to Lines
At times it may be necessary to change the layout of a line on the canvas. Since a single line is typically
made up of multiple segments, to change the direction you need to apply a corner to the line.
You access the Apply Corner command from the Schematic Line Edit option on the right-click menu.

Process: Applying Corners to Lines
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To apply a corner to a line, after starting the Apply Corner command, you select a point on the line
where the corner will begin (left arrow). Then you select additional points (right arrow) to define the
new location of the line.
In the following illustration, the path of the initial line was changed to go around the symbols by
adding corners to the line.

Linking Lines
Schematic lines are linked in drawings when you wish to have the tag data assume the values of
the selected (source) line. You link lines when the line is a single line but cannot be displayed as a
continuous line in the drawing due to space restrictions and inline components.

Process: Linking Lines
To link lines, you start the Link command then select the line to be linked with. You will then be
informed at the command line that the initial line will be deleted and the segment will be linked to the
newly selected line. To complete the link you must respond Yes.
The controlling segment is the second segment selected. The first segment is selected when you rightclick the line to start the command. Therefore, if you are linking an unassigned line and a line with tag
data, and the data is correct, you would right-click the unassigned line first, then select the line with
tag data second.
The following illustrations show the same lines before and after the linking process. Notice that in the
first illustration, only one line segment is highlighted, and the tag data is all question marks. In the
second illustration, both segments are highlighted and the tag data now matches what was the other
line.
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Creating Gaps in Pipe Lines
A P&ID drawing can become very congested. At times, it may be necessary to have a pipe or other
line cross a symbol. When this happens you can create a gap in the line while maintaining the integrity
of the line data.
To access the Add Gap tool, you right-click the line and select Schematic Line Edit > Add Gap.

Process: Creating Gaps in Lines
After starting the command, to create a gap in a line, you select the line where you want the gap to
start, then again where you want the gap to end. The section of the line between the two selected
points will be removed, and symbols will be added to the two endpoints to indicate that the line is
part of another line.
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In the following illustrations, the Add Gap command is started and the first point is selected (left
arrow). Then to complete the command, the second point is selected (right arrow). The result is
shown in the illustration on the right.

Basic Line Editing
AutoCAD P&ID lines respond to basic AutoCAD editing techniques. When you select a P&ID line, grips
are displayed at specific points on the line. These grips can be used to edit the line, or you can use
AutoCAD edit commands as well. To edit a line, you select it to display the grips.
If you need to change the end location of a line, you select the line, then select the endpoint grip.
You then pick a new endpoint location. If the new point selected is inline with the existing line, the
length of the line will change. If the new end is located perpendicular to the existing line, a new line
segment will be created. If the endpoint of the line was connected to a tank, the nozzle will be deleted
automatically, and added if connected to a tank. To move the line parallel to its current location, you
select the line, then select the grip at the midpoint of the line, then select the new location.
AutoCAD commands such as Move, Copy, and Stretch can also be used to edit P&ID drawings. If
you move a tank, the lines connected will adjust to maintain the connection. Copying a symbol will
produce a copy with the tag data copied and a question mark (?) added to inform you that the data
needs to be updated.
In the following illustration, two edits have been performed. Tank TK-008, was moved. Notice that the
lines maintained their connection. A copy of Tank TK-004 was placed just to the right of the original
tank. Note the tag data: TK-004?.
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Process: Basic Line Editing
The following steps describe the use of basic grip editing techniques to edit lines.
First select the line to enable its grips.

To disconnect from the tank and shorten
the line:
■
Click the endpoint grip.
■
Click a new location inline with the
line. Note that the nozzle is deleted.
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To move a line segment parallel:
■
Click the middle grip.
■
Click a new location.

To add segments when the line is not connected to a symbol:
■
Click the endpoint grip.
■
Click the endpoint of the new segments.
Notice how the nozzle is now displayed when the last endpoint specified was on the equipment.

Substitute Symbols
After you have inserted a symbol into your design, you can change the symbol to a similar one without
deleting the original and inserting the new one. If a symbol can be substituted and you select it with
no command active, a substitution arrow displays along with the grip.
In the following illustration, a valve is selected with no command active. In the middle of the valve is
a grip that enables you to move the valve to a new location. At the bottom right is the substitution
arrow.
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Examples of Symbol Substitution
The following table displays some of the substitution menus available when editing P&ID symbols.

Valve Substitution
General Instrument Substitution

Primary Element Substitution
Pump Substitution

Relief Valve Substitution
Welded Connection Substitution
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Flow Arrow
Certain components can only be installed in a specific direction in a pipe line. Typically, if the flow
direction of the pipe is reversed, any flow-dependent symbols also change automatically. However,
if you notice a directionally dependant device in the wrong direction, you can change the direction
without affecting the pipe flow direction.
In the following illustration, a check valve direction does not match the pipe flow direction. The
progression from left to right shows the valve direction not matching the pipe flow direction. The valve
is selected and the Flip Component arrow is selected, resulting in a match for the valve and pipe flow
direction.
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Exercise: Modify the Layout of your P&ID
In this exercise, you make modifications to the layout
of the P&ID using specific P&ID and regular AutoCAD
functionalities.

6.

To change the length of a pipe line:
■
Select the left endpoint of the horizontal
segment of the same line.
■
Move the cursor to the right and click to
relocate the endpoint.

7.

To add segments to the open end of a pipe line:
■
Click the same endpoint of the pipe line.
■
Click directly above the endpoint.
■
Click to the left.
■
Right-click. Click Enter.

The completed exercise

1.
2.

3.
4.
5.
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Start AutoCAD Plant 3D.
Open an existing project by doing the
following:
■
In the Project Manager, Current Project list,
click Open.
■
In the Open dialog box, navigate to the
folder ..\Plant Design\Modify the Layout of
Your PID.
■
Select the file Project.xml. Click Open.
Open PID002.dwg.
Click Workspace Switching > P&ID PIP.
To move a pipe line parallel to its current
position:
■
Select the 6-inch pipe that connects to the
top of tank TK-005.
■
On the horizontal segment, select the
diamond-shaped grip at the midpoint of
the line segment.
■
Move the cursor up, and click to relocate
the pipe line.

■
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8.

Zoom in to the connection to tank TK-005, as
shown.

9.

To disconnect a pipe line:
■
Select the 6" pipe line connecting to tank
TK-005.
■
Select the round grip point at the nozzle.
■
Select a location above the connection.
Note that the nozzle is no longer displayed on
the tank.

10. To connect a pipe line:
■
Select the cross grip at the endpoint of the
6-inch line.
■
Select the tank.
Note that the nozzle is now displayed.

11. To begin to remove a corner from a pipe line,
with the line selected, select the midpoint grip
of the far left segment, as shown.
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14. Zoom to the area of the E-100 Heat Exchanger.
12. Drag the grip until both segments of the pipe
line are collinear.

13. To add a corner to a pipe line:
■
Right-click the line 6-inch pipe that
connects to the top of tank TK-005.
■
Click Schematic Line Edit > Apply Corner.
■
Select a point on the horizontal segment.
■
Click above the selected point.
■
Click to the left of the second selected
point.
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15. Select the vertical electrical line. Using the
grips, move it over the heat exchanger as
shown.

16. To create a gap in a line:
■
Right-click the electrical line.
■
Click Schematic Line Edit > Add Gap.
■
On the line, select two points outside the
Heat Exchanger.

17. To link two pipe lines:
■
Right-click the pipe line below heat
exchanger E-100 (1).
■
Click Schematic Line Edit > Link.
■
Select the line above heat exchanger E-100
(2).
■
Right-click. Click Yes.
■
Move the cursor over one of the pipe lines.
They both highlight.

18. To substitute a P&ID symbol:
■
Select the valve HA-119 (near P-005).
■
Click the arrow.
■
In the replacement options, click Ball Valve.

19. The valve is updated, as shown.
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20. To copy a P&ID symbol using standard AutoCAD
tools:
■
Start the Copy command.
■
Select TK-004.
■
Locate the new tank to the left of the
original.

21. To update the tag information:
■
Right-click the new tank.
■
Click Assign Tag.
■
In the Assign Tag dialog box, for Number,
click the button at the end of the field.
■
The next available number is automatically
inserted.
■
Click Assign.
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22. To move symbols:
■
Start the AutoCAD Move command.
■
Select the two tanks.
■
Move them close to the left vertical line, as
shown.

23. To begin to create more space for additional
P&ID symbols:
■
Start the AutoCAD Stretch command.
■
Select a window as shown.

24. Stretch the selected components to the left, as
shown.
Note: Be sure to have Ortho on or use another
method to ensure horizontal movement.

25. Close all files. Do not save.
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Review
How can I move a line without having to delete and redraw it?
Using the Move Sline Parallel grip.
It is not possible.
When a valve is placed on a line and it turns out to be the wrong valve, how can I correct this without
the valve losing its information?
You have to right-click on the symbol and use the Replace option.
By using the substitution grip.
If a line crosses a piece of equipment, how do I open up the line without losing information?
Using the AutoCAD BREAK or TRIM commands.
By right-clicking on the line and selecting Schematic Line Edit > Add Gap.
I placed a new line. How can I let it join an existing group but keep its own settings?
Click Home tab > Line Group > Make Group.
Right-click on a line segment and click Edit Sline Group > Add.
New lines must be added to existing line groups immediately they are created.
Can I place a line and give it the exact same tag, info, and other information as an existing line without
the lines connecting?
Yes, by using the Join option on the Schematic Line Edit context menu.
Yes, by using the Link option on the Schematic Line Edit context menu.
No.
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Lesson: Data Manager and Reports
In this lesson, you learn how the Data Manager can be used to help create reports, look at the
information in the P&ID, export the data to external files (XLS, XLSX, CSV), and import that same
data again. To be able to view just the right information in the Data Manager, you also learn how to
manipulate the column order and which columns should be visible.

Objectives
After completing this lesson, you will be able to:
■
■
■
■
■
■

Explain the different types of data available in the Data Manager.
Describe the different sections of the Data Manager and access the different classes.
Access drawing, project, and report data.
Export project data.
Import project data.
Access, apply, and remove filters in the Data Manager.

About the Data Manager
For a P&ID drawing to be effective, each object must be fully documented. This is done by assigning
information with tags and properties. The number of objects typically found in a P&ID drawing results
in a large amount of data. In addition, it is often possible to have many drawings within a P&ID design.
To facilitate viewing, editing, importing, and exporting the data for drawings and the project, the data
is stored in a single location.
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The following illustration shows the AutoCAD P&ID Data Manager. In this instance, the data display is
being changed from the Current Drawing Data to another data source.

Definition of the Data Manager
The Data Manager is a centralized location that enables you to view, modify, export, and import
drawing and project data. In addition, you can organize the information within the Data Manager into
different configurations to generate reports.
The following illustration shows the AutoCAD P&ID Data Manager displaying project data. On the left,
the Class list enables you to show specific information.
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Using the Data Manager
The Data Manager is accessed from the Home tab > Project panel on the ribbon. Once it is displayed,
you can access data for the current drawing, project, or project reports.
The following illustration shows two iterations of the Data Manager. First, the display is set to show all
the tanks in the current drawing. Below that, all the tanks for the project are displayed.

Description of the Data Manager
The Data Manager has four main areas. In the top-left corner, the drop-down list (1) enables you
to select from Current Drawing Data, Project Data, or Project Reports. The Class list (2) enables you
to restrict the data displayed based on common P&ID components. The Data Manager toolbar (3)
enables you to perform tasks such as import and export of data, hide blank columns, and print. The
data from the drawing or project is located in a column and row configuration similar to a typical
spreadsheet (4).
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Process: Using the Data Manager
1.

On the ribbon, click Home tab >
Project panel > Data Manager to
display the Data Manager.
Select to display Drawing, Project, or
Report data.

2.
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3.

Select the desired Class.

4.

View the data.

■
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Drawing, Project, and Report Data
The Drawing Manager provides access to all of the data in the drawing or project. In addition, you can
organize the project data into a variety of available reports.
The following illustration shows access to the available Data Manager options.
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The following illustration shows the Instrument List selected in the Project Reports. This data was
exported and the resulting report is open in a spreadsheet.

Exporting Project Data
Data is only useful if it is accurate and gets to those individuals who need it. To share Data Manager
information with others outside of the design team, you can export the data to an Excel spreadsheet
or CSV file.
The following illustration shows the button in the Data Manager for exporting reports.
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Process: Exporting Project Data
To export P&ID data from your project, you first access the Data Manager. In the Data Manager, you
select Project Reports from the list, and then select which type of report you need. On the toolbar,
click Export.
In the following illustrations, the Project Report for the Nozzle List is selected. The resulting
spreadsheet is opened and reviewed.
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Importing Project Data
P&ID data can be imported into your project using the Import option in the Data Manager. There
are many reasons to import data into a P&ID project. Customers can make changes to the design,
specifications on equipment can change, or the data could have been exported because it is easier to
add and edit data in a spreadsheet.
When importing data, it is critical that the worksheet name and column headers match the view/
classes and property names in the Data Manager. Therefore, it is advisable to export the current data
to a spreadsheet, and edit the exported spreadsheet.
The following illustration shows the Data Manager information following an import. The cells of any
data that changed will be highlighted in yellow (1). If the data was changed in the spreadsheet, then
hovering the cursor over the data will reveal the previous value (2). And in the drawing, the symbol
will have a revision cloud placed around it (3) until the edited value is accepted or rejected.
For each edited value, you can right-click the individual cell and choose to accept or reject the edit. If
you are sure that you want to accept or reject all of the edits, you can select the appropriate option in
the toolbar.

The following illustration shows the Import button in the Data Manager for importing reports.
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Process: Importing Data
The following steps describe importing data into a P&ID project.
1.
2.
3.
4.

Access the Data Manager.
Click Import.
Select the spreadsheet or CVS file.
Review any edited data. Choose to accept or reject the changes.

Filtering Data in the Data Manager
The Data Manager provides many classes to filter the data that is displayed. However, there may be
times when you wish to have even greater control over the data displayed in the Data Manager.
To do so, you can use filters. The simplest way to invoke a filter is to select any cell that contains
the value that you filter by. You then right-click and click Filter By Selection. All items in the column
matching the cell selected will be displayed. You can also select to show the inverse of the cell by
selecting the option to Filter Excluding Selection. When complete, right-click and click Remove Filter.
Custom filters can be created by using wildcards.
The following illustration shows access to the filtering options in the Data Manager.
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Filtering Example in the Data Manager
The following illustration shows data in the Data Manager before and after filtering by selection.
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Exercise: Use Data Manager to Review, Export, and Import
Exercise: Data
In this exercise, you use the Data Manager to reorder
columns, filter for the desired data, and print project
reports. You then export data to an Excel spreadsheet,
modify the data in Excel, and import the modified
data back into the design.

The completed exercise

1.
2.

3.
4.
5.

Start AutoCAD Plant 3D.
Open an existing project by doing the following:
■
In the Project Manager, Current Project list,
click Open.
■
In the Open dialog box, navigate to the
folder ..\Plant Design\Use Data Manager to
Review, Export, and Import Data.
■
Select the file Project.xml. Click Open.
Open PID002.dwg.
Click Workspace Switching > P&ID PIP.
To display the Data Manager, on the ribbon,
Home tab, click Project panel > Data Manager.

6.

To view data for the project:
■
In the Data Manager, click the arrow next to
Current Drawing Data, as shown.
■
From the list, select P&ID Project Data.

7.

To view all the equipment in the project, from
the Class List, select Equipment.
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8.

To view data for Project Reports:
■
Click the arrow and select Project Reports.
■
From the Project Reports list, select Valve
List.

12. To remove any filter, right-click any cell. Click
Remove Filter.

9.

Return the Data Manager display to the Current
Drawing Data.

10. To add information using the Data Manager:
■
From the Class list, select Equipment.
■
For TK-006, in the Comment column, enter
In Transit.
■
For TK-007, in the Comment column, enter
On Site.

11. To view filtered data:
■
In the Data Manager, in the Type column,
locate any type designated TK.
■
Right-click any TK cell.
■
Click Filter By Selection.
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13. To filter all objects except selected ones:
■
Right-click any TK type.
■
Click Filter by Excluding Selection.
■
Remove the filter.
14. To view only populated columns, on the Data
Manager toolbar, click Hide Blank Columns.

15. To begin to export data:
■
On the Data Manager toolbar, click Export.
■
In the Export Data dialog box, for Select
Export Settings, select Displayed Data.
■
Under Include Child Nodes, click Active
Node Only.

16. To export the data:
■
Click Browse.
■
Navigate to a location to save the file.
■
For Files of Type, select one of the Excel
Workbook options.
■
Click Save.
Note that a CSV file can also be exported.

17. Navigate to the folder containing the
spreadsheet. Open it.

■

■

■

In the spreadsheet, in the Tag column,
change TK-007 to TK-008.
In the Comment column, for item E-100,
enter On Site.
In the Comment column, for items TL-004
and TK-005, enter In Transit.

19. Save the spreadsheet.
20. To import the spreadsheet data:
■
On the Data Manager toolbar, click Import.
■
If prompted to accept a log file, click OK.
■
Navigate to the spreadsheet. Click Open.
■
In the Import Data dialog box, click OK.
21. In the Data Manager, note the yellow cells
indicating that they have been edited.

22. In the Data Manager, click the first column of
Tag item TK-008. Note that the drawing zooms
to that item.

18. To edit your drawing using the spreadsheet:
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25. To accept edited data:
■
In the Data Manager, Tag column, right-click
the TK-008 cell.
■
Click Accept Edit.
Note the change in the Data Manager and the
drawing.
23. Zoom to extents. Review the drawing, and note
that all edited items are outlined in red revision
clouds.

24. Place the cursor over TK-008 in the Tag column.
26. To accept all changes, on the Data Manager
toolbar, click Accept All.
27. Close all files. Do not save.
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Review
Can I export more than one Data Manager view at the same time?
No.
Yes. All the worksheets from the Excel file can be exported at once as long as the worksheet
names are identical with the class name.
What types of documents can you export to?
HTML
DOC
XLSX
CSV
You need to approve every property that changed individually.
True
False
What is essential when importing from Excel?
You have to make sure that the worksheet name and the column headers match the view/classes
and property names in Data Manager.
Data can’t be imported from Excel, only from CSV files.
You can restore the view settings of the Data Manager after reordering and hiding columns.
True
False
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Lesson: Custom One-off Symbols
This lesson describes how to create custom P&ID symbols from standard AutoCAD geometry, then
convert a symbol to a P&ID object.
Creating custom P&ID symbols enables you to tailor your design to fit the exact needs of your
customers, your company, and industry.
The following illustration shows a custom P&ID symbol.

Objectives
After completing this lesson, you will be able to:
Create a custom P&ID symbol from standard AutoCAD geometry.

■
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Create a Custom P&ID Symbol
AutoCAD P&ID enables you to create P&ID drawings that match your industry and company
requirements. If a need for a symbol arises that AutoCAD P&ID does not already have, you can create a
custom symbol.
In the following illustration, a custom symbol (arrow) is inserted into a P&ID drawing.

Process: Creating a Custom P&ID Symbol
The following steps describe the steps to create a custom P&ID symbol.
1.

Using standard AutoCAD geometry,
create geometry that represents the
symbol.

2.

Select all the geometry.
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3.

Right-click. Click Convert to P&ID
Object.

4.

In the Convert to P&ID Object dialog
box, assign a Class to the custom
symbol.

5.

Select an insertion point.

■
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Exercise: Customize One-off Symbols
In this exercise, you use standard AutoCAD objects
and drawing techniques to create a custom P&ID
object.

6.

Using standard AutoCAD objects and
techniques, create the following geometry to
represent a filter.
Note: It may be beneficial to use Snap and Grid
to quickly create the geometry.

The completed exercise

1.
2.

3.
4.
5.

Start AutoCAD Plant 3D.
Open an existing project by doing the following:
■
In the Project Manager, Current Project list,
click Open.
■
In the Open dialog box, navigate to the
folder ..\Plant Design\Customize One-offSymbols.
■
Select the file Project.xml. Click Open.
Open PID002.dwg.
Click Workspace Switching > P&ID PIP.
Zoom to the empty area above Heat Exchanger
E-100.
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7.

To begin to create a P&ID symbol:
■
Select all the geometry just created.
■
Right-click. Click Convert to P&ID Object.

8.

To define the P&ID object:
In the Convert to P&ID Object dialog box,
expand Engineering Items > Equipment.
■
Expand Filters.
■
Under Filters, click Filter.
■
Click OK.

10. To assign tag information:
■
Right-click the new P&ID Symbol.
■
Click Assign Tag.
■
For Type, enter A.
■
For Number, enter 001.
■
Under Existing Filters, select Place
Annotation After Assigning Tag to display a
check mark.

■

11. To locate the tag:
■
In the Assign Tag dialog box, click Assign.
■
Click above the new filter symbol.

9.

In canvas, select the insertion point at the
midpoint of the bottom line.
Note the change in color to match other P&ID
Filters.

12. Close all files. Do not save.
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Review
Custom symbols can be modified after they have been converted to P&ID symbols.
True
False
How do custom symbols know what tag format to use?
AutoCAD P&ID analyzes the shape of the symbol and therefore knows what it is.
When converting the AutoCAD objects to a P&ID symbol, AutoCAD P&ID asks what class it is and
therefore knows what tag format has to be used for the custom symbol.
You can substitute custom blocks with standard blocks.
True
False
From how many AutoCAD objects can a symbol be made?
Up to 10
Up to 100
Up to 1000
Unlimited
It is necessary to have all AutoCAD objects on Layer 0 and use the color and line type BYLAYER.
True
False
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Lesson: Off Page Connections
In this lesson, you learn how to add off-page connectors and connect these with other drawings. You
also learn how off-page connectors can be used to navigate from drawing to drawing. Finally you learn
how information on a line in one drawing is synchronized with the line on the other drawing, and
which one will be leading.
The number of drawings required to document a P&ID for a plant design depends on the complexity
and size of the design. The more complex the design, the greater the likelihood that it will take
multiple drawings to fully document it. For a line to span from one drawing to another, you need to
use connectors. Off-page connectors are used in pairs: one in the originating drawing and one in the
connecting drawing.

Objectives
After completing this lesson, you will be able to:
■
■
■
■
■
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Describe the purpose of Off-page Connectors.
Add Off-page Connectors to a drawing.
Connect Off-page Connectors.
Remove an Off-page Connector from a project.
Review changes from the Data Manager in Off-page Connectors.

■
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About Off-page Connectors
In the complex world of design and engineering, it is important to keep designs organized. An
organized drawing enables all involved to read and find information efficiently. Organization also
reduces costly errors and saves valuable time both during design, and during downstream operations
such as purchasing and manufacturing.
Since a P&ID design can span multiple drawings, it is important to connect lines going from one
drawing to another with Off-page Connectors. Off-page Connectors enable you to organize your
drawings.

Definition of Off-page Connectors
An Off-page Connector is a symbol inserted at the endpoint of a P&ID line that indicates where that
line continues on another drawing. It alters the behavior of the connected lines in that any operation
performed on one line is automatically applied to the lines in the other drawing. In other words, the
lines act as if they were a single line in a single drawing.
The following illustration shows an example of Off-page Connectors. The pipe line data for both lines
match from one drawing to another.
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Adding Off-Page Connectors
An Off-page Connector is added to a P&ID drawing the same way other symbols are added. They are
accessed from the Non-engineering tool palette > Off Page Connectors and Tie-In Symbol panel.
The following illustration shows the Non-engineering tool palette.

Process: Adding Off-page Connectors
The following illustrations show the process for adding Off-page connectors to a drawing. First, you
select the Non-engineering tool palette. Then, on the Off Page Connectors and Tie-In Symbol panel,
select Off Page Connector. Then you select the endpoint of the line.
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Connecting Off-Page Connectors
After Off-page Connectors are placed on a drawing, they need to be connected to their counterparts.
Typically this will be in another drawing, but it can be within the same drawing if physically connecting
the lines is not feasible.
To connect two lines with an Off-page Connector, you select an existing Off-page Connector in the
drawing, then click the cross grip on the Off-page Connector. Click Connect To. Next, you locate the
drawing and line or connector to be connected to.
The following illustration shows access to the Connect To option for Off-page Connectors.

Create Connection Dialog Box
When you select the Connect To option on an Off-page Connector, the Create Connection dialog box
is displayed. In this dialog box you can select another drawing in the project to connect to. Also, under
Off-page Connector options, you can specify to create a new connector in the selected drawing. This
eliminates the need to go to the other drawing and create a connector if one does not already exist.
Or, if the connector has already been added, you can select Connect to Existing Off-page Connector.
The following illustration shows access to the Connect To option for Off-page Connectors.
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Process: Connecting Off-page Connectors
1.
2.
3.
4.
5.

Add an Off-page Connector to a line.
Click the Off-page Connector and click the cross grip. Click Connect To.
In the Create Connection dialog box, click the drawing to be connected with.
Select to create a new connector or connect to an existing one. Click OK.
Select the connector in the selected drawing.

Delete an Off Page Connector
To delete an Off-page Connector from a project, you use the standard AutoCAD method to delete
objects from a drawing. AutoCAD P&ID deletes the selected Off-page Connector and informs you
which drawings have been updated.

Data Manager Edits and Off-page Connectors
Data for Off-page Connectors is supplied from annotations on the lines that they connect. If you edit
the tag information of a line, the information displayed on the Off-page Connector updates as well.
This is also true for data edited using the Data Manager. Since the Data Manager edits the line data, in
essence, you are directly editing the Off-page Connector.
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Exercise: Add and Leverage Off Page Connectors
In this exercise, you place and connect multiple OffPage Connectors between a newly created drawing
and existing drawings. You add information to the
connectors using the Property dialog box and the
Data Manager. You also navigate to the different
pipelines using the Off-Page Connectors.

6.

On the Tool Palettes, make the Non-Engineering
palette active.

The completed exercise

1.
2.

3.
4.
5.

Start AutoCAD Plant 3D.
Open an existing project by doing the following:
■
In the Project Manager, Current Project list,
click Open.
■
In the Open dialog box, navigate to the
folder ..\Plant Design\Add and Leverage Off
Page Connectors.
■
Select the file Project.xml. Click Open.
Open PID001.dwg. Then, open PID002.dwg.
Click Workspace Switching > P&ID PIP.
To create pipe lines:
■
On the Tool Palettes, click the Lines palette.
■
Under Pipe Lines, select Primary Line
Segment.
■
Create pipe lines entering and exiting
TK-008 as shown.
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7.

To add a page connector:
■
On the Non-Engineering palette, under Off
Page Connectors and Tie-In Symbols, click
Off Page Connector.
■
Select the endpoint of one of the newly
created pipe lines.
■
Add another connector to the other line.

8.

To apply an annotation tag to the pipe lines:
■
Right-click the top pipe line.
■
Click Annotate > Pipeline Tag.
■
Click above the line to locate the tag.

10. Go to drawing PID001.
■
Zoom to the right side of the drawing where
E-101-A and E-101-B are located.
■
Note the two pipe lines with Off Page
Connectors.
■
Also note that these lines have tags applied
(6"-CS150-CWR-2002).

11. To begin to connect to another drawing:
■
Select the top Off Page connector.
■
Click the plus sign at the end of the
connector.
■
Click Connect To.

9.

Also add a tag to the lower pipe line.

12. To connect to another drawing:
■
In the Create Connection dialog box, under
Training Project, select PID002.
■
Under Off-page Connector Options, select
Connect to Existing Off-Page Connector.
■
Click OK.
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Note: When you click OK, the drawing selected
will become the active drawing.

15. To go to the other connector:
■
Click the round grip.
■
Click Go to Connector.
Note that the annotation tag is now populated
with the data from the other off-page
connector.

16. Repeat the previous steps to connect the other
off-page connector you created.

13. In drawing PID002, select the off page
connector going into (top) TK-008.
■
AutoCAD P&ID will make the connection. In
doing so, both drawings will become active
as needed.
■
In the Drawings Updated dialog box, click
OK.
17. To create a new connector when making an offpage connection:
■
In PID001, select the off-page connector at
the bottom-right of the design.
■
Click the plus sign grip.
■
Click Connect To.
14. To review the connection:
■
In PID001, select the connector.
■
Move the cursor to the round grip at
the end of the connector. Note that it is
connected to PID002.
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18. To define the drawing to connect to:
■
In the Create Connection dialog box, under
Training Project, click PID002.
■
Under Off-page Connector Options, verify
that Create New Connector in Selected
Drawing is selected.
■
Click OK.

19. To make the connection:
■
In PID002, select the endpoint of the open
pipe line coming from TK-005 (arrow).
■
Click OK.
Note: AutoCAD P&ID automatically switches to
PID002.

20. To delete an off-page connector:
■
In PID002, right-click the just created off
page connector.
■
Click Erase.
■
In the Drawings Updated dialog box, click
OK.
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21. In drawing PID002, click Home tab > Project
panel > Data Manager.

22. To view drawing data:
■
Verify that Current Drawing Data is
selected.
■
Under Engineering Items > Lines, click Pipe
Line Group.

23. Adjust your drawing so that you can see the
output pipe line from tank TK-008 and the Data
Manager.

26. Close all files. Do not save.
24. To change data:
■
In the Data Manager > Pipe Line Group,
for Line Number 2001, click the cell under
Service.
■
From the list, select CWR - COOLING WATER
RETURN.
■
Click any other cell.

25. Note that the line data updated automatically.
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Review
You can connect one Off-Page Connector to more than one Off-Page Connector.
True
False
When placing Off-Page Connectors, I need to have the drawings open that I want to connect to.
True
False
What type of information can be carried by an Off-Page Connector?
DWG Title
DWG Number
From/To line information
If you change the info on one of the lines that is connected using an Off-Page Connector, what
happens to the line in the other drawing (when it is not opened by someone else)?
The info in the drawing to which the connection is made will be updated when the drawing is
opened.
The changes made will not be carried out in both drawings.
The info in the drawing to which the connection is made will be updated automatically.
Once a connection is made, it can be changed without having to delete the Off-Page Connector.
True
False
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Lesson: Advanced Topics and Troubleshooting
This lesson describes advanced P&ID topics and troubleshooting.
The advanced topics include converting an AutoCAD object to a P&ID object, creating a custom
Equipment symbol, and specifying the connection points and the properties (NO/NC, Flow Direction)
that can be set for an inline symbol. It also includes the creation of annotation using the annotation
template, the modification of a tagging scheme, and the adding of symbols to the tool palette.
The troubleshooting topics cover the validation tool that you use to help validate whether the P&ID is
consistent. You learn how certain issues can be solved by interpreting the validation dialog correctly,
and take the necessary actions.

Objectives
After completing this lesson, you will be able to:
■
■
■
■
■

Create new class definitions.
Create new component symbols.
Add attachment points to a symbol.
Create and apply annotation styles to your project.
Validate components in a drawing or project.

Creating New Class Definitions
When creating custom symbols to use in P&ID drawings, you can add them to existing class definitions
or you can create your own. Creating your own class definitions enables you to isolate custom symbols
and specify the attributes and properties associated with them.
The following illustration shows the beginning of creating a class definition. In the Project Setup dialog
box, under P& ID Class Definitions, right-click an existing Engineering Item class definition. Click New to
create the new definition.
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Process: Creating New Class Definitions
The following steps describe adding a class definition to a P&ID drawing.
1.
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2.

In the Project Setup dialog box,
expand P&ID Class Definitions.
Select the most appropriate heading
that fits your new component. Rightclick. Click New.

3.

Enter a Class Name (no spaces) and
Display Name. Click OK.

■
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4.

Review the new class definition in
the list.

Creating New Component Symbols
Creating a new component symbol gives you the flexibility to create and represent a P&ID project
exactly the way you want it. A new symbol is created in the Project Setup dialog box. You expand the
Class list and select the class your new component will fit best.
When creating a new symbol, it is beneficial to select an existing symbol to use as a template. When
doing so, just be sure to save as a new file before making any changes to the existing block. You make
the modifications in the Block Editor and then adjust any settings.
The following illustration shows the Project Settings dialog box after a new component symbol has
been created.
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Process: Creating New Component Symbols
The following steps describe the process to create new component symbols.
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1.

Access the Project Setup dialog box.

2.

In the Class Definitions list, select the
desired class (P&ID DWG Settings >
P&ID Class Definitions).

■
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3.

Under Class Settings > Symbol, click
Add Symbol.

4.

In the Add Symbols - Select Symbols
dialog box, browse to Open the host
drawing.
Select a block to use as a template
and add it to the Selected Blocks
field. Click Next.

5.

6.
7.
8.

9.

Enter the symbol name, and set any
Symbol Settings. Click Finish.
In the Project Setup dialog box,
under Symbol, click Edit Block.
With the Block Editor displayed, go
to the ribbon. On the Block Editor
tab, expand the Open/Save panel.
Click Save Block As.

Save the block under a new name.
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10. Edit or create geometry as needed.

11. Exit the Block Editor and save
changes.
12. Click Edit Symbol.
13. Access the symbols drawing. Select
the new symbol.

14. Click Apply.

Adding Attachment Points to Symbols
Certain types of components in a P&ID design have specific attachment points. When creating new
component symbols, you can specify the location of attachment points so that AutoCAD P&ID can
automatically create them.
Attachment points are numbered and require you to enter a specific code so that AutoCAD P&ID
can understand and insert the component accurately. The numbering is called the Endcode. Since
AutoCAD P&ID has to interpret this information, the syntax has to be correct.
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The following illustration shows the code required for adding attachment points to a symbol. The
down arrows show the required code. From left to right, the "A" and "P" must be capitalized. The
number indicates which attachment point this is. "EndCode0" indicates the orientation of the
connection.

Process: Adding Attachment Points to Symbols
The following steps give an overview of adding connection points to a P&ID component symbol.
1.

In the Block Editor, on the Block
Authoring Palettes - All Palettes, click
Parameters tab > Point.

2.

Locate the point in the Block Editor.
Then locate the text.
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3.

Select the point to access Properties.

4.

In the Properties palette, under
Property Labels > Position Name,
enter the code.

Creating Equipment Annotation Styles
Creating Annotation styles for your equipment enables you to annotate your drawings based on
company or customer standards. You create or edit annotations in the Project Setup dialog box. To
create or edit an annotation, you find a P&ID Class definition for the component you wish to annotate.
There will be existing annotations in the class to work from. You select the annotation and select Add
Annotation or Edit Annotation.
Either selection will take you to the Symbol Settings dialog box. There, you name the annotation,
change any settings, and access the Block Editor to make changes. In the Block Editor, a small toolbar
is displayed to enable you to access the Assign Annotation Format dialog box. This toolbar is very
small, and contains only one button.
In the Assign Annotation dialog box, you can edit the existing field or add subparts and edit those.
From this dialog box, you have access to Class Properties, Drawing Properties, Project Properties, and
the Define Expression dialog box.
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The following illustration shows the Assign Annotation Format dialog box. Accessed from the
toolbar above, additional properties are being added in the dialog box. The second subpart,
TargetObject.Weight is a class property. The last, General.DWG Number, is a drawing property.

Process: Create Equipment Annotation Styles
The following steps outline how to create an annotation style for equipment symbols.
1.
2.

3.

In the Project Setup dialog box,
select the component.
Under Annotation, select an existing
annotation to use as a template.

Under Annotation, click Add
Annotation.
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4.

In the Symbol Settings dialog box,
enter a new name.

5.

Change any properties as needed.
Click OK.
In the Project Setup dialog box,
under Annotation, click Edit Block.

6.
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7.

In the Block Editor, to add a spec,
click Assign Annotation Format.

8.

Select an attribute to modify.

9.

Add Delimiters if desired.

■
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10. Increase the number of Subparts.

11. Access the Class Property dialog box.

12. Select the Class and Property.

13. Click OK. Close the Block Editor and
save changes.
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14. If desired, set all new components of
this type to use the new Annotation
Style.

Validating Project and Drawings
Before you hand off a P&ID project or drawing, you want to be sure that all connections and
annotations are labeled. To do so, you can run a Validation Check on your project or drawing. To
validate a project, you select Home tab > Validate panel > Run Validation. Keep in mind, if a project
is large, validating the entire project can take a very long time. It may make more sense to validate a
drawing when you feel it is complete.
To validate a drawing, in the Project Manager, you right-click the drawing and click Validate. AutoCAD
P&ID analyzes the drawing and displays a Validation Summary. In the Validation Summary palette,
you can choose to Ignore specific errors, or click on the error to have the display zoom to the specific
component.
The following illustration shows the Validation Summary palette for the drawing PID002.
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Process: Validate P&ID Project and Drawings
The following steps give an overview of validating P&ID drawings and projects.
1.

To validate a project, on the ribbon, click
Home tab > Validate > Run Validation.
To validate a drawing, in the Project
Manager, right-click the drawing. Click
Validate.

2.

Review the results in the Validation
Summary palette.

3.

To see an issue in the drawing, in the
Validation Summary palette, select the error
notification. The drawing automatically
zooms and pans to the location.
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4.

To remove validation issues from further
analysis, in the Validation Summary palette,
right-click the issue. Click Ignore.

5.

The issue is moved to the Errors Marked as
Ignored folder.

■
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Exercise: Convert and Create Symbols / Solve Validation
Exercise: Issues
■

In this exercise, you create P&ID symbols by
converting AutoCAD symbols and creating new
symbols in the Project settings. You then run a
validation and solve issues that came up with the
validation.

6.

Click Properties.

In the Categories list, expand P&ID DWG
Settings > P&ID Class Definitions > Engineering
Items.

The completed exercise

Create a Symbol
In this section of the exercise, you create a custom
symbol based on an existing template.
1.
2.

3.
4.
5.

Start AutoCAD Plant 3D.
Open an existing project by doing the following:
■
In the Project Manager, Current Project list,
click Open.
■
In the Open dialog box, navigate to the
folder ..\Plant Design\Convert and Create
Symbols - Solve Validation Issues.
■
Select the file Project.xml. Click Open.
Open PID002.dwg.
Click Workspace Switching > P&ID PIP.
To access the Project Setup:
■
In the Project Manager, right-click Training
Project.
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7.

8.
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Under Engineering Items, click Equipment.
Under Properties, review the properties shown.

To begin to add a new symbol:
■
In the Categories list, expand Equipment >
Filters.
■
Under Filters, select Suction Filter.
Note that no preview exists.

■
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9.

In the Project Setup dialog box, under Class
Settings: Suction Filter > Symbol, click Add
Symbol. This displays the Add Symbols - Select
Symbols dialog box.

10. To begin to add the symbol, in the Add Symbols
- Select Symbols dialog box, under Selected
Drawings, click More.

11. To select the source library drawing:
■
In the Select Block Drawing dialog box,
navigate to the project folder.
■
Click projSymbolStyle.dwg.
■
Click Open.

12. To select a block:
■
In the Select Block dialog box, under
Available Blocks, select PIP FILTER.
■
Click Add.
■
Click Next.
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13. To define properties:
14. To save the new definition under a new name:
■
Under Symbol Properties, for Symbol Name,
■
In the Project Setup dialog box, under
enter SuctionFilter1.
Symbol, click Edit Block.
■
Under General Style Properties, for Layer,
■
On the ribbon, Block Editor tab, expand
select Equipment.
Open/Save.
■
Under Other Properties, for Tagging
■
Click Save Block As.
Prompt, select Prompt for Tag During
■
In the Save Block As dialog box, for Block
Component Creation.
Name, enter Suction Filter 1.
■
For Join type, select Endline.
■
Click OK.
■
For Auto Nozzle, select Yes.
■
For Auto Nozzle style, select Flanged Nozzle
Style.
■
Click Finish.

15. Using standard AutoCAD commands, delete all
of the current block data.
16. To create new block geometry:
■
On the status bar, turn on Snap.
■
Starting at the origin, create a rectangle 40
x 30.
■
Add a horizontal hidden line four units
above the X axis as shown.

17. Close the Block Editor. Save Changes to Suction
Filter 1.
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18. To select the new symbol:
Add Connection Points
■
In the Project Setup dialog box, under
In this section of the exercise, you create a custom
Symbol, click Edit Symbol.
symbol and add a connection point.
■
In the Edit Symbols dialog box, under
Symbol Properties, select PIP FILTER.
1. To navigate to check valves:
■
Click More.
■
In the Project Setup dialog box, in the
■
In the Select Block Drawing dialog box, click
Categories List, expand Engineering Items >
projSymbolStyle.dwg.
Inline Assets > Hand Valves.
■
Click Open.
■
Under Hand Valves, click Check Valve.
■
In the Select Block dialog box, select Suction
Filter 1.
■
Click OK.

19. To view the block in the Project Setup dialog
box:
■
In the Select Block dialog box, click OK.
■
In the Symbol Setting dialog box, click OK.
■
In the Project Setup dialog box, click Apply.

2.

To create a new class:
In the list, right-click Hand Valves. Click
New.
■
In the Create Class dialog box, for Class
Name, enter CheckValve_DE.
■
For the Display Name of the Class, add a
space so it reads: Check Valve_DE.
■
Click OK.
■
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3.

Verify that the Class is displayed in the list.

8.
4.

5.

6.

7.
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To begin to create a new symbol:
■
With Check Valve_DE selected, under
Symbol, click Add Symbols.
■
In the Add Symbols - Select Symbols dialog
box, for Selected Drawings, click More.
■
Click projSymbolStyle.dwg.
■
Click Open.
To select the block:
■
In the Add Symbols - Select Symbols dialog
box, under Available Blocks, click Check
Valve 01.
■
Click Add.
■
Click Next.
In the Add Symbols - Edit Symbol Settings dialog
box, under Symbol Properties, for Symbol
Name, enter Check Valve_DE.
9.

To set the symbol settings:
■
Under General Style Properties, for Layer,
select Mechanical.
■
For Color, select Red.
■
Under Other Properties, for Symbol Scale,
enter 10.000.
■
For Tagging Prompt, select Automatically
Assign an Auto-Generated Tag.
■
Click Finish.

■

Chapter 2: AutoCAD P&ID

To modify the block:
■
In the Project Setup dialog box, under
Symbol, click Edit Block.
■
In the Block Editor, add the two horizontal
lines as shown.

Note that the check valve has only one
attachment point. Since the valve is an inline
component, a second attachment point is
required.

10. To add an attachment point:
■
On the Block Authoring Palettes - All
Palettes, click the Parameters palette.
■
On the Parameters palette, click Point.
■
Select the midpoint of the right vertical line
as shown (1).
■
Click to the right of the symbol (2).

14. In the Class list, navigate back to the suction
filter created earlier (Equipment > Filters >
Suction Filter). Add that symbol to the tool
palette also.

11. To edit the properties of the new point:
■
Select the new point.
■
In the Properties palette, under Property
Labels, for Position Name, enter:
AttachmentPoint2:EndCode180.
Note: The syntax is specific for this item. Also,
since this block already contains an attachment
point, you could select that point and copy the
properties information to the new point, and
then edit the information as required.

Add Annotation to Symbols
In this section of the exercise, you add an annotation
to a class, then assign that annotation to all new
symbols using that class.
1. In the Categories list, click Engineering Items >
Inline Assets > Hand Valves.

12. Close the Block Editor. Save the changes to
Check Valve_DE.
13. To add the new symbol to the tool palette, in
the Project Setup dialog box, under Symbol,
click Add to Tool Palette. Click OK.
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2.

3.

To begin to create a new annotation:
■
In the Project Setup dialog box, under
Annotation (lower-right corner), verify that
Valve Label is selected.
■
Click Add Annotation.

To begin to add a specification to an
annotation:
■
On the PnID toolbar, click Assign Annotation
Format.
■
Select the attribute: #(TargetObject.Size).
■
In the Assign Annotation Format dialog box,
for Number of Subparts, select 2.

7.

To edit the existing annotation, for
TargetObject.Size, in the Delimiter column, add
a space before and after the dash.

To define the symbol settings:
■
In the Symbol Settings dialog box, under
Symbol Properties, for Symbol Name, enter
My Valve Label.
■
For Block, verify that Valve Label_block is
selected.
■
Click OK.

4.

In the Project Setup dialog box, under
Annotation, click Edit Block.

5.

In the Properties palette, locate the PnID
Annotation toolbar.
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6.
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8.

To begin to add an additional annotation, in the
Assign Annotation Format dialog box, for the
new annotation, click Select Class Properties.

9.

To define the class and property:
■
In the Select Class Property dialog box,
under Class, select Engineering Items >
Inline Assets.
■
Under Property, select Spec.
■
Click OK.

11. Close the Block Editor. Save changes to My
Valve Label_Block.
12. To assign My Valve Label to all new valves:
■
In the Project Setup dialog box, in the
Categories list, verify that Hand Valves is
still selected.
■
Under Properties, for
AnnotationStyleName, in the Default Value
column, select My Valve Label.
■
Click Apply.
■
Click OK.

10. In the Assign Annotation Format dialog box,
click OK.
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13. To insert a valve:
■
On the Tool Palette, locate CheckValve_DE.
Note: When added to the Tool Palette, the new
symbol is added to the palette currently active.
If CheckValve01 is not in the correct location,
drag and drop it to the proper location on the
Tool Palette.
■
■

■
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Click CheckValve_DE.
To locate the check valve, select the input
line to tank TD-005.
Note the new annotation style.

■
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Solve Validation Issues
In this section of the exercise, you run validation
on the current P&ID drawing and resolve validation
issues.
1. To validate a single P&ID drawing:
■
In the Project Manager, under P&ID
Drawings, right click PID002.
■
Click Validate.

2.

3.

4.

To view an issue in the Validation Summary
palette, under PID002 > Non-terminating
line, click 6:-CS150-CWS-1000. AutoCAD P&ID
automatically zooms the display to the area.
To resolve this, the pipe line would need to be
connected.

The symbol is removed from the Validation
Summary and will not be included in future
validation tests.

5.

View the bottom of the Validation list. Ignored
symbols are listed here. To restore the symbol
for validation, under Errors Marked as Ignored,
right-click the symbol, and click Unassigned.

6.

To resolve validation issues:
■
In the Validation Summary list, under
Unconnected Components, click TK-008.
■
On the Tool Palettes, click Lines.
■
On the Lines palette, click Primary Line
Segment.
■
Add pipe lines as shown.

In the Validation Summary palette, under
Unconnected components, click TK-004.
Note that the tank contains nozzles that are
not connected to pipe lines. To resolve this,
pipe lines would need to be connected to the
nozzles.

Assuming tank TK-004 is a unit held in reserve,
you can remove it from validation as follows:
■
In the Validation Summary palette, rightclick TK-004.
■
Click Ignore.
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9.
7.

To rerun the validation:
■
In the Validation Summary palette, click
PID002.
■
Click Revalidate Selected Node.

8.

Note that TK-008 is no longer listed in the
Unconnected Components list.
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Close all files. Do not save.

Review
If you convert a symbol from an AutoCAD object, it will be available in all drawings in the project.
True
False
What is the correct way of drawing an inline symbol and in what direction (including the connection
points) should you draw it?
It doesn't matter. Just draw the symbol and add connection points.
You draw the symbol so that it shows the flow from left to right. Then you add the connection
points including the direction of the attachment points.
You have to define the flow direction with the Flow option on the Block Authoring Palette in the
Block Editor.
Does the flow direction on inline equipment have influence during placement?
Yes. Symbols like Pumps and Blowers will align according to the flow direction of the line.
No. Only Hand valves are flow dependent.
Can you set the layer a symbol must be placed on, or should that be activated in the drawing?
The layer is predetermined in the Project Setup for each symbol.
You have to change the layer of a symbol after inserting it in the drawing.
When you create a new symbol, you have to manually place the symbol in the tool palette.
True
False
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Lesson: P&ID Admin for Users
In this lesson, you learn how to locate drawings that have been physically moved outside of the
Project Manager. In addition, you learn to add categories and properties at the project and drawing
levels, and how these can be used with field functionality in AutoCAD P&ID.
For a P&ID project to be valid, AutoCAD P&ID must gather information from all the drawings in the
project. Locating a drawing that is not in the Project Manager enables you to validate your P&ID
project. Creating custom properties for your project and drawings enables you to define the project to
match your company or customer standards.

Objectives
After completing this lesson, you will be able to:
■
■
■
■
■
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Locate drawings physically moved outside of the Project Manager.
Add project categories to the current project.
Add properties to project categories.
Add drawing categories and properties to a P&ID drawing.
Place project and drawing properties in a drawing.

■
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Locating Drawings
Drawings within a P&ID project are controlled by the Project Manager. Each drawing in the project
should be created new, linked in, or copied to the project by the Project Manager. However, if a
drawing in the project is moved without using the Project Manager, AutoCAD P&ID will not be able
to locate the file. In these cases you use the Locate Drawing option in the Project Manager to show
AutoCAD P&ID where the file is located.
In the following illustration, the P&ID drawing PID004 was moved outside of the Project Manager.
Therefore, AutoCAD P&ID cannot locate the file and informs you of this by drawing a diagonal line
through the drawing icon in the Project Manager.

Process: Locating Drawings
To locate a drawing, in the Project Manager, you right-click the missing drawing name and click Locate
Drawing. The Locate Drawing dialog box is displayed, enabling you to navigate to the drawing. Once
you locate the drawing, you select it and click Open. AutoCAD P&ID updates the path information
internally and removes the line from the drawing icon.
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In the following illustrations, the drawing PID004 was moved to the Area20 folder outside of the
Project Manager. To find the drawing, click Locate Drawing on the menu, and select the drawing in the
Area20 folder.

Adding Project Categories
Adding Project Categories to your P&ID project enables you to add custom fields to the current
project to match your customer and company standards. The information entered can be used at the
project level or displayed in a drawing.
The following illustration shows the Project Setup dialog box, which you access by right-clicking the
current project in the Project Manager and clicking Properties. Under General Settings, Project Details
has been selected to enable the creation of Project Categories.
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Process: Adding Project Categories
The following steps describe how to add project categories to the project.
1.

In the Project Manager, right-click
the current Project. Click Properties.

2.

In the Project Setup dialog box,
under General Settings, select
Project Details.

3.

Under Custom Properties, click Add.
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4.

In the Add Category dialog box, enter
a name. Do not use spaces.

Adding Properties to Categories
After you have created project categories, or if you wish to expand upon the default project
categories, you need to add properties. You add properties in the same place as the categories,
making this a very streamlined process.
The following illustration shows the Custom Properties area of the Project Setup dialog box. First you
select the Custom category from the list, then click Add Row.

Process: Add Properties to Categories
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1.

In the Project Setup dialog box,
under Custom properties, select the
Custom category to add properties.

2.

Click Add Row.

■
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3.

In the Add Row dialog box, enter a
Name and Value (no spaces).

4.

Review the results in the Project
Setup dialog box, under Custom
Properties > Properties of Selected
Category.

Adding Drawing Properties
Drawing properties are added to a drawing using the same process as adding project properties. The
significant difference in creating the properties is that in the Project Setup dialog box, under General
Settings, Drawing Properties is selected.
Drawing properties do not have any predefined categories, so you have to create a custom category
prior to adding drawing properties. Again, the process is the same as creating Project Categories.
The following illustration shows the Drawing Properties area of the Project Setup dialog box. A custom
category has been added along with drawing properties.
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Process: Adding Drawing Properties
In the Project Manager, right-click
the current project. Click Properties.
In the Project Setup dialog box,
under General Settings, click Drawing
Properties.

1.
2.

3.

If previously created, select a custom
category from the list, or create a
new category.

4.

Under Drawing Properties > Custom,
click Add Row.
Enter a Row Name and Description.

5.
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Inserting Property Data
Using the Field command enables you to place project and drawing properties into your drawings. To
access the Field command, on the ribbon, click Insert tab > Data panel > Field, or enter Field at the
command line.
The following illustration shows the Field dialog box. For P&ID use, the Field category has been set to
Project.
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Process: Inserting Property Data
The following steps describe how to insert property data into the drawing as a text field.
1.
2.

Display the Field dialog box.
In the Field dialog box, under Field
Category, select the field.
Select a Field Name.

3.
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4.

If the selected field has custom
categories and names, select the
required category and name.

5.

Locate the field in the drawing.

■
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Exercise: Manage a P&ID Project
In this exercise, you handle and manage project
drawings by moving, locating, and copying drawings,
and you set up the naming scheme and create
selection lists using properties. You then use field
functionality to show the properties of P&ID (Drawing
and Project) in the drawing.

2.

3.
4.

5.

To physically relocate the P&ID Drawings:
■
Select PID003.dwg and PID004.dwg.
■
Drag and drop these drawings into the
Area10 Folder.
■
Select PID001.dwg and PID002.dwg.
■
Drag and drop these drawings into the
Area20 Folder.
Start AutoCAD Plant 3D.
Open an existing project by doing the following:
■
In the Project Manager, Current Project list,
click Open.
■
In the Open dialog box, navigate to the
folder ..Plant Design\Manage a PID Project.
■
Select the file Project.xml. Click Open.
To attempt to open a drawing in AutoCAD P&ID:
■
In the Project Manager, expand P&ID
Drawings category then right-click PID001.
■
Click Open. Note that Open is grayed out,
and a line is drawn through the drawing
icon.

The completed exercise

1.

Open Windows Explorer. Navigate to the
exercise files.
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6.

To locate a drawing using the Project Manager:
■
In the Project Manager, right-click
PID003.dwg.
■
Click Locate Drawing.
■
In the Locate Drawing dialog box, doubleclick Area10.
■
Select PID003.dwg.
■
Click Open.

11. Under Custom Properties, view the default
Custom Categories.

7.
8.
9.

In the Project Data Merged dialog box click OK.
Repeat the previous step to locate the other
three drawings.
To have the Project Manager reflect the
physical locations of the drawings:
■
In the Project Manager, select PID003.dwg
and PID004.dwg.
■
Drag them into the Area10 folder.
■
Select PID001.dwg and PID002.dwg.
■
Drag them into the Area20 folder.

12. To add a custom category:
■
Under Custom Categories, click Add.
■
In the Add Category dialog box, for New
Category Name, enter TitleBlockInfo.
■
Click OK.

10. To access project properties:
■
In the Project Manager, right-click Training
Project.
■
Click Properties.
■
In the Project Setup dialog box, under
General Settings, click Project Details.
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13. To assign properties to the new category:
■
Under Custom Properties, click Add Row.
■
In the Add Row dialog box, for Name, enter
Project Title_2.
■
For Value, enter PO#1234.
■
Click OK.

16. To add properties to the Custom Category:
■
Click Add Row.
■
In the Add Row dialog box, for Name, enter
DrawnBy.
■
For Description, enter PID Author.
■
Click OK.

14. To access drawing properties, in the Project
Setup dialog box, under General Settings, click
Drawing Properties. Note that custom drawing
properties are not included by default.

17. Add an additional row to the category:
■
For Name, enter DrawnDate.
■
For Description, enter Drawing Creation
Date.
■
Click OK.

18. In the Project Setup dialog box, click OK.
15. To add a custom drawing category:
■
Under Drawing Properties, click Add.
■
In the Add Category dialog box, enter
TitleBlockData.
■
Click OK.
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19. To access the new drawing properties:
■
In the Project Manager, right-click PID002.
■
Click Properties.
■
Click and drag the bottom of the Drawing
Properties dialog box to display the custom
drawing properties.

20. To enter title block data:
■
In the Drawing Properties dialog box, for
DrawnBy, enter Engineering.
■
For DrawnDate, enter today's date.
■
Click OK.
Note that as you activate a field, the
Description area is populated with the data
entered when creating the custom property.

21. Open PID002.dwg.
22. To access the layout:
■
On the status bar, click Quick View Layouts.
■
In the Quick View Layouts, click PID ISO A1
Title Block.
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23. Zoom into the title block area in the lower-right
corner of the drawing.

25. To add the custom properties to the current
title block:
■
On the command line, enter Field.
■
To narrow the list, for Field Category, select
Project.
■
In the Field dialog box, under Field names,
click CurrentProjectCustom.
■
For Custom Property Category, select
TitleBlockInfo.
■
For Custom Property Name, select Project
Title_2.
■
Click OK.

24. To enter paper space, on the status bar, click
Model.

26. To locate the field, click in the title block under
the existing fields in the Project Name and
Address area, as shown.
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27. To add the drawing data properties, access
the Field dialog box and select the options
indicated in the following image.

28. Locate the custom drawing property as shown.

29. Use the same technique to access and locate
the DrawnDate property.
30. Close all files. Do not save.
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Review
Is it possible to physically relocate drawings but still make P&ID aware of where they are?
No, drawings cannot be moved once they have been created.
You have to remove the drawing from the Project Manager and link it to the project again.
Yes, by using Locate Drawing on the context menu in Project Manager.
What is the difference between drawing and project properties?
There is no difference.
Project Properties are available to all drawings and objects of the drawing, whereas drawing
properties contain drawing-specific data for each individual drawing.
When you move a drawing in Project Manager to a different subfolder, the drawing is also moved on
the hard drive.
True
False
If you move a drawing in Project Manager to a different folder, what happens with the data of an
object in that drawing?
You have to remove the drawing from the Project Manager and link it to the project again.
Nothing needs to be done. The data is still there.
A drawing cannot be moved in the folder structure in Project Manager.
How many properties can be used in the title block?
Up to 100
Up to 200
Unlimited
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Lesson: Generating Reports
This lesson describes the use of Report Creator to generate different reports of a plant design.
The ability to generate reports from outside of AutoCAD P&ID enables you to create and configure
reports based on project data or drawing data.
The following illustration shows a report created early in the design process. From this report, the
engineer can begin the process of locating manufacturers.

Objectives
After completing this lesson, you will be able to:
■

■

Explain the purpose of plant design project reports and list what reports are common for a
project.
Generate different reports for a project using Report Creator.

About Project Reports
During the process of designing a plant or piping systems, you will need to generate a report of
project items for purchasing or requisition. Throughout the project, other disciplines and managers
will reference the reports that you create to proceed with their assigned portion of the project. You
can avoid many miscommunication errors by providing complete, updated reports from your Plant 3D
projects. Common reports include a line list, valve takeoff, instrument takeoff, pipe components, and
equipment list.

Definition of Project Reports
A project report lists items within the project with relevant information for the discipline for which it
is created.
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Example of Project Reports
Equipment lists typically include the Tag, Description, and Drawing Name fields, among others.
Instrument lists usually include the Tag, Description, Loop, and Drawing Name fields.

Generating Reports Using Report Creator
By using the Report Creator to distribute relevant reports, you can keep your project on track. The
Report Creator includes a number of reference reports. You export these reports to reflect the current
status of your project.
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Report Creator
The Report Creator is a stand-alone application that formats reports from predefined templates and
populates those reports with data from a project. The installer puts shortcuts to launch the Report
Creator on the desktop. AutoCAD Plant Report Creator is also listed on the Start menu in Programs.

Process: Generating Reports Using Report Creator
The following steps give an overview of generating a report using AutoCAD Plant Report Creator:
1.
2.
3.
4.
5.
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Start AutoCAD Plant Report Creator.
Select the project for which you want to create a report.
Select the report configuration you want to use to generate the report.
Specify which drawings should be included when generating the report.
Generate the report as a print or electronic file.

■
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Exercise: Generate Reports
In this exercise, you use Report Creator to generate
a report to a PDF file that lists the equipment in a
project.

5.

From the Report Configuration list, select the
Equipmentlist report. Review the File Path,
Output Type, and Target settings.

6.
7.
8.

Click Print/Export.
In the PDF Export Options dialog box, click OK.
In the Export Results dialog box, double-click
the listed PDF file to open it.

9.

Review the report.

The completed exercise

1.
2.

3.
4.

Start the Report Creator application from your
Desktop.
To set Generate Reports as the active project:
■
In Report Creator, Project list, select Open.
■
In the Open dialog box, navigate to the
folder ..\Plant Design\Generate Reports.
■
Select the file Project.xml.
■
Click Open.

In the Report Configuration area, click Settings.
In the Settings dialog box:
■
Ensure that the General option is selected.
■
Click OK.

10. Close the PDF viewer, Export Results dialog box,
and Report Creator.
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Review
Which fields are usually included in most reports?
Tag
Drawing Name
Supplier
Description
Select valid statements about the Report Creator.
Can be launched from the Data Manager.
Is a stand-alone application.
Includes predefined reports.
Does not export to PDF.
The Report Creator enables you to create reports by project or by drawing.
True
False
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Chapter Summary
In this chapter, you learned how to use AutoCAD P&ID to create, modify and manage 2D piping and
instrumentation diagrams for a plant design. Some of the tasks you learned how to do included adding
industry-standard symbols to the drawing, breaking and mending lines, ensuring flow direction, adding
tags and annotations in industry-formats, identifying and correcting potential inconsistencies, and
sharing project information.
Having completed this chapter, you can:
■

■

■

■
■

■
■

■

■
■

■

■
■

Add drawings to a project by creating new drawings, linking to existing drawings, and copying them
from another project.
Place equipment, set the tag, see the pre-defined type, and make changes to a symbol like adding
nozzles.
Add pipelines to connect equipment, group pipe segments, assign tags and information to the line,
and add and remove components to the line.
Add general and in line instruments and set up an instrument loop.
Describe the purpose of tags and create unique tags including a unique tag that links symbols over
multiple drawings.
Place annotations and modify the properties and data driving the annotations.
Make changes and modifications to the generated P&ID using AutoCAD P&ID's Slinegrips and
substitute arrow commands and with AutoCAD's move, copy and stretch commands.
Use the Data Manager to create reports, review information in the P&ID, export the data to
external files (XLS, XLSX, CSV) and import that same data again after revising externally. Also adjust
the columns displayed in the Data Manager.
Create one-off symbols by converting inserted blocks of symbols to P&ID objects.
Add off-page connectors and connect these with other drawings and utilize them to navigate
between drawings.
Use the identified advanced topics to assist in creating a P&ID and use the validation tool to
validate that the P&ID is consistent.
Conduct administrative functions that are relevant for a P&ID user.
Use of Report Creator to generate different reports of a plant design.
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Chapter

3
AutoCAD Plant 3D - Mixed Metric
In every design field, the optimum work environment is one that enables you to spend your time and
energy ensuring the design meets or exceeds the requirements of its use. When you are creating a
plant design, because the plant will be constructed and operated in a 3D world, the optimal way of
creating the design is in 3D. Using AutoCAD Plant 3D to create your plant designs means you can focus
on your design because the software is driven by industry specifications, it enables you to leverage
existing designs and content, and it can easily generate and share isometrics, orthographics, and other
construction documents. In this chapter, you learn how to use AutoCAD Plant 3D to create and modify
a 3D plant design and 2D views of the 3D design.

Objectives
After completing this chapter, you will be able to:
■

■

■
■
■
■
■
■

Add drawings to a project by creating them new, linking to existing drawings, and copying them
from another project.
Setup a grid, add steel members, ladders, stairs, railings, plates and footing, and modify the steel
structure.
Model and place 3D equipment.
Create and route pipe and place pipe components.
Create and use parts and place holder parts and change a line number, size, or spec.
Use a P&ID to create and validate pipelines in the 3D design.
Create and annotate orthographic views.
Create isometric views.
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Lesson: Creating Project Folders and Drawings
Projects for a plant design typically consist of new design files and the leveraging of existing design
files. To have all of the required drawings properly associated to the project, you need to know the
proper way to create new drawings and leverage existing drawings. This lesson describes how to add
drawings to the active project by creating a new Plant 3D drawing, linking an existing drawing to the
project, and copying an existing drawing from another project to the active project. In this lesson,
you also learn how to further organize the drawings in a project through the creation of folders and
subfolders and how to reorganize the drawings in the folders.

Objectives
After completing this lesson, you will be able to:
■
■
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Describe the tasks you can perform using the Project Manager.
Create project folders.
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Project Manager
You use the Project Manager to open, add, and create drawings. You also perform other tasks such
as exporting and importing data, creating project reports, including referenced drawings (xrefs), and
copying files to the project folders.
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Creating Folders
You create folders using the Project Manager to help manage where your drawings are stored. Folders
enable you to group drawings that contain similar information. You can copy files into project folders
as well as publish project drawings from the Project Manager.
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Process: Creating Folders
To create a new folder, you right-click on the Plant 3D Category and click New Folder. In the Folder
Properties dialog box, you specify the folder name and whether the folder is created relative to the
parent folder storage location. If you do this, the folder is automatically created in the project folder.
Otherwise you can specify an alternate location for the folder to be created. You can also select a
template that will be used when drawings are created in this folder.
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Exercise: Create Project Folders and Drawings
In this exercise, you create a new drawing, and copy
an existing drawing to the project. You also move
drawings from one location to another and locate
them using the Project Manager.

The completed exercise

1.
2.

Launch AutoCAD Plant 3D.
To open a project:
■
In the Project Manager, Current Project list,
click Open.
■
In the Open dialog box, navigate to the
folder ..\Plant Design\Create Project
Folders and Drawings.
■
Select the file Project.xml.
■
Click Open.

3.

In the Project Manager, right-click Plant 3D
Drawings. Click New Folder.
In the Project Folder Properties dialog box:
■
For Folder Name, enter Equipment.
■
Select Create Folders Relative to Parent
Folder Storage Location.

4.
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Click OK.
The folder is created and listed in the Project
Manager.
Repeat the steps to create Steel Structure and
Piping folders as shown.
■

5.

6.
7.

In the Project Manager, right-click the
Equipment folder. Click Copy Drawing to
Project.
In the Select Drawings to Copy to Project dialog
box:
■
Navigate to the folder ..\Plant Design
\Create Project Folders and Drawings
\Drawings.
■
Select Equipment.dwg.
■
Click Open.
■
In the Project Data Merged dialog box, click
OK.

8.

9.
10.

11.
12.

13.
14.

15.
16.

In the Project Manager, verify that the
Equipment drawing is listed under the
Equipment folder.

For Drawing Area, enter 67.
For Description, enter Piping drawing 1.
■
Click OK.
17. Close all files. Do not save.
■
■

In the Project Manager, right-click the Steel
Structure folder. Click Copy Drawing to Project.
In the Select Drawings to Copy to Project dialog
box:
■
Navigate to the folder ..\Plant Design
\Create Project Folders and Drawings
\Drawings.
■
Select Structures.dwg.
■
Click Open.
■
In the Project Data Merged dialog box, click
OK.
In the Project Manager, verify that the
Structures drawing is listed under the Steel
Structure folder.
With the Structures drawing selected, under
Details, verify that the drawing was copied to
the ..\Plant Design\Create Project Folders and
Drawings\Plant 3D Models\Steel Structural
folder.
In the Project Manager, right-click the Piping
folder. Click New Drawing.
In the New DWG dialog box:
■
For the File Name, enter Area67Piping-001.
■
Under Project Properties, notice that the
drawing will be created in the Piping folder.
■
Click OK.
The drawing is created and listed in the Project
Manager. The drawing is also opened in the
Drawing Editor.
In the Project Manager, right-click the Area67Piping-001 drawing. Click Properties.
In the Drawing Properties dialog box:
■
For Drawing Number, enter
100-2659AB201.
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Review
What drawing properties are available by default?
DWG Number
DWG Title
DWG Revision
Description
Which property is mandatory when creating a drawing?
DWG Number
DWG Title
Author
Description
You can move drawings around in the project.
True
False
How do you rename or remove folders from the project?
Just renaming the folder and/or the drawing with Windows Explorer is sufficient.
By using the context menu (Right-Click) on the Project Manager.
You can move a drawing to a different folder in Project Manager.
True
False
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Lesson: Steel Modeling and Editing
This lesson describes how to setup a structural grid, add steel members, ladders, stairs, railings, plates
and footing, and modify the steel structure.
In a plant design, the pipes and piping equipment exist relative to a building or structural framework.
Because of this relationship, when creating a new 3D plant design, the place to start is to include the
steel structure in your design. By having the accurate representation of the steel structure, you can
accurately position the piping equipment and lines.
In the following illustration, the same section of a plant design is shown. On the left, the design
includes the structural framework and all of the piping and piping components. On the right, just the
structural framework is shown.

Objectives
After completing this lesson, you will be able to:
■
■
■

Create a structure.
Select the different structural member types.
Modify structural parts.
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Adding Structural Parts
When your design requires a structural framework to support the piping parts and equipment or the
workers who monitor and work with the system, you should start by first modeling that structural
framework.
The process of modeling a structural framework consists of defining a grid, adding and editing
structural members, and adding and editing structural components like stairs, ladders, footings, and
plate. The common first step in the process is to create a grid. After the grid is added, the adding and
editing of structural member and structural components varies based on the requirements of your
design.

Structure Tools
The Structure tab on the ribbon contains the tools for adding parts, such as members and grids, to
your drawings.

Model Display Options
You also have the ability to change the way the parts are displayed in the model. The shape of the
parts can be displayed or the parts can be displayed as lines, symbols, or outlines.
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The following table contains illustrations that show the same model using the different display
settings.

Line Model

Symbol Model

Outline Model

Shape Model

Lesson: Steel Modeling and Editing
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If your model includes mesh plate, to see through the plate you must have the option
Shape Model selected. Selecting Outline Model causes the plate to display with a
solid color.

Configure the Settings
When you place grids or plates, you are prompted to specify their settings in the corresponding dialog
boxes that are displayed automatically. When you place other structural parts, the current settings for
that object are used.
To change the settings for members, railing, footings, stairs, and ladders, you use the Settings dropdown on the Parts panel before you start the commands for these parts.

Additionally, you can change the settings by right-clicking in the drawing area and clicking Settings
once you start the command for these parts.
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Grid Settings
When you use the Grid tool, the Create Grid dialog box is displayed where you can specify grid
settings. The axis, row, and platform values determine the location of the grid lines in each direction
from the insertion point of the grid. You use a comma to separate each grid line value.
The axis, row, and platform names are what displays in the drawing as labels on the grid lines. The font
size determines the size of the labels. When you modify the values, adding or removing the number of
grid lines, you must select the update button next to the corresponding name to update the name.
You can place the grid using the WCS, the UCS, or the 3 point method.
The settings in the following dialog box were used to create the grid as shown.
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Member Settings
In the Member Settings dialog box, you can select from several member shape standards, types, and
sizes. You can also specify the material standard and code, as well as the orientation point of the
member.

Part Modification
Modify and cutting tools are available on the Structure tab.
You use the Structure Edit tool to modify the settings of existing parts in your drawings. When you use
this tool, the corresponding dialog box for the part selected is displayed where you can modify the
settings for that part.
You use the cutting tools to lengthen, cut back, trim, extend, miter, or restore existing structural
members.
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Exercise: Build a Steel Structure
In this exercise, you create a steel structure using the
basic functionality of the steel structure module of
AutoCAD Plant 3D.

4.
5.

The completed exercise

Create a Grid

6.
7.
8.
9.

Make the Grid layer current.
On the Status Bar, click Grid Display to turn off
the AutoCAD grid.
Click Structure tab > Parts panel > Grid.
In the Create Grid dialog box, under Coordinate
System, select three points.
For the origin, enter 0,0,0.
To specify the X-axis, select a point on the X
plane as shown.

In this section of the exercise, you create a structural
grid.
1.
2.

3.

Launch AutoCAD Plant 3D.
To open a project:
■
In the Project Manager, Current Project list,
click Open.
■
In the Open dialog box, navigate to
the folder ..\Plant Design\Build a Steel
Structure.
■
Select the file Project.xml.
■
Click Open.
In the Project Manager, expand Plant 3D
Drawings > Steel Structure. Double-click the
Structures drawing to open it.

10. To specify a point on the XY plane, select a
point on the Y plane as shown.
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11. To specify the Z-axis, select a point on the Z
plane as shown.

12. In the Create Grid dialog box:
■
For the Axis Value, enter 0,5000.
■
For the Row Value, enter 0,8000.
■
For the Platform Value, enter 0,3500.
■
Click the update (arrow) buttons next to all
three values.

Create Structural Members
In this section of the exercise, you create structural
members.
1.
2.
3.

Make the Steelstructure layer current.
Click Structure tab > Parts panel > Settings
drop-down > Member Settings.
In the Member Settings dialog box:
■
From the Shape Standard list, select AISC.
■
From the Shape Type list, select W.
■
From the Shape Size list, select W6x9.
■
From the Material Standard list, select DIN
17120.
■
From the Material Code list, select St 37-2.
■
Under Orientation, verify that the Middle
orientation point is selected.

13. In the Create Grid dialog box, under Platform
Name (Local Z), enter Top of platform within
the value as shown.

14. In the Create Grid dialog box:
■
Under Font Size, enter 300.
■
Click Create.
The grid is created in the drawing.
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4.
5.
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Click OK.
Click Structure tab > Parts panel > Member.

6.

To specify the start point of the structural
member, select the endpoint as shown.

7.

To specify the end point of the structural
member, select the top corner of the grid box
as shown.

12. Click Structure tab > Parts panel > Member.
13. Right-click in the drawing area. Click Settings.
14. In the Member Settings dialog box, under
Orientation, select the Top Middle orientation
point. Click OK.

8.
9.

Press ENTER to end the command.
Click Structure tab > Parts panel > Shape Model
drop-down >Outline Model.
10. Repeat the command to add members to the
other three corners of the grid.

11. Click Structure tab > Parts panel > Shape Model
drop-down > Line Model.
Only the outline of the members are displayed.
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15. To specify the start point of the structural
member, select the point as shown.

Edit Structural Members

16. To specify the endpoints of the structural
members, snap to the end points in a clockwise
direction. Start with point 1 as shown and
continue selecting the points around the top of
the grid to point 4.

In this section of the exercise, you edit structural
members.
1. Zoom in on the top corner of the grid. Notice
that the members overlap.

17. Press ENTER to end the command.
18. Click Structure tab > Parts panel > Shape Model
drop-down > Shape Model.
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2.

Select and right-click the vertical member. Click
Edit Structure.

5.

3.

To miter two members:
■
Click Structure tab > Cutting panel > Miter
Cut Member.
■
Select the horizontal member on the left.
■
Select the horizontal member on the right.
■
Press ENTER to end the command.

In the Edit Member dialog box, under
Orientation, select the Bottom Middle
orientation point. Click OK.
The member is shifted so that the right edge
lines up with the grid line.

Place a Ladder
In this section of the exercise, you place a ladder.
1.
2.
3.
4.

Click Structure tab > Parts panel > Shape Model
drop-down > Line Model.
Click Structure tab > Parts panel > Ladder.
Right-click in the drawing area. Click Settings.

To trim one member to another:
■
Click Structure tab > Cutting panel > Cut
Back Member.
■
To specify the limiting member, select the
horizontal top member on the left (1).
■
To specify the structural member to cut,
select the vertical member (2).
■
Press ENTER to end the command.
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4.

5.

6.
7.
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In the Ladder Settings dialog box, Ladder tab,
under Geometry, verify the following settings.

8.

To specify the end point of the ladder, select
the perpendicular point at the top of the
platform as shown.

9.

To specify the directional distance point:
■
Move the cursor to the front along the Yaxis.
■
Enter 150.

On the Cage tab, verify the following settings.

Click OK.
To specify the start point of the ladder:
■
Hold SHIFT and right-click in the drawing
area.
■
Click From.
■
To specify the From Base Point, select the
bottom corner of the grid (1).
■
To specify the Offset, enter @600,0.

■
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10. Click Structure tab > Parts panel > Line Model
drop-down > Shape Model.

Add Railings
In this section of the exercise, you add railings to your
model.
1.
2.
3.

4.
11. On the Viewcube, click Left.
12. Zoom in and verify that the ladder was placed
away from the grid.

Click Structure tab > Parts panel > Shape Model
drop-down > Line Model.
Click Structure tab > Parts panel > Railing.
To specify the start point of the railing, select
the point as shown.

To specify the end points of the railing, select
points in a counterclockwise direction around
the top of the grid, ending on the opposite side
of the ladder from where you began.

13. On the Viewcube, navigate to the SouthWest
Isometric view.
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5.

Click Structure tab > Parts panel > Line Model
drop-down > Shape model.

Create Grating
In this section of the exercise, you add grating to
create a floor.
1.
2.
3.

4.
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5.

To specify the other corner point of the grate,
select the opposite top grid corner point as
shown.

6.

Click Structure tab > Parts panel > Line Model
drop-down > Shape model.

Click Structure tab > Parts panel > Shape Model
drop-down > Line Model.
Click Structure tab > Parts panel > Plate.
In the Create Plate/Grate dialog box:
■
From the Type list, select Grating.
■
From the Material Standard list, select DIN
17120.
■
From the Material Code list, select St 37-2.
■
From the Thickness list, select 10.
■
From the Hatch Pattern list, select NET.
■
For Hatch scale, enter 25.
■
Under Justification, select Bottom.
■
Under Shape, select New Rectangular.
■
Click Create.
To specify the first corner of the grate, select
the top grid corner point as shown.

■
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7.

Click Structure tab > Parts panel > Shape Model
drop-down > Outline model.
The grating is shown as a solid and the railings
are shown as square.

5.

To specify the insert point of the footing, select
the bottom grid corner point as shown.

6.

Repeat the command to add footings at the
bottom of the other three grid points.
Click Structure tab > Parts panel > Line Model
drop-down > Shape model.

7.

Add Footings
In this section of the exercise, you add footings below
the structural members.
1.
2.
3.
4.

Click Structure tab > Parts panel > Shape Model
drop-down > Line Model.
Click Structure tab > Parts panel > Footing.
Right-click in the drawing. Click Settings.
In the Footing Settings dialog box, verify the
following settings. Click OK.
8.

Close all files. Do not save changes.
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Review
What is a step that needs to be taken before creating the grid?
Save the drawing.
Create and activate a layer specific for the grid.
Set a different color for the active layer.
When placing a ladder, it will orientate itself based on?
The two points selected.
The two points selected, the direction for the stand-off distance and the WCS.
Based on a reference line created when the grid was placed.
When you want a kick plate on the inside, can you set this in the hand rail dialog box?
No!, you need to draw counter clock wise to get the kick plate on the outside and clock wise to
get the kick plate on the inside.
Yes.
Is it possible to use miter and extend on a railing?
Yes.
No.
Yes, but you need to do a structure explode first on the railing.
What will happen with the placed members when you make changes to the grid?
Nothing, members are not connected to the grid. The grid is only used for reference.
The members will automatically adjust to match with the grid again.

3-24

■

Chapter 3: AutoCAD Plant 3D - Mixed Metric

Lesson: Equipment Modeling and Editing
This lesson describes the modeling and placement of 3D equipment. You learn how to create
equipment using the available basic shapes and how to add nozzles to that equipment. You then learn
how to place the equipment in your design.
After the 3D design contains the structural steel model, your next task is to add the equipment
to the design. Within the field of plant design there are many types of plant and piping design
requirements and the equipment that is used in those designs. The equipment can be standard or
custom equipment. When the specific area you are in requires the inclusion of custom equipment, you
need a way to model that equipment.
In the following illustration, some custom equipment is shown including heat exchangers, pumps, and
tanks. Each of these pieces of equipment consist of a build up of basic shapes of cylinders, cones, and
spheres.

Objectives
After completing this lesson, you will be able to:
■
■
■

Create equipment in a Plant 3D drawing.
Describe the properties you can specify when you add or edit equipment nozzles.
Describe the reason for using equipment templates.
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Creating Equipment
The Equipment panel on the Home tab includes tools for creating, modifying, and attaching
equipment in a Plant 3D drawing. You can also convert AutoCAD solid objects to Plant 3D equipment.
Additionally, you can import Autodesk Inventor AEC export files as Plant 3D equipment.

Process: Creating Equipment
To create equipment in a drawing, you use the Create tool. The Create Equipment dialog box is
displayed and there are several types of equipment listed that you can place in a drawing. You can add
or remove components of several different shapes to customize the equipment as well as specify the
dimensions for each component.
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On the Properties tab, you enter data associated with the equipment such as material, descriptions,
and type. You can also assign a tag to the equipment.
Additionally, the nozzle information is displayed. However, you cannot edit the nozzle information
from here.
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About Nozzles
Most equipment has at least one nozzle by default. You can modify the location and properties
such as type, size, and pressure class of existing nozzles. Additionally, you can add new nozzles to
equipment. You add or edit nozzles using the grips located on any existing piece of equipment in a
drawing.

You initiate the editing of a nozzle by first explicitly selecting the nozzle. To explicitly select a nozzle,
you press CTRL while clicking the nozzle. A nozzle that has been explicitly selected has a pencil edit
icon display next to it which is used to access editing options.
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Equipment Templates
If you customize the properties of equipment in a drawing, you can save the equipment settings as
an equipment template. You can load the equipment settings from the template and easily place
additional equipment with the same properties.
The component shapes and dimensions are saved in an equipment template. The number of nozzles
and nozzle properties are also saved in the template.
Equipment templates that are saved in the ...\Equipment Templates\ folder of the current project are
listed in the Templates menu. You can also select templates from other locations.
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Exercise: Create Equipment
In this exercise, you will create several pieces of
equipment using the standard equipment builder.
You will also convert AutoCAD objects into Plant 3D
equipment.

7.

In the Assign Tag dialog box,
■
Click in the Number field.
■
Click Assign Number (arrow).
■
In the Number field, after the assigned
number, enter A.
■
Click Assign.

The completed exercise

Add Pumps
In this section of the exercise, you add pumps to the
drawing and tag them accordingly.
1.
2.

3.
4.
5.
6.
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Launch AutoCAD Plant 3D.
To open a project:
■
In the Project Manager, Current Project list,
click Open.
■
In the Open dialog box, navigate to the
folder ..\Plant Design\Create Equipment.
■
Select the file Project.xml.
■
Click Open.
In the Project Manager, expand Plant 3D
Drawings > Equipment.
Double-click Equipment.dwg to open it.
Click Home tab > Equipment panel > Create.
In the Create Equipment dialog box:
■
From the Equipment list, select Pump Centrifugal Pump.
■
On the Equipment tab, click in the tag field.

■
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8.

In the Create Equipment dialog box, click
Create.
9. To specify the insertion point, enter
3300,10000.
10. To specify the rotation, enter 90.
The pump is added to the drawing.

11. Hold the cursor over the nozzle on the top of
the pump.
The tooltip displays the name of the nozzle and
a tag of P-001A.

15. Select and right-click the second pump. Click
Assign Tag.
16. In the Assign Tag dialog box:
■
Click in the Number field.
■
Click Assign Number.
■
In the Number field, after the assigned
number, enter B.
■
Click Assign.
17. Hold the cursor over the second pump and
notice that the tooltip displays a tag of P-001B.

Add a Tank
In this section of the exercise, you add a tank to the
drawing.
1.
2.
12. Hold the cursor over the nozzle on the front of
the pump and notice that the tooltip displays a
6" nozzle.
13. Use the AutoCAD Copy command to copy the
pump at a distance of 1200 as shown.

Click Home tab > Equipment panel > Create.
In the Create Equipment dialog box, click
Templates > Vertical Tank with 3 Nozzles.

14. Hold the cursor over the second pump and
notice that the tooltip displays a tag of
P-001A?.
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3.

4.
5.
6.
7.
8.
9.

On the Equipment tab:
■
Under Shapes, select 1. Torispheric Head.
■
Under Dimensions, verify D is set to 2500.
■
Under Shapes, select 2. Cylinder.
■
Under Dimensions, verify D is set to 2500.
■
For H, enter 8000.
■
Under Shapes, select 3. Torispheric Head.
■
Under Dimensions, verify D is set to 2500.
On the Properties tab:
■
Under Data, for Type, enter T.
■
For Tag, click the tag value.
In the Assign Tag dialog box, for Number, enter
101. Click Assign.
In the Create Equipment dialog box, click
Create.
To specify the insertion point, enter
9000,8000,1200.
To specify the rotation, enter 0.
Select the tank you just added to the drawing.
Click Add Nozzle.

■

■

Verify 300 is selected from the Pressure
Class list.
Under Select Nozzle, double-click Nozzle,
Flanged, 4"ND, RF, 300, ASME B16.5.

12. Click Close. The nozzle is added to the top of
the tank.

Add a Vessel
10. In the Add Nozzle dialog box, on the Change
Location tab:
■
From the Nozzle Location list, select Top.
■
For R, enter 750.
■
For A, enter 0.
■
For L, enter 150.
In
the
Add Nozzle dialog box, on the Change
11.
Type tab:
■
Verify Straight Nozzle is selected.
■
From the Size list, select 4".
■
From the End Type list, select FL.
■
Verify IN is selected from the Unit list.
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In this section of the exercise, you add a vessel to the
drawing.
1.
2.
3.

4.
5.
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Click Home tab > Equipment panel > Create.
In the Create Equipment dialog box, click
Templates > Horizontal Vessel with 4 Nozzles.
In the Create Equipment dialog box, on the
Properties tab:
■
Under Data, for Type, enter V.
■
For Tag, click the tag value.
In the Assign Tag dialog box, for Number, enter
101. Click Assign.
In the Create Equipment dialog box, click
Create.

6.
7.
8.

9.

To specify the insertion point, enter
3500,6500,5000.
To specify the rotation, enter 270.
Use the ViewCube to activate the Northeast
Isometric view.

To hide the structural objects to make it easier
to modify the vessel:
■
Click Home tab > Visibility panel > Hide
Selected.
■
To specify the objects to hide, select the
structural railing.
■
Press ENTER to end object selection.
All structural objects are selected since they are
all located in the referenced drawing.

■

Click Edit Nozzle.

11. In the Nozzle dialog box:
■
Verify that N-1 is selected from the Nozzle
list.
■
Verify that you are on the Change Type tab.
■
From the Size list, select 1".
■
From the Pressure Class list, select 150.
■
Under Select Nozzle, double-click Nozzle,
Flanged, 1" ND, RF, 150, ASME B16.5.

12. On the Change Location tab:
■
Verify that Bottom is selected from the
Nozzle Location list.
■
For R, enter 600.
■
For A, enter 90.
■
For L, enter 150.
10. To edit the nozzle:
■
Zoom in and CTRL+select the nozzle on the
end of the vessel.
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13. Click Close.
The nozzle size and location is changed.

2.
3.

Click Home tab > Equipment panel > Create.
In the Create Equipment dialog box, click
Templates > Heat Exchanger.

4.

In the Create Equipment dialog box, Equipment
tab, under Shapes:
■
Select 1 Cylinder.
■
Under Dimensions, for D, enter 1375.
■
For H, enter 100.
Select 2 Cylinder.
■
For D, enter 1200.
■
For H, enter 1000.
Select 3 Cylinder.
■
For D, enter 1375.
■
For H, enter 100.
Select 4 Cone. Click Remove.

14. Click Home tab > Visibility panel > Show All.
15. Perform a Zoom Extents.

Add a Heat Exchanger
In this section of the exercise, you add a heat
exchanger to the drawing.
1. Use the Viewcube to activate the SouthWest
Isometric view.

5.
6.
7.
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8.
9.
10.
11.
12.
13.

Verify 4 Cylinder is selected.
■
For D, enter 1200.
■
For H, enter 4500.
Select 5 Torispheric Head. Click Remove.
Click Add > Cylinder.
Verify 5 Cylinder is selected.
■
For D, enter 1375.
■
For H, enter 100.
Under General, for Tag, click the tag value.
In the Assign Tag dialog box:
■
Verify the Type is set to E.
■
For Number, enter 101A.
■
Click Assign.

14. In the Create Equipment dialog box, click
Create.
15. To specify the insertion point, enter
-3500,2000,1500.
16. To specify the rotation, enter 90.

■

■

CTRL+select the bottom nozzle on the right
side of the Heat Exchanger.
Press DELETE.

19. Click Home tab > Equipment panel > Create.
20. In the Create Equipment dialog box:
■
Under General, for Tag, click the tag value.
■
In the Assign Tag dialog box, for Number,
enter 101B.
■
Click Assign.
■
Click Create.
21. To specify the insertion point, enter
-3500,2000,3000.
22. To specify the rotation, enter 90.
23. Repeat the steps to delete the lower nozzle on
the right end of the second heat exchanger.

17. Use the Viewcube to change to the Left view.
18. To delete a nozzle:
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24. CTRL+select the heat exchanger nozzle on the
top heat exchanger as shown. Click Edit Nozzle.

■
■
■
■

4.
25. In the Nozzle dialog box:
■
Verify N-3 is selected from the Nozzle list.
■
Select the Change Location tab.
■
For H, enter 4300.
■
From the Nozzle list, select N-5.
■
For H, enter 500.
■
Click Close.

5.
6.
7.

For X, enter 9000.
For Y, enter 8000.
Select Explode.
Click OK.

To attach the tank support to the tank:
■
Click Home tab > Equipment panel > Attach
Equipment.
■
To specify the equipment item, select the
tank.
■
To specify the other objects, select the tank
support.
■
Press ENTER to end object selection.
Select the tank. Verify that both the tank and
support are selected.
Right-click the tank. Click Save Selected
Equipment as Template.
In the Save Template To dialog box,
■
For File Name, enter Vertical Tank with
Support Structure.
■
Click Save.
■
Press ESC to clear selection.
The tank with the support structure is now
saved in the Equipment Templates folder of the
current project.

Attach AutoCAD Objects to Equipment

Convert AutoCAD Objects to Equipment

In this section of the exercise, you insert a block
made of AutoCAD solids that represent a support for
the tank. You attach the support to the tank.

In this section of the exercise, you insert a block that
is made up of AutoCAD solids to represent a vessel
with nozzles. You convert the solids to a Plant 3D
piece of equipment and specify where the nozzles are
located.

1.
2.
3.
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Use the ViewCube to activate the Southeast
Isometric view.
Click Insert tab > Block panel > Insert.
In the Insert dialog box:
■
From the Name list, select Tank Support.
■
Under Insertion Point, clear the check box
to Specify On-Screen.

■

1.
2.
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Click Insert tab > Block panel > Insert.
In the Insert dialog box, click Browse.

3.

4.

5.
6.
7.
8.
9.

In the Select Drawing File dialog box:
■
Click Browse.
■
Navigate to the folder ..\Plant Design
\Create Equipment\Related Files.
■
Select AutoCAD Horizontal Vessel.dwg.
■
Click Open.
In the Insert dialog box:
■
Under Insertion Point, select Specify OnScreen.
■
Clear Explode.
■
Click OK.
Select an insertion point anywhere in the
drawing.
Click Home tab > Equipment panel > Convert
Equipment.
To specify the AutoCAD objects to convert,
select the vessel block that you just inserted.
Press ENTER to end object selection.
In the Convert to Equipment dialog box, select
Vessel. Click Select.
Use the Insert object snap to select the
insertion point of the block.

14. In the drawing, select the vessel. Right-click.
Click Add Nozzle.
15. Use object snaps to select the center of the
nozzle as shown.

16. To specify the direction, enter 180.
10. In the Modify Vessel dialog box, for Tag, click in
the tag field.
11. In the Assign Tag dialog box:
■
For Type, enter V.
■
For Number, enter 102.
■
Click Assign.
12. Click OK to exit the Modify Equipment dialog
box.
13. Change to the Southwest Isometric view if
necessary to see the geometry that represents
the nozzles on the end of the vessel.
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17. In the Nozzle dialog box, on the Change Type
tab:
■
From the Size list, select 2".
■
From the Pressure Class list, select 150.
■
Under Select Nozzle, double-click Nozzle,
Flanged, 2" ND, RF, 150, ASME B16.5.
■
Click Close.

Tip: Use the ViewCube to get a better view of
the bottom nozzle.
20. Close all drawings. Do not save changes.

18. Repeat the steps to add the lower nozzle with
the same properties on the end as shown.

19. Repeat the steps to add a 6" nozzle with a
pressure class of 300 on the bottom of the tank
pointing down.
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Review
Where are templates of equipment stored, and can you use them on other projects as well?
Templates are stored in your projesymbstyle.dwg and they cannot be used with other projects.
Templates are stored in the equipment template folder in your active project. To use them on
a different project, simply copy the contents of this folder to the equipment template folder of
another project.
It is not possible to store any templates of equipment, you only have the original templates in the
equipment creation dialog box.
You can attach an AutoCAD solid to a piece of equipment so that it will move with the equipment
when moved.
True
False
When you xref a drawing, what is the best xref type to use?
Attachment
Overlay
Both are possible, it doesn't matter what you use.
If you want to import equipment from another software solution, what formats can be read by
AutoCAD?
ADSK, SAT, DXF, DWG, 3DDXF
SAT, ADSK, IGES, STEP
All of the above
Can you route pipe from an imported or converted model?
Yes, without any extra handling
No
Yes, but you have to add nozzles first
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Lesson: Piping Basics
This lesson describes the creation and routing of pipe and the placement of in-line components.
In the following illustration, the design of the plant is further defined and understood with the
inclusion of the pipe lines and in-line equipment.

Objectives
After completing this lesson, you will be able to:
Route pipe in a 3D model.
Identify the grips you can use to modify pipe.
List the tools available for adding valves and fittings.
List the pipe support tools and types available.

■
■
■
■
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Routing Pipe
The Part Insertion panel on the Home tab includes tools you can use to route pipe, convert AutoCAD
lines to pipe, and assign tags to pipe. You can specify pipe settings such as pipe size, pipe spec, and
pipe number prior to placing pipe in a drawing.
You can also connect custom and placeholder parts to a pipe line that are not in the pipe spec.
Additionally, you use the P&ID Line List tool if you have a P&ID object you want to place in a Plant 3D
model.

Process: Route Pipe
You use the Route Pipe tool to draw a pipe line in the drawing. To connect pipe to a nozzle on an
existing piece of equipment, you use the Node object snap when you are prompted for a start or next
point.
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While routing pipe, the compass is displayed so you can accurately place pipe lines at precise angles.
You press the CTRL + right-click to cycle the compass rotation between the different axes. You can also
select Plane from the shortcut menu to cycle the compass.

As you select the points for the pipe run, the required fittings are automatically inserted.
If the points you select in a pipe run make a connection to existing equipment or another pipe run,
the auto-routing feature will route pipe and add the required fittings to complete the connection. If
multiple paths are available, you can choose from multiple solutions.
You can make connections with existing equipment or pipe runs that are located in
externally referenced drawings.
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Modifying Pipe
The grips that are activated when you select a pipe allow you to add pipe branches, change the
elevation of existing pipe, and substitute parts in the piping run.

Standard grip
Continue Pipe Routing
Substitute Part
Change Pipe Elevation
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Valves and Fittings
Valves and Fittings
Valves and fittings can be added to an existing pipe run using the tools on the tool palettes. You can
select from tools that correspond to the valves and fittings listed in the project spec sheets. For more
information on spec sheets, refer to the lesson on Specs and Catalogs.
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About Pipe Support
You can create and connect pipe supports to pipe in a 3D model. The Pipe Supports panel on the Home
tab contains tools you use for creating, modifying, converting, and attaching pipe supports.

You use the Create tool to add pipe supports to a 3D model. There are a variety of pipe support types
available in the Add Pipe Support dialog box. You can specify support properties and dimensions
before you place the pipe support in the drawing.
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Exercise: Route Pipe and Add Fittings, Branch Connections,
Exercise: and Pipe Supports
■

In this exercise, you create a new piping run with
fittings, branch connections, and pipe supports that
are all positioned relative to the referenced drawing
containing the structural steel and equipment design.

■

7.
8.

From the Pipe Size Selector list, select 6".
From the Spec Selector list, select CS300.

Click Home tab > Part Insertion panel > Route
Pipe.
To specify a start point, select the node on the
tank nozzle as shown.

The completed exercise

Route Pipe
In this section of the exercise, you route pipe from a
nozzle on the tank to a nozzle on the vessel. You also
add a loop to the pipe.
1.
2.

3.
4.
5.
6.
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Launch AutoCAD Plant 3D.
To open a project:
■
In the Project Manager, Current Project list,
click Open.
■
In the Open dialog box, navigate to the
folder ..\Plant Design\Route Pipe and Add
Fittings, Branch Connections, and Pipe
Supports.
■
Select the file Project.xml.
■
Click Open.
In the Project Manager, expand Plant 3D
Drawings > Piping.
Double-click Piping.dwg to open it.
Hold the cursor over the nozzle halfway up the
vertical tank. Verify that it is a flanged 6" ND,
RF, 300, ASME B16.5 nozzle.
On the Home tab > Part Insertion panel:

■

9.

To rotate the compass plane, press CTRL+rightclick.
10. Move the cursor down. Enter 2000.
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11. To rotate the compass plane, press CTRL+rightclick.
12. Move the cursor to the right. Enter 2000.

16. Select the short vertical pipe segment. Click
Continue Pipe Routing.
13. To specify the next point, select the node on
the nozzle of the vessel as shown.

17. To specify the next point, select the
perpendicular point on the long vertical pipe as
shown.
14. Right-click in the drawing area. Click Next.
15. Right-click in the drawing area. Click Accept.
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18. To change the size of the pipe:
■
Double-click the pipe segment that you just
added.
■
On the Properties palette, from the Size list,
select 4".
The pipe is changed to a 4" pipe. Reducers are
automatically added.

Add Valves

19. Press ESC to clear selection.
20. To specify that the tee does not use a reducer:
■
Select the tee on the right.
■
Click the Substitute Part grip.
■
Click 6"x4" TEE (RED).

In this section of the exercise, you add different
valves to the pipe in your drawing.
1. On the Tool Palettes, Dynamic Pipe Spec tab,
under Valve, click Globe Valve, FL, RF, 300.

The tee without a reducer is used.
21. Repeat the steps to substitute the tee on the
left side.
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2.

3.

4.

To specify the insertion point:
■
On the status bar, verify that Dynamic Input
is turned on.
■
Verify that Object Snaps is turned on.
■
Move the cursor over the 4" horizontal
pipe.
■
To change the basepoint to the right side,
with the valve over the pipe, right-click the
valve. Click Basepoint.
■
To change the basepoint to the center,
right-click again. Click Basepoint.
■
With the left dynamic dimension
highlighted, enter 1000.

5.

Repeat the steps to place the gate value in the
6" pipe directly below the globe value.

6.

On the Tool Palettes, click Gate Valve, BV, 300.

7.

To specify the insertion point, select the node
of the elbow as shown.

To specify a rotation, select a point to the front
as shown.

On the Tool Palettes, click Gate Valve, FL, RF,
300.
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8.

To specify the rotation, select a point to the
front as shown.

11. Press ESC to clear selection.
12. Hold the cursor over several pipe segments and
valves. Notice that the tooltip displays their
location as Layer 1001.
9.

Repeat the steps to place another butt-welded
gate valve in the opposite pipe segment as
shown. Press ESC.

10. To add a line number to the existing pipe run:
■
Select one of the pipes. Right-click.
■
Click Add To Selection > Connected Line
Number.
■
On the Properties palette, under Tag, from
the Line Number Tag list, select New.
■
In the Assign Tag dialog box, for
TargetObject.Number, enter 1001.
■
Click Assign.
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Add Additional Pipe and Valves

5.

To specify the next point, move the cursor up.
Enter 1500.

6.

To specify the next point, select the node of the
nozzle on top of the heat exchanger as shown.

7.

Press ENTER to accept the first pipe
configuration.

8.

On the Tool Palettes, click Check Valve, FL, RF,
300.

In this section of the exercise, you add pipes from the
pumps to a heat exchanger.
1. Hold the cursor over the nozzle on top of one of
the pumps. Verify that it is a flanged 4" ND, RF,
300, ASME B16.5 nozzle.

2.

On the Home tab > Part Insertion panel:
■
From the Pipe Size Selector list, select 4".
■
From the Spec Selector list, select CS300.
■
From the Line Number Selector list, select
Route New Line.

3.

In the Assign Tag dialog box, for Number, enter
1002. Click Assign.
To specify the start point, select the node of the
top nozzle on the pump as shown.

4.
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9.

To specify the insertion point, select the node
on the top nozzle of the other pump.

10. To specify the rotation, enter 180. Press ESC.
11. Select the check value that you just placed.
Click Continue Pipe Routing.

12. Right-click in the drawing area. Click pipeFitting.
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13. In the Fitting dialog box:
■
Select Valves.
■
From the Class Types list, select Gate Valve.
■
Under Available Piping Components, select
4" Gate Valve, Double Disc, 300 LB, RF.
■
Click Place.

14. Right-click in the drawing. Click Fitting-toFitting.
15. To finish placing the fitting:
■
To specify the next point, enter 0.
■
To specify the rotation, enter 45.
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16. To specify the next point, select the
perpendicular point as shown.

17. Use the ViewCube to activate the Northeast
Isometric view. Zoom in on the pumps.

19. Use a crossing window as shown to select the
seven objects that make the configuration from
the pump to the horizontal pipe.

18. Select the elbow, pipe, and fitting connected to
the pump on the left. Press DELETE.
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20. Use the Copy command and the Node object
snap to copy the objects to the other pump.

23. Press ENTER to accept the first solution.
21. Select the vertical pipe. Click Continue Pipe
Routing.

22. To specify the next point, select the node on
the horizontal pipe as shown.
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Change Pipe Elevation
In this section of the exercise, you use grips to change
the elevation of a pipe.
1.
2.

Zoom out so you can see the entire section of
4" pipe.
Select the long horizontal section of pipe.

The horizontal pipe run is moved above
the steel structure. All connected pipes are
stretched accordingly.

Create Pipe Supports
3.

Click Change Pipe Elevation.

In this section of the exercise, you create supports for
the pipes in your drawing.
1.
2.
3.

4.

Click Home tab > Pipe Supports panel > Create.
To specify the pipe to add support to, select the
long horizontal 4" pipe.
In the Add Pipe Support dialog box:
■
From the Pipe Support list, select Slide
Anchor > Clamped Slide 1 / Clamped
Anchor 1.
■
Under Dimensional Properties, for SH, enter
150.
■
Click Insert.

Press TAB repeatedly until bottom of pipe
(BOP:) is highlighted. Enter 3094.
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4.

To specify the insertion point, use the Nearest
object snap to select a point on the pipe above
the steel structure as shown.

5.

To specify the rotation, enter 0.
The support is added to the pipe.
Press ENTER to end the command.
Change the view so you can see that the pipe
support is sitting on the steel structure.

6.
7.

Create Pipes from AutoCAD Lines

4.

To insert a block with AutoCAD lines:
■
Click Insert tab > Block panel > Insert.
■
In the Insert dialog box, from the Name list,
select Pipe Lines.
■
Under Insertion Point, check Specify Onscreen.
■
Under Scale, clear Specify On-screen. For X,
enter 1.
■
Select Explode.
■
Click OK.

5.

To specify an insertion point, select the Node
on the bottom nozzle of the vessel.

In this section of the exercise, you create pipes from
AutoCAD lines.
1.
2.
3.

Use the Viewcube to activate the SouthEast
Isometric view.
Use the Hide Selected tool on the Home tab >
Visibility panel to hide the steel structures.
Use the Viewcube Orbit to get a view similar to
the one shown.
The AutoCAD lines are added to the drawing.
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6.
7.

8.

On the Home tab > Part Insertion panel:
■
From the Pipe Size list, select 6".
■
Click Line to Pipe.
To specify the AutoCAD lines to convert, drag
a window around the lines inserted from the
block and press ENTER.
The lines are converted to pipes with the
required fittings and elbows.

9.

Close all files. Do not save.

Place a globe value in each short pipe segment
as shown. Use the Globe Valve, FL, RF, 300 on
the Tool Palettes.
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Review
When you are in the specviewer, what do you need to select to create a tool palette from an entire
spec?
Nothing, this cannot be done.
You need to select the header in the spec, and then the Option Create tool palette will become
available.
You have to add components one at a time to the tool palette.
Why is it important to set the line number, size, and spec?
Otherwise AutoCAD Plant 3D cannot create/route the pipe.
Line number is not immediately necessary, but needs to be there when you want to create an
ISO.
This is not important, AutoCAD Plant 3D will create the pipe anyway.
While routing pipe, you can use all types of options to help you to get things done. How do you
activate these options?
Right-click and the option will appear in a context menu.
On the command line, enter the capital letter that is shown with the options.
Both of the above.
How do you change the direction of the compass that is used while routing pipe to determine its
direction?
By changing the UCS.
By pressing P for Plane in the options on the command line, or selecting Plane on the context
menu.
By choosing the correct elbows and bends in the spec.
When placing a fitting or a valve, dimensions show up allowing you to enter a value or distance. How
can you change which dimension you want to use?
This cannot be done, a valve is always placed in the same way.
The TAB key on your keyboard allows you to toggle between values.
You can only change the basepoint of the valve, but not which dimension you want to use
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Lesson: Piping Editing and Advanced Topics
In this lesson you learn to reuse parts and models within the drawing and between drawings. You also
learn about creating custom parts and placing placeholder parts. To help you change a line number,
size, or spec, you learn how to make selections correctly and how to lock or isolate objects.

Objectives
After completing this lesson, you will be able to:
■
■
■
■
■

Copy parts and pipeline sections within a single drawing or from one drawing to another.
Setup Xrefs for best use in Plant3D.
Understand what placeholders are and how to place custom parts.
Select entire pipe runs.
Isolate, lock, and unlock pipes and components.

Copying Parts and Pipeline Sections
You can copy parts and sections of a pipeline within a single drawing or from one drawing to another.
You use the AutoCAD Copy command to duplicate parts or sections of a pipeline within a single
drawing. You use the traditional Copy/Paste features located on the Clipboard section of the context
menu to duplicate them from one drawing to another. You can also use the keyboard shortcuts CTRL
+X, CTRL+C, CTRL+SHIFT+C, CTRL+V, and CTRL+SHIFT+V to copy parts or pipeline from one drawing to
another.

When you copy parts and/or pipeline, the tags may need to be reassigned. Additionally, line numbers
tags need to be assigned to copied pipelines.
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Line number tag of 1003 applied to
original pipeline.

Copied pipeline without a line number tag assigned.

Managing Changes in Xref files
When working with project files in Plant 3D, it is best practice to reference files (using xrefs) with
relative paths. This allows the project files to be moved or shared with others without the links to the
referenced files being lost.
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External References Palette
If the path of a referenced file is lost, you use the External References palette to locate the referenced
file. You can browse to find the file or enter the correct path of the file. You enter .\ or ..\ at the
beginning of the path to indicate that the path is relative to a project location. For example, .
\Tanks.dwg.
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Placeholder and Custom Parts
Placeholder and custom parts are parts that you place in a specific drawing that aren't listed in the
project spec sheets. A placeholder part can be substituted at a later time for a part from the spec
sheet.
You use the Custom Parts tool on the Home tab > Part Insertion panel to add custom or placeholder
parts. You can use custom geometry, such as a block, or parametric graphics when you place custom
or placeholder parts. You specify the geometry, graphics, and/or part properties in the dialog box that
is displayed when you use the tool.
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Selecting an Entire Pipe Run
Tools for selecting an entire pipe run are available when you select and right-click any object that is
part of a pipe run. On the shortcut menu, under Add to Selection, you can specify to select all objects
in the drawing that connected to the current selection, share a connected path between the current
selection, connected and share the same line number, or you can select the all parts with same line
number.

The following illustration shows connected objects selected by line number.
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Isolate, Hide, and Lock Pipe Runs
You use the Part Hiding/Isolation option on the shortcut menu of selected objects to hide or isolate
them. When you hide selected objects, they no longer display. When you isolate them, all other
objects in the drawing are hidden and only the selected objects display. This allows you to more
clearly view the objects you need to work on in a drawing.
You can end the hiding/isolation of parts when you no longer need the objects hidden or isolated.
When you end the hiding/isolation of parts, all objects in the drawing are again displayed.
Note: Object isolation/hiding does not affect the layers the objects are placed on, and the status of
the layer overrides the isolation/hidden status. For example, if an object is on a hidden or frozen layer,
it will not be displayed even when you end object isolation.

The following images show a drawing before and after some objects are isolated.

Before objects are isolated
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After objects are isolated
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Lock and Unlock Pipes
You lock the placement of one or more pipes and parts so that they can not be moved. To do this, you
use the Lock/Unlock Placement option on the shortcut menu of the pipe(s) or part(s). You also use the
Lock\Unlock Placement option on the shortcut menu to unlock selected object(s). Or you unlock an
entire pipe run using the Unlock Connect Parts option.

Once a pipe is locked, selecting it displays a locked symbol as a visual indication that the pipe cannot
be moved.
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Exercise: Modify and Reuse Data
This sets the drawing reference so that it uses
a relative path and the drawing is found in the
folder of the current project.

In this exercise, you reuse section of pipeline in a
single drawing and between multiple drawings. You
also use auto connect to connect the pipes and make
necessary modifications to the pipelines.

The completed exercise

Correct Xref Path
In this section of the exercise, you open a drawing
that contains an error due to the location of an xref
file. You correct the path by setting the drawing up to
use a relative path.

4.

1.

5.

2.

3.
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To open a project:
■
In the Project Manager, Current Project list,
click Open.
■
In the Open dialog box, navigate to the
folder ..\Plant Design\Modify and Reuse
Data.
■
Select the file Project.xml.
■
Click Open.
In the Project Manager, open Piping.dwg.
The External References palette is displayed.
Notice that the Tanks drawing is not found. This
is because the Tanks drawing was referenced
using the Full Path setting and the path has
changed.
On the External References palette:
■
Under File References, select Tanks.
■
Under Details, for Found At, enter..
\Equipment\Tanks.dwg.

■
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Notice the missing tanks display. Close the
External References palette.
Save the drawing.

Copy and Connect a Pipe Run
In this section of the exercise, you copy a pipe run
with all of its components within a single drawing. You
connect the new pipe run to the old one and assign a
line number tag to the copied objects.
1. Use the SELECT command and the window
option to select all pipes, connectors, and
valves as shown. Forty-four objects are
selected.

5.

2.

Right-click the selected objects. Click Part
Hiding/Isolation > Isolate Selected Parts.
Only the selected objects are visible in the
drawing. All others are hidden.

3.
4.

Select all visible parts.
To copy the objects:
■
Turn Ortho mode on.
■
Use the Copy command to copy the objects
5000 mm towards the bottom left corner.
■
Turn Ortho mode off.

Select the elbow as shown. Select the Continue
Pipe Routing grip.
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6.

To specify the next point, move the cursor to
the right and select the Node on the elbow as
shown.

9.

7.

The pipes are connected and both elbows are
exchanged for tees.

8.

On the Tool Palettes, Dynamic Pipe Spec tab,
click CAP,BV,40.
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To specify the insertion point, select the top
Node on the open pipe as shown.

10. To specify the rotation, enter 0.
11. Press ENTER to end the command.
The cap is added to close off the pipe.
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12. Hold the cursor over any of the copied pipes.
Notice that there are no line number tags
assigned to the objects that were copied.

13. To assign a line number tag to the objects:
■
Select all the copied objects, the newly
drawn pipe, and the cap that was added (47
objects).
■
On the Properties palette, under Plant 3D
> Tag, from the Line Number Tag list, select
1001.

14. Press ESC to clear the selection.
15. Select one of the pipes. Right-click. Click Part
Hiding/Isolation > End Hiding/Isolation of Parts.
Press ESC to clear the selection.
The equipment is again displayed. The copied
pipes should line up with the nozzle on the
second tank.

16. Notice that the flange connected to the first
tank has a connection symbol, but the flange
that you copied does not. Since you did not use
the Node object snap to copy the pipe run, no
actual connection was made with the tank.

17. Select the flange that lines up with the nozzle
on the second tank (the copied one). Rightclick. Click Connect Component to Adjacent.
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18. To specify the adjacent component, select the
nozzle (1).
The connection symbol (2) is now displayed,
indicating that a connection is made.

3.
4.
5.
6.
7.

Copy Piping to Another Drawing
In this section of the exercise, you copy a pipe run
from one drawing to another and reassign the line
number tag. You also copy pipes and make the
necessary connections.
1. Select the blue pipe as shown. Right-click. Click
Add to Selection > Connected Line Number.

2.
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All connected pipes with the same line number
are selected.

■
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8.

Right-click anywhere in the graphics window.
Click Clipboard > Cut.
Save the drawing.
On the Project Manager, under Piping, doubleclick the Tank Piping drawing to open it.
Right-click anywhere in the graphics window.
Click Clipboard > Paste to Original Coordinates.
In the Plant 3D Piping Errors dialog box, click
Close.
Note: This error refers to the open pipe at the
end of the run.
Zoom in on the tank's top nozzle. Notice the
connection symbol between the nozzle and the
blue pipe, indicating that a connection is made.

9.

Hold the cursor over one of the blue pipes.
Notice that the tooltip indicates that the pipe
run does not have a tag assigned to it.

15. Select and delete the pipe as shown.
10. Select the blue pipe as shown. Right-click. Click
Add to Selection > Connected Line Number.

16. Select the open elbow. Click Continue Pipe
Routing.
11. Right-click in the drawing area. Click Properties.
12. On the Properties palette, under Plant 3D > Tag,
from the Line Number Tag list, select 1003.
Note: If 1003 is not listed, use the New option
to create and assign it.
13. Use the AutoCAD Copy command to copy the
pipe run from the nozzle on one tank to the
nozzle on the other. Use the Node object snaps
when selecting the base and second points.
14. Select the second run of pipes and assign the
tag number of 1003.
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17. To specify the next point, use the Node object
snap to select the Node on the elbow as shown.

18. In the Piping - Cannot Determine Autoroute
dialog box, click This May Result in the Use of
Cutback Elbows or a Disconnected Pipe Layout.
Because the pipes are sloped, they are
connected with a cutback elbow.

19. Save and close the Tank Piping drawing.

2.

To specify the second point, select the Node on
the top nozzle of the other vessel.

3.

Select the elbow and pipe as shown.

Create a Custom Part
In this section of the exercise, you create a custom
part that does not currently exist in a project spec
sheet.
1. In the Piping.dwg, select the elbow connected
to the top nozzle on the vessel. Click Continue
Pipe Routing.
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4.

On the Properties palette, under Plant 3D, from
the Size list, select 8".

9.

5.
6.
7.

Note: If the Properties palette is not already
visible, right-click the object. Click Properties.
Press ESC to clear the selection.
Click Home tab > Part Insertion panel > Custom
Part.
In the Custom Part dialog box:
■
Click Use Parametric Graphics.
■
From the Class list, select Valve.
■
From the Units list, select Imperial.
■
From the Size list, select 6".
■
From the Display list, select Valve.

For the second port:
■
From the Port list, select S2.
■
From the End Type list, select FL.
■
For Facing, enter RF.
■
For Pressure Class, enter 300.
10. Click Insert Part.
11. Select a point and rotation to place the part on
the 8" pipe as shown.

12. Press ENTER to end insertion.

Create a Placeholder Part
In this section of the exercise, you create, place, and
edit a placeholder custom part.
1. In the Custom Part dialog box, under General
Properties, select Placeholder.

8.

Click Port Properties. For the first port:
■
From the Port list, verify that S1 is selected.
■
From the End Type list, select FL.
■
For Facing, enter RF.
■
For Pressure Class, enter 300.
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2.

In the Custom Part dialog box, Use Parametric
Graphics tab:
■
From the Class list, select Valve.
■
From the Units list, select Imperial.
■
From the Size list, select 4".
■
From the Display list, select Valve.
■
For L, enter 15.

3.

Under General Properties, from the Replace
With Part From Spec list, select CS300.
Click Insert Part.
Specify the insertion point and rotation to place
the valve as shown. Close the dialog box after
completing the placement.

4.
5.

6.
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To change the placeholder part to a permanent
one:
■
Select the valve that you just placed.
■
Select the Substitute Part grip.
■
From the Part list, select the 6" Globe Valve.
Notice that all the valves in the list come from
the CS300 spec sheet.

■
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The valve changes to a globe valve.
The globe valve may be rotated differently from
the one shown, depending on the rotation that
you selected in the previous step.

Lock a Pipe Run

■

In this section of the exercise, you lock and unlock a
section of pipe.
1.
2.

3.

From the Insulation Type list, select PP Personal Protection.

Select any part in run 1001. Right-click. Click
Add to Selection > Connected Line Number.
With the pipe run selected, right-click in the
drawing area. Click Lock/Unlock Placement.

Select a piece of the pipe run. Notice that the
lock symbols are displayed to indicate that the
pipe run is locked.
3.
4.

Press ESC to clear the selection.
Click Home tab > Visibility panel > Toggle
Insulation Display.

The insulation is displayed on the objects in the
pipe run.

4.

To unlock the pipe run, select the desired parts.
Right-click. Click Unlock Connected Parts.

Add Insulation to Piping
In this section of the exercise, you add insulation to a
section of piping.
1.
2.

Select any part in run 1001. Right-click. Click
Add to Selection > Connected Line Number.
On the Properties palette, under Plant 3D >
Process Line:
■
From the Insulation Thickness list, select 25
- 25.

5.

Close all files. Do not save.
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Review
Can you copy pipe routes or sections of pipe routes from one drawing to another?
Yes. You can do this using the Copy with Base Point option.
Yes. You can do this by using the default copy + paste option.
No. It’s not possible.
There are several ways to select a pipe line. What is the difference between selecting By Line Number
and Connected Parts by Line number?
Both options are the same, they both select the pipe components by line number.
Using By Line Number you only select the pipe routes, not the inline components. Connected
Parts by Line Number selects everything connected.
The option By Line Number selects all components with the same line number, even if they are
not connected. The option Connected Parts by Line Number only select the objects that have the
same line number and are connected.
With AutoCAD Plant 3D, pipe lines can be locked. What cannot be done anymore when a pipe line is
locked?
The pipe line cannot be moved in any direction.
The size and spec cannot be altered.
Pipe components cannot be deleted.
Can you hide a single line number?
No, all lines will hide at the same time.
Yes. Selecting the line using the selection options and then choosing the hide option will hide the
selected line.
Yes, but you need to select the inline components manually.
When a pipe line has been hidden or isolated, how do you reverse the hiding or isolation?
Select the pipe and right-click. Click the Hide or Isolate option to uncheck them.
Selecting the Show All button will bring back all hidden components.
You need to switch the layer containing the pipe routes on.
Close the drawing and reopen it from the Project Manager.
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Lesson: Working with P&ID Data in Plant 3D
This lesson describes the use of P&ID pipeline with tags and valves in a 3D plant design. The use of
the P&ID in the 3D design includes using it to place the lines and valves and using it to validate the 3D
pipeline against the P&ID pipeline.
Plant designs often start with the creation of a piping and instrument diagram because they are
schematic in nature and do not require exact size and position. The design is being worked out and
issues are being resolved. When you have created an AutoCAD P&ID drawing for the project, you can
use these drawings to minimize data entry when creating a 3D model.
In the following illustration, a portion of the P&ID drawing is shown on the left and the corresponding
3D plant design of the piping run is shown on the right. The design information already created and
captured in the P&ID drawing was used to create the appropriate pipe lines and place the correct inline components.

Objectives
After completing this lesson, you will be able to:
■
■
■

Describe how data from a P&ID drawing can be used to create the 3D plant design.
Place lines using the P&ID list.
Validate the project using various settings.
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About Working with P&ID Data in Plant 3D
Because plant designs start with the creation of a P&ID drawing and all of the information is captured
in that drawing, it only makes sense to directly reuse what exists during the creation of the 3D model.
When you work with P&ID data in a 3D design, you leverage what exists to assist in the creation and
placement of equivalent 3D pipe lines and inline equipment. The tag information in the 3D object
reflects the tag information from the P&ID drawing. The actual information added to the 3D objects
depends on the property values in the P&ID tags and the current mapping of the properties.
When you assign tags to the lines you create in P&ID, there are several entries you can make,
including:
■
Size
■
Spec
■
Pipe Line Group.Service
■
Pipe Line Group.Line Number
The specifications that are listed in the Assign
Tag dialog box are only selections. They do not
necessarily represent the specifications that are
used in Plant 3D. P&ID is not spec driven. Any
specification that you enter in this dialog box
must be available within Plant 3D.

While the 3D models that you create can have the same information as what is in the P&ID drawing,
the information is not linked between the drawings. This means that if a design change occurs,
changing the information in one location does not automatically update the other location. To ensure
everything is in sync between the drawings, you simply run a validation.
Refer to the help system topic Map P&ID and Plant 3D Classes and Properties for
more information and details on customizing the default mappings of P&ID and Plant
3D classes and properties.
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Using the P&ID Line List to Place Lines and Inline Equipment
You use the P&ID Line List palette when you want to add 3D pipe lines or inline equipment in to your
3D design when the line has already been created in a P&ID drawing. The P&ID Line List palette is
displayed when you click Home tab > Part Insertion panel, P&ID Line List.

After displaying the P&ID Line List palette, the process of placing 3D pipe lines and inline equipment
in to a Plant 3D drawing is very straight forward. The first thing you do is select from the drop down
list the P&ID drawing that you want to use. The next thing to do is select the line or inline equipment
you want to add. For ease of creation, you will want to place the pipe lines before placing the inline
equipment. By having the line exist first, placing the inline equipment is easier and quicker. After
selecting what to place, you either click Place on the palette or click Place Item from the shortcut
menu. You then create the 3D pipe line or place the inline equipment for which you selected to place.
In the following illustration, the P&ID Line List palette is shown with a list of pipe lines in the drawing
PID001. The 6" line for 1009 is currently selected and being prepared to be added to the design. The
1009 line also consists of two types of valves that can be easily placed.
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When you start a connection, such as starting a pipe on an existing nozzle, the correct connectors are
automatically established based on the specification settings that have been assigned to the items in
the P&ID drawing.

Validating the P&ID and Plant 3D Designs
As you are creating a design, you have the option of checking individual P&ID drawings or all the
drawings in a project to validate that they adhere to company and industry standards. When you
create Plant 3D drawings based on P&ID drawings, the information used and added to the model is
not linked to the P&ID drawing. To ensure the P&ID and Plant 3D design and data are in sync, you
need to validate the project. While you can run a validation on individual P&ID drawings, when you
want to validate a model against a P&ID drawing, you need to run the validation for the entire project.
The validation between the P&ID drawings and Plant 3D drawings is bi-directional. In other words,
mismatches that have been introduced in the P&ID drawing that conflict with data in the 3D model
are identified, and so are mismatches that have been introduced in the 3D drawing that don’t comply
with the P&ID drawings.
After the validation is run on the entire project, any issues that exists between the Plant 3D drawings
and the P&ID drawings list in the Validation Summary palette. To focus the results on what you are
most interested in, you should configure the validation settings prior to running a validation.
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In the following example, Item Line mismatches were found in the Equipment drawing. When you
select any one of these errors, the details panel provides information about the error.

Process: Validating the P&ID and Plant 3D Designs
The following steps describe the overall process of validating a project to ensure the P&ID drawings
and the Plant 3D drawings correspond with each other.
1.
2.
3.

Configure the validation settings to have the validation results list the type of issues or potential
issues you are interested in having identified.
Run Validate Project to have the validation check run against all of the drawings in the project.
Review the validation results and correct or flag any identified issue.
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Access Validate Project and Validation Settings
You access the validation settings or run the validation on the entire project from the shortcut menu
after right-clicking the project name.
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Validation Settings
There are several types of validations that you can set. The high-level organization of these is in the
P&ID Validation Settings dialog box as follows:
■
P&ID objects
■
3D Piping
■
Base AutoCAD objects
■
3D Model to P&ID checks

Refer to the help system topics Validate the 3D Model and P&ID Validation Settings
Dialog Box for more information and details on design validation.
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Exercise: Add and Validate Pipelines Using the P&ID Line
Exercise: List
In this exercise, you create a line with inline
items using P&ID. You assign a line number and
specifications to the new line. You then use this line
to create the line in Plant 3D. Once this is complete,
you set validation settings and run a validation on the
project.

The completed exercise

5.

Right-click the title bar of the Tool palette.
Switch to the PID PIP Tool palette.

6.

In the Lines tab, select the Primary Line
Segment.

7.

To begin drawing the line, click the node on
open nozzle.

Add a P&ID Line
In this section of the exercise, you create a new line
and assign tags in P&ID that will be used to create the
line in Plant 3D.
1.
2.

3.
4.
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Launch AutoCAD Plant 3D.
To open a project:
■
In the Project Manager, Current Project list,
click Open.
■
In the Open dialog box, navigate to the
folder ..\Plant Design\ Add and Validate
Pipelines Using the PID Line List.
■
Select the file Project.xml.
Open the PID001 drawing.
Zoom in to the heat exchangers.

■
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8.

Draw the line as shown.

Notice that as soon as the valve is inserted,
annotation appears.
14. On the Tool palette, Valves tab, select a Globe
valve.
9. Right-click the new pipeline. Click Assign Tag.
10. In the Assign dialog box:
■
Set the size to 6".
■
For the Spec, enter CS300.
■
For Pipe Line Group Service, select PGENERAL PROCESS.
■
For the Pipe Line Group Line Number, enter
1009.
■
Select Place Annotation After Assigning Tag.
■
Click Assign.

15. Place the Globe valve on the line as shown.

16. Leave the drawing open for the next exercise
section.

Create the P&ID Line in the Model
11. Place the tag above the line.

In this section of the exercise, you use the P&ID Line
List to create the line in Plant 3D.
1.
2.

Open the Piping drawing.
Change the tool palette to AutoCAD Plant 3D Piping Components.

12. On the Tool palette, Valves tab, select a Gate
valve.

13. Place the Gate valve on the line as shown.
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3.

Zoom and position the model to the open
nozzle on the heat exchangers.

4.

Click Home tab > Part Insertion panel > P&ID
Line List.

5.

On the P&ID palette, expand the 1009 line to
examine the components.

6.

Right-click 6”-CS300-P-1009. Click Place Item.

9.

Extend the pipe as shown. For Distance, enter
1500.

10. Extend the pipe as shown.
■
For Distance, enter 5500.
■
Press ENTER to end the command.
7.
8.

Select the node on the open nozzle.
Extend the pipe down. For Distance, enter 600.
Press ENTER.

11. On the P&ID Line List palette, right-click the
Gate Valve. Click Place Item.
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12. Place the valve on the line as shown.

Validate Line Tags and Fix
In this section of the exercise, you deliberately place
a valve on a wrong line, then run a validation of the
project.
1. Using grips, move the existing globe valve from
the new line to a line that was already in the
model. These two lines do not have the same
line number tags, and the valve is a mismatch
on the line it has been moved to.

13. Repeat the previous steps to place the Globe
valve as shown.

2.

To review validation settings, in the Project
Manager:
■
Right-click Training Project.
■
Click Validation Settings.

14. Hover the cursor over the line and valves to
confirm the information on these components.

15. Leave the drawing open for the next exercise
section.
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3.

In the P&ID Validation Settings dialog box:
■
Expand P&ID objects. Clear all the options.
■
Expand Base AutoCAD objects. Clear all the
options.
■
Expand 3D Model to P&ID checks. Clear
all the options, except Inline Items Are on
Different Lines in P&ID Drawings and 3D
Models.
■
Click OK.

9.

On the Validation Summary palette:
■
Select the Piping drawing.
■
Click Revalidate Selected Node.

10. Examine the results on the Validation Summary
palette. The Piping drawing has been removed
from the summary. The Equipment drawing
remains with errors.
4.
5.

To validate the model, in the Project Manager:
■
Right-click Training Project.
■
Click Validate Project.
On the Validation Summary palette, there are
several errors found, including errors in the
Equipment drawing.
■
Collapse the errors on the Equipment
drawing.
■
Expand the Piping drawing.
■
Examine the results. The misplaced valve is
listed as an error.

6.

On the Validation Summary palette, click the
HA-122 item.

7.

In the Details section, examine the details of
the error.

8.

In the 3D model, using grips, place the Globe
valve back on line 1009.

3-88

■

Chapter 3: AutoCAD Plant 3D - Mixed Metric

11. Close all files. Do not save changes.

Review
When a line is created in P&ID, you add a spec, size, etc..... The spec that is used in P&ID does that
need to be available in 3D as well?
Yes, otherwise the P&ID List cannot generate the correct pipe route.
No, the spec in P&ID and Plant 3D are not referenced to each other.
That's not important, you need to select which spec you want to use in 3D anyway.
When a valve is placed in 3D and it carries a tag, can I change the tag in the 3D model?
It is not possible.
If you right click the valve in 3D, a pop-up menu shows up with an option called "Assign Tag" in it.
Using this option allows you to change the tag of the valve.
To change the tag, you need to change the tag in the P&ID drawing. The 3D model will update
automatically.
If the tag is set completely in P&ID (Size-Spec-Service-Number), what layer will be generated in 3D (by
default) when this pipe route is created?
Line Number.
Service.
Entire pipe line tag.
Validating can be done on P&ID level, but also between the P&ID and the 3D model. What type of
validation(s) are used between the P&ID and the 3D model?
Pipe line size, spec, Line number and service.
Tag of the inline components.
Number of nozzles on Equipment in 3D and on the P&ID.
If the inline components have been placed on the correct pipe routes.
Is the validation tool capable of recognizing that a valve is placed on the wrong pipe route?
No.
Yes, but only one pipe route at the time.
Yes, this can be done over the entire project and all pipe routes.
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Lesson: Creating and Annotating
Lesson: Orthographic Views
This lesson describes the creation and annotation of 2D views from the 3D model. In this lesson,
you learn how to create orthographic and sectional drawing views and update them when changes
have been made in the 3D model. You also learn how to place, modify, and update dimensions and
annotations.
After a plant design has been created and finalized, you need to communicate that design to
others. To build and install the piping lines and equipment, you must create and supply construction
documents. From the 3D model, you can more easily generate the construction documents.
Information is directly exchanged with the 3D model, helping your construction documents to be
more accurate, consistent, and up to date.

Objectives
After completing this lesson, you will be able to:
Understand what orthographic drawings are within AutoCAD Plant 3D-P&ID.
Explain how orthographic drawings are created.
Identify the annotation and dimensioning tools.
Explain how orthographic drawings are updated to represent changes in the 3D model.

■
■
■
■
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About Orthographic Drawings
About Orthographic Drawings
Orthographic drawings are 2D representations of a Plant 3D model. Rather than drawing these,
you can generate them from the model using general layouts, which are then used as views in the
orthographic drawing.

Creating and Editing Orthographic Views
General Layout
When you set up orthographic drawings, a box is displayed that assists in determining the geometric
extents and view of the resulting orthographic drawing. The current view of the layout is represented
by a red side. In the following example, the view is set to top.
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Settings
Some of the settings you can determine during the general setup are:
■
The view (top, front, right, and so on)
■
Which models to include
■
Scale
■
Extents and sectional views

Editing Views
After a view is created in the orthographic drawing, you can edit certain characteristics of the view,
such as scale. When editing a view, the Ortho Editor context ribbon is displayed.

Adjacent Views
You can easily create and name adjacent views in an orthographic drawing.

All views created are listed on the Orthographic tab of the Project Manager.
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Annotations and Dimensions
Annotations
From within an orthographic drawing, you can create annotations that include data from the objects in
the 3D model. In the example below, an annotation is created from within the orthographic view using
the line number of the line in the model.

Dimensions
You can create dimensions in an orthographic view using standard AutoCAD dimensioning tools.

Lesson: Creating and Annotating Orthographic Views

■

3-93

Updating Orthographic Drawings
Once an orthographic drawing has been created, you can regenerate it if changes are made to the
model. You can choose to regenerate a single view, or all views in the orthographic drawing. Most of
the characteristics of the model are dynamic and are updated during the regeneration. These include
line tags, annotations, physical characteristics of objects such as length, and so on.

Updating Dimensions
While annotations and underlying data are dynamic and update along with objects when you
regenerate an orthographic drawing, dimensions do not. If the physical characteristics of an object
that is dimensioned in the orthographic drawing changes, for example in length, the dimensions are
no longer correct representations.
In the example below, a pipe was shortened in the model. When the orthographic drawing was
updated, the dimension still represents the original length. To correct this, you manually update the
dimension.

If you are going to dimension objects in an orthographic view, it is recommended that
you do so after the model is complete.
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Exercise: Create and Annotate Orthographic Views
In this exercise, you create a general layout of the 3D
model that consists of a number of views including
a sectional view. You further enhance the views by
adding dimensions and annotations. You also update
the views and annotations after making changes to
the 3D model.

4.

Click Home tab > Ortho Views panel > Create
Ortho View.

5.

In the Select Orthographic Drawing dialog box,
click Create New.

6.

In the New DWG dialog box:
■
Enter Orthographic for the drawing name.
■
Click OK.

The completed exercise

Set Up and Create an Orthographic Drawing
In this section of the exercise, you set up an
orthographic view by selecting the models to include,
setting the scale settings, and then creating the view.
1.
2.

3.

Launch AutoCAD Plant 3D.
To open a project:
■
In the Project Manager, Current Project list,
click Open.
■
In the Open dialog box, navigate to the
folder ..\Plant Design\Create and Annotate
2D Drawings.
■
Select the file Project.xml.
■
Click Open.
Open the Piping drawing.
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7.

Examine the new orthographic representation
in the drawing screen. Notice that one side is
red. This is the current view.

11. Set the view back to Top.
12. In the General panel:
■
Enter TopView-1 to change the name.
■
Set the Scale to 1:50.

13. In the General panel:
■
Click the drop-down.
■
Click Save Current View Configuration.

8.

To add models to the orthographic drawing,
click Ortho Editor tab > 3D Models panel >
Choose Models to Include.

9.

In the Select Reference Models dialog box:
■
Select the Equipment, Structure, and Piping
drawings.
■
Click OK.

10. To change the view, on the Ortho Editor tab,
General panel, select the Front view. Notice
that the front view of the ortho is now red.
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14. In the Save View dialog box, for View Name,
enter TopView-1 Scale 1: 50. Click OK. This
saved view can be reloaded using all of the
settings including the boundary geometry.

15. To create the ortho view, click Ortho Editor tab
> Confirm/Cancel panel > Create Ortho View.

16. Drop the new view into the layout:
■
The Ortho Generation dialog box is
displayed with the progress of the
generation.
■
The new viewport is created in the layout.
4.

5.
6.

17. Leave the drawing open for the next section of
the exercise.

Edit View Scale
In this section of the exercise, you use Edit View to
change the scale of the TopView-1 view.
1. To edit the scale of a view, click Ortho View tab
> Ortho Views panel > Edit View.

Create Adjacent Views
In this section of the exercise, you create front and
right views of the model.
1. To create a front view, click Ortho View tab >
Ortho Views panel > Adjacent View.

2.
3.
2.

Select the view frame in the layout.

3.

In the Ortho Editor tab > General panel, for
scale, enter 0.01333. This corresponds to a
scale of 1:75.

Click Ortho Editor tab > Confirm/Cancel panel >
Update Ortho View.
■
The Ortho Generation dialog box is
displayed with the progress of the
generation.
■
The edited viewport is updated in the
layout with the new scale.
Reposition the view in the layout to the upperleft corner.
Leave the drawing open for the next section of
the exercise.

In the layout, select the view frame.
In the Create Adjacent View dialog box:
■
Select Front.
■
For View Name, enter FrontView-1.
■
Click OK.
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4.
5.

6.

Place the front view in the layout below the top
view.
Repeat steps 1 to 3 using the following settings:
■
Right view.
■
Name the view RightView-1.
■
Place the view in the layout to the right of
the front view.
5.

In the drawing screen, rotate the model to Top.

6.

Drag the box to enclose only the pumps in the
model as shown.

7.

In the drawing Screen, change the view to
Front.
Drag the box to enclose only the pumps in the
model as shown.

Leave the drawing open for the next section of
the exercise.

Create a Sectional View
In this section of the exercise, you create a sectional
view of the pumps in the model.
1. Click Ortho View tab > Ortho Views panel >
New View.

8.

2.
3.

4.
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In the Select Reference Models dialog box, click
OK.
In the Ortho Editor tab > General panel:
■
Set the view to Top.
■
For Name, enter Top View Pumps -1.
■
Set the scale to 1:40.

9.

In the drawing screen, select the box to display
grips.

■
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Click Ortho Editor tab > Confirm/Cancel panel >
Create Ortho View.

10. Place the view in the drawing to the right of the
top view.

11. Leave the drawing open for the next section of
the exercise.

4.
5.

Repeat step 3 for the second vessel.
To annotate a pipe, click Ortho View tab >
Annotation panel > Ortho Annotate.
■
Select the pipe as shown.
■
Press ENTER to accept the default tag.
■
Click to place the annotation at the side of
the pipe. Note that the line tag is 1009.

6.

To place a dimension, click Ortho View tab >
Annotation panel > Linear.

Add Annotation
In this section of the exercise, you annotate the top
orthographic view by retrieving and placing tags and
adding dimensions.
1.
2.

Zoom in to the TopView-1 view.
To add annotation to the vessels on the
platform, click Ortho View tab > Annotation
panel > Ortho Annotate.

3.

At the prompt:
■
Select the vessel as shown.
■
Press ENTER to accept the default tag.
■
Click to place the annotation in the center
of the vessel.

Note: Switch out of model space and into paper
space to dimension the pipe.
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7.

8.

Using endpoint osnaps, place the dimension as
shown.

Leave the drawing open for the next section of
the exercise.

Modify the Design
In this section of the exercise, you modify the tag
value for one of the objects previously annotated
and change the length of a pipe segment that was
dimensioned.
1.
2.

Activate the Piping drawing.
Select the pipe as shown:
■
Right-click.
■
Click Add to Selection > Connected Line
Number.

3.

Right-click. Click Properties. On the Properties
palette, for Line Number Tag, select New.
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4.

In the Assign Tag dialog box:
■
For TargetObject.Number, enter 2031.
■
Click Assign.
■
Press ESC to clear the line.

5.

Select the pipe as shown:
■
Select the end grip.
■
For Length, enter 4000.

6.

Save the drawing.

Update Orthographic Drawings
In this section of the exercise, you validate and update
the orthographic drawings to represent the changes
made in the last section of the exercise.
1.
2.
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In the Project Manager, click the Orthographic
DWG tab.
Right-click Orthographic. Click Validate Views.

3.

Examine the results of the validation. All
views turn red, indicating that they no longer
represent the latest version of the model.

4.

Right-click Orthographic again. Click Update
Views.
Examine the results of the update:
■
The annotation on the line is updated to
reflect the new line number.
■
The pipe that was shortened is represented
in orthographic view.
■
The dimension did not update. Dimensions
in orthographic views must be adjusted
manually.

5.

6.

7.

Close all files. Do not save.

Select the dimension. Using an endpoint osnap,
place the dimension on the new endpoint of
the pipe.
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Review
Can you store the settings of a view you created earlier?
Yes, but you need to do this while creating or editing the view settings.
It is not possible.
This has to be done upfront in your template file.
When drawing views have been changed, how can you recognize if a view needs to be updated?
You have to select the update view button and that will show if update is necessary.
By right clicking the drawing name in the project manager, you can select the option "Validate
Views". This will show which views need to be updated.
To get an up-to-date view, you have to re-create the view entirely. It is not linked to the 3D
model.
Is it possible to create an adjacent view from any type of view?
No, only the first view placed can be used to create adjacent views.
Yes, each view you create can be used to create adjacent views.
Yes, but there is a maximum number of adjacent views you can create.
When annotations have changed in the 3D model (like the tag), how do you update these in the
orthographic drawing?
On the orthographic ribbon, beneath the annotate button, you will find an "Update annotate"
button. This will check the value of the annotation in the 3D model and update it if necessary.
You have to re-place the annotation, it is not possible to update the annotation.
Annotations will update automatically when they change in the 3D model.
When you need to create hard copies, do you need to do this drawing by drawing, or are there other
options?
Yes, drawings can only be printed/plotted piece by piece.
No, you can publish drawings by right clicking a drawing, a folder or even the entire project if
necessary.
Yes, plotting and printing can be done per drawing, by selecting them with the right mouse
button in the project manager.
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Lesson: Creating Isometric Drawings
This lesson describes the creation and modification of an isometric drawing. Along with learning how
to create an Iso, you learn how to add Iso-specific information such as insulation, flow arrows, and
floor penetration. You also learn how to change the components and connectors from shop to field
and how to show the 3D insulation.
A single pipe run is rarely all in the same plane. Because a pipe run typically changes direction multiple
times, trying to visualize the pipe lines can be challenging when viewing the design in orthographic
views. To make it easier to view and visualize pipe lines, you need to create isometric drawings.
Isometrics are also used to fabricate the pipelines.

Objectives
After completing this lesson, you will be able to:
■
■
■
■

Describe what isometric drawings are in the project.
Identify the tools used to add data to an isometric drawing.
Identify some of the files that are used during the Isogen process.
State the high-level process to create an isometric drawing.
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About Creating Isometric Drawings
About Creating Isometric Drawings
Isometric drawings are representations of the model that include additional data in the form
of symbols, labels, and drawing objects that describe model components, connections, and
requirements for either the entire model, or specific lines only. Isometric information, symbols, and
labels are represented in the model by points, or small globes. The data itself is not visible in the
model. Rather, the data is mapped through specifications to generate the symbols and additional
information in the isometric drawing once it is created.

Creating, and Adding Data to Isometric Drawings
Creating and Adding Data to Isometric Drawings
There are three main tasks in documenting a 3D plant design:
■
Annotating the 3D model geometry with information so that the isometric drawings are annotated
as required.
■
Producing the isometric drawings of the 3D design.
■
Locking the line so that changes are not made by mistake.
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Iso Annotations
You add Iso information to the 3D design by using the tools on the Iso Annotations panel. The
annotation information you add to the model is then automatically included in isometric drawings of
that line.

You add Iso messages to the isometric drawing from the Create Iso Message dialog box. In the
following example, the message is enclosed within a round-ended box. There are several additional
enclosures that you can use.
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Production ISO
When you create a Production Iso, you select the lines from which to create it in the Create
Production Iso dialog box. Select the Overwrite If Existing check box to prevent creating multiple
Isos of the same line. By selecting the Create DWF check box, DWF files will be created of the Isos
generated. This enables you to create DWF files of the isometric drawings without having to use the
Publish command.

Line Lock and Issue
You can lock a line throughout the project, including the model, directly from the line on the Isometric
DWG tab of the Project Manager.

Refer to the help system to learn more about additional tools and options for
creating isometric drawings.
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Specification Sheets and Files
Isometric customization is handled through the Project Setup. All facets of isometric and style creation
are handled through this dialog box. These settings are project-wide. Care should be taken before
modifying these settings.
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Specification Sheets
The specification sheets are accessed and managed through the Plant 3D Spec Editor. Here, you can
control what symbols are used during the Isometric process. In the example below, the selected
catalog item contains the information for the symbol and type to insert in the isometric drawing.

Refer to the AutoCAD Plant 3D help system for more information about
troubleshooting AutoCAD isometrics.
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Process to Create Isometric Drawings
Process: Create Isometric Drawings
Creating isometric drawings can be an iterative process that might require changes to be made to the
model if there are missing components, or changes to be made to existing components. The basic
process is as follows:
1.
2.

Launch the Production Iso
command.
Select the line from which
you want to create the
isometric drawing.

3.

View the results of the
creation.
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Exercise: Create Isometric Drawings
In this exercise, you create an isometric drawing
based on a line number. You then make changes in
the model such as adding information and messages,
changing shop and field values, adding insulation,
and locking layers. After each change, you recreate
the isometric drawing to examine the result of your
changes.

4.

To identify the line from which you create
the Iso, in the drawing screen, hover your
cursor over the line and make a note of the line
number. In this case, the line number is 1009.

5.
6.

Activate the 3D Piping workspace.
Click Isos tab > Iso Creation panel > Production
Iso.
In the Create Production Iso dialog box, under
Line Numbers, select 1009.

The completed exercise

Create an Isometric Drawing
In this section of the exercise, you create an Isometric
drawing based on a single line section.
1.
2.

3.
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Launch AutoCAD Plant 3D.
To open a project:
■
In the Project Manager, Current Project list,
select Open.
■
In the Open dialog box, navigate to the
folder ..\Plant Design\Create Isometric
Drawings.
■
Select the file Project.xml.
■
Click Open.
In the Project Manager, open the Piping
drawing.

■

7.
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8.

9.

In the Create Production Iso dialog box, under
Output settings:
■
From the Iso Style list, select Final_A3.
■
Click Create.

Change a Shop Weld to a Field Weld
In this section of the exercise, you change shop
welds to field welds in the model, and regenerate the
isometric drawing to view the results.
1. With the model open from the last section of
the exercise, return to the Piping drawing.

When the Isometric creation is complete, at
the bottom of the AutoCAD Plant 3D window,
click the Click to View Isometric Creation
Details link.
2.
3.

10. In the Isometric Details dialog box, under From
1009.pcf, click the link for the file 1009.dwg.

4.

To change the view to 3D wireframe, click
Home tab > View panel > 3DWireframe.
To ensure that the current system variable for
displaying connection markers is on:
■
On the Command line, enter
PLANTWELDDISPLAY.
■
Enter ON.
Connectors in the 3D wireframe view are
represented by points. Using a window (not
a crossing window), select the connector as
shown.

11. Review the symbols and labels in the new Iso
drawing. Notice that welds are represented by
points and position numbers and connections
descriptions are included.
12. Review the Bill of Materials and Cut Piece List
tables.

5.

With the grip displayed on the connector, rightclick and click Properties.

13. Close the isometric drawing.
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6.

On the Properties palette:
■
Verify that you have selected the connector.
■
In the General section, change Shop/Field
to FIELD.

■

■

■

7.

Press ESC to clear the selection. Note that the
drawing marker updates to the FIELD WELD
symbol.

8.
9.

Save the drawing.
To regenerate the isometric drawing, click Isos
tab > Iso Creation panel > Production Iso.
10. Recreate the 1009 line.
11. When the creation is complete, click to view
the isometric creation details. Notice that your
weld is now indicated by an FW and an FW
symbol.

Under Enclose Message In, select Round
Ended Box.
In the message window, enter PaintCode#
157.
Click OK.

3.

When prompted for location, select the pipe as
shown.

4.

Notice the glyph that is inserted.

5.
6.

Recreate the Isometric drawing for line 1009.
Examine the results of the isometric message in
the isometric drawing.

7.

Close the isometric drawing.

12. Close the isometric drawing.

Adding Messages
In this section of the exercise, you add an isometric
message to the drawing.
1.
2.
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With the Piping drawing open, click Isos tab >
Iso Annotations panel > Iso Message.
In the Create Iso Message dialog box:

■
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Create Isometric Information
In this section of the exercise, you add insulation
to a line and specify where on the line to show the
insulation.
1. To select the entire line number that you want
to add insulation to:
■
Select one of the fittings. Right-click.
■
Click Add To Selection > Entire Line Number.

7.

Close the isometric drawing.

Line Lock and Issue
In this section of the exercise, you lock a line so that it
cannot be edited.
1.
2.

On the Properties palette, under Process Line:
■
For Insulation Thickness, select 25 - 25.
■
For Insulation Type, select H - Hot.

3.

To add an insulation symbol:
■
Click Isos tab > Iso Annotations > Insulation
Symbol.
■
Click to position the insulation symbol on
the pipe where identified. Notice the glyph
that is inserted in the line.

4.
5.
6.

2.

With the Piping drawing open, in the Project
Manager, click the Isometric DWG tab.
Under Final_A3, right-click the 1009 line. Click
Lock Line and Issue.

3.

In the drawing screen, hover the cursor over
line 1009 in the model. Notice the lock symbol
and the tooltip.

4.

Close all files. Do not save changes.

Recreate the isometric.
When the creation is complete, click to view
the isometric creation details.
Examine the results in the isometric drawing.
The insulation symbol is now added.
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Review
In the Project Manager, you can lock lines on the Isometric Drawing tab. Is it possible for others to see
by whom and when this line was locked?
Yes, the properties of the 3D pipe will show who locked the pipe and when it was locked.
No, this can only be seen on the Isos tab.
Often an Iso is created multiple times. How do you prevent creating multiple Isos of the same line?
Manually remove the Iso from the Project Manager, and delete the file through Windows
Explorer.
Change the line number.
Select the Overwrite If Existing check box in the Create Production Iso dialog box.
Can you create DWF files of the Isos generated without having to use the Publish command?
In the Create Production Iso dialog box, an option can be found to automatically create a DWF
file of each Iso that is generated.
The only way to created DWF files is by using the Publish command.
You can create DWF files from the command line.
With many Isos, the same information has to display each time you create a new Iso. What options
are available to put this information into the Iso without having to enter it manually every time?
You can add them to your template (properties that are available on your pipe can be used in the
setup of your title block).
The properties that you need have to be placed manually to the Iso each time after you generate
the isometric drawing.
You have to add these properties each time manually by using the MText command.
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Chapter Summary
In this chapter, you learned how to use AutoCAD Plant 3D to create and modify a 3D plant design and
2D views of the 3D design.
Having completed this chapter, you can:
■

■

■
■
■
■
■
■

Add drawings to a project by creating them new, linking to existing drawings, and copying them
from another project.
Setup a grid, add steel members, ladders, stairs, railings, plates and footing, and modify the steel
structure.
Model and place 3D equipment.
Create and route pipe and place pipe components.
Create and use parts and place holder parts and change a line number, size, or spec.
Use a P&ID to create and validate pipelines in the 3D design.
Create and annotate orthographic views.
Create isometric views.
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Chapter

4
Navisworks
Design review, visualization, and error identification are tasks and benefits of creating 3D plant
designs. Being able to do these tasks project-wide when design data is created in a variety of design
and engineering applications can be a daunting task. By using Autodesk Navisworks, you can combine
design files into a single integrated project model for efficient whole-project review. In this chapter,
you learn how to use Navisworks to view, review, and analyze a plant design.

Objectives
After completing this chapter, you will be able to:
■
■
■
■

Work with and handle files in Navisworks.
Navigate and walk through a design in Navisworks.
Conduct clash tests and work with clash detection results.
Create rendered images and animations and use TimeLiner to link to an external scheduling project
file and to create a simulation.
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Lesson: File Handling
This lesson describes how to work with and handle files in Navisworks. In this lesson you learn how
to open existing NWD files, import 3D data from DWG files, save NWF files, and publish NWD files for
sharing with others. You also learn how to set file units, merge 3D design information, refresh files,
and send and receive files by email.
It has become common practice that design projects are created in separate parts by different people
using different design software. These separate files need to be reviewed at the same time to allow
for proper collaboration. One of the most important capabilities in Navisworks is the ability to open
and combine different files for review.

Objectives
After completing this lesson, you will be able to:
Know when to use NWD verses NWF files.
Set the units in a Navisworks file.
Publish NWD files.
Publish NWD files.

■
■
■
■

File Types
Navisworks File Types
Navisworks can create and open the following types of files:
■
NWD - This type of file contains all the graphics and data from one or more DWG files that make
up a Plant 3D project. When you save the NWD file, all the information from the DWG files at the
time of the save is built inside the NWD file. External files are not attached.
■
NWF - This type of file is a more dynamic view of a project. When you use a NWF you link the
various DWG files together. Navisworks automatically makes NWC cache files for each DWG so
there is good performance. When you open a NWF file, Navisworks will automatically check to see
if a DWG file has been changed since it was last cached and make a new cache if it is out of date.
An NWF file is much smaller than an NWD file.
■
NWC - Navisworks cache files used to load NWF files.
The model information within an NWD file is compressed, thus making the file size smaller than an
NWF file and its attached files.
If you are going to send someone a project, you should use an NWD file.
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Appending Files
To add more models to an existing scene, you can to append model files. When appending files into
Navisworks, multiple file formats can be opened. These file types include Navisworks files, AutoCAD
files, Microstation files, 3 Dimensional Point Clouds that come in from scanner systems, and SketchUp
files from Google.
Another option is to make a master model in AutoCAD and xref all the parts into it before you create
a NWD in Navisworks. If all the parts of the model are in DWG files and already xrefed together, this
would be easier than appending each file in Navisworks. The advantage of doing it this way is that you
would only have a single NWD file to work with. However, the disadvantage is that you would have to
recreate the NWD file any time one of the xrefs changes.
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Setting File Units
When you measure lengths in Navisworks, the value is displayed using the unit specified in the
Options Editor. When you change the units, any measurement you have placed in the file is
automatically updated to the new units you select.
For more information on the other settings in the Options Editor, see the Navisworks docs.

These units are independent of and do not affect the units set in the individual DWG
files to a Navisworks file.
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Sharing
You use the Publish command to share information about a project with other Navisworks users. When
you publish an NWF file that has attached files, an NWD file is created that contains all the information
from the attached files inside the one compressed file.
You can specify the information you want to share and password-protect the file if necessary.
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Troubleshooting
Autodesk offers free downloadable enablers that you can use to access, display, and manipulate
object data in applications different from their native environment. This provides essential data
accessibility for design teams who create or receive files using Autodesk software. In particular,
the AutoCAD Plant 3D object enabler allows Navisworks users to directly retrieve property data
while reviewing AutoCAD Plant 3D models. Object enablers exist for Civil 3D, AutoCAD Architecture,
AutoCAD MEP and AutoCAD Plant.
If you open a drawing in Navisworks that contains external references, properties for AutoCAD Plant
3D objects in external reference drawings may not display. To solve this, delete the NWC file for the
external reference, load Navisworks, and open the external reference DWG before opening up the
master drawing.
Do not install the AutoCAD Plant 3D 2012 Object Enablers for use by AutoCAD P&ID 2012. The support
Object Enablers provided is built-in to AutoCAD P&ID 2012. However, if the enablers do get installed
by mistake, do not uninstall them. Removing the enablers from AutoCAD Plant 3D or AutoCAD P&ID
after being installed will cause problems.
Important: When installing AutoCAD Plant 3D 2012 Object Enablers, some applications that appear in
the Object Enabler Setup application list should not be selected, and must be cleared. For example, do
not select AutoCAD P&ID or AutoCAD Plant 3D. Installing enablers to applications that are not listed
above can cause problems.
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Exercise: Work with Navisworks Files
In this exercise, you establish file units prior to
opening multiple files for review. You open a NWD
file, multiple DWG files, and save the NWF file. During
the import of DWG files, you locate missing X-Ref
files. You then publish a NWD file after reviewing the
publish options.

3.

To change the display units:
■
On the Application menu, click Options.
■
In the Options Editor dialog box, left pane,
expand Interface.
■
Click Display Units.
■
In the right pane, from the Linear Units list,
select Feet and Inches.
■
Click OK.
The measured units now display as feet and
inches.

4.

To start a new file, on the Quick Access toolbar,
click New.

The completed exercise

1.
2.

Open Equipment.nwd.
To measure a distance:
■
Click Review tab > Measure panel >
Measure list > Point to Point.
■
Select point 1.
■
Select point 2.
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5.

6.

To append a DWG file:
■
On the Quick Access toolbar, click the arrow
next to Open.
■
Click Append.

In the Resolve dialog box, click Browse.
■
Navigate to the dataset folder. Select
Equipment.dwg.
■
Click Open.
■
Click OK.
■
Repeat the steps to select all additional
files.
NoteNote
8. To save the file:
■
On the Quick Access toolbar, click Save.
■
In the Save As dialog box, for File Name,
enter Plant 3D.
■
Verify that Navisworks File Set (*.nwf) is
selected from the Save As Type list.
■
Click Save.
9. On the Application menu, click Publish.
10. In the Publish dialog box:
■
For Title, enter Plant3D.
■
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In the Append dialog box:
Click the arrow next to Files of Type.
■
Notice all the different file types available to
append.
■
Select Autodesk RealDWG (*.dwg).
■
Navigate to the folder where the datasets
are saved.
■
Select Piping.dwg.
■
Click Open.
: After missing x-ref files are located, you will
not need to relocate the files each time you
reopen the NWF file.
13. Close all files. Do not save.
The drawing has external reference files that
cannot be found.
To select the correct external reference files.
■

7.

For Author, enter Autodesk.
Click OK.
11. In the Save As dialog box:
■
For File Name, enter Plant 3D.
■
Verify that Navisworks (*.nwd) is selected
from the Save As Type list.
■
Click Save.
12. Open a Windows Explorer window. Navigate to
the folder where your files are saved. Notice
the file sizes of the different file types.
■

■
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Review
Navisworks NWD files contain all related files needed and do not require external files links.
True
False
Open the exercise file Equipment.nwd. What is the distance in FEET AND INCHES from the center of
beam A to the center of beam B in figure 1A?

21FT 1.12
26M 2.42
26FT 2.42
16FT 2.31
After missing xref files are located, you will need to relocate the files each time you reopen the NWF
file.
True
False
Navisworks Manage 2012 can directly append or merge Autodesk Inventor files.
True
False
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Lesson: Basic Navigation and Walkthrough
This lesson describes basic navigation and walkthrough in Navisworks Manage and Simulate. You learn
to work with objects by quickly selecting them, viewing them, and displaying properties.
When reviewing designs, you may need to select objects in the design. Large projects can make
selecting objects a lengthy process. Navisworks enables you to simplify this task by providing a range
of tools to help you quickly select interactively, manually, and automatically.
Navisworks provides numerous way to navigate and walk through a design. Viewpoints are an
important tool to save time and return to important model views and to establish design review audit
trails.

Objectives
After completing this lesson, you will be able to:
■
■
■

Describe the different ways of viewing a model.
Select objects in a model.
View object properties.

Viewing a Model
There are several different ways to view your models in Navisworks including the Viewcube, tools on
the Navigation Bar, and viewpoints.

Viewcube
You use the Viewcube to change the view of the 3D model by simply clicking on one of the surfaces of
the cube. Dragging the position of the viewcube also rotates the view of the 3D model.
Additionally, you use the wheel on the mouse to zoom and pan the view of the 3D model.
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Navigation Bar
The Navigation Bar offers a standardized experience across many Autodesk software products;
however, it can also be configured to use classic Navisworks tools to suit user preferences. You can
click on the Navigation Bar Customize button to show the options for Classic Navisworks navigation
modes.
The Navigation Bar includes five navigation modes and six Steering Wheels for interactive navigation
around your 3D models. Most navigation modes have further options accessed by selecting the mode
down arrow.
The following illustration shows the tools on the Navigation Bar.

Steering
Wheels

Steering wheels are task-based floating tool palettes that travel with the
cursor to minimize tool access time. There are three standard wheels, and
three mini wheels. These provide access to nine different navigation tools
(Orbit, Zoom, Rewind, Pan, Center, Walk, Look, Up/Down and Forward).
Various combinations of these nine tools are available in the different versions
of the Steering wheel. In Navisworks, the Full Navigation Wheel (or mini
version of this) will likely be most useful for navigating the 3D model scene.

Pan

Drag the cursor in any direction to pan the model by moving the camera
correspondingly. Press SHIFT or CTRL to temporarily switch to zoom.

Zoom

The Zoom mode includes the following tools:
Zoom Window - Allows you to draw a box and zoom into that area.
Zoom - click a point in the scene view then drag the cursor up or down to
zoom the camera in and out.
Zoom Selected - Zooms in/out of the selected geometry.
Zoom All - Zooms out to show the whole scene.

Orbit

The Orbit Mode includes the following tools:
Orbit - moves the camera around the focal point of the model. The up
direction is always maintained, and no camera rolling is possible.
Free Orbit - rotates the model around the focal point in any direction.
Constrained Orbit - spins the model around the up vector as though the model
is sitting on a turntable. The up direction is always maintained.
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Look

The Look Mode includes the following tools:
Look Around - looks around the scene from the current camera location.
Look At - looks at a particular point in the scene. The camera moves to align
with that point.
Focus - looks at a particular point in the scene. The camera stays where it is.

Walk and Fly

The Walk and Fly Modes
Fly Mode - allows you to fly the camera through the scene. Hold down the left
mouse button and drag the mouse up or down to ascend or descend and left
or right to move correspondingly.
Note: Holding down the SHIFT key speeds up this movement and holding
down the CTRL key rotates the camera around its viewing axis, while still
moving forward.
Walk Mode - allows you to walk around and through the model scene.
Walk mode resets the model to an upright position. Press SHIFT to increase
walking speed or press CTRL to temporarily switch to Pan to adjust the camera
position. Press SPACEBAR to temporarily crouch under an obstacle.
The Walk and Fly Modes also include the following options:
Collision - Select this check box to define a viewer as a collision volume in
Walk and Fly modes. As a result, a viewer acquires some mass, and cannot
pass through other objects, points, or lines in the Scene View.
Gravity - Select this check box to give a viewer some weight in Walk mode.
This option is useful when walking up or down stairs etc and also works in
conjunction with Collision.
Crouch - Select this check box to enable a viewer to crouch under objects that
are too low to pass under in Walk mode. This option works in conjunction with
Collision.
Third Person - This function allows you to navigate the scene from a third
person perspective. When activated, you will be able to see an avatar, which
is a representation of yourself within the 3D model. Using third person in
connection with collision and gravity allows you to visualize exactly how a
person would interact with the intended design. You can customize settings,
such as avatar selection, dimension, and positioning, for the current viewpoint
or as a global option.

Navigation
Bar
Customize

You select the Navigation Bar Customize arrow to:
Activate or deactivate navigation modes currently on the navigation bar.
Dock the Navigation bar in a different position.
Select Navigation Bar Options to change Orbit and Walk options

In Walk and Fly modes, you can set a speed that is suitable for the model size. Select
a viewpoint from where you wish to navigate, then click Application button > Options
to open the Options Editor. In the Options Editor, under Interface, click Viewpoint
Defaults. In the right pane of the Options Editor, select the Override Linear Speed
check box and set the speed as required.
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Viewpoints
Viewpoints are used to save specific views of a 3D model. Creating viewpoints of frequently used
views can save you time. Once viewpoints are created, you simply select the viewpoint from the Saved
Viewpoints palette to change to that view. You can create folders within the Saved Viewpoints palette
for organizing multiple viewpoints.
You can also create animations from the viewpoints you create. An animation will allow you to see
your model transition from one viewpoint to another.
Additionally, you can add redlines and comments to a viewpoint.

Selecting Objects in a Model
With large models, it can be very time-consuming to select items of interest. In Navisworks, there
are several tools available, including the Selection Tree and Selection Sets, that give you flexibility in
selecting the desired items in your model.

Selection Tree
When you select one or more items in the Selection Tree, the corresponding objects are selected in
the viewing window. You can also select objects in the model, and in turn, the corresponding items in
the selection tree are highlighted.
Additionally, you can use the Zoom Selected option on the Zoom Window drop-down of the Navigation
toolbar to zoom in on the selected objects.
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The selection tree hierarchy starts with the DWG file at the top level. The next level lists the layers in
the drawing followed by the objects on the layers. If the object contains other objects, such as blocks,
they are listed in the next level. The levels continue to the lowest level primitive.

Selection Resolution
When you select an item in your model, you can specify whether additional associated items are also
selected. For example, if you change the Selection Resolution to layer, when you select an item, all the
items on the same layer are also selected.

Selection Sets
Using Selection Sets, you have the ability to select multiple objects and group them together. You can
select the objects in the viewer or use the Selection Tree to select the desired objects. Once you have
the objects selected, you simply add the current selection to the Sets palette.
You can also create folders within the Sets palette to organize the selection sets you create and to add
comments to them.
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Searching for Objects
In addition to selecting objects and then putting them into sets, you can use Navisworks to find
objects. You use the Find Items palette to search for items with specific properties. Navisworks goes
through the model and finds the items that fit the specified criteria.
You can also add the current search as a selection set. This creates a dynamic search that will update
as the design progresses.
Additionally, you can use the Hide Selected option on the ribbon to view only the items that are
selected. All other items are hidden.
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Viewing Object Properties
You can view the properties of one or more selected items on the Properties palette. You can also
view Quick Properties, or information specific to an object in the scene view. If you have Quick
Properties turned on, when you hold your cursor over an item, a tooltip is displayed showing the
information. You can customize the information that is displayed in the tooltip.

If the Plant3D attributes do not display, you need to load the Object Enablers.

Tags
You use the Tags panel on the Review tab to add and manage tags. Tags combine the features of
redlining, viewpoints and comments into a single, easy to use review tool. This allows you to tag
anything you want to identify in the model scene. A viewpoint is automatically created for you, and
you can add a comment and status to the tag.

For example, during a review session, you locate an item in the scene that is incorrectly sized or
positioned. You can tag this item, stating the problem, save your review results as an NWF file, and
pass the file to the design team. The design team can search the file, for any tags of status 'new', and
locate your review comments. Once any necessary modifications are made to the drawing files, these
can be reloaded into the *.nwf file, and the tag status can be changed accordingly. You can review this
latest version of the NWF file, ensure all tags have been resolved and finally 'approve' them.
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Exercise: Navigate Your Way through a Design
In this exercise, you practice navigating a model,
selecting objects, using selection sets, and searching.

3.

Click Viewpoint tab > Render Style panel >
Lighting list > No Lights.

4.

Click Viewpoint tab > Render Style panel >
Lighting list > Head Light.
Click Viewpoint tab > Render Style panel >
Lighting list > Full Lights.
Click Viewpoint tab > Camera panel >
Orthographic list > Perspective.

The completed exercise

Basic Navigation
In this section of the exercise, you use the ViewCube
to navigate a model.
1.
2.

Open Plant 3D.nwf.
The drawing has external reference files that
cannot be found.
To select the correct external reference files:
■
■

■
■
■

In the Resolve dialog box, click Browse.
Navigate to the dataset folder. Select
Equipment.dwg.
Click Open.
Click OK.
Repeat the steps to select Structures.dwg,
Str_rack.dwg, and Piping_002.dwg.

5.
6.
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7.

On the ViewCube, click the Northeast Isometric
view.

The view is rotated.

11. Click and hold anywhere on the ViewCube.
Move around while you continue to hold the
left mouse button down. Notice that the model
orbits.
12. Use the wheel on the mouse to zoom in and
out. To pan, hold down the mouse wheel. To
rotate, hold SHIFT and the mouse wheel.
13. On the ViewCube, click Home.

Save Viewpoints
In this section of the exercise, you save different views
of the model as viewpoints.
1.
2.
3.
8.

On the ViewCube, click Top.

4.
5.
6.
7.

9. On the ViewCube, click several other views.
10. On the ViewCube, click Home.
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On the ViewCube, click the Southwest isometric
view.
Click Viewpoint tab > Save, Load & Playback
panel > Save Viewpoint.
On the Saved Viewpoints palette, to rename
the viewpoint, enter South West.
On the ViewCube, click the Northwest isometric
view.
Click Viewpoint tab > Save, Load & Playback
panel > Save Viewpoint.
Rename the new viewpoint North West.
Use the mouse wheel and ViewCube to zoom,
pan, and orbit in on the green platform.

Create Animations
1.

2.

8.
9.

Create a new viewpoint named Platform.
On the Saved Viewports palette, click the South
West and North West viewpoints. Notice the
view change.
10. On the Saved Viewports palette, right-click in a
blank area. Click New Folder. For Name, enter
Views.

3.

4.

11. Drag each viewpoint into the Views folder.

To create an animation:
■
On the Saved Viewports palette, right-click
in a blank area.
■
Click Add Animation.
■
For the Name, enter Plant 3D.
On the Saved Viewpoints palette, drag
the South West viewpoint to the Plant 3D
animation. Repeat the steps for the North West
and Platform viewpoints.

On the Viewpoint tab > Save, Load, & Playback
panel, select Plant 3D from the animation list.
Click Play.

Watch the animation play through.
Use the other controls on the Save, Load &
Playback panel to step forward, step back, and
play different parts of the animation.

Selection and Properties
In this section of the exercise, you select items in the
selection tree and view their properties.
1.
2.

Click Home tab > Select & Search panel >
Selection Tree.
On the Selection Tree palette, under
Piping.dwg, select 0. Notice the objects that are
selected.

Lesson: Basic Navigation and Walkthrough

■

4-19

3.
4.
5.
6.
7.

On the Selection Tree palette, under
Piping.dwg, select piping_002|T-100. Notice the
objects that are selected.
On the Selection Tree palette, under
Piping.dwg, select piping_002|V-102. Notice
the objects that are selected.
On the Navigation toolbar, click Zoom Window
list > Zoom Selected.
To clear the selection, click in a blank area of
the screen.
Select the railing that was part of the previous
selection.

8.
9.

The corresponding object is selected on the
Selection Tree palette.
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To clear the selection, click in a blank area of
the screen.
Select the platform as shown. The
corresponding object is selected on the
Selection Tree palette.

10. To clear the selection, click in a blank area of
the screen.
11. Click Home tab > Select & Search extended
panel > Selection Resolution list > Layer.
12. Select the same platform as before. Notice
that all the objects on the same layer are
automatically selected.
13. Click Home tab > Display panel > Properties.
Examine the properties displayed on the
Properties palette.
14. Click Home tab > Display panel > Quick
Properties. Move the mouse and hold it over
the highlighted objects. Examine the quick
properties displayed as a tooltip.
16. Move the mouse and hold it over the
highlighted objects. Examine the quick
properties displayed as a tooltip. Notice that
the source file name is now displayed in the
tooltip.

Manage Sets
In this section of the exercise, you save groups of
items as selection sets.
1.
2.

Click Home tab > Select & Search panel > Sets
drop-down > Manage Sets.
Press and hold CTRL while you select the
objects shown.

15. To change Quick Properties options:
■
On the Application menu, click Options.
■
In the Options Editor, left pane, expand
Interface > Quick Properties.
■
Click Definitions.
■
In the right pane, click Add Element.
■
From the Property list of the new element,
select Source File Name.
■
Click OK.

3.

To create a selection set:
On the Sets palette, right-click in a blank
area. Click Add Current Selection.
■
For the Name, enter V-102.
■
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4.

5.
6.

7.

8.

9.
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To create a folder:
■
On the Sets palette, right-click in a blank
area. Click New Folder.
■
For the Name, enter V.
On the Sets palette, drag the V-102 set into the
V folder.
To add a comment:
■
On the Sets palette, right-click the V folder.
■
Click Add Comment.
■
In the Add Comment dialog box, enter
V-102 related pipes and tank.
■
Click OK.
To add additional objects to the selection set:
■
On the Sets palette, select the V-102 select
set.
■
Hold the CTRL key while you select
additional objects.
■
On the Sets palette, right-click V-102. Click
Update.

10. Click Home tab > Visibility panel > Hide
Unselected. Navisworks hides everything except
what met the search criteria.
11. On the View Cube, click Home.

To find specific items:
■
Click Home tab > Select & Search panel >
12. To save the items as a selection set:
Find Items.
■
On the Sets palette, right-click in a blank
■
In the Find Items palette, right pane, from
area.
the Category list, select Item.
■
Click Add Current Selection.
■
From the Property list, select Type.
■
For the name, enter Piping.
■
From the Condition list, select Contains.
13. Close all files. Do not save.
■
From the Value list, select ACPPPIPE.
■
Click Find All.
Navisworks goes through the model and finds
all the items that meet that specific criteria. The
items are highlighted in the Selection Tree.
Click Home tab > Display panel > Properties.
The properties palette displays the number of
items selected.

■
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Review
What views does Navisworks enable you to view the 3D model? (Select all that apply.)
Perspective
Stereoscopic
Orthographic
You can open the Selection Tree in the Selection and Search section of the Home tab and dock it at any
side of the scene view.
True
False
You can change the selection resolution setting by selecting the required option on the Selection
Resolution list.
True
False
Which of the following options are available for selection in the Resolution list? (Select all that apply.)
File
Layer
First Layer
Last Object
View
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Lesson: Clash Detection
This lesson describes how to conduct clash tests and work with clash test results.
Bringing multiple 3D designs together from multiple sources into Navisworks allows the design review
process to check for possible geometry interferences. Being able to locate these interferences in
the 3D prototype means that you can attempt to eliminate the conflict before it becomes an actual
problem in the field.
The Clash Detective is only available in Navisworks Manage.

Objectives
After completing this lesson, you will be able to:
Describe the process for conducting a clash test in Navisworks.
Describe how to select geometry and view the results of a clash test.

■
■

Conducting a Clash Test
Process: Conducting a Clash Test
To conduct a clash test, you perform the following steps.
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1.

Activate the Clash Detective
from the Home tab > Tools
panel.

2.

Select to ignore any
necessary clash rules. Using
the Ignore Clashes Between
options will reduce the
number of clash results by
ignoring certain combinations
of clashing items.

■
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3.

Select the geometry to test
for clashes.

4.

View the results.

5.

Make the required changes
to the model or generate a
report to send to others who
need to be notified about the
clashes.
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Clash Detective
You use the Clash Detective tool in Navisworks to effectively identify, inspect, and report interferences
(clashes) in a 3D project model. Using Clash Detective can help you to reduce the incidents of human
error during model inspections.
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Selecting Geometry for Clash Tests
You select the geometry you want to check for clashes on the Select tab of the Clash Detective. The
geometry you select in the left pane will be checked against the geometry selected in the right pane.
You can hold SHIFT to select multiple items in the list.
Additionally, you can select directly from the scene view or you can use predetermined selection sets
or searches.
You can also determine whether you want to find hard interferences or specify clearances.
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Working with Clash Test Results
The results of a clash test are listed on the Results tab of the Clash Detective. When you select a clash
result, the scene view displays the geometry corresponding to that clash, zoomed in and highlighted.
The corresponding items are also highlighted in the tree views at the bottom of the Clash Detective.
In the right pane, you can specify different display options for the clashes, such as having the
transitions between clashes animated. Animating the transitions makes it really easy to see where you
are when you go from clash to clash, instead of instantly jumping from one clash to another, which
can make you lose your bearings in the drawing. The Dim Other and Transparent Dimming options
gray out the geometry that does not clash, making it very obvious where the clashes are in the model.
The View In Context button allows you to quickly zoom out on the entire model and then back in on
the clashing geometry. This will help you regain your bearings if you lose track of where you are in the
model.
In addition, you can rename, change the status of, and add comments to a clash result. Changing the
status of a clash result also changes the color of the geometry in the scene view when it is selected.

SwitchBack
For more information on using SwitchBack, refer to the Navisworks Help.
You can use the SwitchBack functionality to send the current view of the currently loaded file back
to AutoCAD (version 2004 or later) or MicroStation-based CAD products (/J and v8). This will make
locating the clash easier in order to correct the clash.
Important: The native CAD package must be installed on the same machine as Autodesk Navisworks
for SwitchBack to work.
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Exercise: Conduct Clash Tests
In this exercise, you conduct clash tests and work with
clash test results.

4.

To select the items to run the clash detection
on:
■
On the Clash Detective palette, Select tab,
under Left, expand Piping.dwg.
■
Select Str_rack|GRATING.
■
Hold down SHIFT and select Str_rack|
STAIRS.
All five Str_rack items will be selected.

The completed exercise

1.
2.

Open Plant 3D.nwf.
The drawing has external reference files that
cannot be found.
To select the correct external reference files:
■
■

■
■
■

3.

In the Resolve dialog box, click Browse.
Navigate to the dataset folder and select
Equipment.dwg.
Click Open.
Click OK.
Repeat the steps to select Structures.dwg,
Str_rack.dwg, and Piping_002.dwg.

Click Home tab > Tools panel > Clash Detective.
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5.

■
■
■

Under Right, expand Piping.dwg.
Select piping_002|10001.
Scroll down and use SHIFT to select all
piping_002 items.

7.

On the Clash Detective palette, click the Results
tab.
Clash1 is selected by default and the window is
zoomed to the items that clash.

Notice that the items that clash are also
highlighted at the bottom of the Results tab in
the Item Trees.
8. Under Display, select Animate Transitions.
9. Under Results, select Clash2, Clash3, and
Clash4. Notice that the window makes a
smooth transition from each clash.
10. Under Display, select Dim Other. All items that
do not clash turn grey.
11. Under Display, select Transparent Dimming. All
items that do not clash are made transparent.
12. Under View in Context, click View All.

Watch as you are zoomed out to view all items
and then zoomed back in to the clashed items.
13. To rename the clashes:
■
Under Results, select and right-click Clash1.
■
Click Rename.
■
For the name, enter Pipe and Rack Clash.

6.
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Under Run, from the Type list, verify that Hard
is selected. Click Start.
Notice that five clashes are found.

■
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14. From the Status list of the Pipe and Rack Clash,
select Reviewed. Notice that the items change
color.

Click Write Report.
17. To save the file:
■
In the Save As dialog box, navigate to the
folder where the datasets are saved.
■
For File Name, enter Plant 3D Clash Test
Report.
■
Click Save.
18. Open the HTML file just created from Windows
Explorer.
19. Close all files. Do not save.
■

15. To add a comment to a clash:
■
Right-click Pipe and Rack Clash.
■
Click Add Comment.
■
In the Add Comment dialog box, enter This
needs to be checked.
■
At the bottom of the Add Comment dialog
box, from the Status list, verify that New is
selected.
■
Click OK.
16. To create a clash report:
■
On the Clash Detective palette, select the
Report tab.
■
Under Contents, select the options as
shown.

■

■

From the Report Type list, verify that
Current Test is selected.
From the Report Format list, select HTML.
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Review
You cannot select objects for clash testing from the scene, the Selection Tree window, or selection or
search sets.
True
False
Navisworks can detect which of the following object clashes? (Select all that apply.)
Clearance
Piping
Hard
Soft
Duplicates
Match the View in Context option to its definition: 1. Go to Home View 2. View All 3. View File Extents
Circle
One
123

The view zooms out (using an animated transition) such that the extents of the files
containing the items involved in the selected clash are visible in the Scene View.
The view zooms out to make the whole scene visible in the Scene View.
Takes you to the previously defined Home View.

123
123

Which of the following Report Formats are available for exporting Clash Detection? (Select all that
apply.)
XTMP
HTML
XML
TEXT
VIEWPORTS
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Lesson: Highlights of Scheduling,
Lesson: Animation, and Rendering
This lesson describes the use of TimeLiner to link to an external scheduling project file and to create
a simulation. In this lesson you also learn how to create rendered images and animations for sharing
with others.
The Navisworks TimeLiner enables you to create 4D simulations of 3D designs that you use to create
real-time walk-throughs and review complex 3D design projects. 4D simulation enables better planning
and helps to identify scheduling risks at an early stage, which can significantly reduce waste.
Navisworks allows design review animations to be created and saved for viewing by others. High
resolution renderings allow for photorealistic design review.

Objectives
After completing this lesson, you will be able to:
■
■
■

Describe using timeliner for visual 4D planning.
Describe the purpose of using animations.
Describe how to use Presenter to add materials and lighting to your scene.

Timeliner
The TimeLiner tool enables you to link your 3D model to an external schedule, such as a construction
schedule or maintenance process, for visual 4D planning. This allows you to see the effects of
the schedule on the model, and compare planned dates against actual dates. You can combine
the functionality of TimeLiner with other Autodesk Navisworks tools, such as Clash Detective and
Animator.
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TimeLiner Tasks
You use the Tasks tab to create and edit tasks, to attach tasks to geometry items, and to validate your
project schedule.

TimeLiner Links
You use the Data Sources tab to link external schedule information. You can import a list of tasks from
a project file directly into TimeLiner, including start dates, end dates, and times.
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TimeLiner Rules
You use the Rules on the Tasks tab to create and manage TimeLiner rules. All the rules that are
currently available are listed on the Rules tab. You use these rules to map tasks to items in the model.
Each of the default rules can be edited, and new rules may be added as necessary.

TimeLiner Simulate
You use the Simulate tab to simulate your TimeLiner sequence throughout the duration of the project
schedule. You use the playback buttons to play through and reverse the simulation as well as rewind
and forward it. You can also position the slider to quickly move through the simulation.
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Animations
An animation is a prepared sequence of changes to the model. In an animation, objects can be added,
removed, moved, or rotated from one location to another. For example, a crane lifting a vessel. You
create an animation by saving different viewpoints of your model and then assembling them. An
animation allows you to see your model transition from one viewpoint to another.
Once you have created an animation, you can export it as an external file that can be viewed
independently of Navisworks and shared with others.
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Presenter
You use Presenter to add materials and lighting to your scene and render it with more realism and
effects.
Default materials of the elements in a model are based on the colors they were in the application in
which they were created, such as AutoCAD. You can assign predefined Navisworks materials to the
elements using the Materials tab in Presenter. You can also use this tab to create new materials, or
customize existing materials.
You can select and apply different lighting options using the Lighting tab.
Additionally, the RPC tab contains Rich Photorealistic Content (or RPC), such as people, trees, cars, and
so on.

Be careful not to add more than a small required number of lights to a model. The
more lights you place, the longer a model will take to render and the more system
memory it will take.
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Exercise: Work within the Fourth Dimension
In this exercise, you work with Navisworks TimeLiner
to create a 4D simulation. You create, play, and export
an animation. You also add materials to the elements
in your model and export a rendered image.

3.

The completed exercise

Use TimeLiner
In this section of the exercise, you use TimeLiner to
view a simulation.
1.
2.

Open Plant 3D.nwf.
The drawing has external reference files that
cannot be found.
To select the correct external reference files:
■
■

■
■
■
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In the Resolve dialog box, click Browse.
Navigate to the dataset folder and select
Equipment.dwg.
Click Open.
Click OK.
Repeat the steps to select Structures.dwg,
Str_rack.dwg, and Piping_002.dwg.

■
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4.
5.
6.
7.
8.

Click Viewpoint tab > Render Style panel >
Lighting list > Full Lights.
Click Home tab > Tools panel > TimeLiner.
On the TimeLiner palette, click the Tasks tab.
Notice that there are no tasks listed.
On the Data Sources tab, click Add > CSV File.
In the Open dialog box, navigate to the dataset
folder and select Plant 3D.csv.
Click Open.

9.

In the Field Selector dialog box:
■
Select the Row 1 Contains Headings option.
■
Select the External Field Names as shown.
■
Click OK.

10. On the Data Sources tab, right-click the new
link. Click Rebuild Task Hierarchy.

12. On the Tasks tab, under Tasks, click Rules.
■
In the TimeLiner Rules dialog box, verify
that Map TimeLiner Tasks from Column
Name to Layers with the Same Name,
Matching Case is selected.
■
Click Apply Rules.
■
Close the Timeliner Rule dialog box.

11. On the Tasks tab, verify that there is a list of
tasks.
Notice that the Attached field for each task
does not have a value.
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13. On the Tasks tab, verify that in the Attached
field for each task, the value is Explicit
Selection.

14. If this is the first time TimeLiner has been run,
the Task Type column may not be visible. To
expand the Task Type column, click and drag
the left side divider of the Attached column.
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15. On the Tasks tab, for the first task, set the Task
Type column value to Construct.

16. Set the first ten tasks to Construct as shown.

17. On the TimeLiner palette, click the Simulate
tab.

21. Close the TimeLiner palette.

Create and Play an Animation
In this section of the exercise, you create and play an
animation. You also export the animation to a file.
1.
2.

Click Viewpoint tab > Camera panel >
Orthographic drop-down > Perspective.
Pan up on the model so the view is similar to
the one below.

18. To display the task:
■
On the Simulate tab, click Settings.
■
In the Simulate Settings dialog box,under
View, click Planned.
■
Click OK.

3.
4.
5.

Click Viewpoint tab > Save, Load & Playback
panel > Save Viewpoint.
On the Saved Viewpoints palette, verify that
View1 is listed.
On the Viewcube, select the SouthWest
Isometric view.

19. On the Simulate tab, click Play. Watch the
objects added to the model per the task
schedule.

6.
7.
20. Use the other buttons, such as Back, Forward,
and Pause to step through the animation.

8.

Click Viewpoint tab > Save, Load & Playback
panel > Save Viewpoint.
On the Viewcube, select the NorthWest
Isometric view.
Click Viewpoint tab > Save, Load & Playback
panel > Save Viewpoint.
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9.

Zoom in on the platform shown. Create
another saved viewport of the view.

Place your cursor in the center of the
model and click. Hold the mouse button
down as you move through the model.
Note: The higher you move the cursor, the
faster it will move.
■

Move up and to the left.
12. To save the view, click Viewpoint tab > Save,
Load & Playback panel > Save Viewpoint.
13. Use the Walk feature to move through and
then save several more viewpoints.
14. Right-click in a blank area of the Saved
Viewpoints palette. Click Add Animation.
■

10. On the Saved Viewpoints palette, verify that all
four saved views are listed.

11. To walk through the model:
■
On the Navigation toolbar, click Walk.
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15. For the new animation name, enter
Walkthrough.
16. To add views to the animation:
■
In the Saved Viewpoints palette, select
View1.
■
Hold SHIFT while you select the last view
(View 9).
■
Drag and drop the views onto the
Walkthrough animation.

4.

The model is rendered with many of the
elements displaying as black.

In this section of the exercise, you assign materials to
elements and export a rendered image.

5.

1.

6.

On the Presenter palette, click Clear. The
render is no longer displayed.
On the Presenter palette > Materials tab > right
pane. Right-click the ByLayer material. Click
Delete.

17. To play the animation:
■
On the Saved Viewpoints palette, select
Walkthrough.
■
Click Viewpoint tab > Save, Load & Playback
panel > Play.
18. To export the animation:
■
On the Application menu, click Export >
Images & Animations > Animation.
■
In the Animation Export dialog box, set the
desired settings. Click OK.
■
In the Save As dialog box, provide a file
name. Click Save.
19. Use Windows Explorer to locate the animation
file. Play the file.

Use Presenter

2.
3.

On the Saved Viewpoints palette, double-click
View1.
Click Home tab > Tools panel > Presenter.
On the Presenter palette, click Render.
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7.

On the Presenter palette, click Render. The
model is rendered with the elements displaying
in their assigned colors.

12. Drag the Cyan metal from the right pane of the
Presenter palette and drop it onto the element
as shown.
8.

On the Presenter palette, click Clear. The
render is no longer displayed.
9. On the Presenter palette > Materials tab >
left pane, expand Recommended > Metals >
Powder Coated.
10. Select and drag the following to the right pane:
■
Blue metal
■
Cyan metal
■
Green metal
■
Red metal

13. Drag the Red metal from the right pane of
the Presenter palette and drop it onto the
elements as shown.

11. Drag the Blue metal from the right pane of the
Presenter palette and drop it onto the element
as shown.
14. Drag the Green metal from the right pane of
the Presenter palette and drop it onto the
element as shown.
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Click Browse and navigate to the desired
location.
■
Under Size, from the Type list, select Use
View.
■
Click OK.
19. Close all files. Do not save.
■

15. On the Presenter palette, click Render. The
model is rendered with the elements displaying
in their assigned colors.

16. Zoom in on the elements that have the Blue
metal assigned. Render the model.

17. On the Application menu, click Export > Images
& Animations > Rendered Image.
18. In the Export Rendered Image dialog box:
■
From the Type list, verify that JPEG is
selected.
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Review
Which file formats can be linked to a Navisworks file in the TimeLiner module? (Select all that apply.)
Microsoft Word
Primavera
AutoCAD
Microsoft Excel via a CSV file
Microsoft Project must be installed in order to link Microsoft Project MPP files in the TimeLiner.
True
False
Which of the following formats can Navisworks export rendered images? (Select all that apply.)
PNG
QuickTime
Flash
TIFF
Google Earth
QuickTime
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Match the Description with the corresponding TimeLiner tab.
1. Rules
2. Gantt View
3. Simulate
4. Tasks
5. Links
6. Configure
Circle One
1 2 3 4 5 6 Provides controls to view a simulation. Using this tab, you can specify settings such as start
or end dates, interval size, and playback duration for a simulation.
1 2 3 4 5 6 Displays a list of predefined tasks in a project. Each task has an actual start and end date
and a planned start and end date. Using this tab, you can create tasks manually and
automatically. You can also attach each task to objects or groups of objects in the 3D
building model. You can also set the task type as Construct, Demolish, or Temporary.
1 2 3 4 5 6 Displays the rules used for attaching objects to tasks. Using this tab, you can create, edit,
and delete rules, and apply them to tasks.
1 2 3 4 5 6 This tab in TimeLiner provides a read-only graphical representation of your project
schedule, regardless of the originating source of the task data. Tasks are represented as
bars on a chart, and can run sequentially, in parallel or overlapping.
1 2 3 4 5 6 Enables you to set up task parameters, such as task types, appearance definitions for tasks,
and the default model appearance, at the start of the simulation. For example, for the
Construct task type, you can set the default start appearance to different values, such as
White, Grey, Red, and Red (90% Transparent).
1 2 3 4 5 6 Enables you to link and import information such as tasks and their start and end dates from
an external scheduling project file.
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Chapter Summary
In this chapter, you learned how to use Navisworks to view, review, and analyze a plant design. This
included learning how to combine design files from a variety of design and engineering applications
into a single integrated project model for efficient whole-project review.
Having completed this chapter, you can:
■
■
■
■
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Work with and handle files in Navisworks.
Navigate and walk through a design in Navisworks.
Conduct clash tests and work with clash detection results.
Create rendered images and animations and use TimeLiner to link to an external scheduling
project file and to create a simulation.

■
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Chapter

5
Setting up and Administering a
Plant Project
In this chapter you learn the skills and knowledge for setting up and administering a plant project. This
includes tasks like setting up the project file for large projects, controlling the project structure and file
location, customizing the data manager, and creating and editing drawing borders to name just a few.

Objectives
After completing this chapter, you will be able to:
■
■

■
■
■
■
■

■

■
■
■

Create a new project and structure it to your needs.
Explain how projects are structured in AutoCAD Plant 3D and AutoCAD P&ID and identify where
the project files are located.
Set up and maintain a project that can be used for larger projects with multiple users.
Set up the tagging scheme and place symbols on the correct layer with the desired color.
Set up any report or view in the Data Manager and use that set up to export data from the project.
Create drawing templates and use data from the project and the drawing in your title block.
Create, modify, and convert a spec and create and duplicate components to build your own
components.
Create a custom isometric set up and add additional information to your drawing when generating
the Iso.
Troubleshoot issues by recovering drawings and solving error messages.
Set up SQL Express for AutoCAD Plant 3D
Create and manage the report configuration files that are used to generate reports.
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Lesson: Overview of Project Setup
This lesson describes how to create a new project and structure it to your needs.
The number of drawings required to document and communicate a process piping design depends on
the complexity of that design. Being able to create and set up a project is important to ensure proper
management and access to the drawing files and data associated with the project.

Objectives
After completing this lesson, you will be able to:
■
■
■
■

Open an existing project and explain where the project name is derived from.
Create a new project.
Identify where and how the default drawing templates are configured for a project.
Explain the purpose of project folders and how they can be configured.

Opening an Existing Project
Opening an existing P&ID or Plant 3D project is a straightforward process. There are two key things
you need to know about opening an existing project. First, you initiate the opening of a project from
the Project Manager by clicking Open in the Current Project list or from the Project panel on the
Home tab. Second, the file you select to open is always titled Project.xml.
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Project Names
After opening a project, a name for the project displays in the Current Project list. The name that
displays in the Project Manager's Current Project list is the folder name where the Project.xml file
resides. The name of the top node in the Project pane may or may not match the name of the current
project. The name of the top node in the Project pane is the name of the project that was entered
when the project was initially created.
The following illustration shows the Project Manager with an active project and a representation of
the relationship between the project file and project folder. Based on the Project Manager, the current
project is P-IA-1602 and the top node is titled Training Project. This indicates that when the project was
initially created, it was called Training Project. At some point after the project was created, the folder
in which the Project.xml file resides was renamed from Training Project to P-IA-1602.

Location of Projects
To make switching between projects easy and quick, the most recent projects you opened are listed
in the Current Project list. By hovering the cursor over a listed project name, the full path to the
project.xml file displays in a tooltip. This helps you determine if this is truly the project you want to
open.
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After you have opened a project, you can determine where the project file resides by selecting the top
node in the Project pane and then reviewing the information in the Details pane.

Creating a New Project
AutoCAD P&ID and Plant 3D use a project environment to help in the creation and management of
drawings, models, and other related files. The project also helps ensure that you are working with the
correct data and templates.
When you need to create an all new design and you want the design files to be separate from any past
designs, you create a new project. The new project defines the new project environment.
There are a number of locations where you can start the wizard to create a new project. The most
likely access location is the Project Manager.
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Process: Creating a New Project
When you create a new project, a wizard guides you through the steps. The key tasks the wizard
undertakes are:
■
Set the name for the project.
■
Set the initial project folder name and path.
■
Specify the base units for the project.
■
Select the standard to be used for P&ID tool palette content.
■
Specify the storage location for created drawings.
■
Create the corresponding folders and files on the specified drive.
■
Specify the database settings and configuration.
To make it easier and quicker to configure a new project, the project wizard has an option that enables
you to copy the settings from an existing project. When you do this, although some of the options in
the wizard are automatically set, you can still modify some things like the storage locations for the
created drawings.

Default Drawing Templates
Every time you create a new drawing, its initial settings and content are based on a drawing template
file. You configure the default drawing template file that should be used for the creation of a new
P&ID, Plant 3D, or Ortho drawing in the overall project setup.
You select the settings for the overall project in the Project Setup dialog box and save them in
conjunction with the projSymbolStyle.dwg file. An easy way to access the project settings is in the
Project Manager. You right-click the project name in the Project pane and then click Properties.
To set the drawing template file for P&ID drawings, in the Project Setup dialog box under P&ID DWG
Settings, you first select Paths. Then for the Drawing Template File (DWT) field, click browse and select
the required template file.
To set the drawing template file for Plant 3D or orthographic drawings, in the Project Setup dialog box
under Plant 3D DWG Settings, you first select Paths. Then for the Orthographic Template File (DWT)
field or the Drawing Template File (DWT) field, click browse and select the required template file.
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Project Folders
You add folders to a project to visually organize drawings and related files within the Project Manager.
You also add them to assist in controlling the creation of new drawings. The folder adds control
because all project folders are configured with a location where new drawings are saved and with the
drawing template that should be used when new drawings are created.
The following illustration shows a project that has project folders added under P&ID Drawings and
Plant 3D Drawings. The illustration also includes the Project Folder Properties dialog box that is used
when you create and modify a project folder.

The template specified for a project folder is used by default when a new drawing is being created
within that folder. A drawing is created new directly within a folder when you right-click the folder and
then click New Drawing. The new drawing automatically uses those settings as the initial settings in
the New DWG dialog box. While a different template can be selected during the creation of the new
drawing, you should have the required template set as the default template. If you want to force the
selection of a drawing template each time a new drawing is created in the folder, select the Prompt
For Template option when configuring the project folder.
Each project folder can be set to store new drawings in their own unique location. A project folder can
be set to have new drawings stored:
■
In the drive folder of that project folder's parent folder.
■
In a drive folder that is relative to the parent folder.
■
In any location separate from the project structure.
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The following illustration shows an example configuration for project folders and the drive folders they
are configured to save new drawings in. In this example, multiple project folders were added under
P&ID Drawings to add visual organization. Each project is configured to save new drawings to the drive
folder configured for P&ID Drawings. The project folders under Plant 3D Drawings are configured to
have their new drawings saved in a folder relative to their parent folder.

Configure the required default template files in the project before you create folders
in the project. The template file set in the Project Setup dialog box is the template
drawing that is configured for a new folder by default. If you change the default
template in the overall project after creating the folders and you want the folders to
use that other template, you will need to modify each folder's properties accordingly.

Project Folder Order and Location
When a project folder is created, the order in which it displays in the Project Manager is based upon
standard alphanumeric rules. While you cannot change the order in which project folders display, you
can adjust their position by nesting them within other folders. Bars or arrows will display as you drag
the folder to indicate where the folder will be nested.
The following illustration shows the position of the Equipment folder being modified. The modification
process is shown on the left and the results of the modification are shown on the right.
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Modifying Project Folder Properties
The properties of a project folder can be modified by right-clicking the folder in the Project Manager
and then clicking Properties. The same Project Folder Properties dialog box that was used to initially
create the project folder displays to enable you to make changes.
When you edit a project folder you can change its name, the storage location for new drawings, which
drawing template should be used for new drawings in the folder, and whether the user should be
prompted to select a drawing template for each newly created drawing.
Renaming a project folder does not automatically change the name of the folder
on the drive where new drawings will be created. If the drive folder needs to be
updated, you need to modify the name of that folder and then select that modified
drive folder as the storage location.
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Exercise: Set Up and Structure Your Project
In this exercise, you create your own project,
add folders to set up a structure, and change the
necessary paths to locate template files.

3.

Review the contents of this active project as
seen in the Project Manager.
■
On the Source Files tab, expand the tree
structure to see the folders and source files.
■
Click the Orthographic DWG tab to view
the drawing files that contain orthographic
views for the project.
■
Click the Isometric DWG tab. Each pipe line
is listed under the Check, Final, Spool, and
Stress folders. Each folder is suffixed by a
page size designation. Because no drawing
files are listed under any of the pipe lines,
no isometric drawings have been created at
this time.

The completed exercise

Open, Close, and Create a New Project
In this section of the exercise, you open an existing
project to review its structure and associated files.
You then close the project and begin creating a new
project.
1.
2.

Start AutoCAD Plant 3D.
To open an existing project:
■
In the Project Manager, Current Project list,
click Open.
■
In the Open dialog box, navigate to the
folder ..\Plant Design\Set Up and Structure
Your Project\P-IA-1602.
■
Select the file Project.xml. Click Open.
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4.

5.
6.
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Review the folder and files structure for the
project in Windows Explorer.
■
Open Windows Explorer.
■
Navigate to and select the folder ...\PIA-1602.
■
Activate the subfolders Isogen, Orthos, and
PID DWG to see the actual files and file
storage location for the files listed in the
project.

Activate AutoCAD Plant 3D.
To close the active project, in the Project
Manager, top of the tree list, right-click Training
Project. Click Close Project.

■

7.

To begin creating a new project, in the Project
Manager, Current Project list, click New Project.

8.

In the Project Setup Wizard, page 1:
■
In the Enter a Name for this Project field,
enter Custom Project 05.
■
To specify the directory where programgenerated files are stored, click the browse
button to the right of that field.
■
In the Select Project Directory dialog box,
navigate to and select the folder ..\Plant
Design\Set Up and Structure Your Project.
Click Open.
■
Click Next.
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9.

On page 2 of the wizard, for the base units for
the project:
■
Ensure Imperial is selected.
■
Click Next.

10. On page 3 of the wizard:
■
Review the folder location where the P&ID
drawings will be stored.
■
Review which standard will be used for the
palette content.
■
Click Next.

11. On page 4 of the wizard:
■
Review the paths specific to Plant 3D that
can be set during project creation.
■
Click Next.

12. On page 5 of the wizard, make sure that SQLite
Local Database is selected. Click Next.
13. On page 6 of the wizard, click Finish. The
Project Manager now displays as shown.
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14. To review the files and folders that were
automatically created for the new project:
■
Switch to Windows Explorer.
■
Navigate to ..\Plant Design\Set Up and
Structure Your Project\Custom Project 05.
■
Quickly review the files and subfolders in
the project folder.

2.

In the Project Manager and in Windows
Explorer, review what was created. The
resulting project folder and drive folder are
created as shown.

Work with Folders in a Project
In this section of the exercise, you create folders for
the project and modify their properties.
1. To create a new project folder under P&ID
Drawings and have a corresponding folder
created on the drive with the project:
■
In the Project Manager, Project panel, rightclick P&ID Drawings. Click New Folder.
■
In the Project Folder Properties dialog box,
for Folder Name, enter Area 10.
■
Select the Create Folders Relative to Parent
Folder Storage Location check box.
■
In the Store New Project DWG Files In field,
review the listed folder path.
■
Click OK.
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3.

4.

To create another project folder in P&ID
Drawing:
■
Right-click P&ID Drawings. Click New Folder.
■
In the Project Folder Properties dialog box,
for Folder Name, enter Ar 20.
■
Clear the option to Create folders Relative
to Parent Folder Storage Location.
■
In the Store New Project DWG Files In field,
review the listed folder path. Notice that
this folder is set to use the default PID DWG
folder.
■
Click OK.

In the Project Manager and in Windows
Explorer, review what was created. The
resulting project folder was created but no
additional drive folders were created. The
details for the project folder shows that it is set
to the PID DWG folder as identified.

5.

To rename the folder in the project:
■
Right-click Ar 20. Click Rename Folder.
■
Enter Area 20.
■
Press ENTER or click in the panel to accept
the change.

6.

To begin to create a drive folder specifically for
the Area 20 P&ID drawings and set the Area 20
project folder to that drive folder:
■
Right-click Area 20. Click Properties.
■
In the Project Folder Properties dialog box,
to the right of the Store New Project DWG
Files In field, click Browse.
In the Browse for Folder dialog box:
■
Navigate to ...\Plant Design\Set Up and
Structure Your Project\Custom Project
05\PID DWG.
■
Click Create New Folder.
■
Right-click New Folder. Click Rename.
■
Enter Area 20.

7.
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8.

To complete the change:
■
In the Browse for Folder dialog box, ensure
that the folder Area 20 is selected.
■
Click Open.
■
In the Project Folder Properties dialog box,
click OK.
■
Review the details for the folder. They
display as shown.

10. Review the folder details for each newly
created Plant 3D Drawings project folder to
ensure that each one is set to have its files
created and accessed from a subfolder to the
Plant 3D Models drive folder.

9.
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Create four new project folders under Plant
3D Drawings with corresponding subfolders
to the Plant 3D Models drive folder as shown.
While creating the project folders, also select
the check box Create Folders Relative to Parent
Folder Storage Location.
■
Equipment
■
Steel Structure
■
Piping
■
General Arrangement
Note: Regardless of the order in which you
create the folders, they display alphabetically in
the list.

■
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11. To set up the Piping folder so that it has
additional organization with subfolders that
correspond to the P&ID folder structure:
■
Right-click Piping. Click New Folder.
■
In the Project Folder Properties dialog box,
for Folder Name, enter Area 10-P.
■
Select the Create Folders Relative to Parent
Folder Storage Location check box.
■
In the Store New Project DWG Files In field,
review the listed folder path.
■
Click OK.

13. To set up the Equipment folder so that it also
has additional organization with subfolders:
■
Right-click Equipment. Click New Folder.
■
In the Project Folder Properties dialog box,
for Folder Name, enter Area 10-E.
■
This time DO NOT select the Create Folders
Relative to Parent Folder Storage Location
check box.
■
In the Store New Project DWG Files In field,
review the listed folder path.
■
Click OK.

12. Repeat the process to create an Area 20-P
subfolder to create the results as shown. In
this configuration, both subfolders have drive
folders nested in the Piping folder in the Plant
3D Drawings file storage area.

14. Review the folder details for the newly created
Area 10-E subfolder. In this configuration, any
drawing file created in this folder will be stored
in the Equipment folder on the drive but be
visually organized into the subfolders.
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15. To add a folder under Related Files:
■
Right-click Related Files. Click New Folder.
■
In the Project Folder Properties dialog box,
for Folder Name, enter Pump Information
Sheets.
■
Select the Create Folders Relative to Parent
Folder Storage Location check box.
■
In the Store New Project DWG Files In field,
review the listed folder path.
■
Click OK.

16. Review the folder structure created for this
project. At this time the project folders and
subfolders are configured to save their new files
to specific drive folders and to use the same
template drawing that is set for the project for
new drawing files.
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Modify Project Properties
In this section of the exercise, you modify the project
properties to specify where templates are retrieved,
what drawing templates should be used, and where
the spec sheets for Plant 3D are located.
1. In the Project panel, right-click Custom Project
05. Click Properties.

2.

In the Project Setup dialog box, under General
Settings, ensure that Project Details is selected.
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3.

4.

5.

To change the template directory for userdefined reports:
■
In the General Paths and File Locations
area, click Browse, located to the right of
the User-Defined Reports Directory field.
■
In the Select Reports Directory dialog box,
navigate to and open the folder ..\Plant
Design\Set Up and Structure Your Project
\CompanyTemplates\Reports.
■
The path now displays as shown.
6.

In the Project Setup dialog box:
■
Expand Plant 3D DWG Settings.
■
Click Paths.

7.

To have the spec sheets referenced from a
common location:
■
In the Plant 3D Path and File Locations area,
to the right of the Spec Sheets Directory
field, click Browse.
■
In the Select Spec Sheets Directory dialog
box, navigate to and open the folder..\Plant
Design\Set Up and Structure Your Project
\CompanyTemplates\Spec Sheets.
■
The path now displays as shown.

In the Project Setup dialog box, under General
Settings:
■
Expand P&ID DWG Settings.
■
Click Paths.

To change the drawing template to be used
when creating a new P&ID drawing in this
project:
■
In the Paths area, click Browse, located
to the right of the Drawing Template File
(DWT) field.
■
In the Select Template File dialog box,
navigate to and open the file ..\Plant
Design\Set Up and Structure Your
Project\ CompanyTemplates\Drawings\
PID_CompanyD_common.dwt.
■
The path now displays as shown.
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8.

To set the file to be used for orthographic
drawings:
■
To the right of the Orthographic Template
File (DWT) field, click Browse.
■
In the Select Template File dialog box,
navigate to and open the file ..\Plant
Design\Set Up and Structure Your
Project\ CompanyTemplates\Drawings\
Ortho_Company_common.dwt.
■
The path now displays as shown.

9.

To set the folder in which the equipment
templates are located:
■
To the right of the Equipment Templates
Directory field, click Browse.
■
In the Select Equipment Templates
Directory dialog box, navigate to and
open the folder..\Plant Design\Set Up and
Structure Your Project\CompanyTemplates
\Equipment.
■
The path now displays as shown.

11. In the Project Setup dialog box, expand
Isometric DWG Settings. Click Iso Style Setup.

12. To configure the template directory for Final
Iso type drawings, in the Iso Style list, select
Final_ANSI-B.

13. Click OK. The paths and templates for this
project are now configured.
14. Close all files. Do not save changes.

10. To set the drawing template file that should be
used when creating a new 3D plant drawing in
this project:
■
To the right of the Drawing Template File
(DWT) field, click Browse.
■
In the Select Template File dialog box,
navigate to and open the file ..\Plant
Design\Set Up and Structure Your
Project\ CompanyTemplates\Drawings
\Plant3D_Company_common.dwt.
■
The path now displays as shown.
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Review
There are several templates (DWT) that you can setup to be used within the Plant 3D software, how
many and which templates are there?
P&ID Template
Orthographic drawing template
Isometric drawing template
3D piping Template
How can you get to the settings that define where drawings and templates are stored?
Windows explorer.
Right click on your project name in the project manager, then choose properties.
These can only be set-up when creating a project.
Changing these settings is not possible.
Is it possible to create a structure on your hard-drive or network before you have created a project?
No, you can only create a structure through the project manager.
Yes you can, you can use the project manager after that to point to the already created structure.
Yes, but it cannot be used for the storage location of drawings.
Can you use more templates, at the same time, for the same type of drawing?
Yes, the number of templates that you can use is unlimited.
No, by default you can only use one type of template for each type of drawing.
Yes, you can have multiple templates. As long as you set them per sub folder in the project
manager.
Can you set multiple locations where drawings must be stored?
Yes, the number of locations that you can use is unlimited.
No, by default you can only use one location for each type of drawing.
Yes, you can have multiple locations. As long as you set them per sub folder in the project
manager.
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Lesson: Overview of Project Structure and
Lesson: Files
This lesson describes how AutoCAD Plant 3D projects are structured and where the project files can
be found.
If you are responsible for setting up and administering a plant project, along with knowing how to
create a new project, you need to understand what a project consists of and how it can be edited. This
is especially important if you need to move a project to a different location.

Objectives
After completing this lesson, you will be able to:
Describe the two types of data and files that are in a project.
State where to configure the DWG creation directory.
Manage the files and folders in a moved or copied project.
Explain how Plant 3D and P&ID drawing data can be used in standard AutoCAD.

■
■
■
■

Prerequisites
Before taking this lesson, you should be able to:
■
Create a new project and access the properties of the project.
■
Set the default drawing templates for the project.
■
Create and configure project folders.
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About the Data and Files in a Project
The data and files that make up a design project can be grouped into one of two categories: either the
data and files that support the project or those that contain the design and design information. Files
that support the design include spec sheets, equipment templates, and configuration files such as the
projSymbolStyle drawing and the XML files. The files that contain the design and design information
include the DWG drawings and the DCF and DCFX files.
In the following illustrations, two different techniques for structuring the folders and files in a project
are shown. The structure that is set up by default when a new project is created is shown on the left.
A custom structure in which the drawing files and some common project files have been separated is
shown on the right. The configuration of a project is flexible, enabling you to set up your projects the
way that you need to.

New Drawing Creation Locations
When a new project is created using the project creation wizard, the folders where the drawings
are created are set based on what was set in the wizard. If you want to change the location where
new drawings are created after a project has been created, you need to be able to edit the project
properties to specify the required directory.
This type of edit is common when you want to change the location where drawing files are created and
stored. Because in this scenario the project and folders would already exist, you would start making
the change by moving the drawing folders and files to their new location. Then you would set the
project settings so all new drawings are created in that location.
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In the following illustration, the creation of a new P&ID drawing is being initiated. The default
location for the new drawing will be based on the path defined in the project setup.

In the Project Setup dialog box, you can edit the paths that specify where all new P&ID, Plant 3D,
and Isometric drawings are created. You configure the path by selecting the Paths tree entry that
corresponds to what you want to configure. After selecting Paths, you then enter or navigate to the
folder of your choice.

Changing the DWG creation directory for P&ID Drawings or Plant 3D Drawings in the Project Setup
only affects the drawings and project folders that are created at that category's root level. If project
folders already exist and you need to edit their paths, you have to either edit each folder individually
or edit the corresponding XML file for that category.
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Managing Files and Folders in Moved or Copied Projects
As you are aware at this point, a project contains a number of files and folders. Some files support the
project and others are the product of the project. You may have situations where a created project
needs to be moved or copied. In those cases, you need to know how to manage the files and folders in
the moved or copied projects.
Why would a project be moved or copied?
■
A project may be moved for any number of reasons. For example, you may want to change the
location of all of the project files to a new drive. Or you may want to change just a portion of the
folder structure of the project.
■
A project may be copied so you can create a backup of the design, archive the current state of the
design, or create a variation of the design.

Issues When Moving or Copying a Project
As a project is created, paths are specified to indicate where things are stored and thus located. When
drawings are added to a project, their location is linked to the project through its path. The issue with
moving or copying a project is being able to have that moved or copied project correctly locate all of
the files it references.
Moving a project means that the original paths to the files are no longer valid. Depending on what was
moved in the project and where it was moved relative to the project file, the drawing files that are
associated with that project may or may not be automatically located.
Copying a project means that the original files still reside in their original location. Depending on how
the project is set up, the copied project may still locate and use the original files instead of the copied
files. If you are copying a project so you can create a variation of the design, continuing to access the
original files is not good practice. You need to be aware that when you make any changes in the copied
project, all of the changes are being made to the files in that copied project and not to the original
files.
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Correcting Paths and Locating Drawings
When project files and folders are moved around after a project is initially configured, you may need
to correct some paths and locate drawings. Where and how you go about correcting paths depends
on what the paths are associated with. If the path is associated with the P&ID Drawings or Plant 3D
Drawings directory, you make the path changes in the Project Setup. If the path is for a project folder
that has a corresponding drive folder, you make that change in the Project Folder Properties dialog
box associated with that folder.
The following illustrations identify the drawing areas of the project and their corresponding path
configuration areas in the Project Setup dialog box. If you move the PID DWG or Plant 3D Models
folders to a location outside of the project, you will need to modify the directory paths so that they
match their current location.
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If you moved the PID DWG or Plant 3D Models folders to a location outside of the project and they
included project subfolders, you will need to modify the properties of the folders in the project to
point to the drive folders at their new location. You set the path so that any new drawing is placed in
the correct drive folder.
The following illustration shows the Project Folder Properties dialog box for a project folder and
its associated folder path. To access this dialog box, you right-click the project folder in the Project
Manager panel and then click Properties. To change the folder path, you click the Browse button, and
then browse to and select the required folder.

If a drawing is not automatically located, the drawing icon for that drawing in the Project list displays
with a diagonal red line through it. To locate that missing drawing, you right-click the drawing in the
Project Manager and then click Locate Drawing. You then navigate to and open that moved file.

Working with Plant 3D and P&ID Drawings in AutoCAD
When you create a design in AutoCAD P&ID or Plant 3D, you often add objects that are unique to
these applications. For some design projects, you may be required to supply a final drawing file that
only contains native AutoCAD objects. Other individuals who just have standard AutoCAD may need
to review your drawings. To supply a drawing with what they require, you need to know how Plant 3D
and P&ID drawing data can be used in standard AutoCAD.
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The following illustration shows a P&ID and a Plant 3D design. While it appears as though the pipe
lines consist of just lines or 3D cylinders, the objects in the drawings are actually custom objects with
data and behavior that are focused on the needs of process piping. In P&ID, the pipe line lists as an
SLINE object and the exchanger equipment lists as an ACCPASSET object. In Plant 3D, the pipe line lists
as a PIPE object and the exchanger equipment lists as an EQUIPMENT object.

Directly Opening a Drawing in Standard AutoCAD
AutoCAD P&ID and Plant 3D drawings can be opened directly in standard AutoCAD. What is displayed
and what object information is available depends on what was opened and the current configuration
of the standard AutoCAD installation.
When a P&ID drawing is opened in standard AutoCAD, the custom objects display in the drawing if
the option to show proxy graphics was enabled. The custom objects showing as proxy objects cannot
be edited in standard AutoCAD. Their display just allows the drawing to be visually reviewed.
When a Plant 3D drawing is opened in standard AutoCAD, the display of the custom objects depends
on whether the AutoCAD Plant 3D Object Enabler is installed. If the Object Enabler is not installed,
then the custom objects display as proxy objects. If the Object Enabler is installed, then AutoCAD is
able to display the geometry and its properties as if the objects were native. A major benefit of having
the Object Enabler installed is that the properties of the objects can be reviewed in the Properties
palette.
You can download the AutoCAD Plant 3D 2012 Object Enabler from the following
location:
http://usa.autodesk.com/adsk/servlet/ps/dl/item?
siteID=123112&id=17658426&linkID=9240658

Exporting to Native AutoCAD Objects
When you need to supply a drawing file that contains only objects that are native to standard
AutoCAD, you need to export the P&ID or Plant 3D drawing. When you do this, the custom objects
become native objects like blocks, lines, circles, arcs, and text.
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Process: Exporting to Native AutoCAD Objects
The following steps describe how to export a P&ID or Plant 3D drawing to a drawing that contains only
objects that are native to standard AutoCAD.
1.
2.
3.

Open the P&ID or Plant 3D drawing.
In the Project Manager, Project pane, right-click the opened drawing to export. Click Export to
AutoCAD.
Save the drawing file after specifying the location and a new filename.
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Exercise: Manage Your Project
The default path is ..\Plant Design\Manage
Your Project\P_Def-100\ plus the name of the
specific folder for the selected drawing.

In this exercise, you conduct various project
management tasks while exploring the behavior
of drawing file resolution. You copy two differently
structured projects and correct the file resolution.

The completed exercise

4.

Drawings in a Default Project Structure
In this section of the exercise, you review the project
settings and file structure in a default structured
project. You then copy that project and see where
this new project resolves the copied drawings.
1.
2.

3.
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Start AutoCAD Plant 3D.
To set P_Def-100 as the current project:
■
In the Project Manager, Current Project list,
select Open.
■
In the Open dialog box, navigate to the
folder ..\Plant Design\Manage Your Project
\P_Def-100.
■
Select the file Project.xml.
■
Click Open.
In the Project Manager, review the linked
drawings and their location. All four linked
files have been located and thus resolved.
Notice the prefix folder location for the files.

■

5.

To open the Project Setup dialog box for this
project and review the P&ID DWG directory
path:
■
In the Project Manager, right-click Training
Project. Click Properties.
■
In the Project Setup dialog box, under P&ID
DWG Settings, click Paths.
■
Review the path information in the P&ID
DWG directory field.
■
Click Cancel.
To close the active project:
■
In the Project Manager, right-click Training
Project.
■
Click Close Project.
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6.

Review the folder and file structure for the
project in Windows Explorer as follows:
■
Open Windows Explorer.
■
Navigate to and select the folder ..
\P_Def-100.
■
Activate the subfolder PID DWG and the
subfolders in Plant 3D Models to see the
actual files and file storage location for the
files listed in the project.

7.

In Windows Explorer, copy the folder
P_Def-100 and its contents. Rename the copy
P_Def-101.

8.

To set P_Def-101 as the current project:
■
In the Project Manager, Current Project list,
select Open.
■
In the Open dialog box, navigate to the
folder ..\Plant Design\Manage Your Project
\P_Def-101.
■
Select the file Project.xml.
■
Click Open.

9.

In the Project Manager, review the linked
drawings and their location. All four linked
files have been located and thus resolved.
Notice the prefix folder location for the files.
The drawings are now being resolved from the
folder in the path of the \P_Def-101 folder.
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10. To open the Project Setup dialog box for this
project and review the P&ID DWG directory
path:
■
In the Project Manager, right-click Training
Project. Click Properties.
■
In the Project Setup dialog box, under P&ID
DWG Settings, click Paths.
■
Review the path information in the P&ID
DWG directory field. Notice that the path in
the project setting automatically updated
to the subfolder that is in the path of the
active project.
■
Click Cancel.

Resolve Links to Moved Drawings and Folders

2.

To open the Project Setup dialog box for this
project and review the P&ID DWG directory
path:
■
In the Project Manager, right-click Training
Project. Click Properties.
■
In the Project Setup dialog box, under P&ID
DWG Settings, click Paths.
■
Review the path information in the P&ID
DWG directory field. Notice that the path
points to a specific user path.

3.

To set the P&ID DWG directory to the
appropriate drawing folder for this project:
■
To the right of the P&ID DWG Directory
field, click Browse.
■
In the Select Project DWG Directory dialog
box, navigate to and open ..\Plant Design
\Manage Your Project\P_Sep-200\Project
Data\PID DWG.
■
In the Project Setup dialog box, click OK.

In this section of the exercise, you locate the missing
P&ID drawing that was moved from the default
project structure to a separate location. You also
move the Plant 3D drawings to that same separate
location and resolve the link to the new location.
1.
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To set Training Project as the current project:
■
In the Project Manager, Current Project list,
select Open.
■
In the Open dialog box, navigate to the
folder ..\Plant Design\Manage Your Project
\P_Sep-200\Training Project.
■
Select the file Project.xml.
■
Click Open.

■

Chapter 5: Setting up and Administering a Plant Project

4.

To create a new P&ID drawing to verify that
the folder path where it will be saved matches
what you just configured in project properties:
■
In the Project Manager, right-click P&ID
Drawings. Click New Drawing.
■
In the New DWG dialog box, Folder Path
field, review the path information. Notice
that the file will be saved to the PID DWG
folder in the Project Data folder.
■
Click Cancel.

■

■
■

■

7.

8.
5.

Review the list of drawings. Notice that PID001
is currently missing. The PID DWG folder with
this drawing was previously moved from the
default project folder location to a folder
outside the project folder structure.

6.

To locate the PID001 drawing:
■
In the Project Manager, right-click PID001.
Click Locate Drawing.

In the Locate Drawing dialog box, navigate
to ..\Plant Design\Manage Your Project
\P_Sep-200\Project Data\PID DWG.
Open PID001.dwg.
In the Project Data Merged dialog box, click
OK.
The file is now located and the Project
Manager displays as shown.

In the Project Manager, select each Plant 3D
drawing and review its file location detail
information. Notice that the files are in
subfolders under the Training Project folder.
In Windows Explorer, move Plant 3D Models
and its contents from Training Project to
Project Data to create the results as shown.
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9.

In the Project Manager, Project pane, click
Refresh DWG Status. Notice how the three
Plant 3D drawings are now listed as missing.

10. To locate the Equipment drawing:
■
In the Project Manager, right-click the
Equipment drawing. Click Locate Drawing.
■
In the Locate Drawing dialog box, navigate
to ..\Plant Design\Manage Your Project
\P_Sep-200\Project Data\Plant 3D Models
\Equipment.
■
Open Equipment.dwg.
■
In the Project Data Merged dialog box, click
OK.
■
The file is now located and the Project
Manager displays as shown.

11. To create a new drawing under Plant 3D
Drawings to review the default folder path
where the new drawing will be saved:
■
In the Project Manager, right-click Plant 3D
Drawings. Click New Drawing.
■
In the New DWG dialog box, Folder Path
field, review the path information. Notice
that the file will be saved to the old path
(..\P_Sep-200\Training Project\Plant 3D
Models).
■
Click Cancel.
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12. To set the Plant 3D Drawings directory to the
appropriate drawing folder for this project:
■
In the Project Manager, right-click Training
Project. Click Properties.
■
In the Project Setup dialog box, under Plant
3D DWG Settings, click Paths.
■
To the right of the Plant 3D model DWG
Directory field, click Browse.
■
In the Select Project DWG Directory dialog
box, navigate to and open ..\Plant Design
\Manage Your Project\P_Sep-200\ Project
Data\Plant 3D Models.
■
In the Project Setup dialog box, click OK.

13. To create a new drawing under Plant 3D
Drawings to verify that the folder path where it
will be saved matches what you just configured
in project properties:
■
In the Project Manager, right-click Plant 3D
Drawings. Click New Drawing.
■
In the New DWG dialog box, Folder Path
field, review the path information. Notice
that the file will be saved to the Plant 3D
Models folder in the Project Data folder.
■
Click Cancel.
14. To create a new drawing under the Equipment
folder to review the default folder path where
the new drawing will be saved:
■
In the Project Manager, right-click the
Equipment folder. Click New Drawing.
■
In the New DWG dialog box, Folder Path
field, review the path information. Notice
that the file will be saved to a previously
defined path of D:\ Projects\Training
Project\Plant 3D Models\Equipment.
■
Click Cancel.
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15. To set the Equipment folder’s path to match
the new location:
■
In the Project Manager, right-click the
Equipment folder. Click Properties.
■
In the Project Folder Properties dialog box,
to the right of the Store New Project DWG
Files In field, click Browse.
■
In the Browse For Folder dialog box,
navigate to and open ..\Plant Design
\Manage Your Project\P_Sep-200\ Project
Data\Plant 3D Models\Equipment.
■
In the Project Folder Properties dialog box,
click OK.
16. To create a new drawing under the Equipment
folder to verify that the folder path where
it will be saved matches what you just
configured:
■
In the Project Manager, right-click the
Equipment folder. Click New Drawing.
■
In the New DWG dialog box, Folder Path
field, review the path information. Notice
that the file will be saved to the folder ..
\Project Data\Plant 3D Models\Equipment.
■
Click Cancel.
17. Use the previous processes to correct the paths
for the Piping and Steel Structure folders and to
locate the Piping and Structures drawings.

structure. You review what is automatically corrected
and what is not.
1. In Windows Explorer, copy the folder
P_Sep-200 and its contents. Rename the copy
P_Sep-200-B.

2.

Under P_Sep-200-B, rename the folder Training
Project to Training Project-B as shown.

3.

To set Training Project-B as the current project:
■
In the Project Manager, Current Project list,
select Open.
■
In the Open dialog box, navigate to the
folder ..\Plant Design\Manage Your Project
\P_Def-200-B\Training Project-B.
■
Select the file Project.xml.
■
Click Open.
Notice that the name of the folder that
contains the Project.xml file is the name of the
project displayed in the Current Project list.
In the Project Manager, select each drawing
and review its file location details. Notice that
the drawings are located in the P_Sep-200-B
folder path.

4.

18. Close the active project.

Copy a Project for Backup or One-Off Design
Creation
In this section of the exercise, you copy the project
that has the drawing files stored outside the project
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5.

Close the active project.

5.
6.
7.

P&ID and Plant 3D Drawings in Standard
AutoCAD

Close Piping.dwg.
Start AutoCAD.
Open PID001.dwg. If the Proxy Information
dialog box displays, with Show Proxy Graphics
selected, click OK.

In this section of the exercise, you learn how P&ID
and Plant 3D drawings can be used or converted for
use in standard AutoCAD.
1.
2.

3.
4.

Set P_Def-100 as the current project.
To export PID001 as a standard AutoCAD
drawing file:
■
Open PID001.dwg
■
In the Project Manager, right-click PID001.
Click Export to AutoCAD.
■
Save the file in the PID DWG folder with the
name PID001-ACAD.dwg.
Close PID001.dwg.
Follow the same process to export the Piping
drawing as a standard AutoCAD drawing file.
Save the file in the Piping folder with the name
Piping-ACAD.dwg.
8.

List the properties of one of the pipe lines.
Notice that it is ACAD_PROXY_ENTITY. These
objects cannot be edited in AutoCAD.
9. Open PID001-ACAD.dwg.
10. List the properties of one of the pipe lines.
Notice that it is a standard AutoCAD entity.
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11. Open Piping.dwg. If the Proxy Information
dialog box displays, you know that you do not
have the Plant 3D Object Enabler installed or
configured to work with your AutoCAD.
12. To review the properties of a pipe line:
■
In canvas, select a line.
■
Right-click in an open area. Click Properties.
■
On the Properties palette, review the type
of object and the Plant 3D properties that
are included. These objects are recognized
and their properties are available for review
when the Object Enabler is installed.

13. Close all files. Do not save.
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Review
What files are used to store the data from P&ID, 3D, ISO, and Ortho?
DWG.
DCF and DCFX.
The data is stored in the components and the DWG.
Is it possible to have the drawings in a different location than the project files?
Yes.
No.
Only if you use a Document Control System.
To manage files, if you moved the PID DWG or Plant 3D Models folders to a location outside of the
project and they included project subfolders, you need to:
Modify the properties of the folders in the project to point to the drive folders at their new
location.
Modify the Project to include subfolders.
Open and save at least one file in each subfolder.
If a drawing is not automatically located, the drawing icon for that drawing in the Project list displays:
Grayed out.
With a diagonal red line through the icon.
With a horizontal black line through the icon.
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Lesson: Setting Up Larger Projects
This lesson describes how to set up a project that will be used by multiple users and will contain large
number of objects and drawings. After completing this lesson, you will be able to set up and maintain
a project that can be used for larger projects with multiple users.
Large or complex plant designs are rarely completed by a single person. Therefore when you set up
a project, you need to know how to set it up so that multiple users can simultaneously work on the
same project. You should also know what you can do to help ensure consistency and adherence to
company standards regardless of who creates the drawing.

Objectives
After completing this lesson, you will be able to:
■
■
■
■

State the guidelines for setting up a project for multiple user access.
Configure the project so it uses a custom file naming format for new drawings.
Lock the project settings by setting the projSymbolStyle.dwg file for the project to read-only.
Set the external references so they demand load and enable someone else to edit a referenced
drawing.

Setting Up a Project for Multiple User Access
When you set up a project for use by multiple people, you need to create the project in a location that
all of the users can access.
Follow these guidelines when setting up a project that will be accessed by multiple users.
■
Create a new project that is located at a shared network location.
■
Configure the project so it uses shared files that are common between projects.
■
If a file naming scheme is required for the drawing files in the project, configure the file naming
format in the project.
■
Lock the project properties so they cannot be inadvertently modified by someone.
■
Have each project team member open the Project.xml file from the project's shared network
location.
■
Ensure that everyone working on the project has their AutoCAD external reference demand
loading setting set to Enable with Copy.
As a variation in the setup of the project, when the project will be worked on by multiple users you can
set the project up to use SQL Server instead of the default SQLite.
There are different techniques that can be used to access shared network files and folders. To ensure
that every person utilizing the same project file can access the network location configured in the
project, you need to keep the following things in mind:
■
If the path uses mapped drive letters, you need to make sure every user has that same drive letter
and path to that location.
■
Instead of using mapped network drives, use the UNC path instead.
■
To make the paths a little more dynamic, edit the XML files to make sure the relative path
information is valid.
In the following illustration, the pipe design projects are created and saved on a shared network. In
this situation, if everyone has a K-drive mapped to the EngDesigns share on CRWARE-IA10, then the
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paths in the project can use the K:\ drive letter in the paths. If the mapped drive may vary between
user's computers, then the paths should use \\ CRWARE-IA10\EngDrive\ in place of K:\.

Configuring the File Name Format
Many companies have a standardized format for naming their drawing files. This format is often a set
schema consisting of specific length fields and the use of defined nomenclature. If your company has
a defined format for drawing file names, then you should configure the project so it uses a custom file
naming format for new drawings.
In the following illustration, the New DWG dialog box is shown in its default format on the left and
in a custom format on the right. The custom format uses a combination of list fields and text fields
to guide the creation of the drawing name. The resulting file name is shown in the File Name field. If
you need to enter a filename that does not follow the custom filename format, selecting the Override
check box enables you to enter any valid file name.
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Process: Configuring the File Name Format
You configure the file name format as part of the project setup. You start the process of configuring
the file name format by displaying the Project Setup dialog box. With File Name Format selected under
General Settings, you can click to add fields to the file name or modify any fields already added. When
you are defining a field, you enter the name of the field, its data type, whether there is a limit to the
number of characters in the field, and whether a delimiter should be added at the end of the field.

The types of data can be string, numeric, or custom property. If you want to use a custom property in
the file name format, you should create that custom property prior to adding the custom file name
field.

Locking the Project Properties
Having multiple people able to work on the same project is good practice. However, having multiple
people able to modify the settings for a project is not. After you have configured the project and
you are ready to roll it out to all the designers tasked to work on the project, you need to lock the
project settings. You do this to ensure someone does not inadvertently change a setting that will have
a negative impact on the project.
You lock the properties of a project by setting the projSymbolStyle.dwg file for the project to readonly. When that file is set to read-only, the option to access the project properties is not available. The
projSymbolStyle.dwg file is in the same folder as the project.xml file and you set the drawing file to
read-only within the operating system.
In the following illustration, the Read-Only attribute is shown selected in the projSymbolStyle.dwg
Properties dialog box. This dialog box was accessed by right-clicking on the drawing file in Windows
Explorer and then clicking Properties.

Lesson: Setting Up Larger Projects

■

5-39

The following illustration shows the Properties option being accessed when the file is and is not
locked. When the file is set to read-only, the Properties option is greyed out and thus not available, as
shown on the right side of the illustration.

XREF Demand Load
You use external references to separate the design geometry so multiple people can work on the
same overall design at the same time. While everyone is working on the overall design, only one
person is actively editing any one drawing. Therefore by separating the design into multiple files,
multiple people can work on the same project. Different aspects of the design from an external file
are viewed in another drawing by referencing the data from that external file. To ensure that someone
else has the ability to edit a drawing currently being externally referenced, you need to make sure the
demand loading setting for external references is set correctly.
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In the following illustration, the drawing for the equipment, steel structure, and piping are all separate
files. To properly position the equipment, the steel structure was externally referenced into the
equipment drawing. To create the piping design, the equipment and steel structure drawing files were
externally referenced into the piping drawing. With the external references set to demand load, three
different people could work on this overall design all at the same time. One person could be editing
the equipment drawing, another updating the steel structure, and a third completing the piping
drawing.

XLOADCTL System Variable
The XLOADCTL system variable turns xref demand-loading on and off. The variable also determines
whether the xref or a copy of the xref is opened.
If you or someone on your network attempts to open a file that is currently referenced by an open
drawing, depending on the setting of the XLOADCTL system variable, you may be given read-only
access to the drawing.
The XLOADCTL system variable has the following settings:
■
XLOADCTL = 0: Demand-loading is turned off and the entire drawing is loaded.
■
XLOADCTL = 1: Demand-loading is turned on and reference drawings are kept open and locked.
■
Note: The software can display a read-only message if the referenced drawing is opened by you or
someone on your network and the host drawing is currently open.
■
XLOADCTL = 2: Demand-loading is on and copies of referenced drawings are opened and locked.
The original reference drawing is not locked. This is the default setting of the XLOADCTL variable.
You can also change the XLOADCTL settings on the Open and Save tab of the Options
dialog box, in the External References (Xrefs) area. The three options listed for the
Demand Load Xrefs option specify the XLOADCTL setting as followings: Disabled = 0,
Enabled = 1, Enabled with Copy = 2.
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Exercise: Set Up a Project for Multiple Users
In this exercise, you create and set up a new project
that can be used by multiple users.

The completed exercise

Create a New Multi User Project
In this section of the exercise, you create a new
project that can be used by multiple users. You
modify the paths for the project to use files that are
common to multiple projects.
1. In Windows Explorer, review the folder and
files structure set up for multiple user access.
Note: Because the network configuration
and user rights vary so much between every
training and work site, this exercise simulates
the use of a network drive. The structure
below the folder (Network Drive) is an
implementation where multiple users are
accessing the project. The project information
common to multiple projects is separate and
resides under the folder CommonProjectFiles.
The individual projects are created and stored
under the folder Projects.
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2.
3.

Start Plant 3D.
To begin to create a new project configured to
be used by multiple users and accessible from a
network drive, in the Project Manager, Current
Project list, click New Project.
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4.

In the Project Setup Wizard, page 1:
■
In the Enter a Name for this Project field,
enter N_IA-10-029.
■
In the Enter an Optional Description field,
enter Project for multiple user access.
■
For the directory where program-generated
files are stored, browse to ..\Plant Design
\Set Up a Project for Multiple Users
\(NetworkDrive)\Projects .
■
Click Next.

7.

On page 4 of the wizard:
■
In the directory paths for the Plant 3D
model DWG and Orthographic output,
enter Project Data\ before the last folder as
shown.
■
For the Spec Sheets Directory, browse to
and select the folder \CommonProjectFiles
\Spec Sheets as shown.
■
Click Next.

8.

5.

On page 2 of the wizard:
■
Select Metric.
■
Select Inches (Mixed Metric).
■
Click Next.

6.

On page 3 of the wizard:
■
In the field specifying the directory where
P&ID drawings are stored, enter Project
Data\ before PID DWG as shown.
■
Click Next.

On page 5 of the wizard, verify SQLite local
database is selected. Click Next.
9. On page 6 of the wizard:
■
Click the Edit Additional Project Settings
After Creating Project check box.
■
Click Finish.
In
the
Project Setup dialog box, General Paths
10.
and File Locations area, set the directory paths
for user-defined reports and related files. Do
the following:
■
Under General Settings > Project
Details, for the User-defined reports
directory, browse to and select the folder
\CommonProjectFiles\Report Templates as
shown.
■
For the Related Files directory, browse to
the Project Data folder in this new project.
■
In the Select Related Files Directory dialog
box, create a new folder titled Related Files.
■
Select and open that new folder. The new
paths are similar to what is shown.
■
Click Apply.
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11. Set the directory path for the Plant 3D
equipment templates. Do the following:
■
In the list, under Plant 3D DWG Settings,
select Paths.
■
For the Equipment Templates directory,
browse to and select the folder
\CommonProjectFiles\Report Templates as
shown.
■
Click Open.

14. In Windows Explorer, review the folder and
files structure set up for the newly created
project. Notice that the folders Equipment
Templates, Related Files, and ReportTemplates
are listed in two different locations. The folders
in the main project folder identified with the
arrows were automatically created by the
wizard. The second set of folders are what the
project is now configured to use.

12. In the Project Setup dialog box, click OK.
13. Close the project.

15. Delete the three previously identified folders.
The project folder structure now displays as
shown.

16. To begin to update the relative directory for
report queries:
■
In the N_IA-10-029 folder, open
Metric_PipingPart.xml in Notepad.
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Under <PROJECTDIRECTORIES>, locate the
entry ReportQueriesDirectory as shown.

25. In the Project Setup dialog box, under General
Settings, click Reports. The list of defined
reports displays under Project Reports as
shown. If you get an error message, than either
not all of the stated changes were made or
a mistake was made in one or more of the
relative paths.

17. Follow that line of text until you get to the
text starting with relativeDirectoryName=".
Change the text to "..\..\CommonProjectFiles
\ReportTemplates".
18. Save and close Metric_PipingPart.xml.
19. To begin to update the relative paths for
individual report query files:
■
In the N_IA-10-029 folder, open
PIP_Metric_PnIdPart.xml in Notepad.
■
Under <REPORTQUERYFILES>, locate the
nine entries starting with ReportFile as
shown.

20. Follow each line of text until you get to the
text starting with relativeFileName=". Change
the beginning of each of the nine relative
filename paths to "..\..\CommonProjectFiles
\ReportTemplates\.
For example, the text for the "Valve List"
entry becomes relativeFileName= "..\..
\CommonProjectFiles\ReportTemplates
\ValveList.xml".

21.
22.
23.
24.

Tip: To quickly change all nine entries, copy and
paste the text ..\..\CommonProjectFiles or use
Notepad's find and replace functionality.
After changing the relativeFileName paths
for the nine report files, save and close
PIP_Metric_PnIdPart.xml.
Switch to Plant 3D.
In Plant 3D, open the project N_IA-10-029.
In the Project list, right-click N_IA-10-029. Click
Properties.
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Configure the Filename Format

4.

In the Selection List Property dialog box:
■
Click New Selection List.
■
In the Add Selection List dialog box, enter
Area.
■
Click OK. The list displays as shown.

5.

To add values for the Area selection list:
■
Click Add Row.
■
In the Add Row dialog box, Value field,
enter 10.
■
Click OK.
■
Add rows until you have the values 10
through 90 added as shown.

6.

In the Selection List Property dialog box, click
OK.

In this section of the exercise, you configure a
required filename format that users will use when
creating new drawings.
1. In the Project Setup dialog box, expand P&ID
DWG Settings and P&ID Class Definitions.
Select Engineering Items.

2.
3.
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To begin to add a new property for use in the
file name, in the Properties area, click Add.
In the Add Property dialog box:
■
In the Property Name field, enter
Area_Designation.
■
In the Choose a Type area, click Selection
List.
■
Click OK.

■
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7.

To set the default list value for this new
list, in the Default Value column, for the
Area_Designation row, select the top empty
row in the list of values as shown.

8.

Under General Settings, in the tree list , select
File Name Format.

9.

To begin to add a value for the file name
format:
■
In the File Name Format area, click Add.
■
In the Name field, enter Area_Designation.
■
In the Type list, select Area.
■
In the Delimiter field, enter -.

11. Add a third tag to the file name. Do the
following:
■
Click Add.
■
In the Name field, enter System_Type.
■
In the Type list, select String.
■
In the Length list, select 3.
■
In the Delimiter field, enter -.
12. Add the fourth and last tag to the file name. Do
the following:
■
Click Add.
■
In the Name field, enter Sheet_Number.
■
In the Type list, select Numeric.
■
In the Length list, select 2.
With
the file name format now displaying as
13.
shown, click OK.

14. To begin to test the file naming configuration,
right-click P&ID Drawings. Click New Drawing.
15. In the New DWG dialog box:
■
For Area_Designation, select 20.
■
For DWG_Number, first attempt to enter
1010. Notice you are limited to three
characters. Enter 001.
■
For System_Type, enter Oil.
■
For Sheet_Number, enter 01.
■
Review the File Name field for the name of
the drawing that will be created.

10. Add a second tag to the file name. Do the
following:
■
Click Add.
■
In the Name field, enter DWG_Number.
■
In the Type list, select Numeric.
■
In the Length list, select 3.
■
In the Delimiter field, enter -.
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16. In the New DWG dialog box, click OK. The new
drawing is added to the project as shown.

Set External References Demand Load
In this section of the exercise, you ensure that the
demand load setting for external references is set
properly to enable multiple users to work with the
drawings.
1.
2.

Click Application menu > Options.
In the Options dialog box, click the Open and
Save tab.

3.

In the External References (Xrefs) area,
Demand Load Xrefs list, ensure the option
Enabled with Copy is selected.

4.
5.

In the Options dialog box, click OK.
Close all files. Do not save changes.

Lock Project Properties
In this section of the exercise, you lock the properties
for a project so others cannot easily go in and modify
the settings.
1.
2.

3.

5-48

In Windows Explorer, N_IA-10-029 folder, rightclick projSymbolStyle.dwg. Click Properties.
In the Properties dialog box, General tab:
■
Click the Read-only check box.
■
Click OK.

In the Plant 3D Project Manager, right-click
N_IA-10-029. Notice that the Properties option
is unavailable.

■
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Review
What functionality can you use to work with multiple users on a project?
You can’t.
External Reference.
Dynamic blocks.
Can you set the naming scheme for the users, so that the naming of drawings will always look the
same?
No.
Yes, by entering the correct filename when creating the drawings.
You can set up a naming scheme in combination with selection lists, to help the users to build up
the correct name for a drawing.
What is important when working in a network environment?
You are connected and have the correct rights to the network location.
The drawings interact with each other using external references.
Folders are created to create a structure for sub sections and/or areas.
All of the above.
How do you keep people from being able to modify the settings for a project?
In the Project Setup dialog box, select the Password Protect option and enter a password.
In the operating system, set the projSymbolStyle.dwg file for the project to read-only.
In the operating system, set the project.xml file for the project to read-only.
In the Project Manager, right-click the project name. In the shortcut menu click Lock Project
Settings.
For a project that is set up to be accessed by multiple users, each project team member opens the
same Project.xml file from the project's shared network location.
True
False
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Lesson: Defining New Objects and Properties
This lesson describes how to set up the tagging scheme in combination with the Acquire functionality
and how symbols are defined and what settings are required before placing them. After this lesson
you will be able to create P&ID Symbols, define new properties, define various tags, and ensure that
the symbols perform as proper P&ID symbols.

Objectives
After completing this lesson, you will be able to:
Create a custom symbol and assign properties.
Create a selection list for properties.
Create a tag format for a class.
Create a custom annotation style that displays specified properties.

■
■
■
■

Creating Symbols and Setting Color and Layer
When creating a custom symbol, you can apply specific settings to automate the insertion of the
symbol in your design. After creating the geometry for the symbol, you enter the Project Setup dialog
box > P&ID Class Definitions and locate the class that best fits the new symbol. If needed, you can
create a new class.
As the symbol is added to the class, the Symbol Setting dialog box is displayed. This dialog box is
divided into three sections. In the first section, Symbol Properties, you name the symbol and select
the block to be used. When you select the block, regardless of the drawing where it resides, it is
copied into the projSymbolStyle.dwg drawing.
In the General Style Properties section, you can set properties such as Layer, Color, Linetype, and
Lineweight. The Other Properties section can vary slightly depending on the type of symbol being
created. You use this section to set the behavior upon insertion. You set standard AutoCAD functions
such as Scale, Mirror and Rotate here, as well as symbol-specific behavior such as Tagging, Join Type,
Nozzles, and Nozzle style.
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The following illustration shows the Symbol Settings dialog box.

Process: Creating Symbols and Setting Color and Layer
The following steps describe setting color and layer properties for a custom symbol.
1.
2.

Open projSymbolStyle.dwg for the current project.
Create new geometry or explode an existing symbol and modify to create the symbol.

3.
4.
5.

Convert the geometry to a block.
Save and close projSymbolStyle.dwg.
Create a new drawing or open an existing drawing in the project.
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6.

Display the Project Setup dialog box and select or create a class.

7.

In the Project Setup dialog box, under Symbol, click Add Symbol. The Add Symbols - Select
Symbols dialog box displays.

■
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8.

Add the block. Click Next.

9.

Add a Symbol Name, and set any custom properties.

10. Click Finish.

Add Properties as Selection List and Acquire Functions
The Properties section of the Project Setup dialog box contains a table of properties for each class
definition. Some of these properties can be defined by selecting a value from a list. When adding a
custom property, you can set the property to be defined by a list of selectable values.
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The following illustration shows the Add Property dialog box. In this application, a new Selection List
property is being added to the project.

Process: Add Properties as Selection List and Acquire Functions
To add a Selection List property, you need to select a class in the Project Setup dialog box. Under
Properties, click Add to display the Add Property dialog box. In the Add Property dialog box, enter a
name for the property and under Choose a Type, click Selection List.
1.
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In the Project Setup dialog
box, select a class. Under
Properties, click Add.
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2.

In the Add Property dialog
box, enter a name for the
property and under Choose a
Type, click Selection List.

3.

In the Selection List dialog
box, choose from the list of
available selection lists or
create a new one.

4.

If creating a new list, name
the list.
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5.

Click Add Row. Enter a Value
and Description.

Setting a Tag Format
You can assign a custom tag format to any class that has a TagFormatName property assigned to it. If
a class has this property, when selected, the New button under Tag Format will be selectable. When
you click New, the Tag Format Setup dialog box is displayed. In this dialog box, you assign a name and
specify the number of subparts.
For each subpart, you can assign Class Properties, Drawing Properties, and Project Properties to
the class. You can also define Expressions. Once the tag format is complete, you can assign to the
TagFormatName property.
The following illustration shows the Tag Format Setup dialog box access from the Project Setup dialog
box.

5-56

■

Chapter 5: Setting up and Administering a Plant Project

Tag Format Setup Dialog Box
The Tag Format Setup dialog box enables you to access properties based on Class Properties, Drawing
Properties, or Project Properties. Also, an expression can be defined.
Display Class Properties: Selecting this button will display the Select Class Properties dialog box.
Here, you can select properties defined for the class selected. Some examples may include Class
Name, Description and Manufacturer. The available properties will vary depending on the class
selected.
Display Drawing Properties: Selecting this button will display the Select Drawing Property dialog
box. Here, you can select properties defined for the drawing. Some examples may include DWG
Number, DWG Title and Description. The available properties can vary depending on the category
selected.
Display Project Properties: Selecting this button will display the Select Project Property dialog
box. Here, you can select properties defined for the project. Some examples may include Project
Name, Project Description and Company Name. The available properties can vary depending on
the category selected.
Define Expression: Selecting this button will display the Define Expression dialog box. Here, you
can define tagging format expressions.

Process: Setting a Tag Format
The following steps outline the process to assign a tag format to a property.
1.

In the Project Setup dialog
box, select a Class Definition
with a tag property. Under
Tag Format, click New.

2.

In the Tag Format Setup
dialog box, enter a Format
Name and the number of
subparts.
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3.

Select the Class Properties.

4.

In the Properties table, assign
the tag format.

Creating a Custom Annotation Style
A custom annotation style enables you to add annotation to symbols that correspond to your
company or customer specifications.
It is important to understand the difference between a tag and an annotation. In Plant 3D, the tag is a
property which is defined within the properties, while an annotation is what is actually displayed on
the drawing. Both tags and annotations can be formatted to reflect combinations of properties.
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In the following table, two different annotation styles are shown with the same symbol. The
configured annotation style as it is configured in the project setup is shown below each example. The
difference between these styles is the inclusion of an oval around the value and the automatic offset
distance from the symbol.

You create custom annotation styles within the project. Custom annotation styles are available for
use at and below the level they are created. So for example, if a custom annotation style is created at
the Engineering Items level under P&ID Class Settings, every class under that will be able to use that
annotation style. If you create an annotation style at an individual a class level, then only that class has
access to that annotation style.
If you set a custom annotation style as the default annotation for a class, then that annotation style
will be used when a symbol from that class is added to the drawing.

Annotation Styles
An annotation style consists of overall properties and a block definition with a formatted attribute
definition. The formatted attribute definition is configured to be dynamic based on specified
properties or expressions.
When working with annotation styles, your main tasks are to add, edit, or remove the annotation for a
selected class or edit the block definition used by the annotation style.
The following illustration shows the Annotation area of the Project Setup dialog box.

When you are first creating a new annotation style, you select a block definition from a drawing to
base it on. That block definition is then added to the projSymbolStyle drawing file in the active project.
The name of the added block is the name of the annotation style with a _block suffix. So when you
edit the block for an annotation style, you edit the unique block definition in the projSymbolStyle
drawing file.
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The display and placement for the annotation is based on the properties configured in the Symbol
Settings dialog box. You configure how the annotation should display by adjusting the settings under
General Style Properties. You change the different settings under Other Properties to things like the
symbol size, if it is automatically inserted when the symbol is added, where the block is inserted
relative to the symbol insertion point, if a leader line should be included, and the text orientation.

Process: Creating a Custom Annotation Style
The following steps describe the overall process for creating a custom annotation style.
1.
2.
3.
4.
5.
6.
7.

Create a custom block for the annotation and save it in a drawing file.
Define a new annotation style.
Edit the annotation block and replace the placeholder geometry with an attribute and any other
required geometry.
Configure the attribute definition to have an annotation format.
Save the changes to the block.
If you want this custom annotation style to be used by a symbol by default, assign the new
custom annotation style to the AnnotationStyleName property at the required level.
Apply the changes in the Project Setup dialog box so they are saved in the projSymbolStyle.dwg
file. The newly configured annotation style is now available for use in any drawing when the
current project is active.

Create a Custom Block for the Annotation
The block that you create in the first step of the process can consist of any type of geometry as
a placeholder. You just need a block definition saved in a drawing that you can select later in the
process.
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Define a New Annotation Style
The creating and defining of a new annotation style is done within the Project Setup dialog box.
Because the annotation style is associated with a class definition, the first thing you need to do is
select the level where you want to create a new custom annotation style. After selecting the level,
you click Add Annotation in the Annotation area to begin creating the new annotation style. You then
enter a name for the annotation style and select the custom annotation block from the drawing file
you saved it in. After entering the name and selecting the block, you then set the properties for the
annotation block. Properties like layer, layer properties, auto insertion, the text insertion position, and
the use of a leader.

Edit the Block - Add an Attribute
After the new annotation style has been added, your next task is to edit the block associated with the
annotation style. In the Block Editor you delete the placeholder geometry and create an attribute and
specify its insertion point to coincide with the insertion point of the block. This would be the logical
point on the placeholder geometry you object snapped to during the creation of the block. In the Block
Editor environment, it should also be the 0,0 point.
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Configure the Attribute to have an Annotation Format
To have the values in the annotation dynamic to specific properties, you need to configure the
attribute to have an annotation format. You initiate the assigning of an annotation format while
editing the block by clicking Assign Annotation Format on the PnID Annotation toolbar. After selecting
the attribute definition, you specify the number of subparts and where the property values for those
subparts come from.

Assign Annotation Style for a Symbol
After the annotation style has been created and configured, it is ready to be used in any drawing in
the project. If you want it to be the default annotation style for a symbol, in the Project Setup dialog
box, select that symbol in the list and then select the annotation style in the Default Value cell for the
AnnotationStyleName property.

Refer to the help system topic Set Up Annotations to learn more about creating
annotation styles.
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Exercise: Create Symbols and Set Up the Tagging Scheme
In this exercise, you will learn how to create symbols,
set the layer and colors, set up the tag, and create
annotations.

3.

To create a new P&ID drawing:
■
In the Project Manager, right-click P&ID
Drawings. Click New Drawing.
■
In the New DWG dialog box, for File Name,
enter New_Symbols.
■
Click OK.

4.

To prepare the drawing file:
■
Click Workspace Switching > P&ID PIP.
■
Switch to the Model Environment.
■
Make the P&ID PIP tool palette current.

The completed exercise

Creating New Symbols
In this section of the exercise, you create a new inline
symbol, and modify a standard symbol to create a
new endline symbol.
It is recommended that you use both snap and grid
during the course of this exercise. The grid will be
turned on and off throughout the exercise for clarity
purposes.
1.
2.

Start AutoCAD Plant 3D.
To set Create Symbols and Set Up the Tagging
Scheme as the current project:
■
In the Project Manager, Current Project list,
click Open.
■
In the Open dialog box, navigate to the
folder ..\Plant Design\Create Symbols and
Set Up the Tagging Scheme.
■
Select the file Project.xml.
■
Click Open.
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5.

To insert a symbol:
■
On the P&ID PIP tool palette, click the
Equipment tab.
■
Under Pumps, click Horizontal Centrifugal
Pump.
■
Place the pump in the drawing as shown.
■
When the Assign Tag dialog box displays,
click Cancel.
Note: This standard symbol will provide a size
reference for the creation of new symbols.

6.

Place a Gate Valve as shown.
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7.

To create the geometry for a new symbol:
■
Using standard AutoCAD drawing
commands, create geometry that closely
resembles the drawing shown.
■
Use a Polyline for the arrow.

8.

To create a block of the geometry:
■
On the ribbon, click Insert tab > Block
Definition panel > Create Block.
■
In the Block Definition dialog box, for Name,
enter Noise Reduction.
■
For Base Point, click Pick Point. Select
a point in the middle of the geometry
(arrow).
■
Under Objects, click Select Objects. Select
the geometry.
■
Click OK.

9.

Save the drawing.
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10. To begin to create a new symbol from an
existing symbol:
■
Explode the Horizontal Centrifugal Pump.
■
Explode the same geometry again. This
reverts the geometry to lines and arcs.
11. To edit the geometry:
■
Delete the top nozzle.
■
Move the remaining nozzle lower. Copy or
mirror as shown (1).
■
Move and rotate the geometry on the right
to the top as shown (2). You can use grips to
move and rotate.

14. To create a new tool palette:
■
Right-click any name on the tool palette.
■
Click New Palette.
■
For name, enter New_Symbols.
■
Move the palette to the bottom of the
existing palettes.

Assign Properties to New Symbols
In this section of the exercise, you assign properties to
the new symbols.
1.
12. Create a block of the edited geometry:
■
For Name, enter Vertical Pump.
■
For Insertion point, select near the middle
of the geometry with the nozzles.
13. Save the drawing.

To access the Project Properties, in the Project
Manager, right-click Training Project. Click
Properties.
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2.

To begin to add the pump symbol:
■
In the Project Setup dialog box, in the Class
list, expand P&ID DWG Settings > P&ID
Class Definitions > Engineering Items >
Equipment.
■
Click Pumps.

3.

To create a new class:
■
Right-click Pumps.
■
Click New.
■
In the Create Class dialog box, for Class
Name, enter VerticalPump.
■
For Display Name of the Class, add a space
between Vertical and Pump.
■
Click OK.
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4.

To begin to add the new symbol to the new
class:
■
In the Project Setup dialog box, under Class
Settings: Vertical Pump (verify that Vertical
Pump is selected) click Add Symbols.
■
In the Add Symbols - Select Settings dialog
box, under Selected Drawings, click More.
■
Navigate to the Training Project, PID DWG
folder. Select New_Symbols.dwg.
■
Click Open.
■
Under Available Block, click Vertical Pump.
Click Add.

5.

Click Next.
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6.

7.

To assign General Style Properties to the
symbol, make the following changes:
■
For Symbol Name, enter Vertical Pump.
■
For Layer, select Equipment.
■
For Color, select ByLayer.
■
For Linetype, select ByLayer.
■
For Line Weight, select ByLayer.

8.

Click Finish. Note the symbol displayed under
Class Settings.

9.

To add attachment points to the symbol:
■
Under Symbol, click Edit Block.
■
On the Parameters palette, click Point.
■
Use an Endpoint object snap to locate the
point on the top nozzle as shown.
■
Add a second point to the bottom nozzle.

To set Other Properties, make the following
changes:
■
For Scale on Insert, select Yes.
■
For Rotate on Insert, select Yes.
■
For Tagging Prompt, select Prompt for Tag
During Component Creation.
■
For Join type, select Endline.
■
For Auto Nozzle, select Yes.
■
For Auto Nozzle Style, select Assumed
Nozzle Style.
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10. To edit the Point parameters:
■
Right-click the Position1 parameter.
■
Click Rename Parameter.
■
Enter AttachmentPoint1. (Note: It must be
entered exactly as shown.)
■
Rename Position 2 to AttachmentPoint2.

14. To test the symbol:
■
On the New_Symbols tool palette, click
Vertical Pump.
■
Click a location next to the existing block.
■
Accept the default values for scale and
rotation angle.
■
In the Assign Tag dialog box, for Type, select
P-Pumps.
■
For Number, click Next Available.
■
Click Place Annotation After Assigning Tag.
■
Click Assign.
■
Locate the tag below the new symbol.

11. Close the Block Editor. Save changes.
12. In the Project Setup dialog box, click Apply. Click
OK.
13. To add the symbol to the P&ID PIP tool palette:
■
Verify that the current tool palette is
New_Symbols
■
Reaccess the Project Setup dialog box.
■
With Vertical Pump displayed under Class
Settings: Vertical Pump, click Add to Tool
Palette.
■
In the Create Tool dialog box, click OK.
■
In the Project Setup dialog box, click OK.
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15. To begin to add the Noise Reducer symbol:
■
Access the Project Setup dialog box.
■
Expand to the P&ID Class Definitions >
Engineering Items > Inline Assets > Piping
Fittings.

18. Click Next.
19. Set the General Style Properties as shown.

20. Set the Other Properties as shown. Click Finish.

16. To create a new Piping Fittings class:
■
Right-click Piping Fittings. Click New.
■
For Name, enter NoiseReducer.
■
For Display Name, add a space between the
two words.
■
Click OK.

21. Edit the block and add points as shown:
■
Rename the left point to AttachmentPoint1.
■
Rename the right point to
AttachmentPoint2.
■
Close the Block Editor. Save changes.

17. To add the symbol:
■
In the Project Setup dialog box, under Class
Settings: Noise Reducer (verify that Noise
Reducer is selected) click Add Symbols.
■
In the Add Symbols - Select Settings dialog
box, under Selected Drawings, click More.
■
Navigate to the Training Project, PID DWG
folder. Select New_Symbols.dwg.
■
Click Open.
■
Under Available Blocks, click Noise
Reduction.
■
Click Add.
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Creating Selection Lists and Setting Tag
Information

2.

In the Properties table, locate Tag. Note that
under Tag Format, the New button is now
selectable.

In this section of the exercise, you add properties to
both the symbol and the class to enable you to apply
properties and tags to the symbol.
1. To create a tag format:
■
In the Project Setup dialog box, under
Properties, click Add.
■
In the Add Property dialog box, for Property
Name, enter Tag.
■
Click OK.
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3.

4.

To enter a Tag Format, a Type must exist. To
add a Type:
■
From the Project Setup class list, select
Piping Fittings.
■
Under Properties, click Add.
■
In the Add Property dialog box, for Property
Name, enter Type.
■
Under Choose a Type, select Selection List.
■
Click OK.

5.

To create the list:
■
In the Selection List Property dialog box,
click Add Row.
■
In the Add Row dialog box, for Value, enter
NR.
■
For Description, enter Noise Reduction.
■
Click OK.

6.

Add two additional rows as shown. Click OK.

In the Select List Property dialog box:
■
Click New Selection List.
■
In the Add Selection List dialog box, enter
Piping_Fittings_Type.
■
Click OK.
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7.

In the Properties table, for the Property Name:
Type, verify that the selection list is valid. Select
the Blank option (arrow).

8.

To create an additional property for a number:
■
Click Add.
■
In the Add Property dialog box, for Property
Name, enter Number.
■
Verify that the Type is String.
■
Click OK.
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9.

In the Class List, select Noise Reducer.

10. With Noise Reducer selected, under Properties,
set the type to NR.

Chapter 5: Setting up and Administering a Plant Project

11. To set up a new tag format:
■
Under Tag Format, click New.
■
In the Tag Format Setup dialog box, for
Format Name, enter Piping Fitting Tag.
■
For Number of Subparts, select 2.
■
For the first field, click Select Class
Property.

13. In the Tag Format Setup dialog box, click OK.
Note that in the Project Setup dialog box,
under Tag Format, Piping Fitting Tag is
displayed. Also note that in the Properties
table, under Property Name, TagFormatName
is listed, and the Default Value is set to Piping
Fitting Tag.

12. To set the Class Properties:
■
In the Select Class Property dialog box, with
the Noise Reducer class selected, under
Property, click Type.
■
Click OK.
■
For the second subpart, click Select Class
Property.
■
Under Property, click Number.
■
Click OK. The fields now display as shown.
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14. To set the Flow Direction property for the
symbol:
■
In the Properties table, locate the
HasFlowDirection property.
■
Note that the Property Type is Boolean.
■
Under Default Value, set to True.

18. To test the new symbol functionality:
■
Add Primary Line Segment lines in various
directions to the drawing.
■
Add the Noise Reducer symbol to the pipe
lines.

19. Right-click a line segment. Click Schematic Line
Edit > Reverse Flow Direction.

15. In the Project Setup dialog box, click Apply.
16. To place the symbol on the tool palette, under
Symbol, click Add to Tool Palette.
In the Create Tool dialog box, click OK.
Note: Verify that the New_Symbols tool palette
is current. If not, exit the Project Setup dialog
box, make the New_Symbols palette active,
and return to the Project Setup dialog box.

20. To change the flow direction of the symbol:
■
Select one of the symbols.
■
Click the directional arrow.

17. In the Project Setup dialog box, click OK.
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21. To assign a tag:
■
Right-click one of the symbols.
■
Click Assign Tag.
■
In the Assign Tag dialog box, for Number,
enter 001.
■
Verify that Place Annotation After Assigning
Tag is selected.
■
Click Assign.

Create a Custom Annotation
In this section of the exercise, you create a custom
annotation and use it in combination with a custom
symbol.
1. To begin to create the custom annotation for
the symbol:
■
Start the Single Line text command.
■
Set the Justification to Middle Center.
■
In the drawing, click a centered point below
a Noise Reducer symbol.
■
Accept the default values for Height and
Rotation.
■
Enter any line of text.

2.

22. Place the tag below the Noise Reducer.

3.
4.
5.

Make a block of the new text:
■
For Block Name, enter NR-Annotation.
■
For insertion Base Point, select the insertion
point of the text.
Save the drawing file.
Access the Project Setup dialog box. Verify that
the Noise Reducer is selected.
To begin to create a custom annotation, in the
Annotation area, click Add Annotation.
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6.

In the Symbol Setting dialog box, under Symbol
Properties:
■
For Symbol Name, enter Noise Reducer
Annotation.
■
Click in the Block field. Click More.
■
In the Select Block Drawing dialog box,
select and open the New_Symbols drawing
file.
■
In the Select Block dialog box, under
Available Blocks, select NR-Annotation.
■
Click OK.
9.

7.

To set General Style Properties:
■
For Linetype, select ByLayer.
■
For Line Weight, select ByLayer.

8.

For Other Properties:
■
For Auto Insert?, select Auto Insert.
■
For Offset Y, enter -5.
■
Click OK.
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Note that the annotation style is added.
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10. To edit the annotation:
■
Under Annotation, click Edit Block.
■
In the Block Editor, on the ribbon, click
Action Parameters panel > Attribute
Definition.
■
In the Attribute Definition dialog box, under
Attribute, for Tag, enter X.
■
Under Text Settings, for Justification, select
Middle Center.
■
Click OK.

12. Delete the original text.

13. To begin to configure the attribute to have an
annotation format:
■
On the PnID Annotation toolbar, click Assign
Annotation Format.
■
Select the attribute.

11. Use the Insert object snap and select the
existing text.

14. To set the annotation format:
■
In the Assign Annotation Format dialog box,
under Delimiter, delete the X.
■
Click Select Class Properties.
■
Under Class, expand Engineering Items >
Inline Assets > Piping Fittings.
■
Select Noise Reducer.
■
Under Property, click Tag.
■
Click OK.
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15. In the Assign Annotation Format dialog box,
click OK.

16. Close the Block Editor. Save Changes.
17. In the Properties table, locate
AnnotationStyleName. Set the Default Value to
Noise Reducer Annotation.

21. To update the tag information:
■
Right-click the symbol.
■
Click Assign Tag.
■
In the Assign Tag dialog box, for Number,
enter 002.
■
Under Existing Piping Fittings, for
Annotation style, select Noise Reducer
Annotation.
■
Click Assign.

22. Close all files. Do not save.

18. In the Project Setup dialog box, click Apply. Click
OK.
19. In the drawing, delete one of the Noise Reducer
symbols.
20. Place another Noise Reducer symbol.
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Review
When creating properties, you can use a functionality called acquisition. What would you use
acquisition for?
To inherit values from the pipe line
To inherit values from equipment
To inherit values from any other object
All objects used in P&ID have a so-called connection type. Which of the types below are correct?
End type
Inline type
No join type
Segment breaker Type
Segment breaker Type
Segment Group Breaker Type
All of the above
In P&ID and Plant 3D, you find all kinds of classes. What is the purpose of these classes?
They give you a structure so you can easily find the required symbol.
Each class can carry its own settings and properties, and it divides the specific symbols into easy
to understand groups. Using classes, you can also set up and create specific lists and reports
needed for purchasing and production.
Classes have no specific use, they just look cleaner in your project setup.
Annotations are used frequently. Can you combine multiple properties in one annotation?
No, annotations can only show one property on placement.
Yes, the number of properties shown is almost unlimited.
Yes, but it can only be properties of one specific object.
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With the configuring of your project, you can use the symbol list property type for changing the
symbol from one symbol to another (for instance from NO to NC). Is it possible to create more than
one symbol list per class?
No, each class is limited to one symbol list.
Yes, the number of symbol lists in one class is unlimited.
Yes, but each symbol list should be defined with different properties.
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Lesson: Customizing Data Manager
This lesson describes how to manipulate views in the Data Manager and how to edit or create your
own project reports. After this lesson you will be able to set up any report or view in the Data Manager
that could then be used to export data from the project.

Objectives
After completing this lesson, you will be able to:
■
■
■
■
■

Access and view the default reports in the Data Manager.
Modify the default reports in the Data Manager.
View project data in the Data Manager.
Configure a report to display custom data.
Change export and import settings for project data.

Default Reports and Views in the Data Manager
Included within AutoCAD P&ID and Plant 3D Data Manager are many default reports that enable you
to access data at the drawing or project level.
The following illustration shows Data Manager access to drawing and project data and project reports.
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Process: Viewing Default Reports in the Data Manager
There are a multitude of reports available in the Data Manager. The following steps give an overview
of accessing default reports. To access these reports, you start the Data Manager and select Project
Reports. Under Project Reports, you then select a specific report from the list.

Modifying Existing Reports
The default reports that are included can be modified to fit your needs.
The following illustration shows the modification of an existing report. After accessing the default
reports in the Project Setup dialog box, a specific report is selected and properties are defined to
include or remove from the report.
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Process: Modify Existing Reports
The following steps give an overview of modifying an existing report.
1.

In the Project Setup dialog
box, select a defined report.
Click Modify.

2.

Under Report Properties,
select a class and add
or remove properties as
needed.

3.

Order the properties as
needed.
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Setting up Data Manager Views Used in the Project
You can create views in the Data Manager to reflect specific data. To set up views in the Data Manager,
you access the Project Setup dialog box and click the Data Manager Configuration in either the P&ID
DWG Settings or Plant 3D DWG Settings.

Process: Setting up Data Manager Views
The following steps describe setting up views in the Data Manager.
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1.

Open the Data Manager.
Select Project Reports.

2.

Select a report.

3.

Review the data in the
report.

■
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Configuring a Custom Report
Creating a custom report enables you to report on specific components within your design. To create a
custom report, you start with one of the default reports supplied and adjust to fit your needs.

Process: Configuring a Custom Report
The following steps give an overview of configuring a custom report based on a default report.
1.

Access the Project Setup
dialog box and click Reports.

2.

Select the default report that
best fits your needs.

3.

Click New. Enter a Name and
replace the default tables.
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4.

Add or remove properties as
required.

5.

Order the properties as
required.

Setting up Export and Import Settings
Project Reports only display the information based on the class selected. You must use the export and
import settings to enable you to create a report based on all the components inside your drawing.
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The following illustration shows access to the export and import settings. In the Project Setup dialog
box, you expand either the P&ID DWG Settings or Plant 3D DWG Settings to access export and import
settings. The process for both products is the same.

Process: Setting Up Export and Import Settings
1.

In the Project Setup dialog
box, access Export and
Import Settings.

2.
3.

Click New.
Enter a name and
description.
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4.

Select class(es).

5.

Adjust properties as required.

■
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Exercise: Create Views and Manage Reports
In this exercise, you create some Data Manager views
and modify and create custom reports, all to be used
to export and import Microsoft Excel data.

The completed exercise

4.

To view report data in the Data Manager:
■
In the Data Manager, expand P&ID Project
Data or Plant 3D Project Data, depending on
the product being used.
■
Click Project Reports.

5.

In the Project Reports list, click Control Valve
List.

6.

Take time to view the standard default report
data for this and other Project Reports.

Setting up the Data Manager Views
In this section of the exercise, you change settings in
the Data Manager to create specific views.
1.
2.

3.

Start AutoCAD Plant 3D.
Set Create Views and Manage Reports as the
current project by doing the following:
■
In the Project Manager, Current Project list,
click Open.
■
In the Open dialog box, navigate to the
folder ..\Plant Design\Create Views and
Manage Reports.
■
Select the file Project.xml.
■
Click Open.
In the Project Manager:
■
Select Training Project.
■
Expand Reports and click Data Manager.
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7.

From the list, select P&ID or Plant 3D Project
Data.

8.

To view more detailed information:
■
In the Project Manager, click Engineering
Items > Equipment.
■
Note the rows and columns of data.
■
Click Equipment > Pumps.
■
Note the increased number of columns.

11. Under Project Reports > Defined Reports, note
the list. It is the same list that was displayed in
the Data Manager.

12. To begin to modify a report:
■
In the Defined Reports list, click Valve List.
■
Click Modify.

9. Close the Data Manager.
10. Display the Project Setup dialog box:
■
In the Project Manager, right-click the
current project.
■
Click Properties.
■
Click General Settings > Reports.
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13. In the Modify Report - Valve List dialog box,
expand P&ID Object Properties > Hand Valves.

15. To reorder the properties:
■
Press CTRL.
■
Click P&ID.Hand Valves.Normally.
■
Click P&ID.Hand Valves.Failure.
■
Click Move Up Selected Property until the
location matches the illustration below.

14. To add data to the report:
■
Under Hand Valves, check Normally.
■
Check Failure.
Note that those two options are added to the
Property Order list.

Lesson: Customizing Data Manager

■

5-91

16. To remove a property:
■
Under Property Order, locate: P&ID.Pipe
Line Segments.Insulation Thickness.
■
Note that it is in the Pipe Line Segments
class.
■
Under Report Properties, expand Pipe Line
Segments.
■
Locate Insulation Thickness. Clear the check
mark.

18. To accept the modification, in the Project Setup
dialog box, click OK.
19. To view the report in the Data Manager:
■
Open the Data Manager.
■
From the list, select Project Reports.
■
Under Project Reports, click Valve List.

20. Close the Data Manager.

Configure the Data Manager Display
In this section of the exercise, you customize the Data
Manager to display specific data.
17. In the Modify Report dialog box, click OK. Note
the updated display in the modified Valve List
report.
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1.
2.

Open the Project Setup dialog box.
In the Project Setup dialog box, expand
P&ID DWG Settings. Click Data Manager
Configuration.
Note that there are no customized views.
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3.

To create a new view:
■
Under Customized views, click Create View.
■
For Name, enter Valve List by Vendor.
■
For Scope, select Project Data.

4.

Note that the view is added to the Customized
Views list.

5.

To add a level to the customized view:
■
Under Valve List by Vendor - Project Data,
click New Level.
■
In the Select Class Property dialog box,
under Class, expand Engineering Items >
Inline Assets.
■
Click Hand Valves.
■
Under Properties, click Manufacturer.
■
Click OK.

7.

Add a third level:
■
For Class, select Hand Valves.
■
For Properties, select Size.

8. In the Project Setup dialog box, click OK.
9. Start the Data Manager.
10. From the list, select Project Custom Views.
Expand the options and click the different
levels. Observe the display of the Data Manager
with different selections.

11. To export a custom report:
■
In the Data Manager, with Project Custom
Views active, expand Manufacturer Flowserve.
■
Click Valve Code - GV.
■
On the Data Manager toolbar, click Export.
■
In the Export Data dialog box, note the
name and location for the exported data.
■
Click OK.

6.

Add an additional level:
■
For Class, select Hand Valves.
■
For Properties, select Valve Code.
■
Click OK.
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12. Open the exported spreadsheet. Note the
different sheets for each valve size. Close the
spreadsheet.
Note: The following illustration shows the Size
10 sheet in the spreadsheet.

4.

Under the list of defined reports, click New.

5.

To define the new list:
■
In the New Report dialog box, for New
Report Name, enter Pump List.
■
Click Replace Table(s).
■
In the Replace dialog box, click Equipment.
■
In the Equipment List, select Pumps.
■
Click Continue.
■
In the New Report dialog box, click
Continue.

13. Close the Data Manager.

Configure a Custom Report
In this section of the exercise, you set up a custom
report to view a specific component in the project.
1.
2.

Open the Project Setup dialog box.
Expand General Settings and click Reports.

3.

In Project Reports > Defined Reports, click
Equipment List.
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6.

To view the newly created report:
■
In the New Report -Pump List dialog box,
under Report Properties, expand P&ID
Object Properties.
■
Expand Pumps.

9.
7.

To add specific properties to the list, select the
properties as shown.

8.

To remove properties:
■
In the Select Properties to Include list,
expand P&ID Drawing Properties.
■
Clear the check mark for DWG Name.

To reorder the list:
■
Under Property Order, select
P&ID.Pumps.PnPID.
■
Press CTRL and select
P&ID.Drawing.DWG.Number.
■
Press the down arrow to the right of the list
until the two selected properties are at the
bottom of the list.
■
Click OK.
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10. In the Defined Reports list, note that Pump List
is in the list.

11. In the Project Setup dialog box, click OK.
12. To view the report in the Data Manager:
■
Open the Data Manager.
■
Select Project Reports.
■
Click Pump List.

Set Up Import and Export Settings
In this section of the exercise, you set up import
and export settings to create a report for all the
equipment in the project.
1.
2.

Access the Project Setup dialog box.
In the Properties list, expand both P&ID DWG
Settings and Plant 3D DWG Settings. Note
that both headings contain Export and Import
Settings. The processes are the same for both
classes.

3.

To begin to create new settings, under P&ID
DWG Settings:
■
Click Export and Import Settings.
■
Click New.

13. Close the Data Manager.
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4.

To define the settings:
■
For Name, enter Master Project List.
■
For Description, enter Shows all
components.

5.

To add specific data from a class:
■
Under P&ID classes, click Engineering
Items.
■
Under External Data Mapping, Properties
list, make the following selections as
shown.

6.

To add specific information:
■
Expand the Equipment list.
■
Click Heat Exchangers, Pumps, and Tanks.

7.

Under External Data Mapping, clear check
marks for Manufacturer, Comment, Area,
Insulation Type, and Insulation Thickness.
8. In the New Export and Import Settings dialog
box, click OK.
9. In the Project Setup dialog box, click OK.
10. Start the Data Manager.
11. Select P&ID Project Data from the list.
12. To access the report:
■
On the Data Manager toolbar, click Export.
■
In the Export Data dialog box, for Select
Export Settings, select Master Project List.
■
Click OK.
Note the export location.
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13. Open the exported spreadsheet. Review the
document. Note the different tabs created.

14. Close all files. Do not save.
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Review
What is the difference between a Data Manager view and report?
Reports can only be shown over the entire project, Data Manager views can be shown over a
drawing or over the project.
Reports show only one specific class, while the Data Manager view can show multiple classes.
All of the above.
Is it possible to add drawing and project information to your reports?
Yes, but you have to enter the values manually.
No, only class information can be shown.
Yes. All information, drawing, project and class can be part of a report.
Can you set up an export in such a way that multiple classes are exported in one go?
You can do this using the import and export setup option in your project configuration.
No, this can't be done.
This can only be done if you use Microsoft SQLserver.
If you create an import and export scheme, can you also change the UID (unique identifier) of each
component?
No, the UID is always the same.
Yes. The import and export settings are the only way you can change the UID when importing or
exporting data.
Is it possible to export data, rename the type, and then import the data again?
No, the type of the class/symbol needs to stay the same and it is part of the settings that define
which symbol should be used.
Yes, this can be done without any problem.
With some work, you can change and import the type. You only have to check that the correct
symbols are used when importing the data again.
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Lesson: Creating and Editing Drawing
Lesson: Templates and Data Attributes
In this lesson, you create a template that uses AutoCAD Plant 3D and P&ID layers and properties to
drive information in a title block.

Objectives
After completing this lesson, you will be able to:
■
■
■
■

Describe how property fields are used in title blocks.
Explain how to create custom properties.
State the process to change a template from standard AutoCAD to Plant 3D and PID.
Create a new template for AutoCAD Plant 3D and PID.

About Property Fields
About Property Fields
Projects and drawings have several properties that can be used to drive text in a title block. This is
very similar to using block attributes in standard AutoCAD, except in this case, the fields are dynamic
in nature, and their values update when the properties of the project or drawing change. In the
following example, the project description field is used to drive the text in the title block. Any changes
made to the value for the project description in the project properties are reflected in the title block
of the drawings.
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Project Properties and Drawing Properties
When a project property is used in a field, every drawing in the project that uses that field is populated
with the same text. This is a common scenario, as most of the time the same template and the
same title block values are used within a project. Because of this, you can dynamically update all the
drawings in a project by changing only the property definition value in the project properties.
Drawing properties are specific to each drawing. When you enter drawing properties that are mapped
to fields in that drawing, other drawings in the project are not affected. A title block can contain fields
that are driven by both project and drawing properties. This enables a rich and sophisticated system of
annotation that dynamically drives the information in the drawings.
There are two different ways of having project or drawing properties display in a drawing. You can
insert a standard field that uses the property or you can configure a block attribute to use a field. The
main difference between the two is if you want to override the property value. By creating a block
attribute with a default field value from a project or drawing property, you can have the value in the
block display the project or drawing property or you can override the value in the block. When you
override the attribute value, that block attribute no longer uses a field.
When configuring a block attribute to use a field, you specify it as part of its default value. You specify
the property for the field similar to when you directly insert a field.

Custom Properties
Custom Properties
By default, there are several properties, such as project and drawing descriptions, that you can use in
both the project and the drawings within the project. You can also create custom property categories
and fields within those categories for both the project and the drawings. In this way, any information
that you want to drive in the titles of the drawings can be created and mapped into fields in the
templates. In the following example, a custom category called Additional Project Information has been
added to the project. The values in the two rows can be used to drive text in the project drawings.
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Custom Drawing Properties Behavior
When you create custom project properties, you enter the values once, or make changes to the
values as needed. These values are used as the single source of values to populate the fields for all
the drawings in the project. On the other hand, when you create custom drawing properties, you
essentially create fields in the Drawing Properties dialog box that you then populate individually for
each drawing. In the following example, the Drawing Information is a custom category, and Sheet and
Total Sheets are rows within that category.
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Process of Moving AutoCAD Templates to Plant 3D Templates
Process of Moving AutoCAD Templates to Plant 3D Templates
In many cases, you might have company templates that have been in use for some time and are
well designed specifically to your purpose. In these cases, the process to change these over is fairly
straightforward.
1.

Use Design Center to add
Plant 3D-specific layers.

2.

Create any custom fields
for the project and/or the
drawings to match the
information you have used in
the past.

3.

In your existing template,
delete the existing block
attribute tags.

4.

Replace the tags with fields
from the project.
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Exercise:Create a Template for AutoCAD Plant 3D
In this exercise, you start with a typical template and
make changes to convert the template for Plant 3D.
You:
■
Add Layers.
■
Create custom properties.
■
Edit the existing attributes.
■
Add fields.

5.
6.
7.

To import additional layers, click Insert tab >
Content panel > Design Center.
In the Design Center Folders tab, navigate to
..Plant Design Create and Set Up a Border with
Title Block.
Expand the projSymbolStyle.dwg drawing.
Select Layers.

The completed exercise

Open an Existing Template and Add Layers
In this section of the exercise, you open a drawing
that might be a typical template used in a company
for standard AutoCAD drawings. You examine the
title block content, and add new layers specific to
AutoCAD P & ID and Plant 3D.
1.
2.

3.

4.

Start AutoCAD Plant 3D.
To open a project:
■
In the Project Manager, Current Project list,
click Open.
■
In the Open dialog box, navigate to the
folder ..Plant Design Create and Set Up a
Border with Title BlockProject.xml.
Open A1 Layout (template source).dwg. To do
this, do the following:
■
On the Quick Access toolbar, click Open.
■
Navigate to the folder ..Plant Design Create
and Set Up a Border with Title Block Past
Company Templates.
Examine the contents of the title block and
existing layers in the drawing.

8.

In the layer list, select all the layers and drag
them into the drawing screen.

9. Close Design Center.
10. Open the Layer Manager and examine the new
layers in the drawing.
At this point, you could set the bylayer
properties such as color and so on.
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11. Save the drawing as a template in the default
templates folder. Do the following:
■
On the Application menu, click Save As.
■
In the Save Drawing As dialog box, Files of
Type list, select AutoCAD Drawing Template
(*.dwt).
■
For File Name, enter P3D A1.
■
Click Save.
■
In the Template Description dialog, click OK.
12. Leave the template open for the next section of
the exercise.

4.

Under Custom Properties, click Add.

5.

In the Add Category dialog box:
■
Enter Additional Project Information.
■
Click OK.

6.

With Additional Project Information selected
under Custom categories, click Add Row.

7.

In the Add Row dialog box:
■
For Name, enter Project Manager.
■
For Value, enter Plant 3D Instructor.
■
Click OK.

Project Settings for Template Fields
In this section of the exercise, you examine existing
fields and add custom fields that can be used in the
title block.
1. In the Project Manager, right-click Training
Project. Click Properties.

2.

3.

In the Project Setup dialog box, under General
Settings, click Project Details.

For Project Description, enter Plant 3D Training.
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8.

Add a second row with the following values:
■
Name: Project Engineer
■
Value: Plant 3D Student
■
Click OK.

9.

Under General Settings, click Drawing
Properties.

13. Add a second row with these values:
■
Name: Total Sheets
■
Description: Enter the total number of
sheets
■
Click OK.

14. Expand P&ID DWG Settings. Click Paths.

15. To set the template and path as defaults, for
the drawing template file, select the P3D A1
template that you saved in the last section of
the exercise.
10. On the Drawing Properties page, click Add.
11. In the Add Category dialog box, enter Drawing
Information. Click OK.

16. In the Project Setup dialog box, click Apply.
Click OK.

Insert Fields in the Title Block
In this section of the exercise, you replace existing
attributes with fields from the project and drawing
properties.
12. Add a row to the Drawing Information category
with the following values:
■
Name: Sheet
■
Description: Enter the sheet number
■
Click OK.
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1.

To fully purge the old attributes, you explode
the existing block. To explode the existing
block:
■
At the command line enter EXPLODE.
■
At the select objects prompt select the title
block.
■
Press ENTER.
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2.

3.

4.

In the Block Editor, delete all of the existing
attribute tags:
■
PROJDESCR
■
DRAWING_TITLE
■
PROJENG
■
PROJMAN
■
DRAWING_NUMBER
■
SHEETS
■
TOTALSHEETS

6.

Add a field for the field name CurrentDwgTitle
as shown. Do the following:
■
Click Insert tab > Data panel > Field.
■
For Field Names, select CurrentDwgTitle.
■
Click OK.
■
Place the field in the title block as shown.

7.

Follow the previous process to add a field for
the field name CurrentDwgNumber as shown.

8.

To begin to add a field for the custom project
properties, on the Data panel, click Field.
In the Field dialog box:
■
For Field Names, select
CurrentProjectCustom.
■
For Custom Property Category, select
Additional Project Information.
■
For Custom Property Name, select Project
Manager.
■
Click OK.

To begin adding fields to the new block, click
Insert tab > Data panel > Field.

In the Field dialog box:
■
For Field Category, select Project.
■
For Field Names, select
CurrentProjectDescription.
■
Click OK.

9.

10. Place the field in the title block as shown.
5.

Place the field in the title block as shown.
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11. Follow the previous process to add a field for
the Project Engineer custom project property
as shown.
■
Field Names: CurrentProjectCustom.
■
Custom Property Category: Additional
Project Information.
■
Custom Property Name: Project Engineer.

12. To begin to add an attribute with a field to a
custom drawing property, click Insert tab >
Attributes panel > Define Attributes.
13. In the Attribute Definition dialog box:
■
Tag field, enter SheetNo.
■
Prompt field, enter Sheet number:

14. To the right of the Default field, click Insert
Field.
15. In the Field dialog box:
■
For Field Names, click CurrentDwgCustom.
■
In the Custom Property Category list, select
Drawing Information.
■
In the Custom Property Name list, select
Sheet.
■
Click OK.

16. In the Attribute Definition dialog box:
■
In the Text Settings area, Justification list,
select Right.
■
Click OK.
■
Place the attribute in the title block as
shown.

17. Begin to add an attribute for the total number
of sheets, on the Attributes panel, click Define
Attributes.
18. In the Attribute Definition dialog box:
■
Tag field, enter TotalSheets.
■
Prompt field, enter Total sheet count:.
■
Default field, select Insert Field.
❏
Field Names:
CurrentDwgCustom.
❏
Custom Property Category:
Drawing Information
❏
Custom Property Name: Total
Sheets.
❏
Click OK.

19. Click OK. Position the attribute in the title block
as shown.

20. Review the fields and attributes added to the
title block. It now displays as shown.

21. To begin to recreate the block of the border
and title block, on the command line, enter
BLOCK.
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22. In the Block Definition dialog:
■
For Name, select Tblock-A1.
■
Under Objects, click Select Objects.
■
At the Select Objects prompt, enter All.
■
Press ENTER after all the objects are
selected.
■
Click OK.

23. In the Blocks - Redefine Block dialog box, click
Redefine.
24. In the Edit Attributes dialog box, click OK.
25. Save and close the template.

Start a Drawing with the New Template
In this section of the exercise, you start a new
drawing using the template that you created in this
exercise and make changes to some of the properties.
1. In the Project Manager:
■
Right-click P&ID Drawings.
■
Click New Drawing.

4.

In the Drawing Properties dialog box:
■
Scroll down to the Drawing Information
area.
■
For Sheet, enter 1.
■
For Total Sheets, enter 5.
■
Click OK.

5.

In the drawing, verify that all fields are now
populated with the new values.

6.

To change the value of a field for a custom
drawing property:
■
In the Project Manager, right-click the 0001
drawing.
■
Click Properties.
In the Drawing Properties dialog box:
■
For DWG Title, enter Section View of the
Heat Exchangers.
■
Click OK.
Verify that the drawing title in the title block
was updated to reflect the new value.

7.

8.

9.

2.

3.

: You might need to change to paper space.
In the New Drawing dialog box:
■
For File Name, enter 0001.
■
Verify that the new P3D A1 template is set
as the default.
■
Click OK.
NoteNote
In the Project Manager:
■
Right-click the 0001 drawing.
■
Click Properties.

To override the total sheet attribute that is
currently driven by the field value:
■
In the drawing, double-click a line for the
title block.
■
In the Enhanced Attribute Editor dialog box,
with the attribute TOTALSHEET selected, in
the Value field, enter 3.
■
Click OK. The title block values now display
as shown.
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10. To begin to change the title block text for a field
that displays custom project information, in the
Project Manager, right-click Training Project.
Click Properties.
11. In the Project Setup dialog box:
■
Under General Settings, select Project
Details.
■
In the Custom Properties area, Custom
Categories, select Additional Project
Information.
■
In the Project Manager field, enter
Autodesk Instructor.
■
Click OK.

12. Review the values in the title block. The project
manager name has updated as shown.

13. Close all files. Do not save.
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Review
Can you make a combination of attributes with fields?
Yes, you can set the default value of an attribute to use field information.
No, fields and attributes are totally different functionalities.
Yes, but the field needs to be part of the same block as the attribute.
What is a benefit of combining attributes with fields?
There is no benefit, attributes and fields are completely different ways of adding information to
your drawing.
When combining attributes with fields, you get the maximum flexibility of both options. You can
pick up any information from the project and drawing properties, but you can overwrite this data
when necessary.
When you use fields in combination with attributes, where can you find the default project and
drawing properties?
You cannot, they are not available in fields.
When you switch the Field dialog box to Project, you see all P&ID and Plant 3D properties.
They can only be seen if you use fields only, not in combination with attributes.
If you use project and drawing properties, what is the big difference between the two?
These property types are the same, but have different names.
Project properties can appear on each drawing, using the same value over and over, while
drawing properties can differ from drawing to drawing.
Project properties and drawing properties cannot be used at the same time.
Custom project properties are populated once and are the same for all the drawings in the project
while custom drawing properties are populated individually for each drawing.
True
False
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Lesson: Specs and Catalogs
This lesson describes the basic concept of the spec and catalog editor. You learn the techniques
required to edit and create your own specs and to create and duplicate components to build your own
components. You also learn how to change a spec configuration in an existing project and update that
project's 3D models. Finally, you learn how to convert a spec from AutoPlant and about the issues you
may encounter when doing so.

Objectives
After completing this lesson, you will be able to:
■
■
■

Describe the uses of the spec and branch table editors.
Explain the process for editing parts.
Describe catalogs and how to use the catalog editor to customize them.

Spec Editor
You use the spec editor to view and edit spec sheets and catalogs. You can also convert AutoPlant or
CADworx specs to Plant3D specs.
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Spec Sheets
When you open a spec sheet, you see a list of components that you can use while routing. The
components are listed in groups. When more than one of the same size component is listed, you can
specify which one has the highest priority; that is, which one is used most often in Plant 3D. The green
dot next to the part indicates that the part has a priority assigned.

Spec Sheet Naming
When you create a new project using AutoCAD Plant 3D, several spec sheets are created by default.
They are named with specific codes that indicate what components are contained within the spec
sheet.
The US Standard spec sheets are named with codes as follows: CS150, SS300
■
CS - Carbon Steel
■
SS - Stainless Steel
■
150, 300 - Pressure Class, measured in pounds. The higher number can handle higher pressure and
temperatures.
The European Standard spec sheets are named with codes as follows: 2HC01, 16HS01
■
HC - High Carbon
■
HS - High Stainless Steel
■
2, 16, etc. - Pressure Class
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Branch Table Editor
A green check mark next to the part in the Spec Editor indicates that the part is also listed in the
branch table. You use the branch table to determine which branch fittings will be used when
connecting a branch in AutoCAD Plant 3D.
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You edit the legend using the settings in the Branch Table Setup dialog box. You access the dialog box
using the Edit Legend button below the legend in the Branch Table Editor.

If you try to assign connections to branches that are not possible, you will receive a warning message
with the option of selecting the valid branch fitting(s) for the sizes.
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Process: Editing Parts
When you double-click a part listed in the Spec Editor, the Edit Parts dialog box is displayed and
all the sizes available for the selected part are listed. In the Edit Parts dialog box, you change any
necessary properties values such as material code. Additionally, you limit the user to only use certain
sizes by selecting the Remove From Spec option. You view all hidden part sizes by clearing the Hide
Parts Marked "Remove From Spec" option. When you edit a part, properties such as description and
material are reset to the default values.
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Catalogs
The entire library of components is loaded in catalogs. Within a catalog, each component has a name,
end type, facing, and other properties. The end type, such as FL, defines how parts will be connected
to each other. The facing defines how the gasket will be clamped together. Facing values of THDM and
THDF indicate threaded male and threaded female, respectively.

You use filters to list only the parts that fit a particular criterion.

Catalog Editor
The Catalog Editor shows us everything that is listed in a specific catalog. You can use the Catalog
Editor to create, edit, or duplicate components.
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Exercise: Configure Specs and Catalogs
In this exercise, you create a new spec sheet. You add
and edit the components in a spec sheet using the
Spec Editor and Branch Table Editor. You also use the
Catalog Editor to duplicate a component in a catalog
and add it to the spec sheet.

Create a New Spec
In this section of the exercise, you create a new spec.
1.
2.
3.
4.

5.

Start AutoCAD Plant 3D Spec Editor.
Click File menu > New > Create Spec.
In the Create Spec dialog box, for New Spec
Name, click Browse.
In the Save As dialog box:
■
Navigate to the project folder
..ConfigureSpecs\Spec Sheets.
■
For File Name, enter A21-CS150.
■
Click Save.
In the Create Spec dialog box:
■
For Description, enter Specification for
training - A21 Carbon Steel 150#.
■
From the Load Catalog list, select ASME
Pipes and Fittings Catalog.
■
Click Create.

The completed exercise

Create a New Project
In this section of the exercise, you create a new
project using Plant 3D.
1.
2.

Launch AutoCAD Plant 3D.
Create a new project named ConfigureSpecs
with the following settings:
■
Use Metric units that will report Imperial
content in Inches.

Select PIP for the P&ID tool palette content.
Use the default paths.
Exit AutoCAD Plant 3D.
■
■

3.
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Add Components to a Spec Sheet
In this section of the exercise, you add components
from a catalog to a spec sheet.
1. In the bottom pane of the Spec Editor, under
Common Filters, from the Part Category list,
select Pipe.

5.
6.
7.
8.

2.

In the bottom pane of the Spec Editor, under
Common Filters, from the Part Category list,
select Fittings.
In the Filter row, from the Short Description
list, select ELL 90 SR. One elbow component is
listed. Add the elbow to the spec.
In the Filter row, from the Short Description
list, select ELL 90 LR. One elbow component is
listed. Add the elbow to the spec.
In the Filter row, from the Short Description
list, select ELL 45 LR. One elbow component is
listed. Add the elbow to the spec.
Notice the warning symbols that appear in the
Part Use Priority column next to each elbow.

To filter the information based on size
parameters:
■
Under Size Range, from the From list, select
0.25.
■
Under Size Range, from the To list, select
12.

Edit the Component Sizes Available in the
Spec Sheet
3.

4.

To add a Spec:
■
In the Catalog, under Long Description
(Family), select PIPE, SEAMLESS, PE, ASME
B36.10 from the Part list.
■
Click Add to Spec.

In this section of the exercise, you edit the
component sizes that are available in a spec sheet.
1.

In the top pane, double-click PIPE, SEAMLESS,
PE, ASME B36.10.

The B36.10 pipe is added to the spec sheet in
the top pane.
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2.

3.
4.
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To take away sizes that are not used frequently,
in the Edit Parts dialog box:
■
Select the check boxes in the Remove From
Spec column for the following sizes: 1/4",
3/8", 1 1/4", 2 1/2", 3 1/2".
■
Verify that the option Hide Parts Marked
"Remove From Spec" is selected.
■
Click Apply.
The selected part sizes are removed from the
list.

In the Material column, for the 1/2" pipe, enter
CS.
Select the value that you just entered. Press
CTRL+C to copy the value.

■

5.

To copy the value to all the remaining fields:
■
Select the Material value field for the 3/4"
pipe.
■
Hold SHIFT and click the value field for the
12" pipe to select all of the fields between
the two sizes of pipes.
■
Press CTRL+V to paste the value.

6.

Click OK to exit the Edit Parts dialog box.
Notice the Min and Max sizes listed in the spec
sheet for the pipe.

7.

Repeat the steps to remove 1 1/4", 2 1/2",
and 3 1/2" from inclusion for each of the three
elbows listed in the spec sheet. For the Material
of each size, enter CS.
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4.

Edit the Part Use Priority of Components
In this section of the exercise, you edit the part use
priority for each size of a component.
1.
2.

In the top pane, in the Part Use Priority column,
next to ELL 45 LR, click the warning symbol.
In the Part Use Priority dialog box, under Assign
Part Use Priority:
■
Under Size Conflicts, select 1/2".
■
Under Spec Part Use Priority, verify that ELL
90 LR is listed for number 1. If it is not listed
for number 1, click the Up Priority button to
move it to the number 1 position.
■
Select Mark as Resolved.

■

5.

3.

Under Assign Part Use Priority, do the following:
■
Under Size Conflicts, select 1".
■
Under Spec Part Use Priority, verify that the
elbows are listed in the following order:
■
ELL 90 SR.
■
ELL 90 LR.
■
ELL 45 LR.
Note: If they are not listed in this order, under
Priority, use the Up or Down arrows to position
them accordingly.
Select Mark as Resolved.

Repeat the steps for each of the remaining
sizes. Mark each as resolved.

Under Assign Part Use Priority, do the following:
■
Under Size Conflicts, select 3/4".
■
Under Spec Part Use Priority, verify that ELL
90 LR is listed for number 1. If it is not listed
for number 1, click the Up Priority button to
move it to the number 1 position.
■
Select Mark as Resolved.
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6.

Click OK to exit the dialog box.
In the Spec Sheet Parts list, notice that the
warning symbols under Part Use Priority for
each elbow are replaced with green dots to
indicate that the priorities are resolved.

5.

7.

Click File menu > Save.

6.
7.

Apply Property Overrides
In this section of the exercise, you apply property
override values to components as they are added
from a catalog to the spec sheet.
1.
2.
3.

4.

In the bottom pane of the Spec Editor, under
Common Filters, verify that Fittings is selected
from the Part Category list.
In the Filter row, from the Short Description list,
select TEE. Several tees are listed.
In the bottom pane, under Common Filters >
Size Range:
■
From the From list, select 0.50.
■
From the To list, select 12.
The number of parts for each component listed
is reduced.
Under Property Overrides:
■
Select Apply Property Overrides to Parts
Added to Spec.
■
For Material, enter CS.
■
For Material Code, enter ASTM B36.10.

Select TEE, BW, ASME B16.9 from the
component list. Add it to the spec.

In the top pane, double-click the Tee to edit it.
In the Edit Parts dialog box:
■
Verify that the Material and Material Codes
are added to each part size listed.
■
Remove the following sizes from being
included in the spec: 1 1/4", 2 1/2", 3 1/2".
■
Close the dialog box.
8. In the bottom pane, in the Filter row, from the
Short Description list, select TEE (RED).
9. Select TEE (RED), BW, ASME B16.9 from the
component list. Add it to the spec.
10. Repeat the steps to remove all sizes that
reference 1/4", 3/8", 1 1/4", 2 1/2", and 3 1/2".

11. In the top pane, in the Part Use Priority column
next to TEE (RED), BW, ASME B16.9, click the
warning symbol.
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12. For each size:
■
Set TEE, BW as priority 1 and TEE (RED) as
priority 2.
■
Mark as resolved.

5.
6.

7.
8.
13. Close the dialog box. The tees are marked as
resolved.

In the Filter row, from the Short Description
list, select SOCKOLET. Several components are
listed.
Select SOCKOLET, 3000 LB, BWXSW, 3/8" LG,
ASME B16.11 from the component list. Add it to
the spec.

Under Common Filters, from the Part Category
list, select Fasteners.
In the Filter row:
■
From the Short Description list, select BOLT
SET.
■
From the Facing list, select RF.
■
From the Pressure Class list, select 150.
Add all four bolt sets that are listed to the spec.

Add Additional Components
In this section of the exercise, you add additional
components to the spec sheet.
1.

2.
3.

4.

In the bottom pane of the Spec Editor, in the
Filter row, from the Short Description list, select
REDUCER (CONC). Add REDUCER (CONC), BS,
ASME B16.9 to the spec.
Under Common Filters, from the Part Category
list, select Flanges.
In the Filter row:
■
From the Short Description list, select
FLANGE WN.
■
From the End Type list, select FL.
■
From the Facing list, select RF.
■
From the Pressure Class list, select 150.
■
One reducer is listed. Add the remaining
reducer listed to the spec.
Under Common Filters, from the Part Category
list, select Olet.

Note: You can select multiple components at
one time by holding the CTRL key down while
selecting them.
9. In the Filter row, from the Short Description list,
select GASKET, FLAT. Add the 1/16" THK and
1/32" THK components to the spec.
10. In the Filter row, from the Short Description list,
select GASKET, SWG. Add the 1/8" THK and 1/4"
THK components to the spec.

11. Click File menu > Save.
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Assign Connections in a Branch Table
In this section of the exercise, you use the branch
table editor to create a legend and assign connections
in a branch table.
1. In the top-right corner, click the Branch Table
Editor tab.

2.

In the bottom-right corner, click Edit Legend.

3.

In the Branch Table Setup dialog box, click Add
Branch.
Under Branch Connection Part Setup, for the
branch you just added:
■
From the Part Type list, select Pipe.
■
From the Spec Part list, select 1/2" to 12"
PIPE.
■
For the Legend Symbol, enter S001.
■
For the Legend Name, enter Stub-in, Pipe.

4.

5.
6.

7.
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8.

Click OK to exit the dialog box. The legend is
displayed in the right pane.

9.

In the right pane, hold CTRL and select the top
branches of each row as shown.

Click Add Branch.
Under Branch Connection Part Setup, for the
branch you just added:
■
From the Part Type list, select Olet.
■
From the Spec Part list, select 1 1/2" to 12"
SOCKOLET.
■
For the Legend Symbol, enter O001.
■
For the Legend Name, enter Sockolet.
Add the remaining branches with the following
settings.
Note: The reducer is automatically added when
the box is checked in the Add Reducer Column.

■
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10. Right-click on one of the selected branches.
Click Multiple Branch Selection.

12. Click OK to exit the dialog box. The branch table
symbols are listed in each of the branches.

11. In the Select Branch List dialog box:
■
Under Use Branch, select S001 and T001.
■
Select the T001 row.
■
Under Priority, click Up until T001 is listed
first.

Assign Unavailable Branch Sizes
In this section of the exercise, you assign branch
sizes that are unavailable to specific branches. After
receiving a warning, you select a valid branch fitting
for the sizes.
1. Select the branch as shown. Right-click. Click
Multi Branch Selection.

2.
3.
4.

In the Select Branch List dialog box, under Use
Branch, select S001, T002, T003. Click OK.
In the Branch Size Unavailable message box,
click Select a Valid Branch Fitting For These
Sizes.
In the Select Branch Connection dialog box,
select O001. Click OK.
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5.
6.
7.

Select the same branch. Right-click. Click Multi
Branch Selection.
In the Select Branch List dialog box, under Use
Branch, select O001 and S001. Click OK.
Use SHIFT to select and right-click all remaining
unassigned branches along the 1/2" row. Click
Multi Branch Selection.

In the Select Branch List dialog box:
■
Under Use Branch, select S001, T002, T003.
■
Move T003 up so that it has a Priority of 1.
■
Move T002 up so that it has a Priority of 2.
■
Click OK.
9. In the Branch Size Unavailable message box,
click Do Not Change Branch Fitting. The
Branches from 10" to 2" are highlighted in red,
indicating that the assigned fittings are not
available for these sizes.
10. Select the 1/2" x 2" branch as shown. Rightclick. Click Multi Branch Selection.

15. In the Select Branch List dialog box:
■
Under Use Branch, select S001, O001, and
T003.
■
Clear all others.
■
Move T003 up so that it is Priority 1.
■
Move S001 up so that it is Priority 2.
■
Click OK.
16. Click another branch to see that the 1/2" x 2"
branch is no longer red.

8.

17. Use SHIFT to select and right-click the red
branches. Click Multi Branch Selection.
18. In the Select Branch List dialog box, click OK.
19. In the Branch Size Unavailable dialog box, click
Select a Valid Branch Fitting for These Sizes.
20. In the Select Branch Connection dialog box,
note that the valid branches are S001 and
O001. Click Cancel.
21. Select the same branches again. Right-click.
Click Multi Branch Selection.
22. In the Select Branch List dialog box, under Use
Branch, select S001 and O001. Clear all others.
Click OK.
23. Select the branches as shown.

11. In the Select Branch List dialog box, click OK.
12. In the Branch Size Unavailable message box,
click Select a Valid Branch Fitting For These
Sizes.
13. In the Select Branch Connection dialog box,
note that the valid branches are S001, O001,
and T003. Click Cancel.
14. Select the 1/2" x 2" branch again. Right-click.
Click Multi Branch Selection.
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24. Assign the branch symbols with the priority as
shown.

Use the Parts from a Spec Sheet
In this section of the exercise, you use the parts from
a spec sheet to build a model in AutoCAD Plant 3D.
1.
2.
3.
4.

25. In the Branch Size Unavailable message box,
click Do Not Change Branch Fitting.
26. Repeat the steps to assign the correct
connection fittings to the red branches from
the previous selection set. Use T003, O001,
S001 priority.
27. Assign S001 and O001 to the remaining
branches.
28. In the Branch Size Unavailable message box,
click Do Not Change Branch Fitting.
29. Repeat the steps to assign the correct
connection fittings to the red branch (T003,
T002, S001).

5.

Launch AutoCAD Plant 3D.
Open the ConfigureSpecs project.
Under Plant 3D Drawings, create a new project
drawing called 0001.dwg.
On the Home tab > Part Insertion panel, click
Spec Viewer. In the Pipe Spec Viewer, from the
Spec Sheet list, select A21-CS150.

From the Pipe Size list, notice that you can
choose from the sizes specified in the spec
sheet. Select 4".

30. Click File menu > Save.
31. Exit AutoCAD Plant 3D Spec Editor.
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6.

Use the Route Pipe tool to create a pipe run
similar to the one shown.

9.

7.

Select one of the elbows. Click the Substitute
Part grip. Click 4" ELL90 LR.

10. Click the Substitute part grip. Notice the
options you have for substituting the gasket.

8.

Press CTRL and select the gasket symbol as
shown.

Notice the short radius elbow is now a long
radius elbow.
Use the Flange tool to place a flange at the end
of the open pipe.
11. Press ESC to clear the selection.
12. Use the Sockolet tool to place a sockolet in the
top of the pipe shown.
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13. Use the Substitute Part grip to change the
Sockolet to 4" x 1 1/2".

15. Use the Continue Pipe grip to add a horizontal
pipe as shown.

14. Use the Continue Pipe grip to add a vertical
pipe as shown.

16. Use the Properties palette to change the size
of the horizontal pipe to a 3" pipe. A reducer is
used.
17. Select the tee and use the Substitute grip to
change to a 4" x 3" reducing tee.

Lesson: Specs and Catalogs

■

5-129

18. Use the Route Pipe tool on the Home tab > Part
Insertion panel to place a 2" pipe as shown.
Notice the tee used.

22. Select a rotation to the side. Notice the stub-in
created.

23. Save the drawing. Exit AutoCAD Plant 3D.
19. With a 2" pipe selected on the Part Insertion
panel, click Route Pipe.
20. Right-click in the drawing area. Click Stub-in.
Add Values to the Spec Sheet
21. To specify a start point, select a point as shown.
In this section of the exercise, you add values to the
spec sheet.
1.
2.

3.

4.
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Launch AutoCAD Plant 3D Spec Editor.
On the Welcome screen, under Recent Spec
Files, click A21-CS150.
Note: If the spec file is not listed here, click
Open and navigate to the project folder
...ConfigureSpecsSpec Sheets to open the file.
In the bottom pane, upper-right corner, from
the Catalog list, select Open Catalog.

In the Open dialog box:
■
Navigate to the folder...Cpak ASME.
■
Select the file ASME Valves Catalog.pcat.
■
Click Open.
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5.

6.
7.

In the bottom pane, in the Filters row:
■
From the Short Description list, select
GLOBE VALVE.
■
From the End Type list, select FL.
■
From the Facing list, select RF.
■
From the Pressure Class list, select 150.
One Globe Value is listed. Add it to the Spec.
From the Short Description list, select
BUTTERFLY VALVE. Two valves are listed. Add
both to the spec.
From the Short Description list, select BALL
VALVE. Four valves are listed. Add the Series B
and Short Pattern ball valves to the spec.

4.

Select the Hide Parts Marked "Remove From
Spec" option.
Notice that the Material values for the parts
just included are blank.

5.

For the Material of the 1/4" pipe, enter Carbon
Steel.
Select and copy the text value that you just
entered.
Use SHIFT to select the Material field for all of
the remaining sizes.

Edit Pipe Sizes
In this section of the exercise, you edit the pipe sizes
available in the spec sheet.
1.
2.
3.

In the top pane, listed under Pipe, double-click
PIPE, SEAMLESS, PE, ASME B36.10.
In the Edit Parts dialog box, clear the Hide Parts
Marked "Remove From Spec" check box.
Scroll down the list and clear the Remove From
Spec option for the 1/4", 2 1/2", and 3 1/2"
sizes. Click Apply.

6.
7.

8.
9.

Repeat the steps to enter DIN1.4407 for the
Material Code of each size.
Click OK to exit the dialog box.
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Duplicate a Component Using the Catalog
Editor

7.

In the top-right corner, click the Sizes tab.

8.
9.

Here, you can edit the values for each size of
the component individually.
Click Show Advanced Editing Table.
In the Long Description (Size) column, for the
3" part, change NARROW to LONG SHAPE
BODY.

In this section of the exercise, you use the Catalog
Editor to create a custom component. You duplicate
an existing valve and change the values of the new
one. Then you add it to the spec sheet.
1. In the top-right corner, click the Catalog Editor.

2.

3.

4.

In the bottom pane, in the Filters row:
■
From the Short Description list, select
BUTTERFLY VALVE.
■
From the End Type list, select FL.
Two Butterfly Values are listed: Narrow and
Wide.
Select the Narrow valve. Click Duplicate
Component.

10. Repeat this for each size in the table.

In the Duplicate Part Family dialog box, for New
Part Family Name, enter Butterfly Valve, Long
Shape Type - CS150 FL RF. Click Create.
The new component is added to the list.
Notice that since it is a duplicate of the other
component, the Design Std is Narrow.
11. Click Save to Catalog.
12. Click Hide Advanced Editing Table.
13. Under Size, verify that 3" is selected.

5.
6.
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In the bottom panel, select the new butterfly
valve.
In the top panel, under Piping Component
Properties, for Design Std, enter Long Shape
Type. Click Save to Catalog. Notice that the
value changes for the valve in the bottom pane
as well.

■
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14. Under Size Parameters, for L, enter 6.

5.

On the status bar, click Spec Update Check.

6.

15. Select each size and add 1" to the length value
(L) for each.
16. Save to Catalog.
17. Click the Spec Editor tab.
18. In the bottom pane, in the Filters row, from the
Short Description list, select BUTTERFLY VALVE.
19. Add the Long Shape Type Butterfly Valve to the
spec sheet.
20. Save the spec sheet. Exit AutoCAD Plant 3D
Spec Editor.

In the Spec Update Check dialog box, click
Check Now.
7. In the Spec Update Available message box, click
Apply Spec Updates to the Parts in the Model.
8. Click Home tab > Project panel > Data Manager.
9. In the Data Manager, left pane, select Pipe Run
Component.
10. Verify that the Material and Material Code for
the pipe has been updated from the changes
made to the spec sheet.
11. Close the drawing. Do not save changes.

Update a Drawing
In this section of the exercise, you update a drawing
with the changes you made to the spec sheet.
1.
2.
3.
4.

Launch AutoCAD Plant 3D.
Open the ConfigureSpecs project.
Open 0001.dwg.
At the bottom of the Dynamic Pipe Spec tab,
notice that the valve tools are included.
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Review
Before you create a new spec, what information is essential to obtain before you start?
Pressure class, Material, Size range.
The name of the spec.
The location of the spec.
Is it possible to combine multiple catalogs in one spec?
No, each spec can use one catalog.
Yes, it's no problem to have multiple catalogs defining your spec.
In the spec you can have similar components. How do you know which one will be used by default?
It is not possible to know, you must select the component while routing pipe.
Each class in the spec has a priority setting. This way you can set which component should be
used while routing pipe.
You cannot have multiple similar components in one spec.
Is it possible to add equipment to your spec?
No, equipment is not part of the spec.
Yes, you can add all types of components to the spec.
Yes, but only if you also add nozzles to the spec.
When you convert a spec from AutoPlant or CADWorx, what is essential in the conversion of these
specs?
Nothing is essential because the specs cannot be converted .
It is important that the properties, geometry, and parameters match with the AutoCAD Plant 3D
spec. If not, the spec will not be converted.
It is essential that you enter a unique name for the converted spec.
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Lesson: Isometric Setup
This lesson describes how to create a custom isometric setup and how to add additional information to
your drawing when generating the Iso.

Objectives
After completing this lesson, you will be able to:
■
■
■
■
■

Describe what Iso styles are and how they are used.
Explain the basic categories of customization that can be used in an Iso style.
Describe the components of a bill of materials.
Create and configure a new iso style for use in the active project.
Configure a custom drawing template with a custom title block for use for Iso drawings.

About Iso Styles
About Iso Styles
AutoCAD Plant 3D installs with multiple Iso styles and paper sizes by default. The following are the
default Iso styles:
■
Check
■
Stress
■
Final
■
Spool

Custom Iso Styles
You can add custom Iso styles to the project to meet the specific needs of your project. When you
create an Iso drawing, you can use the customized Iso style to control the type of data you want to
include: attributes, styles, formatting, and so on. In the following example, a new Iso style called
Training has been added to the list of available Iso styles. You can customize this without affecting the
rest of the Iso styles.
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Iso Style Customization
Iso Style Customization
You can customize an Iso style using five main settings:
■
Iso Style Setup
■
Annotations
■
Dimensions
■
Sloped and Offset Piping
■
Title Block and Display

Iso Style Setup
The Iso Style Setup controls a number of features such as style information, automatic field weld
control, field fit weld makeup, file naming, and style paths. The following illustration shows a portion
of the Iso Style Setup area of the Project Setup dialog box.
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Annotations
Annotations provide the ability to control different portions of the output text on an Iso, including
bill of material (BOM), numbering and enclosure, cut piece annotations, weld annotations, valve
annotations, and end connection annotations, among other things. The following illustration shows a
portion of the Annotations area of the Project Setup dialog box.

Dimensions
Dimensions enables you to control how not only the overall dimensions are handled, but specific case
overrides for items such as valves, olets, pipe supports, branches and reducers, and other items. The
following illustration shows a portion of the Dimensions area of the Project Setup dialog box.
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Sloped and Offset Piping
Sloped and Offset Piping provides settings that control how sloped lines are annotated in the Iso
drawing. You can control how to show falls, set 2D and 3D skews, and designate the minimum slope to
be represented in the isometric drawing. The following illustration shows a portion of the Sloped and
offset Piping area of the Project Setup dialog box.

Title Block and Display
Title Block and Display enables you to modify and set up new title blocks, as well as the symbols used
on your isometrics. Title blocks are handled as an AutoCAD drawing template, using block references
to control the Title Block and North Arrow. The following illustration shows a portion of the Title Block
& display area of the Project Setup dialog box.
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Setting Up the Bill of Materials (BOM)
When you create an isometric drawing, one of the components of that drawing is a bill of materials
(BOM). The formatting and placement of this is already set up in the Iso styles that are installed with
AutoCAD Plant 3D. If you create a custom isometric drawing, it is likely that you will need to make
adjustments to the BOM.
BOM settings are controlled through the Setup Title Block options. These are part of the Table Setup
dialog boxes. For each table, bill of materials, Cut Piece list, Weld list, and Spool list, you can control
the table layout and settings.

Creating and Configuring a New Iso Style
Creating a new Iso style is key to developing good working Isos that require minimum cleanup. To
obtain good working Isos, you need to understand the process of creating and configuring a new Iso
style in your project. Note that Iso styles are project-specific, and will need to be copied either to the
default project folder or to each project after completion.

Process: Creating and Configuring a New Iso Style
The following steps give an overview of creating and configuring a new custom Iso style:
1.
2.
3.

In the Project Setup, create a new Iso style based on an existing style.
Modify the annotation, dimension, and piping display for the new style.
Modify the title block, BOM, Cut list, Weld list, and Spool list.
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Setting up a Custom Title Block for Iso Drawings
The most important step to generating an Iso is to have a custom title block for the company or
client. To obtain the custom title block that you need, you must understand the necessary steps and
requirements for entering any title block into the system.

Setting up a Custom Title Block for Iso Drawings
Rather than simply inserting a title block, there are steps involved to ensure that you have the proper
template defined for use with your system. This includes modifying the template file with a new title
block definition and redefined coordinates to encompass the larger drawing. Proper creation of the
drawing template will enable easy customization throughout the system when adding the BOM and
other lists.

Process: Setting up a Custom Title Block for Iso Drawings
The following steps give an overview of setting up a custom title block for Iso drawings:
1.
2.
3.
4.

Make a copy of an existing Plant 3D template.
Remove the existing block definition information and purge.
Insert the new title block and rename the block definition.
Set up the Draw Area, No Draw Area, North Arrow Location, and BOM and list information.

Guidelines for Title Block Setup
Follow these guidelines when setting up a custom title block for use with Iso drawings:
■
Title Block can start with any name, but the block reference in the template must be “Title Block.”
■
North Arrow, similar to the title block, has to be defined in the template.
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Exercise: Create a Custom Isometric Drawing Set Up
In this exercise, you create a new Iso style based on
the Final_ANSI-B style. You customize this with a
custom user border, along with new dimension styles
and annotations.

5.

In the Iso Style Setup area, click Create New Iso
Style.

6.

In the Create Iso Style dialog box:
■
For Name, enter Company_D.
■
In the Base On Existing Style list, select
Final_ANSI-B.
■
Click Create.

The completed exercise

Open a Project and Create a New Iso Type
In this section of the exercise, you create a new Iso
style based on Final_ANSI-B. Then, you create an Iso
drawing and examine the results.
1.
2.

3.
4.

Launch AutoCAD Plant 3D.
To open a project:
■
In the Project Manager, Current Project list,
select Open.
■
In the Open dialog box, navigate to the
folder ..\Plant Design\ Create a Custom
Isometric Drawing Set Up \Project.xml.
In the Project Manager:
■
Right-click the Training Project.
■
Click Properties.
In the Project Setup dialog box, under Isometric
DWG Settings, select Iso Style Setup.

7.
8.

In the Project Setup dialog box, click OK.
In the Project Manager, open the Piping
drawing.
9. To run a test of the new Iso style, click Isos tab >
Iso Creation panel > Production Iso.
10. In the Create Production Iso dialog box:
■
From the Select Lines list, select 2031.
■
From the Iso Style list, select Company_D.
■
Click Create.
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11. When the creation is complete, click to view
isometric creation details.

3.

On the dimension page:
■
Ensure that the Iso Style is set to
Company_D.
■
Under Dimension Types, clear the String
Type Dimensions check box.
■
Under General dimension options, In
the Gasket Handling list, select Do Not
Dimension Gaskets.
■
Click Apply.

4.

Under Isometric DWG Settings, select
Annotations.

5.

On the Annotations page, with the Iso Style
set to Company_D, in the End Connection
Annotations area, clear the Append
Coordinates and Elevation check box.

6.

Click OK.

12. In the Isometric Details dialog box, click the file
under From 2031.pcf.

13. In the isometric drawing, examine the results.
This drawing represents the same default
settings as the Final_ANSI-B Iso style because it
was created based on that style.

Customize the Settings
In this section of the exercise, you change various
settings for the Company_D Iso style and recreate the
Iso drawing to examine the results of the changes.
1.
2.
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Open the Project Setup dialog box.
In the Project Setup dialog box, under Isometric
DWG Settings, select Dimensions.
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7.

Recreate the 2031 Iso drawing and examine
the results of the settings. Notice that only one
dimension is along the edge with the valves.
The individual gaskets were not dimensioned
because of the new settings.

3.

To purge the definition of the original title block
from the template:
■
Enter PURGE.
■
In the Purge dialog box, under Blocks, rightclick Title Block. Click Purge.
■
In the Purge – Confirm Purge dialog box,
click Purge This Item.
■
The Blocks list now displays as shown. Click
Close.
Note: Only purge the one definition. Do not
purge the North Arrow block definition. If you
do, it will not be available for placement later in
the exercise.

4.

To begin to insert a custom company D-size
border into the template drawing:
■
On the Insert tab, Block panel, click Insert.
■
In the Insert dialog box, click Browse.
■
Navigate to the folder ..\Plant Design
\Create a Custom Isometric Drawing Set Up
\Company Drawing Templates.
■
Select and open Company_Dsize.dwg.
In the Insert dialog box, with the insertion
point set to 0,0,0, the scale set to 1.00, and the
Rotation set to 0, click OK.
Note: Verify that Explode is not checked.

Note: When you recreate an Iso from the
same line, AutoCAD Plant 3D creates a new Iso
drawing name with a suffix. For example, 2031
(2).

Establish a Custom Iso Template
In this section of the exercise, you modify the Iso
drawing template for the custom style so that it uses
a custom company title block.
1.

2.

To open the iso.dwt file associated with the
Company_D Iso style:
■
On the Quick Access toolbar, click Open.
■
In the Select File dialog box, Files of Type
list, select Drawing Template (*.dwt).
■
Navigate to the folder ..\ Plant Design
\Create a Custom Isometric Drawing Set Up
\Isometric\Company_D.
■
Select and open iso.dwt.
Delete all of the geometry shown in the
graphics window.

5.
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6.

In the Edit Attributes dialog box, click Cancel.
The drawing now displays as shown.

7.

To rename the custom block definition for
the title block and border so that it will be
identified as an Iso title block:
■
Enter RENAME.
■
In the Rename dialog box, Items list, select
Company_Dsize.
■
In the Rename To field, enter Title Block.
■
Click Rename To.
■
Click OK.

8.

To set the drawing limits to match trim marks in
the border block:
■
Enter LIMITS.
■
For the lower left corner, press ENTER.
■
For the upper right corner, use the endpoint
object snap to snap to the uppermost top
right endpoint. The drawing displays as
shown.

9.

Save and close iso.dwt.

Set Up the Custom Iso Title Block
In this section of the exercise, you define the drawing
and BOM area of the custom Iso title block.
1.
2.
3.

4.
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Open the Project Setup dialog box.
Under Isometric DWG Settings, select Title
Block and Display.
In the Title Block & Display area:
■
Ensure that Iso Style is set to Company_D.
■
In the Title Block Preview area, click Setup
Title Block.
To begin to set the drawing area within the
border, on the Title Block Setup tab, Isometric
Drawing Area panel, click Draw Area.
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5.

Select two opposite points to define the area as
shown.

9.

6.

To insert the north arrow symbol in the upper
left corner of the border:
■
On the Title Block Setup tab, North Arrow
panel, click Place North Arrow.
■
Press ENTER to accept the default arrow
direction of upper left.
■
Click to position the north arrow
approximately as shown.

7.

To set the area around the North Arrow as a nodraw area:
■
On the Isometric Drawing Area panel, click
No-Draw Area.
■
Click to specify an area around the North
Arrow as shown.

8.

To begin to specify where the BOM should go,
on the Title Block Setup tab, Table Placement &
Setup panel, click Bill of Materials.

Click to specify an area in the upper right area
of the border as shown.

10. Notice that the BOM table is now at the top of
the specified area.

11. To define the area for a Cut Piece list:
■
On the Table Placement & Setup panel, click
Cut Piece.
■
In the drawing window, click to specify the
area of the table just below the BOM.
■
The completed setup now displays as
shown.

12. On the Title Block Setup tab, Close panel, click
Return to Project Setup.
13. In the Block-Changes Not Saved dialog box, click
Save the Changes to “iso.dwt.”
14. In the Project Setup dialog box, click OK.
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15. Recreate the 2031 Iso drawing and examine the
results of the settings.

16. Close all files. Do not save changes.
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Review
Where do you access the Isometric DWG Settings?
AutoCAD Options.
The Isos tab on the ribbon.
Project Setup.
The Install folder of Plant 3D.
What does the block definition need to be named for the Title Block to work?
Anything you want, the software will recognize it.
Title Block.
Border.
The same as the Style Name.
Which Project Setup section do you go to when you want to set up a new Iso style?
Annotations
Title Block and Display
Iso Style Setup
Dimensions
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Lesson: Troubleshooting
In this lesson, you learn what options there are to recover drawings and solve error messages when
working with AutoCAD Plant 3D. You learn what to do if AutoCAD Plant 3D crashes and the meaning of
any error messages that appear.

Objectives
After completing this lesson, you will be able to:
■
■
■
■

Describe the process to validate components in a drawing or project.
Describe the process for auditing Plant 3D drawings.
List the tools used to create an Iso drawing from components that do not have a line number.
Identify where the Iso creation options for controlling drawing congestion are located.

Validating Drawings
Before you hand off a P&ID project or drawing, you want to be sure that all connections and
annotations are labeled. To do so, you can run a Validation Check on your project or drawing. To
validate a project, you select Home tab > Validate panel > Run Validation. Keep in mind, if a project
is large, validating the entire project can take a very long time. It may make more sense to validate a
drawing when you feel it is complete.
To validate a drawing, in the Project Manager, you right-click the drawing and click Validate. AutoCAD
P&ID analyzes the drawing and displays a Validation Summary. In the Validation Summary palette,
you can choose to Ignore specific errors, or click on the error to have the display zoom to the specific
component.
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The following illustration shows the Validation Summary palette for the drawing PID002.

The Validation Progress dialog box is displayed while the validation is being performed.
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Process: Validate P&ID Projects and Drawings
The following steps give an overview of validating P&ID drawings and projects.
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1.

To validate a project: On the
ribbon, click Home tab >
Validate > Run Validation.
To validate a drawing: In the
Project Manager, right-click
the drawing. Click Validate.

2.

Review the results in the
Validation Summary palette.

3.

To see an issue in the
drawing: On the Validation
Summary palette, select
the error notification. The
drawing automatically zooms
and pans to the location.

■
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4.

To remove validation issues
from further analysis: On the
Validation Summary palette,
right-click the issue. Click
Ignore.

5.

The issue is moved to the
Errors Marked as Ignored
folder.
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Validation Settings
To change the validation settings, you right-click the project name and select Project Settings. The
P&ID Validation Settings dialog box allows you to specify which conditions between specific objects
will be reported as errors during a validation.
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Auditing Drawings
Additionally, you use the AUDITPROJECT command to repair all the drawings in an entire project.
If a project crashes, corrupting the Plant 3D model, you use the PLANTAUDIT command to repair the
model within a single drawing. You simply enter PLANTAUDIT at the command line in the current
drawing to run the command.

IMPORTANT: Do not use the AutoCAD Recover or Audit commands on a Plant 3D
model drawing.

Quick ISO
Quick Iso
If you need to create an Iso drawing with components that do not have a line number assigned, you
use the Quick Iso tool. This tool enables you to select the components in the drawing that you want
to include in the Iso drawing that it creates. The selected components are included in the Iso drawing
even if they do not have line numbers assigned. For more information on the Quick Iso tool, see the
AutoCAD Plant 3D help.
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ISO Congestion
If you create an Iso and wish to force more onto one sheet, or force a less congested split, using the
tools available in the advanced creation will enable you to do so.
The following illustration shows the Advanced Iso Creation Options dialog box. To access this dialog
box, you start the Create Quick Iso tool and select the components to Iso. In the Create Quick Iso
dialog box, click Advanced. Under Drawing congestion splitting, adjust the slider to specify the level of
congestion.
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Exercise: Troubleshooting
In this exercise, you validate a P&ID drawing and fix
some of the errors. You also modify the Advanced Iso
Creation options to reverse the direction of an Iso.

4.

To specify validation settings:
■
In the Project Manager, right-click Training
Project.
■
Click Validation Settings.

5.

In the P&ID Validation Settings dialog box,
verify that all options are selected. Click OK.
To validate a single P&ID drawing:
■
In the Project Manager, under P&ID
Drawings, right-click PID001.
■
Click Validate.

The completed exercise

Validate a P&ID Drawing
In this section of the exercise, you validate a P&ID
drawing and resolve validation issues.
1.
2.

3.

Start AutoCAD Plant 3D.
To open an existing project:
■
In the Project Manager, Current Project,
click Open.
■
In the Open dialog box, navigate to the
folder ..\Plant Design\Troubleshooting.
■
Select the file Project.xml.
■
Click Open.
Under P&ID Drawings, open PID001.dwg.

6.
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7.

On the Validation Summary palette, under
PID001 > Base AutoCAD Objects, click Block
Reference.
AutoCAD P&ID automatically zooms the display
to the area.

8.

In the drawing area, select and right-click the
symbol. Click Convert to P&ID Object.

9.

In the Convert to P&ID dialog box, expand
Engineering Items > Instrumentation > General
Instrument Symbols. Select Field Discrete
Instrument. Click OK.
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10. Select and right-click the blank symbol. Click
Assign Tag.

11. In the Assign Tag dialog box:
■
For Area, enter 10.
■
From the Type list, select PI - Pressure
Indicator.
■
For the Loop Number, enter 104.
■
Click Assign.
12. To refresh the symbol values:
■
Select the symbol.
■
Select the Substitute With Another
Component grip.
■
Select any symbol.
■
Select the Substitute With Another
Component grip again.
■
Click Field Discrete Instrument (the circle).
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13. Notice that the symbol is refreshed and
displayed with the correct values.

14. To rerun the validation:
■
On the Validation Summary palette, click
PID001.
■
Click Revalidate Selected Node.

16. On the Validation Summary palette, under
PID001 > Size Mismatches, click HA-102.
The 4" Gate Valve is highlighted in the drawing.

17. In the drawing area, select the gate valve.
18. On the Properties Palette, under P&ID >
General:
■
Click in the Size field.
■
Click Override Mode.
■
Click Acquire Mode: From Pipe Line
Segments.Size.

15. Note that Block Reference is no longer listed in
the Base AutoCAD Objects folder.

19. Press ESC to clear the selection. The Valve is
changed to a 6" valve.

20. Rerun the validation. Notice that there is no
longer a size mismatch.
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21. On the Validation Summary palette, under
PID001 > Spec Mismatches, click the first
Unlabeled Concentric Reducer.
22. In the drawing area, zoom out and select the
line to the left of the reducer.

23. To assign a different spec sheet to the line:
■
Right-click. Click Assign Tag.
■
In the Assign Tag dialog box, for Spec, enter
CS300.
■
Click Assign.
24. Rerun the validation. Notice that there are no
longer spec mismatches.

25. On the Validation Summary palette, under
PID001 > Orphaned Annotations:
■
Click the first Unlabeled Annotation. Notice
the annotation that is highlighted below the
pump.
■
Under Details, notice that the Allowed
Distance is set to 25 and the Actual Distance
is 27.5.

26. Click the second Unlabeled Annotation. Notice
that under Details, the values are the same.
27. In the drawing area, select the labels under
both pumps.

28. Use the Move command to move the labels
closer to the pumps.
29. Rerun the validation. Notice that there are no
longer orphaned annotations.
30. Close the drawing. Do not save changes.

Audit a Drawing
In this section of the exercise, you audit a Plant 3D
drawing to correct an issue with orphaned fasteners.
1.
2.
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In the Project Manager, under Plant 3D
Drawings > Piping, open the Piping drawing.
Use Zoom to display the drawing extents.
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3.

4.
5.

In the Orphaned Fasteners Detected message
balloon, click the Click Here to Remove Orphans
link.

Note: If the message balloon does not display,
continue to the next step.
To ensure that the drawing database is cleaned
up, on the command line, enter PLANTAUDIT.
Review the auditing information in the Text
Window. The issue with orphaned fasteners is
now completely resolved.

Include Information on One Iso Drawing

2.

In the Isometric Creation Complete message
box, click the Click to View Isometric Creation
Details link.

3.

In the Isometric Creation Results dialog box:
■
Notice that two drawing files were created.
■
Click the second listed file.
■
Notice that only one straight segment was
included on this second drawing.

4.
5.

Close the Iso drawing. Do not save changes.
Begin to recreate the Iso drawing:
■
In AutoCAD Plant 3D, verify that the Piping
drawing is current.
■
Click Isos tab > Create Iso panel >
Production Iso.
■
In the Create Production Iso dialog box,
under Line Numbers, select 1004.
To adjust the Advanced setting so that all the
line is on one drawing:
■
In the Output Settings area, click Advanced.
■
In the Drawing Congestion Splitting area,
drag the slider closer to More as shown.

In this section of the exercise, you modify the
Advanced settings during Iso creation to force more
information onto one drawing.
1.

To create Iso drawings from the piping:
■
Click Isos tab > Iso Creation panel >
Production Iso.
■
In the Create Production Iso dialog box,
under Line Numbers, select 1004.
■
In the Output Settings area, Iso Style list,
select Check_A3.
■
Click Create.

6.

7.
8.

In the Advanced Iso Creation Options dialog
box, click OK.
In the Create Production Iso dialog box, click
Create.
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9.

In the Isometric Creation Complete message
box, click the Click to View Isometric Creation
Details link.

10. In the Isometric Details dialog box, notice that
only one drawing was created.
11. Click the 1004.dwg link to open the drawing.
Notice that your entire spool is now
represented on one sheet rather than two.

12. Close all files. Do not save.
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Review
How can you check whether your P&ID is consistent?
Use the Data Manager to check if everything is connected.
Use the Project Manager to activate the validation settings and validate the drawing.
Print the drawing and check it manually.
There are no options for checking the consistency of your P&ID.
What is wrong when an isometric drawing is created and it consists of multiple drawings with single
components in it?
Nothing, this is the way isometric drawings are created.
The 3D components in the same line are not connected.
How can you reconnect components that are not connected?
By moving them to the correct location.
By rerouting the entire pipe.
By deleting the unconnected parts and replacing them.
Right-click the unconnected component. Click the Connect to Adjacent option.
If AutoCAD Plant 3D crashes, what command can you use to check the integrity of your Plant drawings
(2D and 3D)?
AutoCAD Recovery
AutoCAD Audit
PlantAudit
None of the above
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Lesson: Setting Up SQL Express for AutoCAD
Lesson: Plant 3D
For large projects, the default database, SQLite, may not be robust enough to handle the load. This
lesson describes the reasons for moving to an enterprise database solution, the steps required to set
up a simple configuration for SQL Express, and the steps necessary to connect a current AutoCAD
Plant 3D project to the new server database.

Objectives
After completing this lesson, you will be able to:
■
■
■
■
■

■
■

Explain the different database configurations that can be used in a Plant 3D project.
Explain the overall process for setting up a server database with SQL Server Express.
Install SQL Server Express with the management tools.
Set up the network configuration for SQL Server Express.
Configure and manage an SQL Server Express installation by creating an SQL Server login and using
the required authentication method.
Create a new Plant 3D project and configure it to use an SQL Server Express database.
Convert an existing Plant 3D project that uses a local database to use an SQL server database.

Prerequisites
Before taking this lesson, you should be able to:
■
Install applications on your computer.
■
Have rudimentary IT knowledge.

About Plant 3D Databases
To be used in a scalable environment, AutoCAD Plant 3D must be used with an SQL Server or SQL
Server Express database. By default, AutoCAD Plant 3D uses a local SQLite, which is suitable for
smaller projects without many users.

Database Options in Plant 3D
Plant 3D projects use either a local database or a server database. A local or file-based database is one
that does not require services running to access the database. A server database requires a Windows
service to run in order to access data.
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Using SQLite
When creating a project, AutoCAD Plant 3D uses a popular database format called SQLite (http://
www.sqlite.org/). SQLite is a file-based format, meaning that an application does not have to
be running or launched to maintain a connection to the database. Because of the open format,
developers, using many types of technology, have created methods for interacting with an SQLite
database (for example, C++, .Net, http://www.sqlite.org/cvstrac/wiki?p=SqliteWrappers). SQLite
provides excellent performance for small-scale projects.

Using SQL Server Express
SQL Server Express is a free version of the Microsoft enterprise database server, Microsoft SQL Server.
SQL Express has fewer features compared to SQL Server, but it is able to handle virtually any project
that uses AutoCAD Plant 3D. Also, once the move to SQL Server Express is complete, no data migration
is required to use SQL Server.
SQL Server Express can be installed on desktop operating systems such as Windows 7, XP, or Vista. SQL
Express is free, and can use databases up to 10 gigabytes (GB). For projects that are larger than 10 GB,
using a full SQL Server instance is mandatory.
The server can be connected to the user’s workstation via local area network (LAN), http://
en.wikipedia.org/wiki/Local_area_network. While other connection types are possible, more
complicated setups are better left to IT professionals experienced in domain permissions, wide area
networks (WANs), and general network configuration protocol.

Guidelines for Selecting a Database
Because database performance can fluctuate based on a wide variety of factors, only guidelines for use
can be established. For example, projects that may perform well in one location, may suffer in another
due to differences in servers, connection cables, or even the speed at which users work.
Lab tests have been conducted with up to ten users working simultaneously on a project. In a working
environment, the number of active users may be lower, perhaps six to ten simultaneous users.
When using the SQLite database, file size is not an issue, as files can hold up to 2 terabytes of data.
However, because SQL Server Express is free, it is the preferred method for handling projects that
require multiple users.

Setting Up to Use a Server Database
Because the lesson transitions from a file-based database to a server database, the server database
will be put on a computer. Technically, you can install SQL Server Express on any machine. However,
because the server is usually the only computer guaranteed to be on and accessible, SQL Server
Express is usually installed there. In this lesson, issues regarding Windows Authentication are not
addressed. An SQL authentication is used to simplify the login process and setup.

Server versus Client Workstation
The computer that has the SQL Server Express instance installed and that holds the databases is
referred to as the server. Computers that connect to the server and do not host the databases are
referred to as client workstations or simply, clients.
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Process: Setting Up to Use a Server Database
The following steps give a high level overview of setting up a server database for use with Plant 3D.
1.
2.

Install SQL Server Express or SQL Server on a server computer.
Set up the SQL Server network configuration. This includes configuring SQL Server or Server
Express to allow connections, and configuring the firewall on the server computer to allow
connections for other computers.
Determine the authentication method to use for secure access to the database. Select either
Windows Authentication or SQL Server Authentication.

3.

Security Considerations
An SQL Server implementation must cover many details to ensure that the security of your network
is not compromised. This lesson does not cover setting up a secure instance; it only offers a
few guidelines that may be of use. If you are not versed in network security for your production
environment, an IT professional should be consulted.
Questions to address for limiting access to your SQL Server installation:
■
Can the server be closed to the Internet (not hosting a website)?
■
Have you changed the default passwords and user names to make them custom?
■
Are you using strong passwords?
■
Have you changed the default ports?
Please note that this lesson uses SQL Server Authentication. Windows Authentication is much more
secure and it is the preferred method of Authentication. Due to the constraints of providing a lesson,
address creation and managing users or user roles within the database will not be covered.
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Installing SQL Server Express
Process: Installing SQL Server Express
The following steps provide an overview for installing SQL Server Express.
1.
2.

3.

Download SQL Server Express with Tools from Microsoft. http://www.microsoft.com/sqlserver/
en/us/editions/express.aspx
Follow the prompts to install prerequisite programs. Your machine may already have some of the
prerequisites installed.
■
The Microsoft .NET Framework Core is required.
■
An updated Windows Installer is required.
In the SQL Server Installation Center, select New Installation or Add Features to an Existing
Installation.

4.
5.
6.

Select the features to install.
Specify the shared feature directory.
Specify the Named Instance, Instance ID, and Instance Root Directory.

7.

Specify the Startup Type for the SQL services.
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8.

For Authentication Mode, select Mixed Mode. Enter a password for the SQL Server system
administrator. Make sure to select a strong password. Refer to the following link for information
on strong passwords. http://msdn.microsoft.com/en-us/library/ms161962.aspx

9.

Click Next to skip Error Reporting. Installation will commence and should complete without
errors. When installation is complete, click Close.

Introduction to Setting Up SQL Server to Allow Connections
When you install SQL Server, you have the option of installing SQL Server Management Studio. You
can use this program to remotely access the server or on the server itself. SQL Server Management
Studio is used to view data, modify the database, and perform other administrative tasks. Before you
can use Management Studio or allow client computers to connect, you have to configure SQL Server
to allow connections.

Access
SQL Server Configuration Manager

Start > All Programs > Microsoft SQL Server 2008 R2 > Configuration Tools > SQL Server
Configuration Manager.
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Procedure: Setting up SQL Server’s Protocol
The following steps give an overview of setting up the network configuration by enabling the TCP/IP
protocol.
1.
2.

Open the SQL Server Configuration Manager.
In the SQL Server Configuration Manager dialog box, enable the TCP/IP protocol for SQLEXPRESS.
To do this, expand SQL Server Network Configuration. Right-click TCP/IP. Click Enable.

3.

Restart the SQL services to have the changes take effect. To do this, after selecting SQL Server
Services, right-click SQL Server (SQLEXPRESS). Click Restart.
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Procedure: Setting the Firewall to Allow SQL Server Connections
The following steps provide an overview for setting the firewall to allow SQL Server to connect:
1. On the Control Panel, System and Security area, access Allow a Program Through Windows
Firewall.

In Allowed Programs, click Change Settings. Click Allow Another Program.

2.
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3.

Add the SQL Server program as an allowed program. To do this, in the Add a Program dialog box:
■
Browse to the installation folder, locate sqlservr.exe, and select it. An example path is C:
\Program Files\Microsoft SQL Server\MSSQL10_50.SQLEXPRESS\MSSQL\Binn\sqlservr.exe.
■
Click Network Location Types.
■
As applicable to your setup, select Home, Work, or Public Networks.
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Procedure: Configure Ports in Windows 7 for SQL Server Express
The following steps show how to configure ports in Windows 7 to allow incoming connections for SQL
Server Express.
1. Go to Control Panel > System and Security > Administrative Tools > Windows Firewall with
Advanced Security.
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2.

Locate the SQL Server Windows NT entry from Inbound Rules. Select the Domain rules, rightclick, and enable them.

3.

Under Inbound Rules, click New Rule.
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4.

For Type of Rule, select Port. Click Next.

5.

Select UDP. For Specific Local Ports, enter 1434. Click Next.

6.

Ensure that Allow the Connection is selected. Click Next.
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7.

Ensure that the Domain, Private, and Public check boxes are selected. Click Next.

8.

Name the Inbound rule SQL Browser. Click Finish.

■
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SQL Server Express Configuration and Management
When you install SQL Server, you have the option of installing SQL Server Management Studio.
This program can be used to remotely access the server, or it can be installed directly on the server
itself. SQL Server Management Studio is used to view data, modify the database, and perform other
administrative tasks. Before you can use Management Studio or allow client computers to connect,
you have to configure SQL Server to allow connections.

SQL Server Management
Management of a SQL Server instance is done from within SQL Server Management Studio. You access
SQL Server Management Studio from the Windows Start menu.

Access
SQL Server Management Studio

Start > All Programs > Microsoft SQL Server 2008 R2 > SQL Server Management Studio.
The primary reason to access SQL Server Management Studio is to create database backups or manage
user accounts. The actual creation of databases is done by Plant 3D when you create a new project or
convert an existing project.
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Remote Management
You can run SQL Server Management Studio from the server or on a client computer. To have SQL
Server Management Studio on a client computer, you follow the same steps as the normal SQL Server
Express installation, except for the feature selection. During the installation, you only select the check
box to install Management Tools – Basic.

When you run SQL Server Management Studio from a client computer and you are logging in to SQL
Server remotely for the first time, you must set the connection properties. You access the connection
properties by first expanding the Connect to Server dialog box. Then, on the Connection Properties
tab, you specify the network protocol to use and select the database to connect to.
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After specifying the network protocol to use, you complete the login by specifying the server
information and specifying the login authentication method and information.

Creating a New Plant 3D Project that Uses SQL Server Express
Multiple users working simultaneously on different aspects of Plant and P&ID projects must be
working in a project configured to use an SQL Server Express database configuration. To have a project
configured to use SQL Express, you need to know how to create a new project and configure it to use
an SQL Server Express database.

Specifying SQL Express Server Database
The steps for creating a new plant project that uses an SQL Server Express database configuration is
almost identical to the steps for creating one that uses the default SQLite local database configuration.
The difference is on the Specify Database Settings page of the Project Setup Wizard.
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When creating a new plant project that uses SQL Express, on the Specify Database Settings page of
the Project Setup Wizard, you:
1. Select the SQL Express Server Database option.
2. Select the server and SQL server name.
3. Enter a name for the database. Typically, you enter the same name as the project name you
entered on the first page of the wizard, which is often a recognizable project number.
4. Select the authentication method to use for logging in to the SQL server. Select between Windows
Authentication and SQL Server Authentication.
5. If you set the authentication method to SQL Server Authentication, enter the SQL Server user
name and password login information.
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When the project is being created, four corresponding databases are automatically created and
configured in the SQL Server for that project. Each database has the project name as its prefix and has
either Iso, Ortho, Piping, or PnId as its suffix. The following illustration shows two projects created in
the SQL server.
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Converting a Project to SQL Server
Projects set up to use a file-based database are not conducive to simultaneous access by multiple
users. If you have a situation in which you have an existing file-based database project that needs
to be accessed by multiple users, you need to know how to convert it to use a SQL Server database
instead.

Project Maintenance Utility
You use Project Maintenance Utility to convert a file-based database project to one that uses an SQL
database configuration. Along with converting a project, you can use the utility to move or copy a
project.
When you launch Project Maintenance Utility, the initial dialog box lists the options Convert a Project
to SQL Express, Move a Project Database, or Copy a Project Database. You select the option that you
need and click Next.
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After you select the Convert option and click Next, the Project Maintenance Utility – Convert a Project
to SQL Express dialog box displays. This is where you specify the project to convert and the new
location and database name after conversion.

Access
Project Maintenance Utility

C:\Program Files\Autodesk\AutoCAD Plant 3D 2012 - English\PnPProjectMaintenance.exe

Process: Converting an Existing Plant 3D Project to Use SQL Server
The following steps give an overview of converting an existing Plant 3D project that uses the default
file database to use a SQL Server Express database:
1.
2.
3.
4.
5.
6.
7.

Ensure that AutoCAD Plant 3D is closed.
Launch Project Maintenance Utility. (PnPProjectMaintenance.exe)
Select the option Convert a Project to SQL Express.
Select the project XML file for the project that you want to convert.
Select the server and SQL server name.
Enter a name for the database that will be created in SQL server.
Select the authentication method to use for logging in to the SQL server. If you set the
authentication method to SQL Server Authentication, enter the SQL Server user name and
password login information.
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Exercise: Install SQL Express and Set Up Plant 3D Projects
Exercise: to Use SQL Express
In this exercise, you install and configure SQL Server
Express. You then create and configure a new Plant
3D project to use a server database. You also convert
an existing project that uses a local database to use a
server database.

1.

Download and run SQL Server Express
with Tools from Microsoft. http://
www.microsoft.com/sqlserver/en/us/editions/
express.aspx

2.

If you are prompted to install any prerequisite
programs, click OK.
In the SQL Server Installation Center window,
click New Installation or Add Features to an
Existing Installation.

3.

The completed exercise

Note: In this exercise, for simplicity, a port for SQL
Server to use has not been assigned and the SQL
Server Browser service is running. SQL Server Express
is also set up to connect through the firewall. In
a production environment, you may choose to
implement your configuration differently.
This exercise also uses SQL Server authentication.
In your working environment, you may want to use
Windows authentication instead.

4.

In the SQL Server 2008 R2 Setup window, on
the License Terms page:
■
Select the I Accept the License Terms check
box.
■
Click Next.

Install SQL Express
In this section of the exercise, you install SQL Express.
Note: To complete this section of the exercise, you
must have administrative-level permissions to install
and configure SQL Express. If you are taking this
training at a training center, SQL Server Express may
already be downloaded for you. Or, SQL Express may
be already installed and configured. If that is the case,
you can skip to the section titled Create a New Plant
3D Project that Uses SQL Express.
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5.

On the Features Selection page:
■
In the Features area, ensure that the check
boxes for Database Engine Services, SQL
Server Replication, and Management Tools
– Basic are selected.
■
Clear the SQL Client Connectivity SDK check
box.
■
Review the path in the Shared Feature
Directory field.
■
Click Next.

8.

6.

On the Instance Configuration page:
■
For Named Instance, enter PlantSQL.
■
Review the values for Instance ID and
Instance Root Directory.
■
Click Next.

9.

On the Database Engine Configuration page,
Account Provisioning tab:
■
Under Authentication Mode, select Mixed
Mode.
■
For both Enter Password and Confirm
Password, enter training.

On the Database Engine Configuration page,
click Next.
10. On the Error Reporting page, click Next.
11. On the Complete page with the message
stating your installation was a success, click
Close.
12. Close SQL Server Installation Center.

Configure SQL Server to Allow Connections

7.

On the Server Configuration page:
■
On the Service Accounts tab, in the Startup
Type list for SQL Server Browser, select
Automatic.
■
Click Next.

In this section of the exercise, you configure the SQL
service to allow SQL Server Management Studio
connection access to the SQL server.
1.

Click Start > All Programs > Microsoft SQL
Server 2008 R2 > Configuration Tools >SQL
Server Configuration Manager.
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2.

In the Sql Server Configuration Manager, under
SQL Server Configuration Manager (Local):
■
Expand SQL Server Network Configuration.
■
Select Protocols for PLANTSQL.

3.

In the Protocol Name list, right-click TCP/IP.
Click Enable.

4.
5.

In the Warning dialog box, click OK.
To restart the SQL services so that the changes
take effect:
■
Under SQL Server Configuration Manager
(Local), select SQL Server Services.
■
Right-click SQL Server (PLANTSQL). Click
Restart.

Set the Firewall to Allow SQL Server
Connections
In this section of the exercise, you set the firewall to
allow SQL Server connections.
1.
2.
3.

Click Start > Control Panel.
Click System and Security.
Under Windows Firewall, click Allow a Program
Through Windows Firewall.

4.

On Allow Programs to Communicate Through
Windows Firewall, click Allow Another
Program.

5.

To add the SQL server executable file:
■
In the Add a Program dialog box, click
Browse.
■
In the Browse dialog box, navigate to and
select C:\Program Files\Microsoft SQL.
Server\MSSQL10_50.PLANTSQL\MSSQL
\Binn\sqlservr.exe.
■
Click Add.
In the Allowed Programs and Features list,
ensure that SQL Server Windows NT is listed
and the check box is selected.

6.

6.

Close Sql Server Configuration Manager.

7.
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Close the Control Panel.
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3.

In Microsoft SQL Server Management Studio,
Object Explorer panel, expand Databases.
Review what is listed.

4.

To begin to create a new SQL server login:
■
Expand Security.
■
Right-click Logins. Click New Login.

5.

In the Login – New dialog box:
■
For Login Name, enter PlantUser1.
■
Select SQL Server Authentication.
■
For Password and Confirm Password, enter
Plant3D.

Access the SQL Express Installation and
Configure a Login
In this section of the exercise, you access SQL Express
and configure a login for use in a new Plant 3D
project.
1.
2.

Click Start > All Programs > Microsoft SQL
Server 2008 R2 > SQL Server Management
Studio.
In the Connect to Server dialog box:
■
From the Server Type list, ensure that
Database Engine is selected.
■
From the Server Name list, ensure that your
computer name\PLANTSQL is selected. If
it is not, select Browse for More from the
list. On the Network Servers tab, expand
Database Engine and select the proper
entry.
■
From the Authentication list, ensure that
SQL Server Authentication is selected.
■
From the Login list, ensure that sa is listed.
■
For Password, enter training.
■
Click Connect.
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6.

From the Select a Page list, select Server Roles.

7.

In the Server Roles area, select the dbcreator
check box.

8.
9.

Click OK.
Keep Microsoft SQL Server Management Studio
open. You will refresh the display later in the
exercise.

Create a New Plant 3D Project that Uses SQL
Express
In this section of the exercise, you create a new Plant
3D project that uses the configured SQL Express
installation.
1.
2.
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Launch AutoCAD Plant 3D.
To begin creating a new project, in the Project
Manager, Current Project list, select New
Project.

■

3.

In the Project Setup Wizard, Specify General
Settings page:
■
For Enter a Name For This Project, enter
P_Sep-226.
■
For Enter an Optional Description, enter
SQL Express Setup.
■
For Specify the Directory Where ProgramGenerated Files are Stored, navigate to or
enter C:\Plant Design.
■
Click Next.

4.

In the Project Setup Wizard:
■
On the Specify Unit Settings page, click
Next.
■
On the Specify P&ID Settings page, click
Next.
■
On the Specify Plant 3D Directory Settings
page, click Next.
To begin to specify the database settings, on
the Specify Database Settings page:
■
Click SQL Express Server Database.
■
From the Server Name list, ensure that your
computer name\PLANTSQL is selected.
■
For Database Name Prefix, enter
P_Sep-226.

5.
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6.

7.

8.

To set the authentication information:
■
From the Authentication list, select SQL
Server Authentication.
■
For User Name, enter PlantUser1.
■
For Password, enter Plant3D.

In the Project Setup Wizard:
■
On the Specify Database Settings page, click
Next.
■
On the Finish page, click Finish.
To begin to review the Project Setup for this
new project, in the Project pane, right-click
P_Sep-226. Click Properties.

11. In the Object Explorer:
■
At the top of the list, select computer name
\PLANTSQL.
■
Click Refresh.

12. Expand Databases. Review the updated list of
databases.

Convert a Plant 3D Project to Use SQL Server
9.

In the Project Setup dialog box:
■
Under General Settings, click Database
Setup.
■
Review the Database Setup information.
■
Click Cancel.

In this section of the exercise, you convert an existing
Plant 3D project that uses a file-based database
configuration to use a SQL Server Express database
configuration.
1.

2.

To open a project:
■
In the Project Manager, Current Project list,
select Open.
■
In the Open dialog box, navigate to the
folder ..\Plant Design\Convert a Plant 3D
Project to Use SQL Server\P_Sep-210.
■
Select the file Project.xml.
■
Click Open.
Review the Project Setup for this project.
Notice that the Database Setup shows that it is
configured to use SQLite Local Database. Close
Project Setup.

10. Switch to Microsoft SQL Server Management
Studio.
3.

In the Project pane, right-click Training Project.
Click Close Project.
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4.
5.

6.
7.

Close AutoCAD Plant 3D.
To start Project Maintenance Utility:
■
In Windows Explorer, navigate to C:
\Program Files\Autodesk\AutoCAD Plant 3D
2012 – English.
■
Double-click the executable file
PnPProjectMaintenance.exe.
In Project Maintenance Utility, with the option
Convert a Project to SQL Express selected, click
Next.
To select the project XML file to convert:
■
In the Convert Details area, click Browse.
■
Navigate to the folder Plant Design\Convert
a Plant 3D Project to Use SQL Server
\P_Sep-210.
■
Select and open Project.xml.

13. In Microsoft SQL Server Management Studio,
refresh the display and review the list of
databases.

14. Launch AutoCAD Plant 3D.
15. In the Current Project list, select project
P_Sep-210.

8.

9.

In the Database Details area:
■
From the Server list, select computer name
\PLANTSQL.
■
For Database Prefix, enter P_Sep-210.

In the Authentication Details area:
■
From the list, select SQL Server
Authentication.
■
For User Name, enter PlantUser1.
■
For Password, enter Plant3D.

16. Because SQL Server authentication method
was used, you must sign in to SQL Server to
work on this project. In the SQL Server Sign In
dialog box:
■
For User Name, enter PlantUser1.
■
For Password, enter Plant3D.
■
Click Sign In.

10. In Project Maintenance Utility, click Convert.
11. In the Project Conversion Success dialog box,
click OK.
12. In Project Maintenance Utility, click Close.
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17. Review the Project Setup for this project.
Notice that the Database Setup shows that it
is now configured to use SQL Express server
database. Close Project Setup.

18. Close AutoCAD Plant 3D.
19. Close Microsoft SQL Server Management
Studio.
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Review
What type of database is SQLite?
A server-based database.
A file-based database.
What is the main limiting factor on SQLite performance when used with AutoCAD Plant 3D?
The file size.
The number of items in each drawing.
The number of concurrent users.
The number of files in the project.
Select factors that contribute to a secure implementation of SQL Server:
A good Internet connection.
Standard ports for connections.
Custom user names.
The SQL Browser service.
Strong passwords.

5-188

■

Chapter 5: Setting up and Administering a Plant Project

Lesson: Creating and Managing Report
Lesson: Configurations
This lesson describes the creation and management of report configuration files. This includes
determining file location, creating and customizing report information, and determining how the
report will look.
The advantage of using piping design software with a database is the ability to get the reports you
need for your clients. Because the fields that need to display may differ for each customer, you
configure custom reports to include new fields or remove old fields. The Report Creator makes it easy
to configure a report with customized fields and filtered values. The other big advantage of Report
Creator is that you can predefine a layout template, meaning that you do not have to format your
spreadsheet or other reports after the fact; your reports are produced exactly as you need them every
time.
The following illustration shows a Major Equipment list in Adobe PDF format.

The following illustration shows a Major Equipment list in Microsoft Excel.
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Objectives
After completing this lesson, you will be able to:
■
■

■

■
■
■

■

Describe what report configuration files are used for and what they control.
Identify the three settings for specifying the location of the report configuration files and where
those settings are accessed and set.
Identify where report configuration files are customized and describe the process of customizing
them.
Describe the role of queries in creating reports and the process of configuring a custom query.
Customize a report by adding fields and changing the layout.
State the difference between default fields and calculated fields and identify where to access the
expression for a calculated field.
Identify where to change the style sheet for a report configuration and style of a cell in the report.

About Report Configuration Files
Each project contains information about pumps, tanks, instruments, valves, pipe, steel, and more.
Professionals that are working on the project need to see information about their particular field. To
create reports that display information related to a particular discipline, you need to understand how
report configuration files prepare your reports for export.

Definition of Report Configuration Files
Report Configuration Files are a collection of settings that define the scope of your data, the type of
data included, and how the data is formatted when it is exported. Configuration files may be shared
between projects or users.

Example of Report Configuration Files
You create a configuration file for each type of report that you export. For example, the
instrumentation group requires an instrument report, which includes fields such as Tag, Loop,
Drawing, or Area. Generally, for each project, you will also need an Equipment list, which may include
fields such as Tag, Drawing, Descriptions, or Area. Because the Instrument list and the Equipment list
require different fields, you need to create a separate report configuration for each one.
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Location of Report Configuration Files
Working in a multiuser environment requires that you share your report configurations to avoid
recreating the same report formats. Report Creator has built-in settings that enable you to determine
the location of report configuration files.

Report Configuration Settings
Report Creator has three different locations for storing report configurations:
■
General: When this option is selected, the report configuration files are stored in the default
Program Data folder (C:\ProgramData\Autodesk\AutoCAD Plant 3D 2012 - English\R18.2\enu
\ReportCreator). Use this option for reports that are created and used by an individual.
■
Project: Use this option when you have custom reports specific to a project. The report
configuration files are accessed and stored in a subfolder to the project file.
■
Custom Path: Use this option to specify the folder in which you access and store common company
reports. These are the reports that do not vary with clients or projects.

You access the Settings dialog box to specify the location of the report configuration files by clicking
Settings in the Report Creator dialog box.
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Creating and Editing Report Configurations
To customize the information contained in a report and its presentation, you must first learn how to
access areas to change the underlying report query, the layout, and the export options.

Report Configuration Access
The majority of report configuration editing is done and accessed from the Report Configuration
dialog box. You access the Report Configuration dialog box from within the Report Creator dialog box.
To edit a report configuration, you must first select an existing report configuration from the Report
Configuration list or click New from that same list. If you select an existing report, you then click Edit.
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Description of Report Configuration
The Report Configuration dialog box has three main areas with a total of six key options. The workflow
for customizing a report is to work through the dialog box from the top down.
In the Report Configuration area, you select which report configuration you want to modify and then
save or delete the current configuration. You use the Edit Query option (2) to configure the tables
included in the report and filter the rows for specific values. The Edit Report Layout option (3) opens
the Report Designer, where you control the display of the report fields and the overall look of the
report.
The Output Type options (4), specify whether there is one report per project, one per drawing, or one
per object.
Under Target, you first specify the target file type (5) and the Export File Path and name (6). The export
target options are Printer, PDF, HTML, MHT, Text, CSV, Excel, RTF, or Image. When specifying the Export
File Path, you can use a combination of variables and set values. The question mark button (?) details
the available variables for path and file names.
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Process: Customizing the Report
The following steps give an overview of customizing a report:
1.
2.
3.
4.
5.
6.

Create a new report configuration or select to edit an existing report configuration.
Edit the query underlying the report.
Edit the layout of the report.
Specify the output type of one report per project, drawing, or object.
Set the target report file type and path for the report.
Save changes.

Assigning the Export File Path
Report Creator includes formatting functionality to enable customizing the storage location of the
reports, as well as the file name they are created under. When deciding what format to use, it is
important to visualize how the end user will access them. Using file names that sort in a group often
will help users find the report they are looking for and communicate the purpose of the reports.
For example, reports are often created for a particular discipline or group. You can create a reports
folder for that group and put all of their reports in that folder. Alternatively, sometimes there are
multiple reports for various areas in a plant. If you create reports that begin with the area name and
then include a description of the report, someone looking for information on that area can see which
reports are included. For example, assume that you have two areas in a tank farm (Area 1, Area 2).
You also have to produce an equipment report for each area, an instrument report by area, and a
valve report by area. You can name your files so that Windows groups them together as follows:
Area 1 – Equipment
Area 1 – Instruments
Area 1 – Valves
Area 2 – Equipment
Area 2 – Instruments
Area 2 – Valves
The Report Creator includes some variables that may be used in the Export file path to automate
naming conventions and file name creation. Use the question mark (?) button next to the export file
path to view help on available values.

Notable options are project name [PN], project path [PP], formatting value for date [D:x], formatting
value for time [T:x], and [RCF], which is the name of the current report configuration. With the
variables, you can create the file structure that you need.
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Configuring Report Queries
The query determines which data is used to populate your report. To produce reports, you need the
ability to change the tables for your report configuration.

Access Query Editor
To continue customizing your report, you can change the query by clicking the Edit Query button on
the report configuration dialog box.

Queries and the Query Editor
The Query Editor enables you to select information from a project by using a query. To ensure that the
database understands what you need to see, the program uses Structure Query Language (SQL). Even
though different database formats can have their own dialect of SQL, they use a similar format.
A query is a method of describing a selection of items in a database. A query can have one or more
tables or queries as its base. The basic query consists of three main parts: the SELECT statement,
the FROM statement, and the WHERE statement. The SELECT statement specifies which columns to
include. The FROM statement tells the database which table or query to read. The WHERE statement
limits results from the table.

Example of a Query
A simple example of a query is as follows:
The result of using this query is that only pressure instruments with a type that equals “PI” are
selected.
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Editing Queries
The Query Editor has five main sections: The section at the top (1) changes the classes that are
available to use as a basis of the query. The section to the left (2) lists the available classes (or tables)
that can be used in the query. The top right panel (3) specifies which classes are included (the
FROM statement). The bottom right panel (4) enables input of filters on the included classes (the
WHERE statement). The program selects all of the available columns in the included classes (SELECT
statement). The bottom right button (5) enables you to view the results of your query.

Process: Configuring a Report Query
The following steps give an overview of configuring a query for a report configuration:
1.

With the report configuration file selected in the Report Configuration dialog box, click Edit
Query.
In the Query Configuration dialog box, select the query type.
Include the required class or classes for the query.
Enter the desired filter information.
Set the sort order for the included classes and their properties.
Test the query results. Accepting the changes with the test results displays the information as
required.

2.
3.
4.
5.
6.
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Customizing the Report Layout
To produce reports that match your company standard, you need to learn the formatting options
in the report layout. By saving your standard styles, you can quickly create additional report
configurations that match your company standard exactly.

Access Report Designer
Layout customization is done in or initiated from the Report Designer. You access the Report Designer
by clicking Edit Report Layout in the Report Configuration dialog box.

Types of Layout Customization
There are a number of things that you can do to customize the layout of a report. The most common
changes include:
■
Create fields with expressions that calculate a value.
■
Modify which fields to display.
■
Modify the order, location, or width of fields.
■
Add and modify labels within the report.
■
Specify the style sheet for the overall report.
■
Modify cell styles.
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Report Designer
To modify the layout, you need to become familiar with the Report Designer. Report Designer enables
you to move report fields, change layout items such as images, lines, or grids, and add new fields from
the underlying query to your report. Report Designer consists of six main components:

Contains general commands such as Save, New, and minor editing tools such as Font Style.
This tab opens a preview of what your report template looks like populated with data from your
report. By using the Print Preview tab, you can get a glimpse of the final product.
This palette contains objects you can place within the report.
In the design window, you change the layout using tools such as the standard controls to
configure your template according to your standards.
Report Explorer and Field List: In these two views, you can alternate between viewing the report
structure or the data structure.
This palette changes display based on the object(s) selected and enables you to modify object
properties.

Process: Customizing the Layout of a Report
The following steps give an overview of the process for customizing the layout of a report
configuration file:
1.
2.
3.
4.
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Start AutoCAD Plant Report Creator.
Select the report configuration file that you want to customize and initiate its editing.
Display Report Designer by clicking Edit Report Layout in the Report Configuration dialog box.
In the Report Designer, make the changes required for the report layout to match your
requirements.
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Fields, Calculated Fields, and Expressions
The information stored in the database is not necessarily the value that you want displayed. For
example, some companies may not want to show the .dwg extension in the drawing name. A
calculated field can be used to change the value.

Fields and Expressions
By changing the query for the report configuration, you change the predefined fields that are available
to be used in Report Designer. In addition to predefined fields, you can add calculated fields to your
reports. A calculated field uses an expression to create a new value based on predefined fields.
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Field List
The fields available to be placed in your report are listed in the Field List panel. By default, the Field
List panel is available in the right pane with Report Explorer.

Expression Editor
Expression Editor enables you to create a value that the program will execute to get the calculated
value. Expression Editor includes some program logic, constants, mathematical expressions, and other
data fields. Expression Editor is directly available by right-clicking the calculated field in the Field List,
and then clicking Edit Expression in the shortcut menu.
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The expression can also be edited when editing calculated fields. In the following image, the properties
for the calculated field, MyCustomField, are shown because it is selected in the Members list. The
expression for this field can be edited in the Expression field or the Expression Editor can be opened to
edit the expression.
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The Expression Editor has five main areas.

In this area, you can enter values or type freely. The value stored in this area is the expression
that the program will execute to retrieve the calculated value.
Toolbar with common functions you can easily add to the expression. Functions such as addition,
subtraction; comparison functions such as equals, greater than, or less than; and logic functions
such as and, or, and not.
List of the categories of items that you can use within the Expression Editor.
Contains the items from the currently selected category. The program contains built-in functions
such as Replace, Operators (as in mathematical operators), extra fields available from the query,
general constants, and additional parameters.
Lists help information on the currently selected item.

Styles for Reports and Cells
While you can edit every control in the report to match the look and feel you desire, a style provides a
quick way to apply similar properties to any control that uses that style.
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Report Style Sheet
On the Properties Panel with the current report template selected (xtraReportTemplate1) is a Style
Sheet property. Select the Style Sheet row to display an ellipsis button that launches the Styles Editor.
When you edit styles, the changes take effect on any control that currently uses that style.

The Styles Editor has three main areas: The top row (1) contains command buttons to add a new style,
delete a style, clear all styles, clear unused styles, open styles from a file, and save styles. The left
panel (2) is a list of available styles. The right panel (3) is a list of properties for the current style.

Styles can be saved to an external file for future use via the save button and loaded via the open folder
icon.
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Control Style
Each item that you place in the design window is called a control. The Appearance properties of each
control can be governed by a style, individually, or by overriding the style.
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Exercise: Create and Manage Report Configuration Files
4.

In this exercise, you create a custom report
configuration for a Pressure Indicator List.

The completed exercise

In the Settings dialog box:
■
Select Custom Path.
■
Click Browse for Folder.
■
In the Browse for Folder dialog box,
navigate to the folder ..\Create and Manage
Report Configuration Files\Server\Plant 3D
\Company Reports.
■
Click OK to exit the Browse for Folder dialog
box.
■
Click OK to exit the Settings dialog box.

Set the Report Configuration File Location
In this section of the exercise, you set the location of
report configuration files to a custom path.
1.
2.

Launch AutoCAD Plant Report Creator.
To set the project:
■
In the Report Creator dialog box, Project
list, select Open.
■
In the Open dialog box, navigate to the
folder ..\Plant Design\Create and Manage
Report Configuration Files\P_Aug-11210.
■
Select the file Project.xml.
■
Click Open.

Create a New Report
In this section of the exercise, you create a new blank
report.
1. From the Report Configuration list, select New.

3.

Under Report Configuration, click Settings.
2.

In the New Report Configuration dialog box:
■
Select New Blank Report.
■
Click OK.

Lesson: Creating and Managing Report Configurations

■

5-205

3.

In the Report Configuration dialog box, under
Report Configuration, enter Pressure Indicator
List.

3.

To set the filter and sort order for the
Instrumentation class:
■
In the Filter field, for Type, enter =’PI’.
■
Double-click the Tag Sort field to set the
sort order by A-Z or 0-9.

4.

To test and review the query results:
■
Click Test Query Result.
■
In the Query Result dialog box, scroll to
view the information for the results. The
query returned only instruments with the PI
Type.
■
Click Close.

5.

In the Query Configuration dialog box, click OK.

Create a Query
In this section of the exercise, you create a new query
for the custom report.
1. In the Report Configuration dialog box, under
Report Configuration, click Edit Query.

Create the Report Layout
2.
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In the Query Configuration dialog box:
■
From the Available Classes list, select
Instrumentation.
■
Click the top button to the right of the list
to include the selected class.

■

In this section of the exercise, you create a new report
layout using the Report Wizard.
1.

In the Report Configuration dialog box, click
Edit Report Layout.
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2.

3.

4.

In the Report Wizard, select the following fields.
Click the identified button to include them in
the Fields to Display in a Report list.
■
Engineering Items_Description
■
Instrumentation_Tag
■
Instrumentation_Area
■
Instrumentation_Loop Number
■
Instrumentation_Location
■
Drawings_DWG Name

5.

On the Layout page of the wizard:
■
Under Layout, select Tabular.
■
Click Next.

6.

On the Style page, with Bold selected, click
Next.

7.

To accept the default name for the report, click
Finish.

With the Fields to Display in a Report list
displayed, click Next.

On the Grouping Levels page, click Next.
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8.

To preview the output of the new report, in
the Report Designer, click the Print Preview
tab. Notice that the drawing name includes
the .dwg extension.

9.

In the Report Designer, click the Report
Designer tab.

2.

In the Field List panel, right-click a field.
Select Add Calculated field. A field named
calculatedField1 is added to the Field list.

3.

In the Field List, right-click calculatedField1.
Click Edit Expression.

4.

With the Functions category highlighted, scroll
down in the middle pane and find Replace.
Double-click Replace to add it to the Edit
window at the top.

Create a Calculated Field
In this section of the exercise, you create a calculated
field and then define an expression for the field.
1. In the Report Explorer panel, click the Field List
tab.
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5.

To specify the first parameter of the Replace
function:
■
Delete the two apostrophes (single quotes)
to the left of the first comma.
■
Position the cursor to the left of the first
comma.
■
In the Category list, select Fields.
■
Double-click [Drawings_DWG Name].

9.

Switch to Print Preview and view the results of
your calculated field. Your report displays as
expected.

10. Switch back to the Report Designer tab.
11. On the Report Designer tab, Report panel, click
Save

Modify Fields

6.

To specify the second parameter of the Replace
function:
■
Position the cursor between the two
apostrophes in the second parameter.
■
Enter .dwg.
■
The expression displays as shown.

In this section of the exercise, you modify the
properties and layout of fields.
1. From the Field List panel, drag and drop the
Instrumentation_Tag field onto the first data
field on the left in the Detail row as shown.

2.

7.
8.

From the Field list, drag and drop
calculatedField1 onto the second position from
the left in the Detail row as shown.

Click OK.
To replace the previous field name for the
drawing name with this new calculated
field, from the Field list, drag and drop
calculatedField1 onto the Drawings_DWG
Name field in the Detail section of the report.
The results display as shown.
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3.

Select the Engineering Items_Description field
and drag it into the last position in the Detail
row as shown.

4.

Double-click each header and change the title
of the fields as follows: Tag, Drawing Name,
Area, Loop, Location, and Type.

5.

Change the title of the report to Pressure
Indicator List.

6.

7.

From the Standard Control panel, drag and drop
the Label control under the title as shown.

8.

In the Field List, expand Parameters.

9.

Drag and drop the parameter
General_Project_Name onto the previously
added label to create the results as shown.

To expand the Header Band so that there is
room for another label under the title, click and
drag the edge approximately as shown.

10. Expand the label to the right to make sure there
is ample room for the project name.
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4.

In the Appearance area, from the Foreground
Color list, select Black.

5.

For Text Alignment, select Middle Center.

6.

Select the DataField style and change the text
alignment to Middle Center.

7.

Select the Title style and change Foreground
Color to black.

Change the Style Sheet
In this section of the exercise, you modify the style
sheet and then assign different cells and labels to use
the modified style sheet.
1. To select the overall report template, on the
Report Explorer tab, at the top of the list, select
xtraReportTemplate1.

2.

3.

To open the Style Editor, on the Property Grid
panel, Appearance area, in the Style Sheet field,
click the ellipsis button.

In the Styles Editor, list of styles, select
FieldCaption.
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8.

To begin to add and configure a new style, click
Add.

13. In the Styles Editor, click Close.
14. Select the label [General_Project_Name].

9.

In the Design area, in the (Name) field, enter
HeaderProperty.

15. In the Property Grid panel, Appearance area:
■
Expand Styles.
■
In the Style field, select HeaderProperty.

10. For the HeaderProperty style:
■
For Foreground Color, select Black.
■
For Text Alignment, select Middle Left.

16. On the Report Designer tab, Report panel, click
Save.
17. Close Report Designer.
11. Set the font style to Arial 12 pt, Bold.

12. To save the changes to a Report StyleSheet file
so it can be imported in the future in a different
template:
■
In the Styles Editor, click Save.
■
In the Save As dialog box, navigate to
the folder ..\Create and Manage Report
Configuration Files\Server\Plant3D
\CompanyReports.
■
Save the file to the selected folder with the
name TypicalReport-1.
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Set the Publish Format and Location
In this section of the exercise, you complete the
configuration of the new report configuration file by
setting the format and location to publish the report.
1. In the Report Configuration dialog box, Output
Type area, verify that One Report / Project is
selected.

2.
3.

From the Target list, select PDF File.
For Export File Path, enter [PP]\Reports\[RCF][D:YYMMDD]-[T:HH-MM-SS].
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4.

Clear the Show Options When Printing/
Exporting check box.

5.

Under Report Configuration, click Save.

6.

Click OK.

Test the Report Configuration
In this section of the exercise, you test the report
configuration by exporting the data for the selected
project.
1.

4.

In the Report Creator dialog box, verify that the
Data Source is set to Project Data.
Click Print/Export.
In the Export Results dialog box, double-click
the listed file.
In the PDF viewer, review the configuration and
order of information in the report.
Note: In this case, the column width for Type is
wide enough for the data. To adjust the column
widths so that all of the information displays,
you must return to the Report Designer.

5.

Close the PDF viewer, Export Results dialog box,
and Report Creator.

2.
3.

Lesson: Creating and Managing Report Configurations

■
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Review
Which of the following settings types are saved in a report configuration?
The number of valves in the project.
Fields to display.
Project name.
The font used in the report.
Which of the following statements about report configuration files are true?
You have to use the reports included with the program.
You have to create new ones for every project.
You can customize the file output type.
Which panel contains the fields that are available to use in the report?
Standard Controls
Field List
Properties
Report Explorer
Select statements about calculated fields that are true.
Calculated fields are based on predefined fields.
Calculated fields must include math operations.
Calculated fields use expression to create new values.
Values returned by calculated fields are stored in the database.
What is the best way to manage the appearance of a report?
Use the same template for all of your reports.
Set up standard styles.
Use a macro to format the report.
Copy/Paste from existing reports.
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Chapter Summary
In this chapter, you learned the skills and knowledge for setting up and administering a plant project.
This included tasks like setting up the project file for large projects, controlling the project structure
and file location, customizing the data manager, and creating and editing drawing borders to name just
a few.
Having completed this chapter, you can:
■
■

■
■
■
■
■

■

■
■
■

Create a new project and structure it to your needs.
Explain how projects are structured in AutoCAD Plant 3D and AutoCAD P&ID and identify where
the project files are located.
Set up and maintain a project that can be used for larger projects with multiple users.
Set up the tagging scheme and place symbols on the correct layer with the desired color.
Set up any report or view in the Data Manager and use that set up to export data from the project.
Create drawing templates and use data from the project and the drawing in your title block.
Create, modify, and convert a spec and create and duplicate components to build your own
components.
Create a custom isometric set up and add additional information to your drawing when generating
the Iso.
Troubleshoot issues by recovering drawings and solving error messages.
Set up SQL Express for AutoCAD Plant 3D
Create and manage the report configuration files that are used to generate reports.

Chapter Summary

■
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